Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / cpio.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages cpio)
20 #:use-module (guix licenses)
21 #:use-module (gnu packages)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu))
25
26 (define-public cpio
27 (package
28 (name "cpio")
29 (version "2.11")
30 (source (origin
31 (method url-fetch)
32 (uri (string-append "mirror://gnu/cpio/cpio-"
33 version ".tar.bz2"))
34 (sha256
35 (base32
36 "1gavgpzqwgkpagjxw72xgxz52y1ifgz0ckqh8g7cckz7jvyhp0mv"))
37 (patches (list (search-patch "cpio-gets-undeclared.patch")))))
38 (build-system gnu-build-system)
39 (home-page "https://www.gnu.org/software/cpio/")
40 (synopsis "Manage cpio and tar file archives")
41 (description
42 "GNU cpio copies files into or out of cpio or tar archives. Indeed,
43 many formats are supported, including legacy formats. The format is
44 determined automatically by the program and is handled appropriately.
45 Furthermore, the location of the archive is not important. It can be another
46 file on the drive, a tape, or data on a pipe.")
47 (license gpl3+)))