Merge branch 'master' into gnome-updates
[jackhill/guix/guix.git] / gnu / packages / patches / glibc-hurd-extern-inline.patch
1 This changes the way _EXTERN_INLINE is defined so we can
2 avoid external definition errors.
3 https://lists.gnu.org/archive/html/bug-hurd/2014-04/msg00002.html
4
5 diff --git a/signal/sigsetops.c b/signal/sigsetops.c
6 index 0317662..b92c296 100644
7 --- a/signal/sigsetops.c
8 +++ b/signal/sigsetops.c
9 @@ -3,7 +3,9 @@
10
11 #include <features.h>
12
13 -#define _EXTERN_INLINE
14 +#ifndef _EXTERN_INLINE
15 +#define _EXTERN_INLINE __extern_inline
16 +#endif
17 #ifndef __USE_EXTERN_INLINES
18 # define __USE_EXTERN_INLINES 1
19 #endif
20
21 Link libmachuser and libhurduser automatically with libc, since they are
22 considered a standard part of the API in GNU-land.
23
24 --- a/Makerules
25 +++ b/Makerules
26 @@ -978,6 +978,9 @@
27 '$(libdir)/$(patsubst %,$(libtype.oS),$(libprefix)$(libc-name))'\
28 ' AS_NEEDED (' $(rtlddir)/$(rtld-installed-name) ') )' \
29 ) > $@.new
30 +ifeq ($(patsubst gnu%,,$(config-os)),)
31 + echo 'INPUT ( AS_NEEDED ( -lmachuser -lhurduser ) )' >> $@.new
32 +endif
33 mv -f $@.new $@
34
35 endif