Merge branch 'master' into gnome-updates
[jackhill/guix/guix.git] / gnu / packages / patches / dico-libtool-deterministic.patch
1 Dico 2.2 uses an old Libtool (2.2.7a) that did not sort the output
2 of 'find', thereby leading to non-deterministic file name ordering
3 in the arguments passed to 'ar rcu' for libdico.a & co.
4
5 --- dico-2.2/build-aux/ltmain.sh 1970-01-01 01:00:00.000000000 +0100
6 +++ dico-2.2/build-aux/ltmain.sh 2015-11-25 09:39:30.826169050 +0100
7 @@ -2926,7 +2926,7 @@ func_extract_archives ()
8 func_extract_an_archive "$my_xdir" "$my_xabs"
9 ;;
10 esac
11 - my_oldobjs="$my_oldobjs "`find $my_xdir -name \*.$objext -print -o -name \*.lo -print | $NL2SP`
12 + my_oldobjs="$my_oldobjs "`find $my_xdir -name \*.$objext -print -o -name \*.lo -print | sort | $NL2SP`
13 done
14
15 func_extract_archives_result="$my_oldobjs"