Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / haskell-apps.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
3 ;;; Copyright © 2015, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2016, 2017, 2018 Nikita <nikita@n0.is>
5 ;;; Copyright © 2017 Danny Milosavljevic <dannym@scratchpost.org>
6 ;;; Copyright © 2017, 2018 Alex Vong <alexvong1995@gmail.com>
7 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2018 Timothy Sample <samplet@ngyro.com>
9 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
10 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
11 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
12 ;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
13 ;;; Copyright © 2015 John Soo <jsoo1@asu.edu>
14 ;;; Copyright © 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
15 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
16 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
17 ;;; Copyright © 2020 Brian Leung <bkleung89@gmail.com>
18 ;;;
19 ;;; This file is part of GNU Guix.
20 ;;;
21 ;;; GNU Guix is free software; you can redistribute it and/or modify it
22 ;;; under the terms of the GNU General Public License as published by
23 ;;; the Free Software Foundation; either version 3 of the License, or (at
24 ;;; your option) any later version.
25 ;;;
26 ;;; GNU Guix is distributed in the hope that it will be useful, but
27 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
28 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29 ;;; GNU General Public License for more details.
30 ;;;
31 ;;; You should have received a copy of the GNU General Public License
32 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
33
34 (define-module (gnu packages haskell-apps)
35 #:use-module (guix download)
36 #:use-module (guix git-download)
37 #:use-module (guix packages)
38 #:use-module ((guix licenses) #:prefix license:)
39 #:use-module (guix build-system haskell)
40 #:use-module (gnu packages)
41 #:use-module (gnu packages base)
42 #:use-module (gnu packages curl)
43 #:use-module (gnu packages gl)
44 #:use-module (gnu packages haskell)
45 #:use-module (gnu packages haskell-check)
46 #:use-module (gnu packages haskell-crypto)
47 #:use-module (gnu packages haskell-web)
48 #:use-module (gnu packages haskell-xyz)
49 #:use-module (gnu packages ncurses)
50 #:use-module (gnu packages perl)
51 #:use-module (gnu packages pkg-config)
52 #:use-module (gnu packages rsync)
53 #:use-module (gnu packages version-control))
54
55 (define-public apply-refact
56 (package
57 (name "apply-refact")
58 (version "0.6.0.0")
59 (source
60 (origin
61 (method url-fetch)
62 (uri (string-append
63 "https://hackage.haskell.org/package/apply-refact/apply-refact-"
64 version ".tar.gz"))
65 (sha256
66 (base32
67 "0p2mqgjcqr1zcmk8zgr0yq7g8z1agsa6l493lkj6g3ya9lyhxgig"))))
68 (build-system haskell-build-system)
69 (inputs
70 `(("ghc-refact" ,ghc-refact)
71 ("ghc-exactprint" ,ghc-exactprint)
72 ("ghc-syb" ,ghc-syb)
73 ("ghc-temporary" ,ghc-temporary)
74 ("ghc-filemanip" ,ghc-filemanip)
75 ("ghc-unix-compat" ,ghc-unix-compat)
76 ("ghc-optparse-applicative"
77 ,ghc-optparse-applicative)))
78 (native-inputs
79 `(("ghc-tasty" ,ghc-tasty)
80 ("ghc-tasty-golden" ,ghc-tasty-golden)
81 ("ghc-tasty-expected-failure"
82 ,ghc-tasty-expected-failure)
83 ("ghc-silently" ,ghc-silently)))
84 (home-page "https://hackage.haskell.org/package/apply-refact")
85 (synopsis "Perform refactorings specified by the refact library")
86 (description
87 "This package lets you perform refactorings specified by the refact
88 library. It is primarily used with HLint's @code{--refactor} flag.")
89 (license license:bsd-3)))
90
91 ;; In Stackage LTS 14, this package is at 2.4.1.0. However, that
92 ;; version requires version 2.4.1.0 of the 'Cabal' package, which is
93 ;; provided by GHC 8.6.5 at version 2.4.0.1. Hence, we use an older
94 ;; version to match the compiler's library.
95 (define-public cabal-install
96 (package
97 (name "cabal-install")
98 (version "2.4.0.0")
99 (source
100 (origin
101 (method url-fetch)
102 (uri (string-append
103 "https://hackage.haskell.org/package/cabal-install/cabal-install-"
104 version
105 ".tar.gz"))
106 (sha256
107 (base32 "1xmyl0x8wqfrnray6ky5wy0g0samv4264fbdlzxhqsvk9dbfja8k"))))
108 (build-system haskell-build-system)
109 (arguments
110 `(#:cabal-revision
111 ("2" "1xil5pim6j1ckqj61zz6l7xpfxxr3rkw2hvpws2f7pr9shk645dl")
112 #:phases
113 (modify-phases %standard-phases
114 (add-before 'configure 'update-constraints
115 (lambda _
116 (substitute* "cabal-install.cabal"
117 (("zip-archive >= 0\\.3\\.2\\.5 && < 0\\.4,")
118 "zip-archive >= 0.3.2.5 && <= 0.4.1,"))
119 #t)))))
120 (inputs
121 `(("ghc-async" ,ghc-async)
122 ("ghc-base16-bytestring" ,ghc-base16-bytestring)
123 ("ghc-cryptohash-sha256" ,ghc-cryptohash-sha256)
124 ("ghc-echo" ,ghc-echo)
125 ("ghc-edit-distance" ,ghc-edit-distance)
126 ("ghc-hackage-security" ,ghc-hackage-security)
127 ("ghc-hashable" ,ghc-hashable)
128 ("ghc-http" ,ghc-http)
129 ("ghc-network-uri" ,ghc-network-uri)
130 ("ghc-network" ,ghc-network)
131 ("ghc-random" ,ghc-random)
132 ("ghc-resolv" ,ghc-resolv)
133 ("ghc-tar" ,ghc-tar)
134 ("ghc-zip-archive" ,ghc-zip-archive)
135 ("ghc-zlib" ,ghc-zlib)))
136 (home-page "https://www.haskell.org/cabal/")
137 (synopsis "Command-line interface for Cabal and Hackage")
138 (description
139 "The cabal command-line program simplifies the process of managing
140 Haskell software by automating the fetching, configuration, compilation and
141 installation of Haskell libraries and programs.")
142 (license license:bsd-3)))
143
144 (define-public corrode
145 (let ((commit "b6699fb2fa552a07c6091276285a44133e5c9789"))
146 (package
147 (name "corrode")
148 (version (string-append "0.0.1-" (string-take commit 7)))
149 (source
150 (origin
151 (method git-fetch)
152 (uri (git-reference
153 (url "https://github.com/jameysharp/corrode.git")
154 (commit "b6699fb2fa552a07c6091276285a44133e5c9789")))
155 (file-name (git-file-name name version))
156 (sha256
157 (base32 "02v0yyj6sk4gpg2222wzsdqjxn8w66scbnf6b20x0kbmc69qcz4r"))))
158 (build-system haskell-build-system)
159 (inputs
160 `(("ghc-language-c" ,ghc-language-c)
161 ("ghc-markdown-unlit" ,ghc-markdown-unlit)))
162 (home-page "https://github.com/jameysharp/corrode")
163 (synopsis "Automatic semantics-preserving translation from C to Rust")
164 (description
165 "This program reads a C source file and prints an equivalent module in
166 Rust syntax. It is intended to be useful for two different purposes:
167
168 @enumerate
169 @item Partial automation for migrating legacy code that was implemented in C.
170 @item A new, complementary approach to static analysis for C programs.
171 @end enumerate\n")
172 (license license:gpl2+))))
173
174 (define-public cpphs
175 (package
176 (name "cpphs")
177 (version "1.20.8")
178 (source
179 (origin
180 (method url-fetch)
181 (uri (string-append
182 "https://hackage.haskell.org/package/" name "/"
183 name "-" version ".tar.gz"))
184 (sha256
185 (base32
186 "1bh524asqhk9v1s0wvipl0hgn7l63iy3js867yv0z3h5v2kn8vg5"))))
187 (build-system haskell-build-system)
188 (inputs
189 `(("ghc-polyparse" ,ghc-polyparse)
190 ("ghc-old-locale" ,ghc-old-locale)
191 ("ghc-old-time" ,ghc-old-time)))
192 (home-page "http://projects.haskell.org/cpphs/")
193 (synopsis "Liberalised re-implementation of cpp, the C pre-processor")
194 (description "Cpphs is a re-implementation of the C pre-processor that is
195 both more compatible with Haskell, and itself written in Haskell so that it
196 can be distributed with compilers. This version of the C pre-processor is
197 pretty-much feature-complete and compatible with traditional (K&R)
198 pre-processors. Additional features include: a plain-text mode; an option to
199 unlit literate code files; and an option to turn off macro-expansion.")
200 (license (list license:lgpl2.1+ license:gpl3+))))
201
202 ;; Darcs has no https support:
203 ;; http://darcs.net/manual/Configuring_darcs.html#SECTION00440070000000000000
204 ;; and results of search engines will show that if the protocol is http, https
205 ;; is never mentioned.
206 (define-public darcs
207 (package
208 (name "darcs")
209 (version "2.14.2")
210 (source
211 (origin
212 (method url-fetch)
213 (uri (string-append "https://hackage.haskell.org/package/darcs/"
214 "darcs-" version ".tar.gz"))
215 (sha256
216 (base32
217 "0zm2486gyhiga1amclbg92cd09bvki6vgh0ll75hv5kl72j61lb5"))
218 (modules '((guix build utils)))
219 ;; Remove time-dependent code for reproducibility.
220 (snippet
221 '(begin
222 (substitute* "darcs/darcs.hs"
223 (("__DATE__") "\"1970-01-01\"")
224 (("__TIME__") "\"00:00:00\""))
225 #t))))
226 (build-system haskell-build-system)
227 (arguments
228 `(#:cabal-revision
229 ("1" "0xl7j5cm704pbl2ms0dkydh7jvrz0ym76d725ifpg4h902m1zkhg")
230 #:configure-flags '("-fpkgconfig" "-fcurl" "-flibiconv" "-fthreaded"
231 "-fnetwork-uri" "-fhttp" "--flag=executable"
232 "--flag=library")
233 #:phases
234 (modify-phases %standard-phases
235 (add-after 'patch-source-shebangs 'patch-sh
236 (lambda _
237 (substitute* "tests/issue538.sh"
238 (("/bin/sh") (which "sh")))
239 #t))
240 (add-before 'configure 'update-constraints
241 (lambda _
242 (substitute* "darcs.cabal"
243 (("QuickCheck >= 2\\.8\\.2 && < 2\\.13,")
244 "QuickCheck >= 2.8.2 && < 2.14,"))
245 #t)))))
246 (inputs
247 `(("ghc-cmdargs" ,ghc-cmdargs)
248 ("ghc-split" ,ghc-split)
249 ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
250 ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
251 ("ghc-test-framework" ,ghc-test-framework)
252 ("ghc-quickcheck" ,ghc-quickcheck)
253 ("ghc-findbin" ,ghc-findbin)
254 ("ghc-hunit" ,ghc-hunit)
255 ("ghc-async" ,ghc-async)
256 ("ghc-attoparsec" ,ghc-attoparsec)
257 ("ghc-base16-bytestring" ,ghc-base16-bytestring)
258 ("ghc-bytestring-builder" ,ghc-bytestring-builder)
259 ("ghc-cryptohash" ,ghc-cryptohash)
260 ("ghc-data-ordlist" ,ghc-data-ordlist)
261 ("ghc-fgl" ,ghc-fgl)
262 ("ghc-system-filepath" ,ghc-system-filepath)
263 ("ghc-graphviz" ,ghc-graphviz)
264 ("ghc-hashable" ,ghc-hashable)
265 ("ghc-html" ,ghc-html)
266 ("ghc-mmap" ,ghc-mmap)
267 ("ghc-old-time" ,ghc-old-time)
268 ("ghc-random" ,ghc-random)
269 ("ghc-regex-applicative" ,ghc-regex-applicative)
270 ("ghc-regex-compat-tdfa" ,ghc-regex-compat-tdfa)
271 ("ghc-sandi" ,ghc-sandi)
272 ("ghc-shelly" ,ghc-shelly)
273 ("ghc-tar" ,ghc-tar)
274 ("ghc-transformers-compat" ,ghc-transformers-compat)
275 ("ghc-unix-compat" ,ghc-unix-compat)
276 ("ghc-utf8-string" ,ghc-utf8-string)
277 ("ghc-vector" ,ghc-vector)
278 ("ghc-zip-archive" ,ghc-zip-archive)
279 ("ghc-zlib" ,ghc-zlib)
280 ("ghc-http" ,ghc-http)
281 ("curl" ,curl)
282 ("ghc" ,ghc)
283 ("ncurses" ,ncurses)
284 ("perl" ,perl)
285 ("libiconv" ,libiconv)
286 ("ghc-network" ,ghc-network)
287 ("ghc-network-uri" ,ghc-network-uri)))
288 (native-inputs
289 `(("pkg-config" ,pkg-config)))
290 (home-page "http://darcs.net")
291 (synopsis "Distributed Revision Control System")
292 (description
293 "Darcs is a revision control system. It is:
294
295 @enumerate
296 @item Distributed: Every user has access to the full command set, removing boundaries
297 between server and client or committer and non-committers.
298 @item Interactive: Darcs is easy to learn and efficient to use because it asks you
299 questions in response to simple commands, giving you choices in your work flow.
300 You can choose to record one change in a file, while ignoring another. As you update
301 from upstream, you can review each patch name, even the full diff for interesting
302 patches.
303 @item Smart: Originally developed by physicist David Roundy, darcs is based on a
304 unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
305 @end enumerate")
306 (license license:gpl2)))
307
308 (define-public ghcid
309 (package
310 (name "ghcid")
311 (version "0.8.4")
312 (source
313 (origin
314 (method url-fetch)
315 (uri (string-append "https://hackage.haskell.org/package/ghcid/"
316 "ghcid-" version ".tar.gz"))
317 (sha256
318 (base32
319 "0wpm4ikrm1krz1ckzwk0srng091yh2skjal4fh95iz1hq3dw6qlw"))))
320 (build-system haskell-build-system)
321 (inputs
322 `(("ghc-extra" ,ghc-extra)
323 ("ghc-ansi-terminal" ,ghc-ansi-terminal)
324 ("ghc-cmdargs" ,ghc-cmdargs)
325 ("ghc-fsnotify" ,ghc-fsnotify)
326 ("ghc-terminal-size" ,ghc-terminal-size)))
327 (native-inputs
328 `(("ghc-tasty" ,ghc-tasty)
329 ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
330 (home-page
331 "https://github.com/ndmitchell/ghcid#readme")
332 (synopsis "GHCi based bare bones IDE")
333 (description
334 "Either \"GHCi as a daemon\" or \"GHC + a bit of an IDE\". A very simple Haskell
335 development tool which shows you the errors in your project and updates them whenever
336 you save. Run @code{ghcid --topmost --command=ghci}, where @code{--topmost} makes the
337 window on top of all others (Windows only) and @code{--command} is the command to start
338 GHCi on your project (defaults to @code{ghci} if you have a @file{.ghci} file, or else
339 to @code{cabal repl}).")
340 (license license:bsd-3)))
341
342 (define-public git-annex
343 (package
344 (name "git-annex")
345 (version "8.20200501")
346 (source
347 (origin
348 (method url-fetch)
349 (uri (string-append "https://hackage.haskell.org/package/"
350 "git-annex/git-annex-" version ".tar.gz"))
351 (patches (search-patches "git-annex-S3v4.patch"))
352 (sha256
353 (base32 "19rggaymvqy7r61n2rl2nigwdi2hzq5l1afcd5l0k1vbacwgq4jl"))))
354 (build-system haskell-build-system)
355 (arguments
356 `(#:configure-flags
357 '("--flags=-Android -Assistant -Pairing -Webapp -WebDAV")
358 #:phases
359 (modify-phases %standard-phases
360 (add-before 'configure 'patch-shell-for-tests
361 (lambda _
362 ;; Shell.hs defines "/bin/sh" that is used in Git hooks. We
363 ;; shouldn't patch hooks with Guix's current bash because the
364 ;; hooks can exist after that bash is garbage collected, but
365 ;; let's temporarily patch it so that we can run the tests.
366 (copy-file "Utility/Shell.hs" "/tmp/Shell.hs")
367 (substitute* "Utility/Shell.hs"
368 (("/bin/sh") (which "sh")))
369 #t))
370 (add-before 'configure 'factor-setup
371 (lambda _
372 ;; Factor out necessary build logic from the provided
373 ;; `Setup.hs' script. The script as-is does not work because
374 ;; it cannot find its dependencies, and there is no obvious way
375 ;; to tell it where to look. Note that we do not preserve the
376 ;; code that installs man pages here.
377 (call-with-output-file "PreConf.hs"
378 (lambda (out)
379 (format out "import qualified Build.Configure as Configure~%")
380 (format out "main = Configure.run Configure.tests~%")))
381 (call-with-output-file "Setup.hs"
382 (lambda (out)
383 (format out "import Distribution.Simple~%")
384 (format out "main = defaultMain~%")))
385 #t))
386 (add-before 'configure 'pre-configure
387 (lambda _
388 (invoke "runhaskell" "PreConf.hs")
389 #t))
390 (replace 'check
391 (lambda _
392 ;; We need to set the path so that Git recognizes
393 ;; `git annex' as a custom command.
394 (setenv "PATH" (string-append (getenv "PATH") ":"
395 (getcwd) "/dist/build/git-annex"))
396 (with-directory-excursion "dist/build/git-annex"
397 (symlink "git-annex" "git-annex-shell"))
398 (invoke "git-annex" "test")
399 #t))
400 (add-after 'check 'unpatch-shell-and-rebuild
401 (lambda args
402 ;; Undo `patch-shell-for-tests'.
403 (copy-file "/tmp/Shell.hs" "Utility/Shell.hs")
404 (apply (assoc-ref %standard-phases 'build) args)))
405 (add-after 'install 'install-symlinks
406 (lambda* (#:key outputs #:allow-other-keys)
407 (let* ((out (assoc-ref outputs "out"))
408 (bin (string-append out "/bin")))
409 (symlink (string-append bin "/git-annex")
410 (string-append bin "/git-annex-shell"))
411 (symlink (string-append bin "/git-annex")
412 (string-append bin "/git-remote-tor-annex"))
413 #t))))))
414 (inputs
415 `(("curl" ,curl)
416 ("ghc-aeson" ,ghc-aeson)
417 ("ghc-async" ,ghc-async)
418 ("ghc-aws" ,ghc-aws)
419 ("ghc-bloomfilter" ,ghc-bloomfilter)
420 ("ghc-byteable" ,ghc-byteable)
421 ("ghc-case-insensitive" ,ghc-case-insensitive)
422 ("ghc-concurrent-output" ,ghc-concurrent-output)
423 ("ghc-crypto-api" ,ghc-crypto-api)
424 ("ghc-cryptonite" ,ghc-cryptonite)
425 ("ghc-data-default" ,ghc-data-default)
426 ("ghc-disk-free-space" ,ghc-disk-free-space)
427 ("ghc-dlist" ,ghc-dlist)
428 ("ghc-edit-distance" ,ghc-edit-distance)
429 ("ghc-esqueleto" ,ghc-esqueleto)
430 ("ghc-exceptions" ,ghc-exceptions)
431 ("ghc-feed" ,ghc-feed)
432 ("ghc-filepath-bytestring" ,ghc-filepath-bytestring)
433 ("ghc-free" ,ghc-free)
434 ("ghc-hslogger" ,ghc-hslogger)
435 ("ghc-http-client" ,ghc-http-client)
436 ("ghc-http-conduit" ,ghc-http-conduit)
437 ("ghc-http-types" ,ghc-http-types)
438 ("ghc-ifelse" ,ghc-ifelse)
439 ("ghc-magic" ,ghc-magic)
440 ("ghc-memory" ,ghc-memory)
441 ("ghc-monad-control" ,ghc-monad-control)
442 ("ghc-monad-logger" ,ghc-monad-logger)
443 ("ghc-network" ,ghc-network)
444 ("ghc-old-locale" ,ghc-old-locale)
445 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
446 ("ghc-persistent" ,ghc-persistent)
447 ("ghc-persistent-sqlite" ,ghc-persistent-sqlite)
448 ("ghc-persistent-template" ,ghc-persistent-template)
449 ("ghc-quickcheck" ,ghc-quickcheck)
450 ("ghc-random" ,ghc-random)
451 ("ghc-regex-tdfa" ,ghc-regex-tdfa)
452 ("ghc-resourcet" ,ghc-resourcet)
453 ("ghc-safesemaphore" ,ghc-safesemaphore)
454 ("ghc-sandi" ,ghc-sandi)
455 ("ghc-securemem" ,ghc-securemem)
456 ("ghc-socks" ,ghc-socks)
457 ("ghc-split" ,ghc-split)
458 ("ghc-stm-chans" ,ghc-stm-chans)
459 ("ghc-tagsoup" ,ghc-tagsoup)
460 ("ghc-unix-compat" ,ghc-unix-compat)
461 ("ghc-unordered-containers" ,ghc-unordered-containers)
462 ("ghc-utf8-string" ,ghc-utf8-string)
463 ("ghc-uuid" ,ghc-uuid)
464 ("git" ,git)
465 ("rsync" ,rsync)))
466 (native-inputs
467 `(("ghc-tasty" ,ghc-tasty)
468 ("ghc-tasty-hunit" ,ghc-tasty-hunit)
469 ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
470 ("ghc-tasty-rerun" ,ghc-tasty-rerun)))
471 (home-page "https://git-annex.branchable.com/")
472 (synopsis "Manage files with Git, without checking in their contents")
473 (description "This package allows managing files with Git, without
474 checking the file contents into Git. It can store files in many places,
475 such as local hard drives and cloud storage services. It can also be
476 used to keep a folder in sync between computers.")
477 ;; The main author has released all his changes under AGPLv3+ as of March
478 ;; 2019 (7.20190219-187-g40ecf58d4). These are also licensed under the
479 ;; original GPLv3+ license, but going forward new changes will be under
480 ;; only AGPLv3+. The other licenses below cover code written by others.
481 ;; See git-annex's COPYRIGHT file for details on each file.
482 (license (list license:agpl3+
483 license:gpl3+
484 license:bsd-2
485 license:expat
486 license:gpl2))))
487
488 (define-public hlint
489 (package
490 (name "hlint")
491 (version "2.1.26")
492 (source
493 (origin
494 (method url-fetch)
495 (uri (string-append
496 "https://hackage.haskell.org/package/" name
497 "/" name "-" version ".tar.gz"))
498 (sha256
499 (base32
500 "16zkkpbfrd69853cdqf597fva969lirfc86b039i9zd7ghlrcayc"))))
501 (build-system haskell-build-system)
502 (inputs
503 `(("cpphs" ,cpphs)
504 ("ghc-unordered-containers" ,ghc-unordered-containers)
505 ("ghc-yaml" ,ghc-yaml)
506 ("ghc-vector" ,ghc-vector)
507 ("ghc-data-default" ,ghc-data-default)
508 ("ghc-cmdargs" ,ghc-cmdargs)
509 ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
510 ("ghc-haskell-src-exts-util" ,ghc-haskell-src-exts-util)
511 ("ghc-uniplate" ,ghc-uniplate)
512 ("ghc-ansi-terminal" ,ghc-ansi-terminal)
513 ("ghc-extra" ,ghc-extra)
514 ("ghc-refact" ,ghc-refact)
515 ("ghc-aeson" ,ghc-aeson)
516 ("ghc-lib-parser" ,ghc-lib-parser)
517 ("hscolour" ,hscolour)))
518 (home-page "https://github.com/ndmitchell/hlint")
519 (synopsis "Suggest improvements for Haskell source code")
520 (description "HLint reads Haskell programs and suggests changes that
521 hopefully make them easier to read. HLint also makes it easy to disable
522 unwanted suggestions, and to add your own custom suggestions.")
523 (license license:bsd-3)))
524
525 (define-public hoogle
526 (package
527 (name "hoogle")
528 (version "5.0.17.11")
529 (source
530 (origin
531 (method url-fetch)
532 (uri
533 (string-append
534 "https://hackage.haskell.org/package/hoogle/hoogle-"
535 version ".tar.gz"))
536 (sha256
537 (base32
538 "1svp8z9pad8z2j386pr0dda0ds8ddxab0salnz4gm51q877w93p1"))))
539 (build-system haskell-build-system)
540 (inputs
541 `(("ghc-quickcheck" ,ghc-quickcheck)
542 ("ghc-aeson" ,ghc-aeson)
543 ("ghc-blaze-html" ,ghc-blaze-html)
544 ("ghc-blaze-markup" ,ghc-blaze-markup)
545 ("ghc-cmdargs" ,ghc-cmdargs)
546 ("ghc-conduit" ,ghc-conduit)
547 ("ghc-conduit-extra" ,ghc-conduit-extra)
548 ("ghc-connection" ,ghc-connection)
549 ("ghc-extra" ,ghc-extra)
550 ("ghc-foundation" ,ghc-foundation)
551 ("ghc-old-locale" ,ghc-old-locale)
552 ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
553 ("ghc-http-conduit" ,ghc-http-conduit)
554 ("ghc-http-types" ,ghc-http-types)
555 ("ghc-js-flot" ,ghc-js-flot)
556 ("ghc-js-jquery" ,ghc-js-jquery)
557 ("ghc-mmap" ,ghc-mmap)
558 ("ghc-process-extras" ,ghc-process-extras)
559 ("ghc-resourcet" ,ghc-resourcet)
560 ("ghc-storable-tuple" ,ghc-storable-tuple)
561 ("ghc-tar" ,ghc-tar)
562 ("ghc-uniplate" ,ghc-uniplate)
563 ("ghc-utf8-string" ,ghc-utf8-string)
564 ("ghc-vector" ,ghc-vector)
565 ("ghc-wai" ,ghc-wai)
566 ("ghc-wai-logger" ,ghc-wai-logger)
567 ("ghc-warp" ,ghc-warp)
568 ("ghc-warp-tls" ,ghc-warp-tls)
569 ("ghc-zlib" ,ghc-zlib)))
570 (home-page "https://hoogle.haskell.org/")
571 (synopsis "Haskell API Search")
572 (description "Hoogle is a Haskell API search engine, which allows
573 you to search many standard Haskell libraries by either function name,
574 or by approximate type signature.")
575 (license license:bsd-3)))
576
577 (define-public hscolour
578 (package
579 (name "hscolour")
580 (version "1.24.4")
581 (source
582 (origin
583 (method url-fetch)
584 (uri (string-append
585 "https://hackage.haskell.org/package/hscolour/hscolour-"
586 version
587 ".tar.gz"))
588 (sha256
589 (base32
590 "079jwph4bwllfp03yfr26s5zc6m6kw3nhb1cggrifh99haq34cr4"))))
591 (build-system haskell-build-system)
592 (home-page "https://hackage.haskell.org/package/hscolour")
593 (synopsis "Script to colourise Haskell code")
594 (description "HSColour is a small Haskell script to colourise Haskell
595 code. It currently has six output formats: ANSI terminal codes (optionally
596 XTerm-256colour codes), HTML 3.2 with font tags, HTML 4.01 with CSS, HTML 4.01
597 with CSS and mouseover annotations, XHTML 1.0 with inline CSS styling, LaTeX,
598 and mIRC chat codes.")
599 (license license:bsd-3)))
600
601 (define-public kmonad
602 (package
603 (name "kmonad")
604 (version "0.3.0")
605 (source
606 (origin
607 (method git-fetch)
608 (uri (git-reference
609 (url "https://github.com/david-janssen/kmonad.git")
610 (commit version)))
611 (file-name (git-file-name name version))
612 (sha256
613 (base32 "1g40nkpldih6h1rlxjx5yf9iavr3qs1f2b6j0gd8135p5hkg8d8n"))))
614 (build-system haskell-build-system)
615 (arguments
616 `(#:phases
617 (modify-phases %standard-phases
618 (delete 'haddock) ; Haddock fails to generate docs
619 (add-after 'install 'install-udev-rules
620 (lambda* (#:key outputs #:allow-other-keys)
621 (let* ((out (assoc-ref outputs "out"))
622 (rules (string-append out "/lib/udev/rules.d")))
623 (mkdir-p rules)
624 (call-with-output-file (string-append rules "/70-kmonad.rules")
625 (lambda (port)
626 (display
627 (string-append
628 "KERNEL==\"uinput\", MODE=\"0660\", "
629 "GROUP=\"input\", OPTIONS+=\"static_node=uinput\"\n")
630 port)))
631 #t)))
632 (add-after 'install-udev-rules 'install-documentation
633 (lambda* (#:key outputs #:allow-other-keys)
634 (let* ((out (assoc-ref outputs "out"))
635 (doc (string-append out "/share/doc/kmonad-" ,version)))
636 (install-file "README.md" doc)
637 (copy-recursively "doc" doc)
638 (copy-recursively "example" (string-append doc "/example"))
639 #t))))))
640 (inputs
641 `(("ghc-cereal" ,ghc-cereal)
642 ("ghc-exceptions" ,ghc-exceptions)
643 ("ghc-hashable" ,ghc-hashable)
644 ("ghc-lens" ,ghc-lens)
645 ("ghc-megaparsec" ,ghc-megaparsec)
646 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
647 ("ghc-unagi-chan" ,ghc-unagi-chan)
648 ("ghc-unliftio" ,ghc-unliftio)
649 ("ghc-unordered-containers" ,ghc-unordered-containers)))
650 (home-page "https://github.com/david-janssen/kmonad")
651 (synopsis "Advanced keyboard manager")
652 (description "KMonad is a keyboard remapping utility that supports
653 advanced functionality, such as custom keymap layers and modifiers, macros,
654 and conditional mappings that send a different keycode when tapped or held.
655 By operating at a lower level than most similar tools, it supports X11,
656 Wayland, and Linux console environments alike.")
657 (license license:expat)))
658
659 (define-public raincat
660 (package
661 (name "raincat")
662 (version "1.2.1")
663 (source
664 (origin
665 (method url-fetch)
666 (uri (string-append "mirror://hackage/package/Raincat/"
667 "Raincat-" version ".tar.gz"))
668 (sha256
669 (base32
670 "10y9zi22m6hf13c9h8zd9vg7mljpwbw0r3djb6r80bna701fdf6c"))))
671 (build-system haskell-build-system)
672 (arguments
673 `(#:phases
674 (modify-phases %standard-phases
675 (add-after 'install 'wrap-executable
676 (lambda* (#:key inputs outputs #:allow-other-keys)
677 (let ((out (assoc-ref outputs "out")))
678 (wrap-program (string-append out "/bin/raincat")
679 `("LD_LIBRARY_PATH" ":" =
680 (,(string-append (assoc-ref inputs "freeglut")
681 "/lib"))))
682 #t))))))
683 (inputs
684 `(("ghc-extensible-exceptions" ,ghc-extensible-exceptions)
685 ("ghc-random" ,ghc-random)
686 ("ghc-glut" ,ghc-glut)
687 ("freeglut" ,freeglut)
688 ("ghc-opengl" ,ghc-opengl)
689 ("ghc-sdl2" ,ghc-sdl2)
690 ("ghc-sdl2-image" ,ghc-sdl2-image)
691 ("ghc-sdl2-mixer" ,ghc-sdl2-mixer)))
692 (home-page "https://www.gamecreation.org/games/raincat")
693 (synopsis "Puzzle game with a cat in lead role")
694 (description "Project Raincat is a game developed by Carnegie Mellon
695 students through GCS during the Fall 2008 semester. Raincat features game
696 play inspired from classics Lemmings and The Incredible Machine. The project
697 proved to be an excellent learning experience for the programmers. Everything
698 is programmed in Haskell.")
699 (license license:bsd-3)))
700
701 (define-public scroll
702 (package
703 (name "scroll")
704 (version "1.20180421")
705 (source
706 (origin
707 (method url-fetch)
708 (uri (string-append
709 "https://hackage.haskell.org/package/scroll/scroll-"
710 version ".tar.gz"))
711 (sha256
712 (base32
713 "0apzrvf99rskj4dbmn57jjxrsf19j436s8a09m950df5aws3a0wj"))))
714 (build-system haskell-build-system)
715 (inputs
716 `(("ghc-case-insensitive" ,ghc-case-insensitive)
717 ("ghc-data-default" ,ghc-data-default)
718 ("ghc-ifelse" ,ghc-ifelse)
719 ("ghc-monad-loops" ,ghc-monad-loops)
720 ("ghc-ncurses" ,ghc-ncurses)
721 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
722 ("ghc-random" ,ghc-random)
723 ("ghc-vector" ,ghc-vector)))
724 (home-page "https://joeyh.name/code/scroll/")
725 (synopsis "scroll(6), a roguelike game")
726 (description
727 "You're a bookworm that's stuck on a scroll. You have to dodge between
728 words and use spells to make your way down the page as the scroll is read. Go
729 too slow and you'll get wound up in the scroll and crushed.")
730 (license license:gpl2)))
731
732 (define-public shellcheck
733 (package
734 (name "shellcheck")
735 (version "0.7.0")
736 (source
737 (origin
738 (method url-fetch)
739 (uri (string-append
740 "https://hackage.haskell.org/package/ShellCheck/ShellCheck-"
741 version ".tar.gz"))
742 (sha256
743 (base32 "1vx895cp5k5h0680xfwj74lk97m9y627n965x6srds0gfnbkzy9s"))
744 (file-name (string-append name "-" version ".tar.gz"))))
745 (build-system haskell-build-system)
746 (inputs
747 `(("ghc-aeson" ,ghc-aeson)
748 ("ghc-diff" ,ghc-diff)
749 ("ghc-quickcheck" ,ghc-quickcheck)
750 ("ghc-regex-tdfa" ,ghc-regex-tdfa)))
751 (home-page "https://www.shellcheck.net/")
752 (synopsis "Static analysis for shell scripts")
753 (description "@code{shellcheck} provides static analysis for
754 @command{bash} and @command{sh} shell scripts.
755 It gives warnings and suggestions in order to:
756
757 @enumerate
758 @item Point out and clarify typical beginner's syntax issues that cause
759 a shell to give cryptic error messages.
760 @item Point out and clarify typical intermediate level semantic problems
761 that cause a shell to behave strangely and counter-intuitively.
762 @item Point out subtle caveats, corner cases and pitfalls that may cause an
763 advanced user's otherwise working script to fail under future circumstances.
764 @end enumerate")
765 (license license:gpl3+)))
766
767 (define-public stylish-haskell
768 (package
769 (name "stylish-haskell")
770 (version "0.9.2.2")
771 (source
772 (origin
773 (method url-fetch)
774 (uri
775 (string-append
776 "mirror://hackage/package/stylish-haskell/"
777 "stylish-haskell-" version ".tar.gz"))
778 (sha256
779 (base32
780 "1zs624xqp6j8vrl6pfv18dm8vz8hvz25grri65ximxhcizgwhnax"))))
781 (build-system haskell-build-system)
782 (inputs
783 `(("ghc-aeson" ,ghc-aeson)
784 ("ghc-file-embed" ,ghc-file-embed)
785 ("ghc-haskell-src-exts" ,ghc-haskell-src-exts)
786 ("ghc-semigroups" ,ghc-semigroups)
787 ("ghc-syb" ,ghc-syb)
788 ("ghc-yaml" ,ghc-yaml)
789 ("ghc-strict" ,ghc-strict)
790 ("ghc-optparse-applicative" ,ghc-optparse-applicative)
791 ("ghc-hunit" ,ghc-hunit)
792 ("ghc-test-framework" ,ghc-test-framework)
793 ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
794 (home-page "https://github.com/jaspervdj/stylish-haskell")
795 (synopsis "Haskell code prettifier")
796 (description "Stylish-haskell is a Haskell code prettifier. The goal is
797 not to format all of the code in a file, to avoid \"getting in the way\".
798 However, this tool can e.g. clean up import statements and help doing various
799 tasks that get tedious very quickly. It can
800 @itemize
801 @item
802 Align and sort @code{import} statements
803 @item
804 Group and wrap @code{{-# LANGUAGE #-}} pragmas, remove (some) redundant
805 pragmas
806 @item
807 Remove trailing whitespaces
808 @item
809 Align branches in @code{case} and fields in records
810 @item
811 Convert line endings (customisable)
812 @item
813 Replace tabs by four spaces (turned off by default)
814 @item
815 Replace some ASCII sequences by their Unicode equivalent (turned off by
816 default)
817 @end itemize")
818 (license license:bsd-3)))
819
820 (define-public ghc-stylish-haskell
821 (deprecated-package "ghc-stylish-haskell" stylish-haskell))