gnu: sqlite: Upgrade to 3.8.4.3.
[jackhill/guix/guix.git] / gnu / packages / sqlite.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages sqlite)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (srfi srfi-26)
27 #:use-module (ice-9 match))
28
29 (define-public sqlite
30 (package
31 (name "sqlite")
32 (version "3.8.4.3")
33 (source (origin
34 (method url-fetch)
35 ;; TODO: Download from sqlite.org once this bug :
36 ;; http://lists.gnu.org/archive/html/bug-guile/2013-01/msg00027.html
37 ;; has been fixed.
38 (uri (let ((numeric-version
39 (match (string-split version #\.)
40 ((first-digit other-digits ...)
41 (string-append first-digit
42 (string-pad-right
43 (string-concatenate
44 (map (cut string-pad <> 2 #\0)
45 other-digits))
46 6 #\0))))))
47 (string-append
48 "mirror://sourceforge/sqlite.mirror/SQLite%20" version
49 "/sqlite-autoconf-" numeric-version ".tar.gz")))
50 (sha256
51 (base32
52 "0rcdsk5sz34w8vy0g5yhfms4saiq81i872jxx5m5sjij7bi9bsg0"))
53 (patches
54 (list (search-patch "sqlite-large-page-size-fix.patch")))))
55 (build-system gnu-build-system)
56 (home-page "http://www.sqlite.org/")
57 (synopsis "The SQLite database management system")
58 (description
59 "SQLite is a software library that implements a self-contained, serverless,
60 zero-configuration, transactional SQL database engine. SQLite is the most
61 widely deployed SQL database engine in the world. The source code for SQLite is
62 in the public domain.")
63 (license public-domain)))