gnu: libgcrypt: Ungraft.
[jackhill/guix/guix.git] / gnu / packages / scribus.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
5 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages scribus)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix utils)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix build-system cmake)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages boost)
30 #:use-module (gnu packages compression)
31 #:use-module (gnu packages cups)
32 #:use-module (gnu packages fontutils)
33 #:use-module (gnu packages ghostscript)
34 #:use-module (gnu packages gtk)
35 #:use-module (gnu packages icu4c)
36 #:use-module (gnu packages image)
37 #:use-module (gnu packages imagemagick)
38 #:use-module (gnu packages libreoffice)
39 #:use-module (gnu packages linux)
40 #:use-module (gnu packages pdf)
41 #:use-module (gnu packages pkg-config)
42 #:use-module (gnu packages python)
43 #:use-module (gnu packages qt)
44 #:use-module (gnu packages tls)
45 #:use-module (gnu packages xml))
46
47 (define-public scribus
48 (package
49 (name "scribus")
50 (version "1.5.4")
51 (source
52 (origin
53 (method url-fetch)
54 (uri (string-append "mirror://sourceforge/scribus/scribus-devel/"
55 version "/scribus-" version ".tar.xz"))
56 (sha256
57 (base32
58 "00ys0p6h3iq77kh72dkl0qrf7qvznq18qdrgiq10gfxja1995034"))
59 (modules '((guix build utils)))))
60 (build-system cmake-build-system)
61 (arguments
62 `(#:tests? #f ;no test target
63 #:configure-flags
64 '("-DWANT_GRAPHICSMAGICK=1")
65 #:phases
66 (modify-phases %standard-phases
67 (add-after 'install 'wrap-program
68 (lambda* (#:key inputs outputs #:allow-other-keys)
69 ;; Fix "ImportError: No module named _sysconfigdata_nd" where
70 ;; Scribus checks PATH and eventually runs system's Python
71 ;; instead of package's.
72 (let* ((out (assoc-ref outputs "out"))
73 (py2 (assoc-ref inputs "python")))
74 (wrap-program (string-append out "/bin/scribus")
75 `("PATH" ":" prefix (,(string-append py2 "/bin")))))
76 #t)))))
77 (inputs
78 `(("boost" ,boost)
79 ("cairo" ,cairo)
80 ("cups" ,cups)
81 ("fontconfig" ,fontconfig)
82 ("freetype" ,freetype)
83 ("graphicsmagick" ,graphicsmagick)
84 ("harfbuzz" ,harfbuzz)
85 ("hunspell" ,hunspell)
86 ("icu4c" ,icu4c)
87 ("lcms" ,lcms)
88 ("libcdr" ,libcdr)
89 ("libfreehand" ,libfreehand)
90 ("libjpeg" ,libjpeg)
91 ("libmspub" ,libmspub)
92 ("libpagemaker" ,libpagemaker)
93 ("librevenge" ,librevenge)
94 ("libtiff" ,libtiff)
95 ("libvisio" ,libvisio)
96 ("libxml2" ,libxml2)
97 ("libzmf" ,libzmf)
98 ("openssl" ,openssl)
99 ("podofo" ,podofo)
100 ("poppler" ,poppler)
101 ("python" ,python-2) ;need Python library
102 ("qtbase" ,qtbase)
103 ("qtdeclarative" ,qtdeclarative)
104 ("zlib" ,zlib)))
105 (native-inputs
106 `(("pkg-config" ,pkg-config)
107 ("qttools" ,qttools)
108 ("util-linux" ,util-linux)))
109 (home-page "https://www.scribus.net")
110 (synopsis "Desktop publishing and page layout program")
111 (description
112 "Scribus is a @dfn{desktop publishing} (DTP) application and can be used
113 for many tasks; from brochure design to newspapers, magazines, newsletters and
114 posters to technical documentation. Scribus supports professional DTP
115 features, such as CMYK color and a color management system to soft proof
116 images for high quality color printing, flexible PDF creation options,
117 Encapsulated PostScript import/export and creation of four color separations,
118 import of EPS/PS and SVG as native vector graphics, Unicode text including
119 right to left scripts such as Arabic and Hebrew via freetype.")
120 (license license:gpl2+)))