Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / libunistring.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
6 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages libunistring)
24 #:use-module (guix licenses)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages base))
30
31 (define-public libunistring
32 (package
33 (name "libunistring")
34 (version "0.9.7")
35 (source (origin
36 (method url-fetch)
37 (uri (string-append
38 "mirror://gnu/libunistring/libunistring-"
39 version ".tar.xz"))
40 (sha256
41 (base32
42 "15z76qrmrvkc3c6hfq2lzzqysgd21s682f2smycfab5g598n8drf"))
43 ;; test-lock has performance issues on multi-core machines,
44 ;; it hangs or takes a long time to complete.
45 ;; This is a commit from gnulib to fix this issue.
46 (patches (search-patches "libunistring-gnulib-multi-core.patch"))))
47 (propagated-inputs (libiconv-if-needed))
48 (build-system gnu-build-system)
49 (arguments
50 ;; Work around parallel build issue whereby C files may be compiled before
51 ;; config.h is built: see <http://hydra.gnu.org/build/59381/nixlog/2/raw> and
52 ;; <http://lists.openembedded.org/pipermail/openembedded-core/2012-April/059850.html>.
53 '(#:parallel-build? #f))
54 (synopsis "C library for manipulating Unicode strings")
55 (description
56 "GNU libunistring is a library providing functions to manipulate
57 Unicode strings and for manipulating C strings according to the Unicode
58 standard.")
59 (home-page "https://www.gnu.org/software/libunistring/")
60 (license (list lgpl3+ gpl2))))