gnu: libuv: Update to 1.14.1.
[jackhill/guix/guix.git] / gnu / packages / libevent.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015, 2017 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
5 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
6 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
7 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages libevent)
25 #:use-module (gnu packages)
26 #:use-module (guix licenses)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix build-system gnu)
30 #:use-module (guix build-system perl)
31 #:use-module (gnu packages autotools)
32 #:use-module (gnu packages base)
33 #:use-module (gnu packages perl)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (gnu packages python)
36 #:use-module (gnu packages tls))
37
38 (define-public libevent
39 (package
40 (name "libevent")
41 (version "2.1.8")
42 (source (origin
43 (method url-fetch)
44 (uri (string-append
45 "https://github.com/libevent/libevent/releases/download/release-"
46 version "-stable/libevent-" version "-stable.tar.gz"))
47 (sha256
48 (base32
49 "1hhxnxlr0fsdv7bdmzsnhdz16fxf3jg2r6vyljcl3kj6pflcap4n"))
50 (patches (search-patches "libevent-2.1-dns-tests.patch"
51 ;; XXX: Try removing this for > 2.1.8.
52 ;; https://github.com/libevent/libevent/issues/452
53 "libevent-2.1-skip-failing-test.patch"))))
54 (build-system gnu-build-system)
55 (arguments
56 ;; This skips some of the tests which fail on armhf and aarch64.
57 '(#:configure-flags '("--disable-libevent-regress")))
58 (inputs
59 `(("python" ,python-2))) ; for 'event_rpcgen.py'
60 (native-inputs
61 `(("which" ,which)))
62 (home-page "http://libevent.org/")
63 (synopsis "Event notification library")
64 (description
65 "The libevent API provides a mechanism to execute a callback
66 function when a specific event occurs on a file descriptor or after a
67 timeout has been reached. Furthermore, libevent also support callbacks
68 due to signals or regular timeouts.
69
70 libevent is meant to replace the event loop found in event driven
71 network servers. An application just needs to call event_dispatch() and
72 then add or remove events dynamically without having to change the event
73 loop.")
74 (license bsd-3)))
75
76 (define-public libevent-2.0
77 (package
78 (inherit libevent)
79 (version "2.0.22")
80 (source (origin
81 (method url-fetch)
82 (uri (string-append
83 "https://github.com/libevent/libevent/releases/download/release-"
84 version "-stable/libevent-" version "-stable.tar.gz"))
85 (sha256
86 (base32
87 "18qz9qfwrkakmazdlwxvjmw8p76g70n3faikwvdwznns1agw9hki"))
88 (patches
89 (search-patches
90 "libevent-dns-tests.patch"
91 "libevent-2.0-CVE-2016-10195.patch"
92 "libevent-2.0-CVE-2016-10196.patch"
93 "libevent-2.0-CVE-2016-10197.patch"
94 "libevent-2.0-evbuffer-add-use-last-with-datap.patch"))))
95 (arguments '())))
96
97 (define-public libev
98 (package
99 (name "libev")
100 (version "4.24")
101 (source (origin
102 (method url-fetch)
103 (uri (string-append "http://dist.schmorp.de/libev/Attic/libev-"
104 version
105 ".tar.gz"))
106 (sha256
107 (base32
108 "08gqsza1czx0nf62nkk183jb0946yzjsymaacxbzdgcs8z9r6dcp"))))
109 (build-system gnu-build-system)
110 (home-page "http://software.schmorp.de/pkg/libev.html")
111 (synopsis "Event loop loosely modelled after libevent")
112 (description
113 "libev is a full-featured and high-performance event loop that
114 is loosely modelled after libevent, but without its limitations and
115 bugs. It is used in GNU Virtual Private Ethernet, rxvt-unicode,
116 auditd, the Deliantra MORPG Server and Client, and many other
117 programs.")
118 (license
119 (list bsd-2 gpl2+))))
120
121 (define-public libuv
122 (package
123 (name "libuv")
124 (version "1.14.1")
125 (source (origin
126 (method url-fetch)
127 (uri (string-append "https://dist.libuv.org/dist/v" version
128 "/libuv-v" version ".tar.gz"))
129 (sha256
130 (base32
131 "08kx4mzjsdv90n9pivqxqjxlxk5vaf9p33zzvx661dwfmp9468pk"))))
132 (build-system gnu-build-system)
133 (arguments
134 '(#:phases (alist-cons-after
135 'unpack 'autogen
136 (lambda _
137 ;; Fashionable people don't run 'make dist' these days, so
138 ;; we need to do that ourselves.
139 (zero? (system* "sh" "autogen.sh")))
140 %standard-phases)
141
142 ;; XXX: Some tests want /dev/tty, attempt to make connections, etc.
143 #:tests? #f))
144 (native-inputs `(("autoconf" ,(autoconf-wrapper))
145 ("automake" ,automake)
146 ("libtool" ,libtool)
147
148 ;; libuv.pc is installed only when pkg-config is found.
149 ("pkg-config" ,pkg-config)))
150 (home-page "https://github.com/libuv/libuv")
151 (synopsis "Library for asynchronous I/O")
152 (description
153 "libuv is a multi-platform support library with a focus on asynchronous
154 I/O. Among other things, it supports event loops via epoll, kqueue, and
155 similar IOCP, and event ports, asynchronous TCP/UDP sockets, asynchronous DNS
156 resolution, asynchronous file system operations, and threading primitives.")
157
158 ;; A few files fall under other non-copyleft licenses; see 'LICENSE' for
159 ;; details. Documentation is CC-BY 4.0 as of 1.12.0; see 'LICENSE-docs'.
160 (license (list expat cc-by4.0))))
161
162 (define-public perl-anyevent
163 (package
164 (name "perl-anyevent")
165 (version "7.14")
166 (source (origin
167 (method url-fetch)
168 (uri (string-append "mirror://cpan/authors/id/M/ML/MLEHMANN/"
169 "AnyEvent-" version ".tar.gz"))
170 (sha256
171 (base32
172 "0akxr9y0q9yjkl614x4clbiiayvh5a67y8gmci54plxs4p95i4sk"))))
173 (build-system perl-build-system)
174 (native-inputs
175 `(("perl-canary-stability" ,perl-canary-stability)))
176 (propagated-inputs
177 `(("perl-async-interrupt" ,perl-async-interrupt)
178 ("perl-ev" ,perl-ev)
179 ("perl-guard" ,perl-guard)
180 ("perl-json" ,perl-json)
181 ("perl-json-xs" ,perl-json-xs)
182 ("perl-net-ssleay" ,perl-net-ssleay)
183 ("perl-task-weaken" ,perl-task-weaken)))
184 (home-page "http://search.cpan.org/dist/AnyEvent")
185 (synopsis
186 "API for I/O, timer, signal, child process and completion events")
187 (description
188 "This module allows using a variety of events without forcing module
189 authors to pick a specific event loop, and without noticeable overhead.
190 Currently supported event loops are EV, Event, Glib/Gtk2, Tk, Qt,
191 @code{Event::Lib}, Irssi, @code{IO::Async} and POE (and thus also WxWidgets
192 and Prima). It also comes with a very fast Pure Perl event loop that does
193 not rely on XS.")
194 (license perl-license)))
195
196 (define-public perl-ev
197 (package
198 (name "perl-ev")
199 (version "4.22")
200 (source (origin
201 (method url-fetch)
202 (uri (string-append "mirror://cpan/authors/id/M/ML/MLEHMANN/EV-"
203 version ".tar.gz"))
204 (sha256
205 (base32
206 "14d9115q8f2ca2q3vbcalm55zqsbx8xjq5aj098laj9f9rrzirra"))
207 (modules '((guix build utils)))
208 (snippet
209 '(begin
210 ;; Drop bundled libev.
211 (delete-file-recursively "libev")
212 #t))))
213 (build-system perl-build-system)
214 (arguments
215 '(#:phases
216 (modify-phases %standard-phases
217 (add-after 'unpack 'unpack-libev
218 ;; This package requires the libev *sources* in order
219 ;; to build. Unpack system libev here...
220 (lambda* (#:key inputs #:allow-other-keys)
221 (mkdir "./libev")
222 (zero? (system* "tar" "-xf" (assoc-ref inputs "libev-source")
223 "-C" "./libev" "--strip-components=1")))))))
224 (native-inputs
225 `(("libev-source" ,(package-source libev))
226 ("perl-canary-stability" ,perl-canary-stability)))
227 (propagated-inputs
228 `(("perl-common-sense" ,perl-common-sense)))
229 (home-page "http://search.cpan.org/dist/EV")
230 (synopsis "Perl interface to libev")
231 (description
232 "This module provides an interface to @code{libev}, a high performance
233 full-featured event loop. It can be used through the @code{AnyEvent} module
234 and still be faster than other event loops currently supported in Perl.")
235 (license perl-license)))