gnu: Add pdfposter.
[jackhill/guix/guix.git] / gnu / packages / hexedit.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages hexedit)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages ncurses)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public hexedit
28 (package
29 (name "hexedit")
30 (version "1.2.13")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "http://rigaux.org/"
34 name "-" version ".src.tgz"))
35 (sha256
36 (base32
37 "1mwdp1ikk64cqmagnrrps5jkn3li3n47maiqh2qc1xbp1ains4ka"))))
38 (build-system gnu-build-system)
39 (arguments '(#:tests? #f)) ; no check target
40 (inputs `(("ncurses" ,ncurses)))
41 (synopsis "View and edit files or devices in hexadecimal or ASCII")
42 (description "hexedit shows a file both in ASCII and in hexadecimal. The
43 file can be a device as the file is read a piece at a time. You can modify
44 the file and search through it.")
45 (home-page "http://rigaux.org/hexedit.html")
46 (license license:gpl2+)))