gnu: ghostscript: Fix CVE-2019-14869.
[jackhill/guix/guix.git] / gnu / packages / ghostscript.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014, 2015, 2016, 2017 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2013, 2015, 2016, 2017, 2019 Ludovic Courtès <ludo@gnu.org>
6 ;;; Copyright © 2017 Alex Vong <alexvong1995@gmail.com>
7 ;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
8 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
9 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
11 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
12 ;;;
13 ;;; This file is part of GNU Guix.
14 ;;;
15 ;;; GNU Guix is free software; you can redistribute it and/or modify it
16 ;;; under the terms of the GNU General Public License as published by
17 ;;; the Free Software Foundation; either version 3 of the License, or (at
18 ;;; your option) any later version.
19 ;;;
20 ;;; GNU Guix is distributed in the hope that it will be useful, but
21 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
22 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
23 ;;; GNU General Public License for more details.
24 ;;;
25 ;;; You should have received a copy of the GNU General Public License
26 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
27
28 (define-module (gnu packages ghostscript)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages autotools)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages cups)
33 #:use-module (gnu packages fontutils)
34 #:use-module (gnu packages image)
35 #:use-module (gnu packages perl)
36 #:use-module (gnu packages pkg-config)
37 #:use-module (gnu packages python)
38 #:use-module (gnu packages tcl)
39 #:use-module (gnu packages xorg)
40 #:use-module ((guix licenses) #:prefix license:)
41 #:use-module (guix packages)
42 #:use-module (guix download)
43 #:use-module (guix utils)
44 #:use-module (guix build-system gnu)
45 #:use-module (guix build-system trivial)
46 #:use-module (srfi srfi-1))
47
48 (define-public lcms
49 (package
50 (name "lcms")
51 (version "2.9")
52 (source (origin
53 (method url-fetch)
54 (uri (string-append "mirror://sourceforge/lcms/lcms/" version
55 "/lcms2-" version ".tar.gz"))
56
57 (patches (search-patches "lcms-CVE-2018-16435.patch"))
58 (sha256 (base32
59 "083xisy6z01zhm7p7rgk4bx9d6zlr8l20qkfv1g29ylnhgwzvij8"))))
60 (build-system gnu-build-system)
61 (arguments
62 `(#:configure-flags '("--disable-static")))
63 (inputs `(("libjpeg" ,libjpeg)
64 ("libtiff" ,libtiff)
65 ("zlib" ,zlib)))
66 (synopsis "Little CMS, a small-footprint colour management engine")
67 (description
68 "Little CMS is a small-footprint colour management engine, with special
69 focus on accuracy and performance. It uses the International Color
70 Consortium standard (ICC), approved as ISO 15076-1.")
71 (license license:x11)
72 (home-page "http://www.littlecms.com/")
73 (properties '((cpe-name . "little_cms_color_engine")))))
74
75 (define-public libpaper
76 (package
77 (name "libpaper")
78 (version "1.1.24")
79 (source (origin
80 (method url-fetch)
81 (uri (string-append
82 ;; Debian moved their libpaper-1.1.24 to archive.debian.net
83 ;; but in the move the hash of their tarball changed.
84 "http://pkgs.fedoraproject.org/repo/pkgs/libpaper/libpaper_"
85 version ".tar.gz/5bc87d494ba470aba54f6d2d51471834/libpaper_"
86 version ".tar.gz"))
87 (sha256 (base32
88 "0zhcx67afb6b5r936w5jmaydj3ks8zh83n9rm5sv3m3k8q8jib1q"))))
89 (build-system gnu-build-system)
90 (native-inputs
91 `(("automake" ,automake))) ; For up to date 'config.guess' and 'config.sub'.
92 (arguments
93 `(#:configure-flags '("--disable-static")
94 #:phases
95 (modify-phases %standard-phases
96 (add-after 'unpack 'fix-configure
97 (lambda* (#:key inputs native-inputs #:allow-other-keys)
98 ;; Replace outdated config.sub and config.guess:
99 (for-each (lambda (file)
100 (install-file
101 (string-append (assoc-ref
102 (or native-inputs inputs) "automake")
103 "/share/automake-"
104 ,(version-major+minor
105 (package-version automake))
106 "/" file) "."))
107 '("config.sub" "config.guess"))
108 #t)))))
109 (synopsis "Library for handling paper sizes")
110 (description
111 "The paper library and accompanying files are intended to provide a simple
112 way for applications to take actions based on a system- or user-specified
113 paper size.")
114 (license license:gpl2)
115 (home-page "https://packages.qa.debian.org/libp/libpaper.html")))
116
117 (define-public psutils
118 (package
119 (name "psutils")
120 (version "17")
121 (source (origin
122 (method url-fetch)
123 (uri "ftp://ftp.knackered.org/pub/psutils/psutils.tar.gz")
124 (sha256 (base32
125 "1r4ab1fvgganm02kmm70b2r1azwzbav2am41gbigpa2bb1wynlrq"))))
126 (build-system gnu-build-system)
127 (inputs `(("perl" ,perl)))
128 (arguments
129 `(#:tests? #f ; none provided
130 #:phases
131 (modify-phases %standard-phases
132 (replace 'configure
133 (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
134 (let ((perl (assoc-ref inputs "perl"))
135 (out (assoc-ref outputs "out")))
136 (copy-file "Makefile.unix" "Makefile")
137 (substitute* "Makefile"
138 (("/usr/local/bin/perl") (string-append perl "/bin/perl")))
139 (substitute* "Makefile"
140 (("/usr/local") out))
141 ;; for the install phase
142 (substitute* "Makefile"
143 (("-mkdir") "mkdir -p"))
144 ;; drop installation of non-free files
145 (substitute* "Makefile"
146 ((" install.include") "")))
147 #t)))))
148 (synopsis "Collection of utilities for manipulating PostScript documents")
149 (description
150 "PSUtils is a collection of utilities for manipulating PostScript
151 documents. Programs included are psnup, for placing out several logical pages
152 on a single sheet of paper, psselect, for selecting pages from a document,
153 pstops, for general imposition, psbook, for signature generation for booklet
154 printing, and psresize, for adjusting page sizes.")
155 (license (license:non-copyleft "file://LICENSE"
156 "See LICENSE in the distribution."))
157 (home-page "http://knackered.org/angus/psutils/")))
158
159 (define-public ghostscript
160 (package
161 (name "ghostscript")
162 (version "9.50")
163 (source
164 (origin
165 (method url-fetch)
166 (uri (string-append "https://github.com/ArtifexSoftware/"
167 "ghostpdl-downloads/releases/download/gs"
168 (string-delete #\. version)
169 "/ghostscript-" version ".tar.xz"))
170 (sha256
171 (base32
172 "1m770dwc82afdgzgq2kar3120r1lbybm3mssdm79f8kggf0v16yv"))
173 (patches (search-patches "ghostscript-CVE-2019-14869.patch"
174 "ghostscript-no-header-creationdate.patch"
175 "ghostscript-no-header-id.patch"
176 "ghostscript-no-header-uuid.patch"))
177 (modules '((guix build utils)))
178 (snippet
179 ;; Remove bundled libraries. The bundled OpenJPEG is a patched fork so
180 ;; we leave it, at least for now.
181 ;; TODO Try unbundling ijs, which is developed alongside Ghostscript.
182 ;; Likewise for the thread-safe lcms2 fork called "lcms2art".
183 '(begin
184 (for-each delete-file-recursively '("freetype" "jbig2dec" "jpeg"
185 "libpng" "tiff" "zlib"))
186 #t))))
187 (build-system gnu-build-system)
188 (outputs '("out" "doc")) ;19 MiB of HTML/PS doc + examples
189 (arguments
190 `(#:disallowed-references ("doc")
191 ;; XXX: Starting with version 9.27, building the tests in parallel
192 ;; occasionally fails like this:
193 ;; In file included from ./base/memory_.h:23:0,
194 ;; from ./obj/gsmd5.h:1,
195 ;; from ./obj/gsmd5.c:56:
196 ;; ./base/std.h:25:10: fatal error: arch.h: No such file or directory
197 #:parallel-tests? #f
198 #:configure-flags
199 (list (string-append "LDFLAGS=-Wl,-rpath="
200 (assoc-ref %outputs "out") "/lib")
201 "--with-system-libtiff"
202 "LIBS=-lz"
203 (string-append "ZLIBDIR="
204 (assoc-ref %build-inputs "zlib") "/include")
205 "--enable-dynamic"
206 "--disable-compile-inits"
207 (string-append "--with-fontpath="
208 (assoc-ref %build-inputs "gs-fonts")
209 "/share/fonts/type1/ghostscript")
210
211 ,@(if (%current-target-system)
212 '(;; Specify the native compiler, which is used to build 'echogs'
213 ;; and other intermediary tools when cross-compiling; see
214 ;; <https://ghostscript.com/FAQ.html>.
215 "CCAUX=gcc"
216
217 ;; Save 'config.log' etc. of the native build under
218 ;; auxtmp/, useful for debugging.
219 "--enable-save_confaux")
220 '()))
221 #:phases
222 (modify-phases %standard-phases
223 (add-before 'configure 'create-output-directory
224 (lambda* (#:key outputs #:allow-other-keys)
225 ;; The configure script refuses to function if the directory
226 ;; specified as -rpath does not already exist.
227 (mkdir-p (string-append (assoc-ref outputs "out") "/lib"))
228 #t))
229 (add-after 'configure 'remove-doc-reference
230 (lambda _
231 ;; Don't retain a reference to the 'doc' output in 'gs'.
232 ;; The only use of this definition is in the output of
233 ;; 'gs --help', so this change is fine.
234 (substitute* "base/gscdef.c"
235 (("GS_DOCDIR")
236 "\"~/.guix-profile/share/doc/ghostscript\""))
237 ;; The docdir default changed in 9.23 and a compatibility
238 ;; symlink was added from datadir->docdir. Remove it.
239 (substitute* "base/unixinst.mak"
240 (("ln -s \\$\\(DESTDIR\\)\\$\\(docdir\\).*") ""))
241 #t))
242 (add-after 'configure 'patch-config-files
243 (lambda _
244 (substitute* "base/unixhead.mak"
245 (("/bin/sh") (which "sh")))
246 #t))
247 ,@(if (%current-target-system)
248 `((add-after 'configure 'add-native-lz
249 (lambda _
250 ;; Add missing '-lz' for native tools such as 'mkromfs'.
251 (substitute* "Makefile"
252 (("^AUXEXTRALIBS=(.*)$" _ value)
253 (string-append "AUXEXTRALIBS = -lz " value "\n")))
254 #t)))
255 '())
256 (replace 'build
257 (lambda _
258 ;; Build 'libgs.so', but don't build the statically-linked 'gs'
259 ;; binary (saves 22 MiB).
260 (invoke "make" "so" "-j"
261 (number->string (parallel-job-count)))))
262 (replace 'install
263 (lambda _
264 (invoke "make" "soinstall")))
265 (add-after 'install 'create-gs-symlink
266 (lambda* (#:key outputs #:allow-other-keys)
267 (let ((out (assoc-ref outputs "out")))
268 ;; Some programs depend on having a 'gs' binary available.
269 (symlink "gsc" (string-append out "/bin/gs"))
270 #t))))))
271 (native-inputs
272 `(("perl" ,perl)
273 ("pkg-config" ,pkg-config) ;needed for freetype
274 ("python" ,python-wrapper)
275 ("tcl" ,tcl)
276
277 ;; When cross-compiling, some of the natively-built tools require all
278 ;; these libraries.
279 ,@(if (%current-target-system)
280 `(("zlib/native" ,zlib)
281 ("libjpeg/native" ,libjpeg))
282 '())))
283 (inputs
284 `(("fontconfig" ,fontconfig)
285 ("freetype" ,freetype)
286 ("gs-fonts" ,gs-fonts)
287 ("jbig2dec" ,jbig2dec)
288 ("libjpeg" ,libjpeg)
289 ("libpaper" ,libpaper)
290 ("libpng" ,libpng)
291 ("libtiff" ,libtiff)
292 ("zlib" ,zlib)))
293 (synopsis "PostScript and PDF interpreter")
294 (description
295 "Ghostscript is an interpreter for the PostScript language and the PDF
296 file format. It also includes a C library that implements the graphics
297 capabilities of the PostScript language. It supports a wide variety of
298 output file formats and printers.")
299 (home-page "https://www.ghostscript.com/")
300 (license license:agpl3+)))
301
302 (define-public ghostscript/x
303 (package/inherit ghostscript
304 (name (string-append (package-name ghostscript) "-with-x"))
305 (inputs `(("libxext" ,libxext)
306 ("libxt" ,libxt)
307 ,@(package-inputs ghostscript)))))
308
309 (define-public ghostscript/cups
310 (package/inherit ghostscript
311 (name "ghostscript-with-cups")
312 (inputs `(("cups" ,cups-minimal)
313 ,@(package-inputs ghostscript)))))
314
315 (define-public ijs
316 (package
317 (name "ijs")
318 (version (package-version ghostscript))
319 (source (package-source ghostscript))
320 (build-system gnu-build-system)
321 (native-inputs
322 `(("libtool" ,libtool)
323 ("automake" ,automake)
324 ("autoconf" ,autoconf)))
325 (arguments
326 `(#:phases
327 (modify-phases %standard-phases
328 (add-after 'unpack 'autogen
329 (lambda _
330 ;; need to regenerate macros
331 (system* "autoreconf" "-if")
332 ;; do not run configure
333 (substitute* "autogen.sh"
334 (("^.*\\$srcdir/configure.*") ""))
335 (system* "bash" "autogen.sh")
336 ;; create configure script in ./ijs/
337 (chdir "ijs")
338 ;; do not run configure
339 (substitute* "autogen.sh"
340 (("^.*\\$srcdir/configure.*") "")
341 (("^ + && echo Now type.*$") ""))
342 (invoke "bash" "autogen.sh"))))))
343 (synopsis "IJS driver framework for inkjet and other raster devices")
344 (description
345 "IJS is a protocol for transmission of raster page images. This package
346 provides the reference implementation of the raster printer driver
347 architecture.")
348 (license license:expat)
349 (home-page (package-home-page ghostscript))))
350
351 (define-public gs-fonts
352 (package
353 (name "gs-fonts")
354 (version "8.11")
355 (source (origin
356 (method url-fetch)
357 (uri (string-append "mirror://sourceforge/gs-fonts/gs-fonts/"
358 version
359 "%20%28base%2035%2C%20GPL%29/ghostscript-fonts-std-"
360 version
361 ".tar.gz"))
362 (sha256 (base32
363 "00f4l10xd826kak51wsmaz69szzm2wp8a41jasr4jblz25bg7dhf"))))
364 (build-system gnu-build-system)
365 (arguments
366 `(#:tests? #f ; nothing to check, just files to copy
367
368 #:modules ((guix build gnu-build-system)
369 (guix build utils)
370 (srfi srfi-1))
371 #:phases
372 (modify-phases %standard-phases
373 (delete 'configure)
374 (delete 'build)
375 (replace 'install
376 (lambda* (#:key outputs #:allow-other-keys)
377 (let* ((out (assoc-ref outputs "out"))
378 (dir (string-append out "/share/fonts/type1/ghostscript")))
379 (mkdir-p dir)
380 (for-each
381 (lambda (file)
382 (copy-file file (string-append dir "/" file)))
383 (find-files "." "pfb|afm"))
384 #t))))))
385 (synopsis "Free replacements for the PostScript fonts")
386 (description
387 "Ghostscript fonts provides fonts and font metrics customarily distributed with
388 Ghostscript. It currently includes the 35 standard PostScript fonts.")
389 (license license:gpl2)
390 (home-page "https://sourceforge.net/projects/gs-fonts/")))
391
392 (define-public libspectre
393 (package
394 (name "libspectre")
395 (version "0.2.8")
396 (source (origin
397 (method url-fetch)
398 (uri (string-append "https://libspectre.freedesktop.org/releases/libspectre-"
399 version ".tar.gz"))
400 (sha256 (base32
401 "1a67iglsc3r05mzngyg9kb1gy8whq4fgsnyjwi7bqfw2i7rnl9b5"))))
402 (build-system gnu-build-system)
403 (inputs `(("ghostscript" ,ghostscript)))
404 (native-inputs `(("pkg-config" ,pkg-config)))
405 (synopsis "Postscript rendering library")
406 (description
407 "libspectre is a small library for rendering Postscript documents.
408 It provides a convenient easy to use API for handling and rendering
409 Postscript documents.")
410 (license license:gpl2+)
411 (home-page "https://www.freedesktop.org/wiki/Software/libspectre")))