Merge remote-tracking branch 'origin/master' into wip-texlive
[jackhill/guix/guix.git] / gnu / packages / mes.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2018, 2019 Jan Nieuwenhuizen <janneke@gnu.org>
3 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages mes)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages base)
24 #:use-module (gnu packages commencement)
25 #:use-module (gnu packages cross-base)
26 #:use-module (gnu packages gcc)
27 #:use-module (gnu packages graphviz)
28 #:use-module (gnu packages guile)
29 #:use-module (gnu packages man)
30 #:use-module (gnu packages package-management)
31 #:use-module (gnu packages perl)
32 #:use-module (gnu packages pkg-config)
33 #:use-module (gnu packages texinfo)
34 #:use-module (guix build-system gnu)
35 #:use-module (guix download)
36 #:use-module (guix git-download)
37 #:use-module (guix licenses)
38 #:use-module (guix packages))
39
40 (define-public nyacc-0.86
41 (package
42 (name "nyacc")
43 (version "0.86.0")
44 (source (origin
45 (method url-fetch)
46 (uri (string-append "mirror://savannah/nyacc/"
47 name "-" version ".tar.gz"))
48 (patches (search-patches "nyacc-binary-literals.patch"))
49 (sha256
50 (base32
51 "0lkd9lyspvhxlfs0496gsllwinh62jk9wij6gpadvx9gwz6yavd9"))))
52 (build-system gnu-build-system)
53 (native-inputs
54 `(("guile" ,guile-2.2)))
55 (synopsis "LALR(1) Parser Generator in Guile")
56 (description
57 "NYACC is an LALR(1) parser generator implemented in Guile.
58 The syntax and nomenclature should be considered not stable. It comes with
59 extensive examples, including parsers for the Javascript and C99 languages.")
60 (home-page "https://savannah.nongnu.org/projects/nyacc")
61 (license (list gpl3+ lgpl3+))))
62
63 (define-public nyacc
64 (package
65 (inherit nyacc-0.86)
66 (version "0.99.0")
67 (source (origin
68 (method url-fetch)
69 (uri (string-append "mirror://savannah/nyacc/nyacc-"
70 version ".tar.gz"))
71 (sha256
72 (base32
73 "0hl5qxx19i4x1r0839sxm19ziqq65g4hy97yik81cc2yb9yvgyv3"))
74 (modules '((guix build utils)))
75 (snippet
76 '(begin
77 (substitute* (find-files "." "^Makefile\\.in$")
78 (("^SITE_SCM_DIR =.*")
79 "SITE_SCM_DIR = \
80 @prefix@/share/guile/site/@GUILE_EFFECTIVE_VERSION@\n")
81 (("^SITE_SCM_GO_DIR =.*")
82 "SITE_SCM_GO_DIR = \
83 @prefix@/lib/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n")
84 (("^INFODIR =.*")
85 "INFODIR = @prefix@/share/info\n")
86 (("^DOCDIR =.*")
87 "DOCDIR = @prefix@/share/doc/$(PACKAGE_TARNAME)\n"))
88 #t))))
89 (native-inputs
90 `(("pkg-config" ,pkg-config)))
91 (inputs
92 `(("guile" ,guile-2.2)))))
93
94 (define-public mes
95 (package
96 (name "mes")
97 (version "0.20")
98 (source (origin
99 (method url-fetch)
100 (uri (string-append "mirror://gnu/mes/"
101 "mes-" version ".tar.gz"))
102 (sha256
103 (base32
104 "04pajp8v31na34ls4730ig5f6miiplhdvkmsb9ls1b8bbmw2vb4n"))))
105 (build-system gnu-build-system)
106 (supported-systems '("i686-linux" "x86_64-linux"))
107 (propagated-inputs
108 `(("mescc-tools" ,mescc-tools)
109 ("nyacc" ,nyacc)))
110 (native-inputs
111 `(("guile" ,guile-2.2)
112 ,@(let ((target-system (or (%current-target-system)
113 (%current-system))))
114 (cond
115 ((string-prefix? "x86_64-linux" target-system)
116 ;; Use cross-compiler rather than #:system "i686-linux" to get
117 ;; MesCC 64 bit .go files installed ready for use with Guile.
118 `(("i686-linux-binutils" ,(cross-binutils "i686-unknown-linux-gnu"))
119 ("i686-linux-gcc" ,(cross-gcc "i686-unknown-linux-gnu"))))
120 (else
121 '())))
122 ("graphviz" ,graphviz)
123 ("help2man" ,help2man)
124 ("perl" ,perl) ; build-aux/gitlog-to-changelog
125 ("texinfo" ,texinfo)))
126 (arguments
127 `(#:strip-binaries? #f)) ; binutil's strip b0rkes MesCC/M1/hex2 binaries
128 (synopsis "Scheme interpreter and C compiler for full source bootstrapping")
129 (description
130 "GNU Mes--Maxwell Equations of Software--brings the Reduced Binary Seed
131 bootstrap to Guix and aims to help create full source bootstrapping for
132 GNU/Linux distributions. It consists of a mutual self-hosting Scheme
133 interpreter in C and a Nyacc-based C compiler in Scheme and is compatible with
134 Guile.")
135 (home-page "https://gnu.org/software/mes")
136 (license gpl3+)))
137
138 (define-public mescc-tools
139 (package
140 (name "mescc-tools")
141 (version "0.6.1")
142 (source (origin
143 (method url-fetch)
144 (uri (string-append
145 "http://git.savannah.nongnu.org/cgit/mescc-tools.git/snapshot/"
146 name "-Release_" version
147 ".tar.gz"))
148 (file-name (string-append name "-" version ".tar.gz"))
149 (sha256
150 (base32
151 "06jpvq6xfjzn2al6b4rdwd3zv3h4cvilc4n9gqcnjr9cr6wjpw2n"))))
152 (build-system gnu-build-system)
153 (supported-systems '("i686-linux" "x86_64-linux"))
154 (arguments
155 `(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
156 "CC=gcc")
157 #:test-target "test"
158 #:phases (modify-phases %standard-phases
159 (delete 'configure))))
160 (synopsis "Tools for the full source bootstrapping process")
161 (description
162 "Mescc-tools is a collection of tools for use in a full source
163 bootstrapping process. It consists of the M1 macro assembler, the hex2
164 linker, the blood-elf symbol table generator, the kaem shell, exec_enable and
165 get_machine.")
166 (home-page "https://savannah.nongnu.org/projects/mescc-tools")
167 (license gpl3+)))