gnu: icecat: Add fixes for CVE-2016-{2818,2819,2821,2824,2828,2831}.
[jackhill/guix/guix.git] / gnu / packages / patches / icecat-CVE-2016-2818-pt6.patch
1 changeset: 312067:380ddd689680
2 user: Timothy Nikkel <tnikkel@gmail.com>
3 Date: Tue May 10 22:58:26 2016 -0500
4 summary: Bug 1261752. Part 1. r=mats a=ritu
5
6 diff -r 02df988a56ae -r 380ddd689680 view/nsViewManager.cpp
7 --- a/view/nsViewManager.cpp Thu May 26 10:06:15 2016 -0700
8 +++ b/view/nsViewManager.cpp Tue May 10 22:58:26 2016 -0500
9 @@ -416,7 +416,7 @@
10 if (aWidget->NeedsPaint()) {
11 // If an ancestor widget was hidden and then shown, we could
12 // have a delayed resize to handle.
13 - for (nsViewManager *vm = this; vm;
14 + for (RefPtr<nsViewManager> vm = this; vm;
15 vm = vm->mRootView->GetParent()
16 ? vm->mRootView->GetParent()->GetViewManager()
17 : nullptr) {