gnu: Add LV2 mda Piano plugin.
[jackhill/guix/guix.git] / gnu / packages / onc-rpc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages onc-rpc)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu))
24
25 (define-public libtirpc
26 (package
27 (name "libtirpc")
28 (version "0.2.4")
29 (source (origin
30 (method url-fetch)
31 (uri (string-append "mirror://sourceforge/libtirpc/"
32 version "/libtirpc-"
33 version ".tar.bz2"))
34 (sha256
35 (base32
36 "18a337wa4amf0k21wnimp3yzs5l3cxqndz4x3x8bm993zhfy5hs5"))))
37 (build-system gnu-build-system)
38 (arguments
39 '(;; Doesn't work with GNU GSS.
40 #:configure-flags '("--disable-gssapi")
41
42 #:phases (alist-cons-after
43 'unpack 'remote-dangling-symlink
44 (lambda _
45 ;; Remote the dangling symlinks since it breaks the
46 ;; 'patch-source-shebangs' file tree traversal.
47 (delete-file "INSTALL"))
48 %standard-phases)))
49 (home-page "http://sourceforge.net/projects/libtirpc/")
50 (synopsis "Transport-independent Sun/ONC RPC implementation")
51 (description
52 "This package provides a library that implements the Sun/ONC RPC (remote
53 procedure calls) protocol in a transport-independent manner. It supports both
54 IPv4 and IPv6. ONC RPC is notably used by the network file system (NFS).")
55 (license bsd-3)))