gnu: tryton: Updated to 4.6.2.
[jackhill/guix/guix.git] / gnu / packages / tryton.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages tryton)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (gnu packages)
22 #:use-module (gnu packages check)
23 #:use-module (gnu packages databases)
24 #:use-module (gnu packages gtk)
25 #:use-module (gnu packages python)
26 #:use-module (gnu packages python-web)
27 #:use-module (gnu packages time)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix build-system python))
31
32 (define-public trytond
33 (package
34 (name "trytond")
35 (version "4.6.2")
36 (source
37 (origin
38 (method url-fetch)
39 (uri (pypi-uri "trytond" version))
40 (sha256
41 (base32
42 "0asc3pd37h8ky8j66iqxr0fv0k6mpjcwxwm0xgm5hrdi32l5cdda"))))
43 (build-system python-build-system)
44 (inputs
45 `(("python-dateutil" ,python-dateutil)
46 ("python-genshi" ,python-genshi)
47 ("python-polib" ,python-polib)
48 ("python-magic" ,python-magic)
49 ;; there's no python-mysql in Guix right now
50 ;; so python-psycopg2 (postgresql) only for now
51 ("python-psycopg2" ,python-psycopg2)
52 ("python-relatorio" ,python-relatorio)
53 ("python-lxml" ,python-lxml)
54 ("python-sql" ,python-sql)
55 ("python-werkzeug" ,python-werkzeug)
56 ("python-wrapt" ,python-wrapt)))
57 (native-inputs
58 `(("python-mock" ,python-mock)))
59 (arguments
60 `(#:phases
61 (modify-phases %standard-phases
62 (add-before 'check 'preparations
63 (lambda _
64 (setenv "DB_NAME" ":memory:"))))))
65 (home-page "https://www.tryton.org/")
66 (synopsis "Server component of Tryton")
67 (description "Tryton is a three-tier high-level general purpose
68 application platform using PostgreSQL as its main database engine. It is the
69 core base of a complete business solution providing modularity, scalability
70 and security.")
71 (license license:gpl3+)))
72
73 (define-public tryton
74 (package
75 (name "tryton")
76 (version "4.6.2")
77 (source
78 (origin
79 (method url-fetch)
80 (uri (pypi-uri "tryton" version))
81 (sha256
82 (base32
83 "0bamr040np02gfjk8c734rw3mbgg75irfgpdcl2npgkdzyw1ksf9"))))
84 (build-system python-build-system)
85 (inputs
86 `(("python2-chardet" ,python2-chardet)
87 ("python2-dateutil" ,python2-dateutil)
88 ("python2-pygtk" ,python2-pygtk)))
89 (arguments
90 `(#:python ,python-2))
91 (home-page "https://www.tryton.org/")
92 (synopsis "Client component of Tryton")
93 (description "This package is the client component of Tryton.")
94 (license license:gpl3+)))