gnu: Add namespace-clean.
[jackhill/guix/guix.git] / gnu / packages / perl.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages perl)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix build-system perl))
29
30 ;;;
31 ;;; Please: Try to add new module packages in alphabetic order.
32 ;;;
33
34 \f
35 (define-public perl
36 ;; Yeah, Perl... It is required early in the bootstrap process by Linux.
37 (package
38 (name "perl")
39 (version "5.16.1")
40 (source (origin
41 (method url-fetch)
42 (uri (string-append "http://www.cpan.org/src/5.0/perl-"
43 version ".tar.gz"))
44 (sha256
45 (base32
46 "15qxzba3a50c9nik5ydgyfp62x7h9vxxn12yd1jgl93hb1wj96km"))
47 (patches (list (search-patch "perl-no-sys-dirs.patch")))))
48 (build-system gnu-build-system)
49 (arguments
50 '(#:tests? #f
51 #:phases
52 (alist-replace
53 'configure
54 (lambda* (#:key inputs outputs #:allow-other-keys)
55 (let ((out (assoc-ref outputs "out"))
56 (libc (assoc-ref inputs "libc")))
57 ;; Use the right path for `pwd'.
58 (substitute* "dist/Cwd/Cwd.pm"
59 (("/bin/pwd")
60 (which "pwd")))
61
62 (zero?
63 (system* "./Configure"
64 (string-append "-Dprefix=" out)
65 (string-append "-Dman1dir=" out "/share/man/man1")
66 (string-append "-Dman3dir=" out "/share/man/man3")
67 "-de" "-Dcc=gcc"
68 "-Uinstallusrbinperl"
69 "-Dinstallstyle=lib/perl5"
70 "-Duseshrplib"
71 (string-append "-Dlocincpth=" libc "/include")
72 (string-append "-Dloclibpth=" libc "/lib")))))
73 %standard-phases)))
74 (native-search-paths (list (search-path-specification
75 (variable "PERL5LIB")
76 (files '("lib/perl5/site_perl")))))
77 (synopsis "Implementation of the Perl programming language")
78 (description
79 "Perl 5 is a highly capable, feature-rich programming language with over
80 24 years of development.")
81 (home-page "http://www.perl.org/")
82 (license gpl1+))) ; or "Artistic"
83
84 (define-public perl-archive-zip
85 (package
86 (name "perl-archive-zip")
87 (version "1.30")
88 (source
89 (origin
90 (method url-fetch)
91 (uri (string-append
92 "mirror://cpan/authors/id/A/AD/ADAMK/Archive-Zip-"
93 version ".tar.gz"))
94 (sha256
95 (base32
96 "0633zah5z9njiqnvy3vh42fjymncmil1jdfb7d18w8xpfzzp5d7q"))))
97 (build-system perl-build-system)
98 (synopsis "Perl API to zip files")
99 (description "The Archive::Zip module allows a Perl program to create,
100 manipulate, read, and write Zip archive files.")
101 (home-page "http://search.cpan.org/~phred/Archive-Zip-1.37/lib/Archive/Zip.pm")
102 (license (package-license perl))))
103
104 (define-public perl-b-hooks-endofscope
105 (package
106 (name "perl-b-hooks-endofscope")
107 (version "0.13")
108 (source
109 (origin
110 (method url-fetch)
111 (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
112 "B-Hooks-EndOfScope-" version ".tar.gz"))
113 (sha256
114 (base32
115 "1f5d0lbkwf23dfjn60g6fynmjhy5rxdyxcpdfb07srm73qpg2zpi"))))
116 (build-system perl-build-system)
117 (propagated-inputs
118 `(("perl-module-runtime" ,perl-module-runtime)
119 ("perl-module-implementation" ,perl-module-implementation)
120 ("perl-sub-exporter-progressive" ,perl-sub-exporter-progressive)
121 ("perl-variable-magic" ,perl-variable-magic)))
122 (home-page "http://search.cpan.org/dist/B-Hooks-EndOfScope")
123 (synopsis "Execute code after a scope finished compilation")
124 (description "This module allows you to execute code when perl finished
125 compiling the surrounding scope.")
126 (license (package-license perl))))
127
128 (define-public perl-benchmark-timer
129 (package
130 (name "perl-benchmark-timer")
131 (version "0.7102")
132 (source (origin
133 (method url-fetch)
134 (uri (string-append "mirror://cpan/authors/id/D/DC/DCOPPIT/"
135 "Benchmark-Timer-" version ".tar.gz"))
136 (sha256
137 (base32
138 "1gl9ybm9hgia3ld5s11b7bv2p2hmx5rss5hxcfy6rmbzrjcnci01"))))
139 (build-system perl-build-system)
140 ;; The optional input module Statistics::PointEstimation (from
141 ;; Statistics-TTest) lists no license.
142 (synopsis "Benchmarking with statistical confidence")
143 (description
144 "The Benchmark::Timer class allows you to time portions of code
145 conveniently, as well as benchmark code by allowing timings of repeated
146 trials. It is perfect for when you need more precise information about the
147 running time of portions of your code than the Benchmark module will give you,
148 but don't want to go all out and profile your code.")
149 (home-page (string-append "http://search.cpan.org/~dcoppit/"
150 "Benchmark-Timer-" version))
151 (license gpl2)))
152
153 (define-public perl-capture-tiny
154 (package
155 (name "perl-capture-tiny")
156 (version "0.28")
157 (source
158 (origin
159 (method url-fetch)
160 (uri (string-append
161 "mirror://cpan/authors/id/D/DA/DAGOLDEN/Capture-Tiny-"
162 version ".tar.gz"))
163 (sha256
164 (base32
165 "117gmwipql1y5xnw9jil3lhdsrf2wsm9wjdzqj66x971n3fwm573"))))
166 (build-system perl-build-system)
167 (home-page "http://search.cpan.org/dist/Capture-Tiny")
168 (synopsis "Capture STDOUT and STDERR from Perl, XS or external programs")
169 (description
170 "Capture::Tiny provides a simple, portable way to capture almost anything
171 sent to STDOUT or STDERR, regardless of whether it comes from Perl, from XS
172 code or from an external program. Optionally, output can be teed so that it
173 is captured while being passed through to the original file handles.")
174 (license asl2.0)))
175
176 (define-public perl-clone
177 (package
178 (name "perl-clone")
179 (version "0.37")
180 (source (origin
181 (method url-fetch)
182 (uri (string-append "mirror://cpan/authors/id/G/GA/GARU/"
183 "Clone-" version ".tar.gz"))
184 (sha256
185 (base32
186 "17fdhxpzrq2nwim3zkcrz4m9gjixp0i886yz54ysrshxy3k53wnr"))))
187 (build-system perl-build-system)
188 (synopsis "Recursively copy Perl datatypes")
189 (description
190 "This module provides a clone() method which makes recursive copies of
191 nested hash, array, scalar and reference types, including tied variables and
192 objects.")
193 (home-page (string-append "http://search.cpan.org/~garu/"
194 "Clone-" version))
195 (license (package-license perl))))
196
197 (define-public perl-cpan-meta-check
198 (package
199 (name "perl-cpan-meta-check")
200 (version "0.009")
201 (source
202 (origin
203 (method url-fetch)
204 (uri (string-append "mirror://cpan/authors/id/L/LE/LEONT/"
205 "CPAN-Meta-Check-" version ".tar.gz"))
206 (sha256
207 (base32
208 "0qbk5dwvhd78qgq5x6nim2n0l78pylvlklpbrm56w9yss6pl6bgb"))))
209 (build-system perl-build-system)
210 (native-inputs `(("perl-test-deep" ,perl-test-deep)))
211 (propagated-inputs `(("perl-cpan-meta" ,perl-cpan-meta)))
212 (home-page "http://search.cpan.org/dist/CPAN-Meta-Check")
213 (synopsis "Verify requirements in a CPAN::Meta object")
214 (description "This module verifies if requirements described in a
215 CPAN::Meta object are present.")
216 (license (package-license perl))))
217
218 (define-public perl-data-optlist
219 (package
220 (name "perl-data-optlist")
221 (version "0.109")
222 (source
223 (origin
224 (method url-fetch)
225 (uri (string-append
226 "mirror://cpan/authors/id/R/RJ/RJBS/Data-OptList-"
227 version ".tar.gz"))
228 (sha256
229 (base32
230 "1j44rm2spprlq3bc80cxni3dzs3gfjiqv1qc9q7820n1qj0wgmqw"))))
231 (build-system perl-build-system)
232 (propagated-inputs
233 `(("perl-sub-install" ,perl-sub-install)
234 ("perl-params-util" ,perl-params-util)))
235 (home-page "http://search.cpan.org/dist/Data-OptList")
236 (synopsis "Parse and validate simple name/value option pairs")
237 (description
238 "Data::OptList provides a simple syntax for name/value option pairs.")
239 (license (package-license perl))))
240
241 (define-public perl-digest-sha1
242 (package
243 (name "perl-digest-sha1")
244 (version "2.13")
245 (source (origin
246 (method url-fetch)
247 (uri (string-append "mirror://cpan/authors/id/G/GA/GAAS/"
248 "Digest-SHA1-" version ".tar.gz"))
249 (sha256
250 (base32
251 "1k23p5pjk42vvzg8xcn4iwdii47i0qm4awdzgbmz08bl331dmhb8"))))
252 (build-system perl-build-system)
253 (synopsis "Perl implementation of the SHA-1 message digest algorithm")
254 (description
255 "This package provides 'Digest::SHA1', an implementation of the NIST
256 SHA-1 message digest algorithm for use by Perl programs.")
257 (home-page (string-append "http://search.cpan.org/~gaas/Digest-SHA1-"
258 version "/SHA1.pm"))
259 (license (package-license perl))))
260
261 (define-public perl-dist-checkconflicts
262 (package
263 (name "perl-dist-checkconflicts")
264 (version "0.11")
265 (source (origin
266 (method url-fetch)
267 (uri (string-append "mirror://cpan/authors/id/D/DO/DOY/"
268 "Dist-CheckConflicts-" version ".tar.gz"))
269 (sha256
270 (base32
271 "1i7dr9jpdiy2nijl2p4q5zg2q2s9ckbj2hs4kmnnckf9hsb4p17a"))))
272 (build-system perl-build-system)
273 (native-inputs `(("perl-test-fatal" ,perl-test-fatal)))
274 (propagated-inputs
275 `(("perl-module-runtime" ,perl-module-runtime)))
276 (home-page "http://search.cpan.org/dist/Dist-CheckConflicts")
277 (synopsis "Declare version conflicts for your dist")
278 (description "This module allows you to specify conflicting versions of
279 modules separately and deal with them after the module is done installing.")
280 (license (package-license perl))))
281
282 (define-public perl-exporter-lite
283 (package
284 (name "perl-exporter-lite")
285 (version "0.06")
286 (source (origin
287 (method url-fetch)
288 (uri (string-append "mirror://cpan/authors/id/N/NE/NEILB/"
289 "Exporter-Lite-" version ".tar.gz"))
290 (sha256
291 (base32
292 "0k4gkvid4fr8yvwj0axdx5111mzfw2iipls3qllxr364fqhmclpj"))))
293 (build-system perl-build-system)
294 (synopsis "Lightweight exporting of functions and variables")
295 (description
296 "Exporter::Lite is an alternative to Exporter, intended to provide a
297 lightweight subset of the most commonly-used functionality. It supports
298 import(), @EXPORT and @EXPORT_OK and not a whole lot else.")
299 (home-page (string-append "http://search.cpan.org/~neilb/"
300 "Exporter-Lite-" version))
301 (license (package-license perl))))
302
303 (define-public perl-file-list
304 (package
305 (name "perl-file-list")
306 (version "0.3.1")
307 (source (origin
308 (method url-fetch)
309 (uri (string-append
310 "mirror://cpan/authors/id/D/DO/DOPACKI/File-List-"
311 version ".tar.gz"))
312 (sha256
313 (base32
314 "00m5ax4aq59hdvav6yc4g63vhx3a57006rglyypagvrzfxjvm8s8"))))
315 (build-system perl-build-system)
316 (arguments
317 `(#:phases
318 (alist-cons-after
319 'unpack 'cd
320 (lambda* _
321 (chdir "List"))
322 %standard-phases)))
323 (license (package-license perl))
324 (synopsis "Perl extension for crawling directory trees and compiling
325 lists of files")
326 (description
327 "The File::List module crawls the directory tree starting at the
328 provided base directory and can return files (and/or directories if desired)
329 matching a regular expression.")
330 (home-page "http://search.cpan.org/~dopacki/File-List/")))
331
332 (define-public perl-file-which
333 (package
334 (name "perl-file-which")
335 (version "1.09")
336 (source (origin
337 (method url-fetch)
338 (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
339 "File-Which-" version ".tar.gz"))
340 (sha256
341 (base32
342 "1hxjyh9yrv32f3g8vrnr8iylzprajsac14vjm75kf1qnj1jyqbxp"))))
343 (build-system perl-build-system)
344 (native-inputs `(("test-script" ,perl-test-script)))
345 (synopsis "Portable implementation of the `which' utility")
346 (description
347 "File::Which was created to be able to get the paths to executable
348 programs on systems under which the `which' program wasn't implemented in the
349 shell.")
350 (home-page (string-append "http://search.cpan.org/~adamk/"
351 "File-Which-" version))
352 (license (package-license perl))))
353
354 (define-public perl-getopt-tabular
355 (package
356 (name "perl-getopt-tabular")
357 (version "0.3")
358 (source (origin
359 (method url-fetch)
360 (uri (string-append "mirror://cpan/authors/id/G/GW/GWARD/"
361 "Getopt-Tabular-" version ".tar.gz"))
362 (sha256
363 (base32
364 "0xskl9lcj07sdfx5dkma5wvhhgf5xlsq0khgh8kk34dm6dv0dpwv"))))
365 (build-system perl-build-system)
366 (synopsis "Table-driven argument parsing for Perl")
367 (description
368 "Getopt::Tabular is a Perl 5 module for table-driven argument parsing,
369 vaguely inspired by John Ousterhout's Tk_ParseArgv.")
370 (home-page (string-append "http://search.cpan.org/~gward/"
371 "Getopt-Tabular-" version))
372 (license (package-license perl))))
373
374 (define-public perl-io-tty
375 (package
376 (name "perl-io-tty")
377 (version "1.11")
378 (source (origin
379 (method url-fetch)
380 (uri (string-append "mirror://cpan/authors/id/T/TO/TODDR/IO-Tty-"
381 version ".tar.gz"))
382 (sha256
383 (base32
384 "0lgd9xcbi4gf4gw1ka6fj94my3w1f3k1zamb4pfln0qxz45zlxx4"))))
385 (build-system perl-build-system)
386 (home-page "http://search.cpan.org/~toddr/IO-Tty/")
387 (synopsis "Perl interface to pseudo ttys")
388 (description
389 "This package provides the 'IO::Pty' and 'IO::Tty' Perl interfaces to
390 pseudo ttys.")
391 (license (package-license perl))))
392
393 (define-public perl-ipc-run3
394 (package
395 (name "perl-ipc-run3")
396 (version "0.048")
397 (source (origin
398 (method url-fetch)
399 (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
400 "IPC-Run3-" version ".tar.gz"))
401 (sha256
402 (base32
403 "0r9m8q78bg7yycpixd7738jm40yz71p2q7inm766kzsw3g6c709x"))))
404 (build-system perl-build-system)
405 (synopsis "Run a subprocess with input/ouput redirection")
406 (description
407 "The IPC::Run3 module allows you to run a subprocess and redirect stdin,
408 stdout, and/or stderr to files and perl data structures. It aims to satisfy
409 99% of the need for using system, qx, and open3 with a simple, extremely
410 Perlish API and none of the bloat and rarely used features of IPC::Run.")
411 (home-page (string-append "http://search.cpan.org/~rjbs/"
412 "IPC-Run3-" version))
413 ;; "You may use this module under the terms of the BSD, Artistic, or GPL
414 ;; licenses, any version."
415 (license (list bsd-3 gpl3+))))
416
417 (define-public perl-module-implementation
418 (package
419 (name "perl-module-implementation")
420 (version "0.09")
421 (source
422 (origin
423 (method url-fetch)
424 (uri (string-append "mirror://cpan/authors/id/D/DR/DROLSKY/"
425 "Module-Implementation-" version ".tar.gz"))
426 (sha256
427 (base32
428 "0vfngw4dbryihqhi7g9ks360hyw8wnpy3hpkzyg0q4y2y091lpy1"))))
429 (build-system perl-build-system)
430 (native-inputs
431 `(("perl-test-fatal" ,perl-test-fatal)
432 ("perl-test-requires" ,perl-test-requires)))
433 (propagated-inputs
434 `(("perl-module-runtime" ,perl-module-runtime)
435 ("perl-try-tiny" ,perl-try-tiny)))
436 (home-page "http://search.cpan.org/dist/Module-Implementation")
437 (synopsis "Loads alternate underlying implementations for a module")
438 (description "This module abstracts out the process of choosing one of
439 several underlying implementations for a module. This can be used to provide
440 XS and pure Perl implementations of a module, or it could be used to load an
441 implementation for a given OS or any other case of needing to provide multiple
442 implementations.")
443 (license artistic2.0)))
444
445 (define-public perl-module-runtime
446 (package
447 (name "perl-module-runtime")
448 (version "0.014")
449 (source
450 (origin
451 (method url-fetch)
452 (uri (string-append "mirror://cpan/authors/id/Z/ZE/ZEFRAM/"
453 "Module-Runtime-" version ".tar.gz"))
454 (sha256
455 (base32
456 "19326f094jmjs6mgpwkyisid54k67w34br8yfh0gvaaml87gwi2c"))))
457 (build-system perl-build-system)
458 (home-page "http://search.cpan.org/dist/Module-Runtime")
459 (synopsis "Perl runtime module handling")
460 (description "The functions exported by this module deal with runtime
461 handling of Perl modules, which are normally handled at compile time.")
462 (license (package-license perl))))
463
464 (define-public perl-namespace-clean
465 (package
466 (name "perl-namespace-clean")
467 (version "0.25")
468 (source
469 (origin
470 (method url-fetch)
471 (uri (string-append "mirror://cpan/authors/id/R/RI/RIBASUSHI/"
472 "namespace-clean-" version ".tar.gz"))
473 (sha256
474 (base32
475 "016dds70ql1mp18b07chkxiy4drn976ibnbshqc2hmhrh9xjnsll"))))
476 (build-system perl-build-system)
477 (propagated-inputs
478 `(("perl-package-stash" ,perl-package-stash)
479 ("perl-b-hooks-endofscope" ,perl-b-hooks-endofscope)))
480 (home-page "http://search.cpan.org/dist/namespace-clean")
481 (synopsis "Keep imports and functions out of your namespace")
482 (description "The namespace::clean pragma will remove all previously
483 declared or imported symbols at the end of the current package's compile
484 cycle. Functions called in the package itself will still be bound by their
485 name, but they won't show up as methods on your class or instances.")
486 (license (package-license perl))))
487
488 (define-public perl-package-anon
489 (package
490 (name "perl-package-anon")
491 (version "0.05")
492 (source
493 (origin
494 (method url-fetch)
495 (uri (string-append "mirror://cpan/authors/id/A/AU/AUGGY/"
496 "Package-Anon-" version ".tar.gz"))
497 (sha256
498 (base32
499 "1fj1fakkfklf2iwzsl64vfgshya3jgm6vhxiphw12wlac9g2il0m"))))
500 (build-system perl-build-system)
501 (propagated-inputs
502 `(("perl-sub-exporter" ,perl-sub-exporter)
503 ("perl-params-util" ,perl-params-util)))
504 (home-page "http://search.cpan.org/dist/Package-Anon")
505 (synopsis "Anonymous packages")
506 (description "This module allows for anonymous packages that are
507 independent of the main namespace and only available through an object
508 instance, not by name.")
509 (license (package-license perl))))
510
511 (define-public perl-package-stash
512 (package
513 (name "perl-package-stash")
514 (version "0.37")
515 (source
516 (origin
517 (method url-fetch)
518 (uri (string-append "mirror://cpan/authors/id/D/DO/DOY/"
519 "Package-Stash-" version ".tar.gz"))
520 (sha256
521 (base32
522 "0b3vg2nbzmz1m5qla4123rmfzmpfmwxkw78fghvwsc4iiww0baq6"))))
523 (build-system perl-build-system)
524 (native-inputs
525 `(("perl-dist-checkconflicts" ,perl-dist-checkconflicts)
526 ("perl-test-fatal" ,perl-test-fatal)
527 ("perl-test-requires" ,perl-test-requires)
528 ("perl-package-anon" ,perl-package-anon)))
529 (propagated-inputs
530 `(("perl-module-implementation" ,perl-module-implementation)
531 ("perl-dist-checkconflicts" ,perl-dist-checkconflicts)
532 ("perl-package-stash-xs" ,perl-package-stash-xs)))
533 (home-page "http://search.cpan.org/dist/Package-Stash")
534 (synopsis "Routines for manipulating stashes")
535 (description "Manipulating stashes (Perl's symbol tables) is occasionally
536 necessary, but incredibly messy, and easy to get wrong. This module hides all
537 of that behind a simple API.")
538 (license (package-license perl))))
539
540 (define-public perl-package-stash-xs
541 (package
542 (name "perl-package-stash-xs")
543 (version "0.28")
544 (source
545 (origin
546 (method url-fetch)
547 (uri (string-append "mirror://cpan/authors/id/D/DO/DOY/"
548 "Package-Stash-XS-" version ".tar.gz"))
549 (sha256
550 (base32
551 "11nl69n8i56p91pd0ia44ip0vpv2cxwpbfakrv01vvv8az1cbn13"))))
552 (build-system perl-build-system)
553 (native-inputs
554 `(("perl-test-fatal" ,perl-test-fatal)
555 ("perl-test-requires" ,perl-test-requires)
556 ("perl-package-anon" ,perl-package-anon)))
557 (home-page "http://search.cpan.org/dist/Package-Stash-XS")
558 (synopsis "Faster implementation of the Package::Stash API")
559 (description "This is a backend for Package::Stash, which provides the
560 functionality in a way that's less buggy and much faster. It will be used by
561 default if it's installed, and should be preferred in all environments with a
562 compiler.")
563 (license (package-license perl))))
564
565 (define-public perl-params-util
566 (package
567 (name "perl-params-util")
568 (version "1.07")
569 (source
570 (origin
571 (method url-fetch)
572 (uri (string-append
573 "mirror://cpan/authors/id/A/AD/ADAMK/Params-Util-"
574 version ".tar.gz"))
575 (sha256
576 (base32
577 "0v67sx93yhn7xa0nh9mnbf8mixf54czk6wzrjsp6dzzr5hzyrw9h"))))
578 (build-system perl-build-system)
579 (home-page "http://search.cpan.org/dist/Params-Util")
580 (synopsis "Simple, compact and correct param-checking functions")
581 (description
582 "Params::Util provides a basic set of importable functions that makes
583 checking parameters easier.")
584 (license (package-license perl))))
585
586 (define-public perl-probe-perl
587 (package
588 (name "perl-probe-perl")
589 (version "0.03")
590 (source (origin
591 (method url-fetch)
592 (uri (string-append "mirror://cpan/authors/id/K/KW/KWILLIAMS/"
593 "Probe-Perl-" version ".tar.gz"))
594 (sha256
595 (base32
596 "0c9wiaz0mqqknafr4jdr0g2gdzxnn539182z0icqaqvp5qgd5r6r"))))
597 (build-system perl-build-system)
598 (synopsis "Information about the currently running perl")
599 (description
600 "Probe::Perl provides methods for obtaining information about the
601 currently running perl interpreter. It originally began life as code in the
602 Module::Build project, but has been externalized here for general use.")
603 (home-page (string-append "http://search.cpan.org/~kwilliams/"
604 "Probe-Perl-" version))
605 (license (package-license perl))))
606
607 (define-public perl-regexp-common
608 (package
609 (name "perl-regexp-common")
610 (version "2013031301")
611 (source (origin
612 (method url-fetch)
613 (uri (string-append "mirror://cpan/authors/id/A/AB/ABIGAIL/"
614 "Regexp-Common-" version ".tar.gz"))
615 (sha256
616 (base32
617 "112wybsm0vr8yfannx6sdfvgp5vza28gjgr3pgn69ak4sac836kj"))))
618 (build-system perl-build-system)
619 (synopsis "Provide commonly requested regular expressions")
620 (description
621 "This module exports a single hash (`%RE') that stores or generates
622 commonly needed regular expressions. Patterns currently provided include:
623 balanced parentheses and brackets, delimited text (with escapes), integers and
624 floating-point numbers in any base (up to 36), comments in 44 languages,
625 offensive language, lists of any pattern, IPv4 addresses, URIs, and Zip
626 codes.")
627 (home-page (string-append "http://search.cpan.org/~abigail/"
628 "Regexp-Common-" version))
629 ;; Quad-licensed: Perl Artistic, Perl Artistic 2.0, X11, and BSD.
630 (license (list (package-license perl) x11 bsd-3))))
631
632 (define-public perl-sub-exporter
633 (package
634 (name "perl-sub-exporter")
635 (version "0.987")
636 (source
637 (origin
638 (method url-fetch)
639 (uri (string-append
640 "mirror://cpan/authors/id/R/RJ/RJBS/Sub-Exporter-"
641 version ".tar.gz"))
642 (sha256
643 (base32
644 "1ml3n1ck4ln9qjm2mcgkczj1jb5n1fkscz9c4x23v4db0glb4g2l"))))
645 (build-system perl-build-system)
646 (propagated-inputs
647 `(("perl-data-optlist" ,perl-data-optlist)
648 ("perl-params-util" ,perl-params-util)))
649 (home-page "http://search.cpan.org/dist/Sub-Exporter")
650 (synopsis "Sophisticated exporter for custom-built routines")
651 (description
652 "Sub::Exporter provides a sophisticated alternative to Exporter.pm for
653 custom-built routines.")
654 (license (package-license perl))))
655
656 (define-public perl-sub-exporter-progressive
657 (package
658 (name "perl-sub-exporter-progressive")
659 (version "0.001011")
660 (source
661 (origin
662 (method url-fetch)
663 (uri (string-append "mirror://cpan/authors/id/F/FR/FREW/"
664 "Sub-Exporter-Progressive-" version ".tar.gz"))
665 (sha256
666 (base32
667 "01kwzbqwdhvadpphnczid03nlyj0h4cxaq3m3v2401bckkkcc606"))))
668 (build-system perl-build-system)
669 (native-inputs `(("perl-sub-exporter" ,perl-sub-exporter)))
670 (home-page "http://search.cpan.org/dist/Sub-Exporter-Progressive")
671 (synopsis "Only use Sub::Exporter if you need it")
672 (description "Sub::Exporter is an incredibly powerful module, but with
673 that power comes great responsibility, as well as some runtime penalties.
674 This module is a \"Sub::Exporter\" wrapper that will let your users just use
675 Exporter if all they are doing is picking exports, but use \"Sub::Exporter\"
676 if your users try to use \"Sub::Exporter\"'s more advanced features, like
677 renaming exports, if they try to use them.")
678 (license (package-license perl))))
679
680 (define-public perl-sub-install
681 (package
682 (name "perl-sub-install")
683 (version "0.928")
684 (source
685 (origin
686 (method url-fetch)
687 (uri (string-append
688 "mirror://cpan/authors/id/R/RJ/RJBS/Sub-Install-"
689 version ".tar.gz"))
690 (sha256
691 (base32
692 "03zgk1yh128gciyx3q77zxzxg9kf8yy2gm46gdxqi24mcykngrb1"))))
693 (build-system perl-build-system)
694 (home-page "http://search.cpan.org/dist/Sub-Install")
695 (synopsis "Install subroutines into packages easily")
696 (description
697 "Sub::Install makes it easy to install subroutines into packages without
698 the unsightly mess of C<no strict> or typeglobs lying about where just anyone
699 can see them.")
700 (license (package-license perl))))
701
702 (define-public perl-sys-cpu
703 (package
704 (name "perl-sys-cpu")
705 (version "0.61")
706 (source (origin
707 (method url-fetch)
708 (uri (string-append "mirror://cpan/authors/id/M/MZ/MZSANFORD/"
709 "Sys-CPU-" version ".tar.gz"))
710 (sha256
711 (base32
712 "1r6976bs86j7zp51m5vh42xlyah951jgdlkimv202413kjvqc2i5"))))
713 (build-system perl-build-system)
714 (synopsis "Perl extension for getting CPU information")
715 (description
716 "In responce to a post on perlmonks.org, a module for counting the number
717 of CPU's on a system. Support has now also been added for type of CPU and
718 clock speed.")
719 (home-page (string-append "http://search.cpan.org/~mzsanford/"
720 "Sys-CPU-" version))
721 (license (package-license perl))))
722
723 (define-public perl-test-deep
724 (package
725 (name "perl-test-deep")
726 (version "0.114")
727 (source (origin
728 (method url-fetch)
729 (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
730 "Test-Deep-" version ".tar.gz"))
731 (sha256
732 (base32
733 "09yr47vw7vj27sdik312x08938higcij8ybyq8k67mlccx8cpqf0"))))
734 (build-system perl-build-system)
735 (inputs `(("perl-test-tester" ,perl-test-tester)
736 ("perl-test-nowarnings" ,perl-test-nowarnings)))
737 (synopsis "Flexible deep comparison for the Test::Builder framework")
738 (description
739 "Test::Deep compares two structures by going through each level, ensuring
740 that the values match, that arrays and hashes have the same elements and that
741 references are blessed into the correct class. It also handles circular data
742 structures without getting caught in an infinite loop.")
743 (home-page (string-append "http://search.cpan.org/~rjbs/"
744 "Test-Deep-" version))
745 (license gpl1+))) ; or "Artistic License"
746
747 (define-public perl-test-fatal
748 (package
749 (name "perl-test-fatal")
750 (version "0.014")
751 (source
752 (origin
753 (method url-fetch)
754 (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
755 "Test-Fatal-" version ".tar.gz"))
756 (sha256
757 (base32
758 "1c6bs68mss4q7cyapkv2c0jn66i21050p0faxf3s3417gdffzp5w"))))
759 (build-system perl-build-system)
760 (propagated-inputs `(("perl-try-tiny" ,perl-try-tiny)))
761 (home-page "http://search.cpan.org/dist/Test-Fatal")
762 (synopsis "Simple helpers for testing code with exceptions")
763 (description "Test::Fatal is an alternative to the popular
764 Test::Exception. It does much less, but should allow greater flexibility in
765 testing exception-throwing code with about the same amount of typing.")
766 (license (package-license perl))))
767
768 (define-public perl-test-nowarnings
769 (package
770 (name "perl-test-nowarnings")
771 (version "1.04")
772 (source (origin
773 (method url-fetch)
774 (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
775 "Test-NoWarnings-" version ".tar.gz"))
776 (sha256
777 (base32
778 "0v385ch0hzz9naqwdw2az3zdqi15gka76pmiwlgsy6diiijmg2k3"))))
779 (build-system perl-build-system)
780 (inputs `(("perl-test-tester" ,perl-test-tester)))
781 (synopsis "Ensure no warnings are produced while testing")
782 (description
783 "This modules causes any warnings during testing to be captured and
784 stored. It automatically adds an extra test that will run when your script
785 ends to check that there were no warnings. If there were any warings, the
786 test will fail and output diagnostics of where, when and what the warning was,
787 including a stack trace of what was going on when it occurred.")
788 (home-page (string-append "http://search.cpan.org/~adamk/"
789 "Test-NoWarnings-" version))
790 (license lgpl2.1)))
791
792 (define-public perl-test-output
793 (package
794 (name "perl-test-output")
795 (version "1.03")
796 (source (origin
797 (method url-fetch)
798 (uri (string-append "mirror://cpan/authors/id/B/BD/BDFOY/"
799 "Test-Output-" version ".tar.gz"))
800 (sha256
801 (base32
802 "12991jnzj4cbw9whhprmqvnzd1ayii84g2mh8vxbjngwqrjsy41i"))))
803 (build-system perl-build-system)
804 (propagated-inputs
805 `(("perl-capture-tiny" ,perl-capture-tiny)
806 ("perl-test-tester" ,perl-test-tester)
807 ("perl-sub-exporter" ,perl-sub-exporter)))
808 (synopsis "Utilities to test STDOUT and STDERR messages")
809 (description
810 "Test::Output provides a simple interface for testing output sent to
811 STDOUT or STDERR. A number of different utilities are included to try and be
812 as flexible as possible to the tester.")
813 (home-page (string-append "http://search.cpan.org/~bdfoy/"
814 "Test-Output-" version))
815 (license (package-license perl))))
816
817 (define-public perl-test-requires
818 (package
819 (name "perl-test-requires")
820 (version "0.08")
821 (source
822 (origin
823 (method url-fetch)
824 (uri (string-append "mirror://cpan/authors/id/T/TO/TOKUHIROM/"
825 "Test-Requires-" version ".tar.gz"))
826 (sha256
827 (base32
828 "08c29m0dn34384mmmpqqlbb899zpbkkc01c2lsp31mch1frv9cg7"))))
829 (build-system perl-build-system)
830 (home-page "http://search.cpan.org/dist/Test-Requires")
831 (synopsis "Checks to see if the module can be loaded")
832 (description "Test::Requires checks to see if the module can be loaded.
833 If this fails, then rather than failing tests this skips all tests.")
834 (license (package-license perl))))
835
836 (define-public perl-test-script
837 (package
838 (name "perl-test-script")
839 (version "1.07")
840 (source (origin
841 (method url-fetch)
842 (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
843 "Test-Script-" version ".tar.gz"))
844 (sha256
845 (base32
846 "15pb4zzsnm33msc1syhig2bk05xqc0pckmfyahdwbd177bj5w7p2"))))
847 (build-system perl-build-system)
848 (propagated-inputs
849 `(("probe-perl" ,perl-probe-perl)
850 ("ipc-run3" ,perl-ipc-run3)))
851 (synopsis "Basic cross-platform tests for scripts")
852 (description
853 "The intent of the Test::Script module is to provide a series of basic
854 tests for 80% of the testing you will need to do for scripts in the script (or
855 bin as is also commonly used) paths of your Perl distribution.")
856 (home-page (string-append "http://search.cpan.org/~adamk/"
857 "Test-Script-" version))
858 (license (package-license perl))))
859
860 (define-public perl-test-simple
861 (package
862 (name "perl-test-simple")
863 (version "1.001014")
864 (source (origin
865 (method url-fetch)
866 (uri (string-append "mirror://cpan/authors/id/E/EX/EXODIST/"
867 "Test-Simple-" version ".tar.gz"))
868 (sha256
869 (base32
870 "0szi95shwwdvc4nqykzgx05g2m1001mjhvqqhjg5wypbi771992m"))))
871 (build-system perl-build-system)
872 (synopsis "Basic utilities for writing tests")
873 (description
874 "Test::Simple contains basic utilities for writing tests.")
875 (home-page (string-append "http://search.cpan.org/~exodist/"
876 "Test-Simple-" version))
877 (license (package-license perl))))
878
879 (define-public perl-test-tester
880 (package
881 (name "perl-test-tester")
882 (version "0.109")
883 (source (origin
884 (method url-fetch)
885 (uri (string-append "mirror://cpan/authors/id/F/FD/FDALY/"
886 "Test-Tester-" version ".tar.gz"))
887 (sha256
888 (base32
889 "0m9n28z09kq455r5nydj1bnr85lvmbfpcbjdkjfbpmfb5xgciiyk"))))
890 (build-system perl-build-system)
891 (synopsis "Simplify running Test::Builder tests")
892 (description
893 "Test::Tester allows testing of test modules based on Test::Builder with
894 a minimum of effort.")
895 (home-page (string-append "http://search.cpan.org/~fdaly/"
896 "Test-Tester-" version))
897 ;; "Under the same license as Perl itself"
898 (license (package-license perl))))
899
900 (define-public perl-test-warnings
901 (package
902 (name "perl-test-warnings")
903 (version "0.020")
904 (source
905 (origin
906 (method url-fetch)
907 (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
908 "Test-Warnings-" version ".tar.gz"))
909 (sha256
910 (base32
911 "1x262kybrdnbiiw53m1axp4zyh4lsfb9mm2shmpm8lwf7sp30isi"))))
912 (build-system perl-build-system)
913 (home-page "http://search.cpan.org/dist/Test-Warnings")
914 (synopsis "Test for warnings and the lack of them")
915 (description "This module is intended to be used as a drop-in replacement
916 for Test::NoWarnings. It also adds an extra test, but runs this test before
917 done_testing calculates the test count, rather than after. It does this by
918 hooking into done_testing as well as via an END block. You can declare a
919 plan, or not, and things will still Just Work.")
920 (license (package-license perl))))
921
922 (define-public perl-try-tiny
923 (package
924 (name "perl-try-tiny")
925 (version "0.22")
926 (source
927 (origin
928 (method url-fetch)
929 (uri (string-append "mirror://cpan/authors/id/D/DO/DOY/"
930 "Try-Tiny-" version ".tar.gz"))
931 (sha256
932 (base32
933 "068vdbpacfawc3lkfs0b82xxl27h3l0gj14iada3vlwk8rps9yv0"))))
934 (build-system perl-build-system)
935 (home-page "http://search.cpan.org/dist/Try-Tiny")
936 (synopsis "Minimal try/catch with proper preservation of $@")
937 (description "This module provides bare bones try/catch/finally statements
938 that are designed to minimize common mistakes with eval blocks, and nothing
939 else.")
940 (license x11)))
941
942 (define-public perl-variable-magic
943 (package
944 (name "perl-variable-magic")
945 (version "0.55")
946 (source
947 (origin
948 (method url-fetch)
949 (uri (string-append "mirror://cpan/authors/id/V/VP/VPIT/"
950 "Variable-Magic-" version ".tar.gz"))
951 (sha256
952 (base32
953 "0xzh2vy45ph80bp09j5fcjy8ydgn8yaxsa0fj831q6p1spvyniwg"))))
954 (build-system perl-build-system)
955 (home-page "http://search.cpan.org/dist/Variable-Magic")
956 (synopsis "Associate user-defined magic to variables from Perl")
957 (description "Magic is Perl's way of enhancing variables. This mechanism
958 lets the user add extra data to any variable and hook syntactical
959 operations (such as access, assignment or destruction) that can be applied to
960 it. With this module, you can add your own magic to any variable without
961 having to write a single line of XS.")
962 (license (package-license perl))))
963
964 \f
965 ;;; Some packaged modules need versions of core modules that are newer than
966 ;;; those in our perl 5.16.1.
967
968 (define-public perl-cpan-meta
969 (package
970 (name "perl-cpan-meta")
971 (version "2.143240")
972 (source
973 (origin
974 (method url-fetch)
975 (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
976 "CPAN-Meta-" version ".tar.gz"))
977 (sha256
978 (base32
979 "1d80bxphpp5dq7fx5ipxszn7j8q9d85w6fnapdrbym21k1vsmlf6"))))
980 (build-system perl-build-system)
981 (propagated-inputs
982 `(("perl-cpan-meta-requirements" ,perl-cpan-meta-requirements)
983 ("perl-cpan-meta-yaml" ,perl-cpan-meta-yaml)
984 ("perl-parse-cpan-meta" ,perl-parse-cpan-meta)))
985 (home-page "http://search.cpan.org/dist/CPAN-Meta")
986 (synopsis "Distribution metadata for a CPAN dist")
987 (description "Software distributions released to the CPAN include a
988 META.json or, for older distributions, META.yml, which describes the
989 distribution, its contents, and the requirements for building and installing
990 the distribution. The data structure stored in the META.json file is
991 described in CPAN::Meta::Spec. CPAN::Meta provides a simple class to
992 represent this distribution metadata (or distmeta), along with some helpful
993 methods for interrogating that data.")
994 (license (package-license perl))))
995
996 (define-public perl-cpan-meta-requirements
997 (package
998 (name "perl-cpan-meta-requirements")
999 (version "2.131")
1000 (source
1001 (origin
1002 (method url-fetch)
1003 (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
1004 "CPAN-Meta-Requirements-" version ".tar.gz"))
1005 (sha256
1006 (base32
1007 "12p5s7w3cwcrbpcrxzanvpr0syswhwlqzbaki6m044c45jix2fss"))))
1008 (build-system perl-build-system)
1009 (home-page "http://search.cpan.org/dist/CPAN-Meta-Requirements")
1010 (synopsis "Set of version requirements for a CPAN dist")
1011 (description "A CPAN::Meta::Requirements object models a set of version
1012 constraints like those specified in the META.yml or META.json files in CPAN
1013 distributions, and as defined by CPAN::Meta::Spec. It can be built up by
1014 adding more and more constraints, and will reduce them to the simplest
1015 representation.")
1016 (license (package-license perl))))
1017
1018 (define-public perl-cpan-meta-yaml
1019 (package
1020 (name "perl-cpan-meta-yaml")
1021 (version "0.012")
1022 (source
1023 (origin
1024 (method url-fetch)
1025 (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
1026 "CPAN-Meta-YAML-" version ".tar.gz"))
1027 (sha256
1028 (base32
1029 "0a0d62w8d81kkas4j1h48znk0f0vrpibl31gvz9r8hm77dbqqwkw"))))
1030 (build-system perl-build-system)
1031 (arguments
1032 `(#:tests? #f)) ;Tests require Test::More >= 0.99
1033 (home-page "http://search.cpan.org/dist/CPAN-Meta-YAML")
1034 (synopsis "Read and write a subset of YAML for CPAN Meta files")
1035 (description "This module implements a subset of the YAML specification
1036 for use in reading and writing CPAN metadata files like META.yml and
1037 MYMETA.yml.")
1038 (license (package-license perl))))
1039
1040 (define-public perl-parse-cpan-meta
1041 (package
1042 (name "perl-parse-cpan-meta")
1043 (version "1.4414")
1044 (source
1045 (origin
1046 (method url-fetch)
1047 (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
1048 "Parse-CPAN-Meta-" version ".tar.gz"))
1049 (sha256
1050 (base32
1051 "06ya2rg599qanqb1fxiyrd489mvmdgzbw4ph23hwjwpv9lahhxnd"))))
1052 (build-system perl-build-system)
1053 (propagated-inputs
1054 `(("perl-cpan-meta-yaml" ,perl-cpan-meta-yaml)))
1055 (home-page "http://search.cpan.org/dist/Parse-CPAN-Meta")
1056 (synopsis "Parse META.yml and META.json CPAN metadata files")
1057 (description "Parse::CPAN::Meta is a parser for META.json and META.yml
1058 files, using JSON::PP and/or CPAN::Meta::YAML.")
1059 (license (package-license perl))))
1060
1061 ;;; END: Core module overrides