gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / toys.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages toys)
20 #:use-module (gnu packages ncurses)
21 #:use-module (guix build-system gnu)
22 #:use-module (guix git-download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages))
25
26 (define-public sl
27 (package
28 (name "sl")
29 (version "5.02")
30 (source
31 (origin
32 (method git-fetch)
33 (uri (git-reference
34 (url "https://github.com/mtoyoda/sl.git")
35 (commit version)))
36 (file-name (git-file-name name version))
37 (sha256
38 (base32 "1zrfd71zx2px2xpapg45s8xvi81xii63yl0h60q72j71zh4sif8b"))))
39 (build-system gnu-build-system)
40 (inputs
41 `(("ncurses" ,ncurses)))
42 (arguments
43 `(#:phases
44 (modify-phases %standard-phases
45 (delete 'configure) ; no configure script
46 (delete 'check) ; no tests
47 (replace 'install ; no ‘make install’ target
48 (lambda* (#:key outputs #:allow-other-keys)
49 (let* ((out (assoc-ref outputs "out"))
50 (bin (string-append out "/bin"))
51 (man (string-append out "/share/man"))
52 (man1 (string-append man "/man1"))
53 (man1-ja (string-append man "/ja/man1")))
54 (install-file "sl" bin)
55 (install-file "sl.1" man1)
56 (mkdir-p man1-ja)
57 (copy-file "sl.1.ja" (string-append man1-ja "/sl.1"))
58 #t))))))
59 (home-page "http://www.tkl.iis.u-tokyo.ac.jp/~toyoda/index_e.html")
60 (synopsis "Joke command to correct typing \"sl\" by mistake")
61 (description
62 "@dfn{SL} (for Steam Locomotive) displays one of several animated trains
63 on the text terminal. It serves no useful purpose but to discourage mistakenly
64 typing @command{sl} instead of @command{ls}.")
65 (license (license:non-copyleft "file://LICENSE"
66 "See LICENSE in the distribution."))))