gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / tmux.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
5 ;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
6 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages tmux)
24 #:use-module (guix licenses)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix git-download)
28 #:use-module (guix build-system gnu)
29 #:use-module (gnu packages)
30 #:use-module (gnu packages libevent)
31 #:use-module (gnu packages ncurses))
32
33
34 (define-public tmux
35 (package
36 (name "tmux")
37 (version "2.8")
38 (source (origin
39 (method url-fetch)
40 (uri (string-append
41 "https://github.com/tmux/tmux/releases/download/"
42 version "/tmux-" version ".tar.gz"))
43 (sha256
44 (base32
45 "1fm22wva2znkcs5jczrnlxrpzsk2jlwdwy4dhzzyrbsgccsz6svz"))))
46 (build-system gnu-build-system)
47 (inputs
48 `(("libevent" ,libevent)
49 ("ncurses" ,ncurses)))
50 (home-page "http://tmux.github.io/")
51 (synopsis "Terminal multiplexer")
52 (description
53 "tmux is a terminal multiplexer: it enables a number of terminals (or
54 windows), each running a separate program, to be created, accessed, and
55 controlled from a single screen. tmux may be detached from a screen and
56 continue running in the background, then later reattached.")
57 (license isc)))
58
59 (define-public tmux-themepack
60 (let ((commit "03a372866f7677f7fe63bcee140b48b9fd372c48")
61 (revision "1"))
62 (package
63 (name "tmux-themepack")
64 (version
65 (string-append "0.0.0-" revision "." (string-take commit 7))) ;; No version tags
66 (source (origin
67 (method git-fetch)
68 (uri (git-reference
69 (url
70 (string-append "https://github.com/jimeh/" name ".git"))
71 (commit commit)))
72 (sha256
73 (base32
74 "1d3k87mq5lca042jbap5kxskjy3kg79wjhhpnm6jacbn3anc67zl"))
75 (file-name (string-append name "-" version "-checkout"))))
76 (build-system gnu-build-system)
77 (arguments
78 `(#:tests? #f ; No test suite.
79 #:phases (modify-phases %standard-phases
80 (delete 'configure)
81 (delete 'build)
82 (replace 'install
83 (lambda* (#:key outputs #:allow-other-keys)
84 (let* ((out (string-append
85 (assoc-ref outputs "out")
86 "/share/" ,name "-" ,version)))
87 (copy-recursively "." out)))))))
88 (home-page "https://github.com/jimeh/tmux-themepack")
89 (synopsis "Collection of themes for Tmux")
90 (description "A collection of various themes for Tmux.")
91 (license
92 (non-copyleft "http://www.wtfpl.net/txt/copying/")))))
93
94 (define-public tmuxifier
95 (package
96 (name "tmuxifier")
97 (version "0.13.0")
98 (source (origin
99 (method url-fetch)
100 (uri (string-append
101 "https://github.com/jimeh/tmuxifier/archive/v"
102 version ".tar.gz"))
103 (file-name (string-append name "-" version ".tar.gz"))
104 (sha256
105 (base32
106 "1j9fj6zg0j3sdn7svpybzsqh7876rv81zi437976kj7hxnyjkcz7"))))
107 (build-system gnu-build-system)
108 (arguments
109 `(#:tests? #f
110 #:phases (modify-phases %standard-phases
111 (delete 'configure)
112 (delete 'build)
113 (replace 'install
114 (lambda* (#:key outputs #:allow-other-keys)
115 (let* ((out (assoc-ref %outputs "out"))
116 (bindir (string-append out "/bin"))
117 (share (string-append out "/share/" ,name)))
118 (install-file "bin/tmuxifier" bindir)
119 (substitute* (string-append bindir "/tmuxifier")
120 (("set -e")
121 (string-append "TMUXIFIER=" share "\nset -e")))
122 (for-each (lambda (init-script)
123 (install-file init-script (string-append
124 share "/init")))
125 '("init.sh" "init.tcsh" "init.fish"))
126 (for-each (lambda (dir)
127 (copy-recursively dir (string-append
128 share "/" dir)))
129 '("completion" "lib" "libexec"
130 "templates"))))))))
131 (home-page "https://github.com/jimeh/tmuxifier")
132 (synopsis "Powerful session, window & pane management for Tmux")
133 (description "Tmuxifier allows you to easily create, edit, and load
134 @code{layout} files, which are simple shell scripts where you use the tmux
135 command and helper commands provided by tmuxifier to manage Tmux sessions and
136 windows.")
137 (license expat)))