gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / php.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Julien Lepiller <julien@lepiller.eu>
3 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
6 ;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages php)
24 #:use-module (gnu packages)
25 #:use-module (gnu packages algebra)
26 #:use-module (gnu packages aspell)
27 #:use-module (gnu packages base)
28 #:use-module (gnu packages bison)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages curl)
31 #:use-module (gnu packages cyrus-sasl)
32 #:use-module (gnu packages databases)
33 #:use-module (gnu packages fontutils)
34 #:use-module (gnu packages gd)
35 #:use-module (gnu packages gettext)
36 #:use-module (gnu packages glib)
37 #:use-module (gnu packages gnupg)
38 #:use-module (gnu packages image)
39 #:use-module (gnu packages linux)
40 #:use-module (gnu packages multiprecision)
41 #:use-module (gnu packages openldap)
42 #:use-module (gnu packages pcre)
43 #:use-module (gnu packages pkg-config)
44 #:use-module (gnu packages readline)
45 #:use-module (gnu packages textutils)
46 #:use-module (gnu packages tls)
47 #:use-module (gnu packages web)
48 #:use-module (gnu packages xml)
49 #:use-module (gnu packages xorg)
50 #:use-module (guix packages)
51 #:use-module (guix download)
52 #:use-module (guix build-system gnu)
53 #:use-module (guix utils)
54 #:use-module ((guix licenses) #:prefix license:))
55
56 (define-public php
57 (package
58 (name "php")
59 (version "7.3.0")
60 (home-page "https://secure.php.net/")
61 (source (origin
62 (method url-fetch)
63 (uri (string-append home-page "distributions/"
64 name "-" version ".tar.xz"))
65 (sha256
66 (base32
67 "1db0lm84hynilrjj3k1s7skp1y2gl4ip1ihr7662i2xgannmq6bx"))
68 (modules '((guix build utils)))
69 (snippet
70 '(with-directory-excursion "ext"
71 (for-each delete-file-recursively
72 ;; Some of the bundled libraries have no proper upstream.
73 ;; Ideally we'd extract these out as separate packages:
74 ;;"mbstring/libmbfl"
75 ;;"date/lib"
76 ;;"bcmath/libbcmath"
77 ;;"fileinfo/libmagic" ; This is a patched version of libmagic.
78 '("gd/libgd"
79 "mbstring/oniguruma"
80 "pcre/pcre2lib"
81 "sqlite3/libsqlite"
82 "xmlrpc/libxmlrpc"
83 "zip/lib"))
84 #t))))
85 (build-system gnu-build-system)
86 (arguments
87 '(#:configure-flags
88 (let-syntax ((with (syntax-rules ()
89 ((_ option input)
90 (string-append option "="
91 (assoc-ref %build-inputs input))))))
92 (list (with "--with-bz2" "bzip2")
93 (with "--with-curl" "curl")
94 (with "--with-freetype-dir" "freetype")
95 (with "--with-gd" "gd")
96 (with "--with-gdbm" "gdbm")
97 (with "--with-gettext" "glibc") ; libintl.h
98 (with "--with-gmp" "gmp")
99 (with "--with-jpeg-dir" "libjpeg")
100 (with "--with-ldap" "openldap")
101 (with "--with-ldap-sasl" "cyrus-sasl")
102 (with "--with-libzip" "zip")
103 (with "--with-libxml-dir" "libxml2")
104 (with "--with-onig" "oniguruma")
105 (with "--with-pcre-dir" "pcre")
106 (with "--with-pcre-regex" "pcre")
107 (with "--with-pdo-pgsql" "postgresql")
108 (with "--with-pdo-sqlite" "sqlite")
109 (with "--with-pgsql" "postgresql")
110 (with "--with-png-dir" "libpng")
111 ;; PHP’s Pspell extension, while retaining its current name,
112 ;; now uses the Aspell library.
113 (with "--with-pspell" "aspell")
114 (with "--with-readline" "readline")
115 (with "--with-sqlite3" "sqlite")
116 (with "--with-tidy" "tidy")
117 (with "--with-webp-dir" "libwebp")
118 (with "--with-xpm-dir" "libxpm")
119 (with "--with-xsl" "libxslt")
120 (with "--with-zlib-dir" "zlib")
121 ;; We could add "--with-snmp", but it requires netsnmp that
122 ;; we don't have a package for. It is used to build the snmp
123 ;; extension of php.
124 "--with-iconv"
125 "--with-openssl"
126 "--with-mysqli" ; Required for, e.g. wordpress
127 "--with-pdo-mysql"
128 "--with-zlib"
129 "--enable-bcmath" ; Required for, e.g. Zabbix frontend
130 "--enable-calendar"
131 "--enable-dba=shared"
132 "--enable-exif"
133 "--enable-flatfile"
134 "--enable-fpm"
135 "--enable-ftp"
136 "--enable-inifile"
137 "--enable-mbstring"
138 "--enable-pcntl"
139 "--enable-sockets"))
140 #:phases
141 (modify-phases %standard-phases
142 (add-after 'unpack 'do-not-record-build-flags
143 (lambda _
144 ;; Prevent configure flags from being stored and causing
145 ;; unnecessary runtime dependencies.
146 (substitute* "scripts/php-config.in"
147 (("@CONFIGURE_OPTIONS@") "")
148 (("@PHP_LDFLAGS@") ""))
149 ;; This file has ISO-8859-1 encoding.
150 (with-fluids ((%default-port-encoding "ISO-8859-1"))
151 (substitute* "main/build-defs.h.in"
152 (("@CONFIGURE_COMMAND@") "(omitted)")))
153 #t))
154 (add-before 'build 'patch-/bin/sh
155 (lambda _
156 (substitute* '("run-tests.php" "ext/standard/proc_open.c")
157 (("/bin/sh") (which "sh")))
158 #t))
159 (add-before 'check 'prepare-tests
160 (lambda _
161 ;; Some of these files have ISO-8859-1 encoding, whereas others
162 ;; use ASCII, so we can't use a "catch-all" find-files here.
163 (with-fluids ((%default-port-encoding "ISO-8859-1"))
164 (substitute* '("ext/mbstring/tests/mb_send_mail02.phpt"
165 "ext/mbstring/tests/mb_send_mail04.phpt"
166 "ext/mbstring/tests/mb_send_mail05.phpt"
167 "ext/mbstring/tests/mb_send_mail06.phpt")
168 (("/bin/cat") (which "cat"))))
169 (substitute* '("ext/mbstring/tests/mb_send_mail01.phpt"
170 "ext/mbstring/tests/mb_send_mail03.phpt"
171 "ext/mbstring/tests/bug52861.phpt"
172 "ext/standard/tests/general_functions/bug34794.phpt"
173 "ext/standard/tests/general_functions/bug44667.phpt"
174 "ext/standard/tests/general_functions/proc_open.phpt")
175 (("/bin/cat") (which "cat")))
176
177 ;; The encoding of this file is not recognized, so we simply drop it.
178 (delete-file "ext/mbstring/tests/mb_send_mail07.phpt")
179
180 (substitute* "ext/standard/tests/streams/bug60602.phpt"
181 (("'ls'") (string-append "'" (which "ls") "'")))
182
183 ;; Drop tests that are known to fail.
184 (for-each delete-file
185 '("ext/posix/tests/posix_getgrgid.phpt" ; Requires /etc/group.
186 "ext/sockets/tests/bug63000.phpt" ; Fails to detect OS.
187 "ext/sockets/tests/socket_shutdown.phpt" ; Requires DNS.
188 "ext/sockets/tests/socket_send.phpt" ; Likewise.
189 "ext/sockets/tests/mcast_ipv4_recv.phpt" ; Requires multicast.
190 ;; These needs /etc/services.
191 "ext/standard/tests/general_functions/getservbyname_basic.phpt"
192 "ext/standard/tests/general_functions/getservbyport_basic.phpt"
193 "ext/standard/tests/general_functions/getservbyport_variation1.phpt"
194 ;; And /etc/protocols.
195 "ext/standard/tests/network/getprotobyname_basic.phpt"
196 "ext/standard/tests/network/getprotobynumber_basic.phpt"
197 ;; And exotic locales.
198 "ext/standard/tests/strings/setlocale_basic1.phpt"
199 "ext/standard/tests/strings/setlocale_basic2.phpt"
200 "ext/standard/tests/strings/setlocale_basic3.phpt"
201 "ext/standard/tests/strings/setlocale_variation1.phpt"
202
203 ;; XXX: These gd tests fails. Likely because our version
204 ;; is different from the (patched) bundled one.
205 ;; Here, gd quits immediately after "fatal libpng error"; while the
206 ;; test expects it to additionally return a "setjmp" error and warning.
207 "ext/gd/tests/bug39780_extern.phpt"
208 "ext/gd/tests/libgd00086_extern.phpt"
209 ;; Extra newline in gd-png output.
210 "ext/gd/tests/bug45799.phpt"
211 ;; Different error message than expected from imagecrop().
212 "ext/gd/tests/bug66356.phpt"
213 ;; Similarly for imagecreatefromgd2().
214 "ext/gd/tests/bug72339.phpt"
215 ;; Call to undefined function imageantialias(). They are
216 ;; supposed to fail anyway.
217 "ext/gd/tests/bug72482.phpt"
218 "ext/gd/tests/bug72482_2.phpt"
219 "ext/gd/tests/bug73213.phpt"
220 ;; Test expects generic "gd warning" but gets the actual function name.
221 "ext/gd/tests/createfromwbmp2_extern.phpt"
222 ;; This bug should have been fixed in gd 2.2.2.
223 ;; Is it a regression?
224 "ext/gd/tests/bug65148.phpt"
225 ;; TODO: Enable these when libgd is built with xpm support.
226 "ext/gd/tests/xpm2gd.phpt"
227 "ext/gd/tests/xpm2jpg.phpt"
228 "ext/gd/tests/xpm2png.phpt"
229
230 ;; XXX: These iconv tests have the expected outcome,
231 ;; but with different error messages.
232 ;; Expects "illegal character", instead gets "unknown error (84)".
233 "ext/iconv/tests/bug52211.phpt"
234 "ext/iconv/tests/bug60494.phpt"
235 ;; Expects "wrong charset", gets unknown error (22).
236 "ext/iconv/tests/iconv_mime_decode_variation3.phpt"
237 "ext/iconv/tests/iconv_strlen_error2.phpt"
238 "ext/iconv/tests/iconv_strlen_variation2.phpt"
239 "ext/iconv/tests/iconv_substr_error2.phpt"
240 ;; Expects conversion error, gets "error condition Termsig=11".
241 "ext/iconv/tests/iconv_strpos_error2.phpt"
242 "ext/iconv/tests/iconv_strrpos_error2.phpt"
243 ;; Similar, but iterating over multiple values.
244 ;; iconv breaks the loop after the first error with Termsig=11.
245 "ext/iconv/tests/iconv_strpos_variation4.phpt"
246 "ext/iconv/tests/iconv_strrpos_variation3.phpt"
247 ;; Expects "invalid multibyte sequence" but got
248 ;; "unknown error".
249 "ext/iconv/tests/bug76249.phpt"
250
251 ;; XXX: These test failures appear legitimate, needs investigation.
252 ;; open_basedir() restriction failure.
253 "ext/curl/tests/bug61948.phpt"
254 ;; Expects a false boolean, gets empty array from glob().
255 "ext/standard/tests/file/bug41655_1.phpt"
256 "ext/standard/tests/file/glob_variation5.phpt"
257 ;; Test output is correct, but in wrong order.
258 "ext/standard/tests/streams/proc_open_bug64438.phpt"
259 ;; The test expects an Array, but instead get the contents(?).
260 "ext/gd/tests/bug43073.phpt"
261 ;; imagettftext() returns wrong coordinates.
262 "ext/gd/tests/bug48732-mb.phpt"
263 "ext/gd/tests/bug48732.phpt"
264 ;; Similarly for imageftbbox().
265 "ext/gd/tests/bug48801-mb.phpt"
266 "ext/gd/tests/bug48801.phpt"
267 ;; Different expected output from imagecolorallocate().
268 "ext/gd/tests/bug53504.phpt"
269 ;; Wrong image size after scaling an image.
270 "ext/gd/tests/bug73272.phpt"
271 ;; Expects iconv to detect illegal characters, instead gets
272 ;; "unknown error (84)" and heap corruption(!).
273 "ext/iconv/tests/bug48147.phpt"
274 ;; Expects illegal character ".", gets "=?utf-8?Q?."
275 "ext/iconv/tests/bug51250.phpt"
276 ;; @iconv() does not return expected output.
277 "ext/iconv/tests/iconv003.phpt"
278 ;; iconv throws "buffer length exceeded" on some string checks.
279 "ext/iconv/tests/iconv_mime_encode.phpt"
280 ;; file_get_contents(): iconv stream filter
281 ;; ("ISO-8859-1"=>"UTF-8") unknown error.
282 "ext/standard/tests/file/bug43008.phpt"
283 ;; Table data not created in sqlite(?).
284 "ext/pdo_sqlite/tests/bug_42589.phpt"
285
286 ;; Small variation in output.
287 "ext/mbstring/tests/mb_ereg_variation3.phpt"
288 "ext/mbstring/tests/mb_ereg_replace_variation1.phpt"
289 "ext/mbstring/tests/bug72994.phpt"
290 "ext/ldap/tests/ldap_set_option_error.phpt"
291
292 ;; Sometimes cannot start the LDAP server.
293 "ext/ldap/tests/bug76248.phpt"
294
295 ;; Bug #76909 preg_match difference between 7.3 and < 7.3
296 "ext/pcre/tests/bug76909.phpt"))
297
298 ;; Skip tests requiring network access.
299 (setenv "SKIP_ONLINE_TESTS" "1")
300 ;; Without this variable, 'make test' passes regardless of failures.
301 (setenv "REPORT_EXIT_STATUS" "1")
302 ;; Skip tests requiring I/O facilities that are unavailable in the
303 ;; build environment
304 (setenv "SKIP_IO_CAPTURE_TESTS" "1")
305 #t)))
306 #:test-target "test"))
307 (inputs
308 `(("aspell" ,aspell)
309 ("bzip2" ,bzip2)
310 ("curl" ,curl)
311 ("cyrus-sasl" ,cyrus-sasl)
312 ("freetype" ,freetype)
313 ("gd" ,gd)
314 ("gdbm" ,gdbm)
315 ("glibc" ,glibc)
316 ("gmp" ,gmp)
317 ("gnutls" ,gnutls)
318 ("libgcrypt" ,libgcrypt)
319 ("libjpeg" ,libjpeg)
320 ("libpng" ,libpng)
321 ("libwebp" ,libwebp)
322 ("libxml2" ,libxml2)
323 ("libxpm" ,libxpm)
324 ("libxslt" ,libxslt)
325 ("libx11" ,libx11)
326 ("oniguruma" ,oniguruma-5)
327 ("openldap" ,openldap)
328 ("openssl" ,openssl)
329 ("pcre" ,pcre2)
330 ("postgresql" ,postgresql)
331 ("readline" ,readline)
332 ("sqlite" ,sqlite)
333 ("tidy" ,tidy)
334 ("zip" ,zip)
335 ("zlib" ,zlib)))
336 (native-inputs
337 `(("pkg-config" ,pkg-config)
338 ("bison" ,bison)
339 ("intltool" ,intltool)
340 ("procps" ,procps))) ; For tests.
341 (synopsis "PHP programming language")
342 (description
343 "PHP (PHP Hypertext Processor) is a server-side (CGI) scripting
344 language designed primarily for web development but is also used as
345 a general-purpose programming language. PHP code may be embedded into
346 HTML code, or it can be used in combination with various web template
347 systems, web content management systems and web frameworks." )
348 (license (list
349 (license:non-copyleft "file://LICENSE") ; The PHP license.
350 (license:non-copyleft "file://Zend/LICENSE") ; The Zend license.
351 license:lgpl2.1 ; ext/mbstring/libmbfl
352 license:lgpl2.1+ ; ext/bcmath/libbcmath
353 license:bsd-2 ; ext/fileinfo/libmagic
354 license:expat)))) ; ext/date/lib
355
356 (define-public php-with-bcmath
357 (deprecated-package "php-with-bcmath" php))