gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / perl-web.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages perl-web)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (gnu packages)
23 #:use-module (guix packages)
24 #:use-module (gnu packages perl-check)
25 #:use-module (guix download)
26 #:use-module (guix build-system perl))
27
28 (define-public perl-mojolicious
29 (package
30 (name "perl-mojolicious")
31 (version "7.59")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append "mirror://cpan/authors/id/S/SR/SRI/Mojolicious-"
36 version ".tar.gz"))
37 (sha256
38 (base32
39 "11whfrbafj191ahbhlhadws0vkg9kmvqswzkvswgwajhr1x678rh"))))
40 (build-system perl-build-system)
41 (home-page "http://mojolicious.org/")
42 (synopsis "Real-time web framework")
43 (description "Back in the early days of the web, many people learned Perl
44 because of a wonderful Perl library called @code{CGI}. It was simple enough
45 to get started without knowing much about the language and powerful enough to
46 keep you going, learning by doing was much fun. While most of the techniques
47 used are outdated now, the idea behind it is not. Mojolicious is a new
48 endeavor to implement this idea using modern technologies.")
49 (license license:artistic2.0)))
50
51 (define-public perl-uri-escape
52 (package
53 (name "perl-uri-escape")
54 (version "1.74")
55 (source
56 (origin
57 (method url-fetch)
58 (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/URI-"
59 version ".tar.gz"))
60 (sha256
61 (base32
62 "0gfmrpyy075pn2mbshs5599h8m096gjdz2dn8vcivjw9bzs59hm9"))))
63 (build-system perl-build-system)
64 (native-inputs
65 `(("perl-test-needs" ,perl-test-needs)))
66 (home-page "https://github.com/libwww-perl/URI")
67 (synopsis "Percent-encode and percent-decode unsafe characters")
68 (description "This module provides functions to percent-encode and
69 percent-decode URI strings as defined by RFC 3986. Percent-encoding URI's is
70 informally called URI escaping. This is the terminology used by this module,
71 which predates the formalization of the terms by the RFC by several years.")
72 (license license:perl-license)))