gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / nutrition.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages nutrition)
22 #:use-module (guix packages)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (guix build-system python)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages databases)
28 #:use-module (gnu packages gtk)
29 #:use-module (gnu packages glib)
30 #:use-module (gnu packages image)
31 #:use-module (gnu packages python))
32
33 (define-public gourmet
34 (package
35 (name "gourmet")
36 (version "0.17.4")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "https://github.com/thinkle/gourmet/archive/"
41 version ".tar.gz"))
42 (file-name (string-append name "-" version ".tar.gz"))
43 (sha256
44 (base32
45 "1qvz175arzqm10lpfx8ffadrgirs3240zzqcp0h7sl53qfwx7v8k"))))
46 (build-system python-build-system)
47 (native-inputs
48 `(("distutils-extra" ,python2-distutils-extra)
49 ("intltool" ,intltool)
50 ("python-pygtk" ,python2-pygtk))) ;for tests
51 ;; TODO: Add python-reportlab and/or python-poppler for printing/pdf
52 ;; export, and python-beautifulsoup for web import plugin.
53 (inputs
54 `(("pygtk" ,python2-pygtk)
55 ("sqlalchemy" ,python2-sqlalchemy)
56 ("python-lxml" ,python2-lxml)
57 ("python-pillow" ,python2-pillow)
58 ("elib.intl" ,python2-elib.intl)))
59 (arguments
60 `(#:python ,python-2 ;exception and print syntax
61 #:tests? #f ;tests look bitrotted
62 #:phases
63 (modify-phases %standard-phases
64 (replace 'install
65 (lambda* (#:key make-flags #:allow-other-keys)
66 (invoke "python" "setup.py" "install" "--prefix"
67 (assoc-ref %outputs "out")))))))
68 (home-page "https://thinkle.github.io/gourmet/")
69 (synopsis "Recipe organizer")
70 (description
71 "Gourmet Recipe Manager is a recipe organizer that allows you to collect,
72 search, organize, and browse your recipes. Gourmet can also generate shopping
73 lists and calculate nutritional information. It imports Mealmaster,
74 MasterCook and KRecipe files and exports PDFs, webpages, and other formats.")
75 (license gpl2+)))