gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / lolcode.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Nils Gillmann <ng0@n0.is>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages lolcode)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages python)
22 #:use-module (gnu packages readline)
23 #:use-module (guix build-system cmake)
24 #:use-module (guix download)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages))
27
28 (define-public lci
29 (package
30 (name "lci")
31 (version "0.11.2")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "https://github.com/justinmeza/lci/archive/v"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "1li7ikcrs7wqah7gqkirg0k61n6pm12w7pydin966x1sdn9na46b"))
39 (file-name (string-append name "-" version ".tar.gz"))))
40 (build-system cmake-build-system)
41 (inputs
42 `(("readline" ,readline)))
43 (native-inputs
44 `(("python-2" ,python-2))) ; for the tests
45 (synopsis "LOLCODE interpreter written in C")
46 (description
47 "@code{lci} is a LOLCODE interpreter written in C and is designed to be
48 correct, portable, fast, and precisely documented.
49 @enumerate
50 @item correct: Every effort has been made to test lci's conformance to the
51 LOLCODE language specification. Unit tests come packaged with the lci source code.
52 @item portable: lci follows the widely ported ANSI C specification allowing it
53 to compile on a broad range of systems.
54 @item fast: Much effort has gone into producing simple and efficient code
55 whenever possible to the extent that the above points are not compromized.
56 @end enumerate")
57 (home-page "http://lolcode.org/")
58 (license license:gpl3+)))