gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / gprolog.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2013 Mark H Weaver <mhw@netris.org>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages gprolog)
21 #:use-module (guix download)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix build-system gnu)
25 #:use-module (srfi srfi-1))
26
27 (define-public gprolog
28 (package
29 (name "gprolog")
30 (version "1.4.5")
31 (source
32 (origin
33 (method url-fetch)
34 ;; Recent versions are not hosted on the GNU mirrors.
35 (uri (list (string-append "http://gprolog.org/gprolog-" version
36 ".tar.gz")
37 (string-append "mirror://gnu/gprolog/gprolog-" version
38 ".tar.gz")))
39 (sha256
40 (base32
41 "0z4cc42n3k6i35b8mr816iwsvrpxshw6d7dgz6s2h1hy0l7g1p5z"))))
42 (build-system gnu-build-system)
43 (arguments
44 `(#:configure-flags
45 (list (string-append
46 "--with-install-dir=" %output "/share/gprolog"))
47 #:phases
48 (modify-phases %standard-phases
49 (add-before 'configure 'change-dir-n-fix-shells
50 (lambda _
51 (chdir "src")
52 (substitute* "configure"
53 (("-/bin/sh") (string-append "-" (which "sh")))
54 (("= /bin/sh") (string-append "= " (which "sh"))))
55 #t)))))
56 (home-page "https://www.gnu.org/software/gprolog/")
57 (synopsis "Prolog compiler")
58 (description
59 "GNU Prolog is a standards-compliant Prolog compiler with constraint
60 solving over finite domains. It accepts Prolog+ constraint programs and
61 produces a compiled, native binary which can function in a stand-alone
62 manner. It also features an interactive interpreter.")
63 (license (list gpl2+ lgpl3+))
64
65 ;; See 'configure' for the list of supported architectures.
66 (supported-systems (fold delete
67 %supported-systems
68 '("armhf-linux" "mips64el-linux")))))