gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / gdb.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages gdb)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages ncurses)
24 #:use-module (gnu packages readline)
25 #:use-module (gnu packages dejagnu)
26 #:use-module (gnu packages texinfo)
27 #:use-module (gnu packages multiprecision)
28 #:use-module (gnu packages xml)
29 #:use-module (gnu packages guile)
30 #:use-module (gnu packages python)
31 #:use-module (gnu packages pkg-config)
32 #:use-module ((guix licenses) #:select (gpl3+))
33 #:use-module (guix packages)
34 #:use-module (guix download)
35 #:use-module (guix build-system gnu))
36
37 (define-public gdb
38 (package
39 (name "gdb")
40 (version "8.2")
41 (source (origin
42 (method url-fetch)
43 (uri (string-append "mirror://gnu/gdb/gdb-"
44 version ".tar.xz"))
45 (sha256
46 (base32
47 "0fbw6j4z7kmvywwgavn7w3knp860i5i9qnjffc5p52bwkji43963"))))
48 (build-system gnu-build-system)
49 (arguments
50 `(#:tests? #f ; FIXME "make check" fails on single-processor systems.
51
52 #:modules ((srfi srfi-1)
53 ,@%gnu-build-system-modules)
54
55 #:phases (modify-phases %standard-phases
56 (add-after
57 'configure 'post-configure
58 (lambda _
59 (for-each patch-makefile-SHELL
60 (find-files "." "Makefile\\.in"))
61 #t))
62 (add-after
63 'install 'remove-libs-already-in-binutils
64 (lambda* (#:key inputs outputs #:allow-other-keys)
65 ;; Like Binutils, GDB installs libbfd, libopcodes, etc.
66 ;; However, this leads to collisions when both are
67 ;; installed, and really is none of its business,
68 ;; conceptually. So remove them.
69 (let* ((binutils (assoc-ref inputs "binutils"))
70 (out (assoc-ref outputs "out"))
71 (files1 (with-directory-excursion binutils
72 (append (find-files "lib")
73 (find-files "include"))))
74 (files2 (with-directory-excursion out
75 (append (find-files "lib")
76 (find-files "include"))))
77 (common (lset-intersection string=?
78 files1 files2)))
79 (with-directory-excursion out
80 (for-each delete-file common)
81 #t)))))))
82 (inputs
83 `(("expat" ,expat)
84 ("mpfr" ,mpfr)
85 ("gmp" ,gmp)
86 ("readline" ,readline)
87 ("ncurses" ,ncurses)
88 ("guile" ,guile-2.0)
89 ("python" ,python)
90 ("python-wrapper" ,python-wrapper)
91 ("dejagnu" ,dejagnu)
92
93 ;; Allow use of XML-formatted syscall information. This enables 'catch
94 ;; syscall' and similar commands.
95 ("libxml2" ,libxml2)))
96 (native-inputs
97 `(("texinfo" ,texinfo)
98 ("pkg-config" ,pkg-config)))
99 (home-page "https://www.gnu.org/software/gdb/")
100 (synopsis "The GNU debugger")
101 (description
102 "GDB is the GNU debugger. With it, you can monitor what a program is
103 doing while it runs or what it was doing just before a crash. It allows you
104 to specify the runtime conditions, to define breakpoints, and to change how
105 the program is running to try to fix bugs. It can be used to debug programs
106 written in C, C++, Ada, Objective-C, Pascal and more.")
107 (license gpl3+)))