gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / dav.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2017 Leo Famulari <leo@famulari.name>
3 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages dav)
21 #:use-module (guix build-system python)
22 #:use-module (guix download)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages check)
27 #:use-module (gnu packages python)
28 #:use-module (gnu packages python-web))
29
30 (define-public radicale
31 (package
32 (name "radicale")
33 (version "1.1.6")
34 (source (origin
35 (method url-fetch)
36 (uri (pypi-uri "Radicale" version))
37 (sha256
38 (base32
39 "0ay90nj6fmr2aq8imi0mbjl4m2rzq7a83ikj8qs9gxsylj71j1y0"))))
40 (build-system python-build-system)
41 (arguments
42 '(#:tests? #f)) ; The tests are not distributed in the PyPi release.
43 (propagated-inputs
44 ;; TODO: Add python-pam
45 `(("python-requests" ,python-requests)))
46 (synopsis "Basic CalDAV and CardDAV server")
47 (description "Radicale is a CalDAV and CardDAV server for UNIX-like
48 platforms. Calendars and address books are available for both local and remote
49 access, possibly limited through authentication policies. They can be viewed
50 and edited by calendar and contact clients on mobile phones or computers.
51
52 Radicale intentionally does not fully comply with the CalDAV and CardDAV RFCs.
53 Instead, it supports the CalDAV and CardDAV implementations of popular
54 clients.")
55 (home-page "http://radicale.org/")
56 (license gpl3+)))
57
58 (define-public vdirsyncer
59 (package
60 (name "vdirsyncer")
61 (version "0.16.7")
62 (source (origin
63 (method url-fetch)
64 (uri (pypi-uri name version))
65 (sha256
66 (base32
67 "1vqjhn2bffy2bx45a1r14crsyn2cylf5by567g44c4mhpjwwz6vc"))))
68 (build-system python-build-system)
69 (arguments
70 `(#:phases (modify-phases %standard-phases
71 (replace 'check
72 (lambda* (#:key inputs outputs #:allow-other-keys)
73 (add-installed-pythonpath inputs outputs)
74 (setenv "DETERMINISTIC_TESTS" "true")
75 (setenv "DAV_SERVER" "radicale")
76 (setenv "REMOTESTORAGE_SERVER" "skip")
77 (invoke "make" "test")))
78 (add-after 'install 'manpage
79 (lambda* (#:key inputs outputs #:allow-other-keys)
80 (invoke "make" "--directory=docs/" "man")
81 (install-file
82 "docs/_build/man/vdirsyncer.1"
83 (string-append
84 (assoc-ref outputs "out")
85 "/share/man/man1"))
86 #t)))))
87 (native-inputs
88 `(("python-setuptools-scm" ,python-setuptools-scm)
89 ("python-sphinx" ,python-sphinx)
90 ;; Required for testing
91 ("python-hypothesis" ,python-hypothesis)
92 ("python-pytest" ,python-pytest)
93 ("python-pytest-localserver" ,python-pytest-localserver)
94 ("python-pytest-subtesthack" ,python-pytest-subtesthack)
95 ("python-urllib3" ,python-urllib3)
96 ("python-wsgi-intercept" ,python-wsgi-intercept)
97 ("radicale" ,radicale)))
98 (propagated-inputs
99 `(("python-atomicwrites" ,python-atomicwrites)
100 ("python-click" ,python-click)
101 ("python-click-log" ,python-click-log)
102 ("python-click-threading" ,python-click-threading)
103 ("python-requests-toolbelt" ,python-requests-toolbelt)))
104 (synopsis "Synchronize calendars and contacts")
105 (description "Vdirsyncer synchronizes your calendars and addressbooks
106 between two storage locations. The most popular purpose is to
107 synchronize a CalDAV or CardDAV server with a local folder or file. The
108 local data can then be accessed via a variety of programs, none of which
109 have to know or worry about syncing to a server.")
110 (home-page "https://github.com/pimutils/vdirsyncer")
111 (license bsd-3)))