gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / bison.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages bison)
21 #:use-module (guix licenses)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages m4)
26 #:use-module (gnu packages perl)
27 #:use-module (gnu packages flex)
28 #:use-module (srfi srfi-1))
29
30 (define-public bison
31 (package
32 (name "bison")
33 (version "3.0.5")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append "mirror://gnu/bison/bison-"
38 version ".tar.xz"))
39 (sha256
40 (base32
41 "0f7kjygrckkx8vas2nm673592jif0a9mw5g8207f6hj6h4pfyp07"))))
42 (build-system gnu-build-system)
43 (native-inputs `(("perl" ,perl)
44 ;; m4 is not present in PATH when cross-building.
45 ("m4" ,m4)))
46 (inputs `(("flex" ,flex)))
47 (propagated-inputs `(("m4" ,m4)))
48 (home-page "https://www.gnu.org/software/bison/")
49 (synopsis "Parser generator")
50 (description
51 "GNU Bison is a general-purpose parser generator. It can build a
52 deterministic or generalized LR parser from an annotated, context-free
53 grammar. It is versatile enough to have many applications, from parsers for
54 simple tools through complex programming languages.")
55 (license gpl3+)))