gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / ada.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages ada)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix build-system gnu)
22 #:use-module (guix build-system python)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix git-download)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages check)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages python))
30
31 (define-public python2-langkit
32 (let ((commit "fe0bc8bf60dbd2937759810df76ac420d99fc15f")
33 (revision "0"))
34 (package
35 (name "python2-langkit")
36 (version (git-version "0.0.0" revision commit))
37 (source (origin
38 (method git-fetch)
39 (uri (git-reference
40 (url "https://github.com/AdaCore/langkit.git")
41 (commit commit)))
42 (sha256
43 (base32
44 "1abqgw2p8pb1pm54my5kkbbixfhc6l0bwajdv1xlzyrh31xki3wx"))
45 (file-name (string-append name "-" version "-checkout"))))
46 (build-system python-build-system)
47 (propagated-inputs
48 `(("python2-docutils" ,python2-docutils)
49 ("python2-enum34" ,python2-enum34)
50 ("python2-funcy" ,python2-funcy)
51 ("python2-mako" ,python2-mako)))
52 (arguments
53 `(#:python ,python-2
54 #:tests? #f)) ; Tests would requite gprbuild (Ada).
55 (synopsis "Semantic analysis tool generator in Python")
56 (description "@code{Langkit} is a tool whose purpose is to make it easy
57 to create syntactic and semantic analysis engines. Write a language
58 specification in our Python DSL and Langkit will generate for you an
59 Ada library with bindings for the C and Python programming languages.")
60 (home-page "https://github.com/AdaCore/langkit/")
61 (license license:gpl3+)))) ; and gcc runtime library exception
62
63 (define-public python2-libadalang
64 (let ((commit "9b205e9bacdd50a68117727332e16fbef5f6ac49")
65 (revision "0"))
66 (package
67 (name "python2-libadalang")
68 (version (git-version "0.0.0" revision commit))
69 (source (origin
70 (method git-fetch)
71 (uri (git-reference
72 (url "https://github.com/AdaCore/libadalang.git")
73 (commit commit)))
74 (sha256
75 (base32
76 "06hsnzj2syqpq2yhg1bb0zil7ydbyqkdmkjbf8j9b5sdgkyh5xrp"))
77 (file-name (string-append name "-" version "-checkout"))))
78 (build-system python-build-system)
79 (native-inputs
80 `(("python2-langkit" ,python2-langkit)
81 ("python2-quex" ,python2-quex-0.67.3)))
82 (arguments
83 `(#:python ,python-2
84 #:phases
85 (modify-phases %standard-phases
86 (replace 'build
87 (lambda _
88 (invoke "python2" "ada/manage.py" "generate")
89 (invoke "python2" "ada/manage.py" "build")))
90 (replace 'check
91 (lambda _
92 (invoke "python2" "ada/manage.py" "test")))
93 (replace 'install
94 (lambda* (#:key outputs #:allow-other-keys)
95 (let* ((out (assoc-ref outputs "out")))
96 (invoke "python2" "ada/manage.py" "install" out)))))))
97 (synopsis "Semantic Analysis for Ada in Python")
98 (description "@code{libadalang} provides a high-performance semantic
99 engine for the Ada programming language.")
100 (home-page "https://github.com/AdaCore/libadalang")
101 (license license:gpl3)))) ; and gcc runtime gcc lib exception