gnu: wordnet: Compile with optimizations.
[jackhill/guix/guix.git] / gnu / packages / wordnet.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages wordnet)
21 #:use-module (guix packages)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages tcl))
27
28 (define-public wordnet
29 (package
30 (name "wordnet")
31 (version "3.0")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "http://wordnetcode.princeton.edu/"
35 version "/WordNet-" version ".tar.bz2"))
36 (sha256
37 (base32
38 "08pgjvd2vvmqk3h641x63nxp7wqimb9r30889mkyfh2agc62sjbc"))
39 (patches (search-patches
40 "wordnet-CVE-2008-2149.patch"
41 "wordnet-CVE-2008-3908-pt1.patch"
42 "wordnet-CVE-2008-3908-pt2.patch"))))
43 (build-system gnu-build-system)
44 (arguments
45 `(#:configure-flags (list (string-append "--with-tcl="
46 (assoc-ref %build-inputs "tcl")
47 "/lib")
48 (string-append "--with-tk="
49 (assoc-ref %build-inputs "tk")
50 "/lib")
51
52 ;; Provide the `result' field in `Tcl_Interp'.
53 ;; See <https://bugs.gentoo.org/show_bug.cgi?id=452034>.
54 "CFLAGS=-DUSE_INTERP_RESULT -O2")
55 #:phases
56 (modify-phases %standard-phases
57 (add-after 'install 'post-install
58 (lambda* (#:key inputs outputs #:allow-other-keys)
59 (let ((out (assoc-ref outputs "out"))
60 (bin (assoc-ref outputs "tk"))
61 (tk (assoc-ref inputs "tk"))
62 (tkv ,(let ((v (package-version tk)))
63 (string-take v (string-index-right v #\.)))))
64 ;; Move `wishwn' and `wnb' to BIN.
65 (for-each (lambda (prog)
66 (let ((orig (string-append out "/bin/" prog))
67 (dst (string-append bin "/bin/" prog))
68 (dir (string-append tk "/lib/tk" tkv)))
69 (mkdir-p (dirname dst))
70 (copy-file orig dst)
71 (delete-file orig)
72 (wrap-program dst
73 `("TK_LIBRARY" "" = (,dir))
74 `("PATH" ":" prefix
75 (,(string-append out
76 "/bin"))))))
77 '("wishwn" "wnb"))
78 #t))))))
79 (outputs '("out"
80 "tk")) ; for the Tcl/Tk GUI
81 (inputs `(("tk" ,tk)
82 ("tcl" ,tcl)))
83 (home-page "http://wordnet.princeton.edu/")
84 (synopsis "Lexical database for the English language")
85 (description
86 "WordNet is a large lexical database of English. Nouns, verbs,
87 adjectives and adverbs are grouped into sets of cognitive synonyms (synsets),
88 each expressing a distinct concept. Synsets are interlinked by means of
89 conceptual-semantic and lexical relations. The resulting network of
90 meaningfully related words and concepts can be navigated with the browser.
91 WordNet is also freely and publicly available for download. WordNet's
92 structure makes it a useful tool for computational linguistics and natural
93 language processing.")
94 (license x11)))