Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / upnp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages upnp)
20 #:use-module (gnu packages)
21 #:use-module (gnu packages python)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix download)
24 #:use-module (guix licenses)
25 #:use-module (guix packages))
26
27 (define-public miniupnpc
28 (package
29 (name "miniupnpc")
30 (version "1.9")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append
35 "http://miniupnp.tuxfamily.org/files/miniupnpc-"
36 version ".tar.gz"))
37 (sha256
38 (base32 "0r24jdqcyf839n30ppimdna0hvybscyziaad7ng99fw0x19y88r9"))))
39 (build-system gnu-build-system)
40 (native-inputs
41 `(("python" ,python-2)))
42 (arguments
43 ;; The build system does not use a configure script but depends on
44 ;; `make'. Hence we should pass parameters to `make' instead and remove
45 ;; the configure phase.
46 '(#:make-flags
47 (list
48 (string-append
49 "SH=" (assoc-ref %build-inputs "bash") "/bin/sh")
50 (string-append "INSTALLPREFIX=" (assoc-ref %outputs "out"))
51 "CC=gcc"
52
53 ;; Allow executables to find libminiupnpc.so.
54 (string-append "LDFLAGS=-Wl,-rpath="
55 (assoc-ref %outputs "out") "/lib"))
56 #:phases
57 (alist-delete 'configure %standard-phases)))
58 (home-page "http://miniupnp.free.fr/")
59 (synopsis "Library implementing the client side UPnP protocol")
60 (description
61 "MiniUPnPc is a library is useful whenever an application needs to listen
62 for incoming connections but is run behind a UPnP enabled router or firewall.
63 Examples for such applications include: P2P applications, FTP clients for
64 active mode, IRC (for DCC) or IM applications, network games, any server
65 software.")
66 (license
67 (x11-style "file://LICENSE" "See 'LICENSE' file in the distribution"))))