gnu: Add ruby-puma.
[jackhill/guix/guix.git] / gnu / packages / patches / pygpgme-disable-problematic-tests.patch
1 These tests require a gpg agent to run, and are difficult to get to work right
2 in Guix's environment. For more details, see:
3 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=713074
4 https://bugs.launchpad.net/pygpgme/+bug/999949
5
6 --- pygpgme-0.3/tests/test_encrypt_decrypt.py 2012-02-28 19:10:28.000000000 -0800
7 +++ pygpgme-0.3/tests/test_encrypt_decrypt.py 2016-02-05 10:21:58.966685384 -0800
8 @@ -125,7 +125,7 @@
9 ctx.decrypt(ciphertext, plaintext)
10 self.assertEqual(plaintext.getvalue(), b'Hello World\n')
11
12 - def test_encrypt_symmetric(self):
13 + def skip_test_encrypt_symmetric(self):
14 plaintext = BytesIO(b'Hello World\n')
15 ciphertext = BytesIO()
16 def passphrase(uid_hint, passphrase_info, prev_was_bad, fd):
17
18 --- pygpgme-0.3/tests/test_passphrase.py 2012-02-28 19:04:17.000000000 -0800
19 +++ pygpgme-0.3/tests/test_passphrase.py 2016-02-05 10:21:47.990630956 -0800
20 @@ -30,7 +30,7 @@
21
22 import_keys = ['passphrase.pub', 'passphrase.sec']
23
24 - def test_sign_without_passphrase_cb(self):
25 + def skip_test_sign_without_passphrase_cb(self):
26 ctx = gpgme.Context()
27 key = ctx.get_key('EFB052B4230BBBC51914BCBB54DCBBC8DBFB9EB3')
28 ctx.signers = [key]
29 @@ -51,7 +51,7 @@
30 self.prev_was_bad = prev_was_bad
31 os.write(fd, b'test\n')
32
33 - def test_sign_with_passphrase_cb(self):
34 + def skip_test_sign_with_passphrase_cb(self):
35 ctx = gpgme.Context()
36 key = ctx.get_key('EFB052B4230BBBC51914BCBB54DCBBC8DBFB9EB3')
37 ctx.signers = [key]