gnu: biber: Update to 2.12.
[jackhill/guix/guix.git] / gnu / packages / patches / make-impure-dirs.patch
1 Purity: don't look for library dependencies (of the form `-lfoo') in
2 /lib and /usr/lib. Likewise, when searching for included Makefiles,
3 don't look in /usr/include and friends.
4
5 Patch from Nixpkgs, by Eelco Dolstra.
6
7 diff -rc make-3.81-orig/src/read.c make-3.81/src/read.c
8 *** make-3.81-orig/src/read.c 2006-03-17 15:24:20.000000000 +0100
9 --- make-3.81/src/read.c 2007-05-24 17:16:31.000000000 +0200
10 ***************
11 *** 99,107 ****
12 --- 99,109 ----
13 #endif
14 INCLUDEDIR,
15 #ifndef _AMIGA
16 + #if 0
17 "/usr/gnu/include",
18 "/usr/local/include",
19 "/usr/include",
20 + #endif
21 #endif
22 0
23 };
24 diff -rc make-3.81-orig/src/remake.c make-3.81/src/remake.c
25 *** make-3.81-orig/src/remake.c 2006-03-20 03:36:37.000000000 +0100
26 --- make-3.81/src/remake.c 2007-05-24 17:06:54.000000000 +0200
27 ***************
28 *** 1452,1460 ****
29 --- 1452,1462 ----
30 static char *dirs[] =
31 {
32 #ifndef _AMIGA
33 + #if 0
34 "/lib",
35 "/usr/lib",
36 #endif
37 + #endif
38 #if defined(WINDOWS32) && !defined(LIBDIR)
39 /*
40 * This is completely up to the user at product install time. Just define