gnu: Add python-pychm.
[jackhill/guix/guix.git] / gnu / packages / ebook.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
5 ;;; Copyright © 2017, 2019, 2020 Brendan Tildesley <mail@brendan.scot>
6 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
7 ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
8 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
9 ;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
10 ;;; Copyright © 2020 Zheng Junjie <873216071@qq.com>
11 ;;;
12 ;;; This file is part of GNU Guix.
13 ;;;
14 ;;; GNU Guix is free software; you can redistribute it and/or modify it
15 ;;; under the terms of the GNU General Public License as published by
16 ;;; the Free Software Foundation; either version 3 of the License, or (at
17 ;;; your option) any later version.
18 ;;;
19 ;;; GNU Guix is distributed in the hope that it will be useful, but
20 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
21 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
22 ;;; GNU General Public License for more details.
23 ;;;
24 ;;; You should have received a copy of the GNU General Public License
25 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
26
27 (define-module (gnu packages ebook)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (guix packages)
30 #:use-module (guix download)
31 #:use-module (guix utils)
32 #:use-module (guix git-download)
33 #:use-module (guix build-system cmake)
34 #:use-module (guix build-system gnu)
35 #:use-module (guix build-system meson)
36 #:use-module (guix build-system python)
37 #:use-module (gnu packages)
38 #:use-module (gnu packages compression)
39 #:use-module (gnu packages curl)
40 #:use-module (gnu packages databases)
41 #:use-module (gnu packages file)
42 #:use-module (gnu packages fonts)
43 #:use-module (gnu packages fontutils)
44 #:use-module (gnu packages freedesktop)
45 #:use-module (gnu packages fribidi)
46 #:use-module (gnu packages gcc)
47 #:use-module (gnu packages gettext)
48 #:use-module (gnu packages gtk)
49 #:use-module (gnu packages gnome)
50 #:use-module (gnu packages glib)
51 #:use-module (gnu packages gstreamer)
52 #:use-module (gnu packages icu4c)
53 #:use-module (gnu packages image)
54 #:use-module (gnu packages javascript)
55 #:use-module (gnu packages libusb)
56 #:use-module (gnu packages libreoffice)
57 #:use-module (gnu packages music)
58 #:use-module (gnu packages pdf)
59 #:use-module (gnu packages pkg-config)
60 #:use-module (gnu packages python)
61 #:use-module (gnu packages python-web)
62 #:use-module (gnu packages python-xyz)
63 #:use-module (gnu packages qt)
64 #:use-module (gnu packages serialization)
65 #:use-module (gnu packages sqlite)
66 #:use-module (gnu packages time)
67 #:use-module (gnu packages tls)
68 #:use-module (gnu packages web)
69 #:use-module (gnu packages xml)
70 #:use-module (gnu packages xorg)
71 #:use-module (gnu packages wxwidgets))
72
73 (define-public chmlib
74 (package
75 (name "chmlib")
76 (version "0.40")
77 (source (origin
78 (method url-fetch)
79 (uri (string-append "http://www.jedrea.com/chmlib/chmlib-"
80 version ".tar.bz2"))
81 (sha256
82 (base32
83 "18zzb4x3z0d7fjh1x5439bs62dmgsi4c1pg3qyr7h5gp1i5xcj9l"))
84 (patches (search-patches "chmlib-inttypes.patch"))))
85 (build-system gnu-build-system)
86 (home-page "http://www.jedrea.com/chmlib/")
87 (synopsis "Library for CHM files")
88 (description "CHMLIB is a library for dealing with ITSS/CHM format files.")
89 (license license:lgpl2.1+)))
90
91 (define-public python-pychm
92 (package
93 (name "python-pychm")
94 (version "0.8.6")
95 (source
96 (origin
97 (method url-fetch)
98 (uri (pypi-uri "pychm" version))
99 (sha256
100 (base32
101 "0wpn9ijlsmrpyiwg3drmgz4dms1i1i347adgqw37bkrh3vn6yq16"))))
102 (build-system python-build-system)
103 (inputs
104 `(("chmlib" ,chmlib)))
105 (home-page "https://github.com/dottedmag/pychm")
106 (synopsis "Handle CHM files")
107 (description "This package provides a Python module for interacting
108 with Microsoft Compiled HTML (CHM) files")
109 (license license:gpl2+)))
110
111 (define-public calibre
112 (package
113 (name "calibre")
114 (version "4.18.0")
115 (source
116 (origin
117 (method url-fetch)
118 (uri (string-append "http://download.calibre-ebook.com/"
119 version "/calibre-"
120 version ".tar.xz"))
121 (sha256
122 (base32
123 "0w9pcfvskjh4v00vjw3i6hzrafy863pgsmmqdx4lffip3p856brw"))
124 (modules '((guix build utils)))
125 (snippet
126 '(begin
127 ;; Unbundle python2-odfpy.
128 (delete-file-recursively "src/odf")
129 ;; Disable test that attempts to load it.
130 (substitute* "setup/test.py"
131 ((".*SRC, 'odf'.*")
132 ""))
133
134 ;; Remove unneeded resources.
135 (delete-file "resources/viewer.js")
136 (delete-file "resources/viewer.html")
137 (delete-file "resources/mozilla-ca-certs.pem")
138 (delete-file "resources/calibre-portable.bat")
139 (delete-file "resources/calibre-portable.sh")
140 #t))
141 (patches (search-patches "calibre-no-updates-dialog.patch"
142 "calibre-remove-test-sqlite.patch" ; TODO: fix test.
143 "calibre-remove-test-unrar.patch"))))
144 (build-system python-build-system)
145 (native-inputs
146 `(("pkg-config" ,pkg-config)
147 ("qtbase" ,qtbase) ; for qmake
148 ("python2-flake8" ,python2-flake8)
149 ("xdg-utils" ,xdg-utils)))
150 (inputs
151 `(("chmlib" ,chmlib)
152 ("fontconfig" ,fontconfig)
153 ("font-liberation" ,font-liberation)
154 ("glib" ,glib)
155 ("hunspell" ,hunspell)
156 ("hyphen" ,hyphen)
157 ("icu4c" ,icu4c)
158 ("js-mathjax" ,js-mathjax)
159 ("libmtp" ,libmtp)
160 ("libpng" ,libpng)
161 ("libusb" ,libusb)
162 ("openssl" ,openssl)
163 ("optipng" ,optipng)
164 ("podofo" ,podofo)
165 ("poppler" ,poppler)
166 ("python" ,python-2)
167 ("python2-apsw" ,python2-apsw)
168 ("python2-beautifulsoup4" ,python2-beautifulsoup4)
169 ("python2-chardet" ,python2-chardet)
170 ("python2-cssselect" ,python2-cssselect)
171 ("python2-css-parser" ,python2-css-parser)
172 ("python2-dateutil" ,python2-dateutil)
173 ("python2-dbus" ,python2-dbus)
174 ("python2-dnspython" ,python2-dnspython-1.16)
175 ("python2-dukpy" ,python2-dukpy)
176 ("python2-feedparser" ,python2-feedparser)
177 ("python2-html2text" ,python2-html2text)
178 ("python2-html5-parser" ,python2-html5-parser)
179 ("python2-html5lib" ,python2-html5lib)
180 ("python2-lxml" ,python2-lxml)
181 ("python2-markdown" ,python2-markdown)
182 ("python2-mechanize" ,python2-mechanize)
183 ;; python2-msgpack is needed for the network content server to work.
184 ("python2-msgpack" ,python2-msgpack)
185 ("python2-netifaces" ,python2-netifaces)
186 ("python2-odfpy" ,python2-odfpy)
187 ("python2-pillow" ,python2-pillow)
188 ("python2-psutil" ,python2-psutil)
189 ("python2-pygments" ,python2-pygments)
190 ("python2-pyqtwebengine" ,python2-pyqtwebengine)
191 ("python2-pyqt" ,python2-pyqt)
192 ("python2-sip" ,python2-sip)
193 ("python2-regex" ,python2-regex)
194 ("qtwebengine" ,qtwebengine)
195 ("sqlite" ,sqlite)))
196 (arguments
197 `(#:python ,python-2
198 ;; Calibre is using setuptools by itself, but the setup.py is not
199 ;; compatible with the shim wrapper (taken from pip) we are using.
200 #:use-setuptools? #f
201 #:phases
202 (modify-phases %standard-phases
203 (add-after 'unpack 'patch-source
204 (lambda _
205 (substitute* "src/calibre/linux.py"
206 ;; We can't use the uninstaller in Guix. Don't build it.
207 (("self\\.create_uninstaller()") ""))
208 #t))
209 (add-after 'patch-source-shebangs 'patch-more-shebangs
210 (lambda _
211 ;; Patch various inline shebangs.
212 (substitute* '("src/calibre/gui2/preferences/tweaks.py"
213 "src/calibre/gui2/dialogs/custom_recipes.py"
214 "setup/install.py"
215 "setup/linux-installer.sh")
216 (("#!/usr/bin/env python")
217 (string-append "#!" (which "python")))
218 (("#!/bin/sh")
219 (string-append "#!" (which "sh"))))
220 #t))
221 (add-after 'unpack 'dont-load-remote-icons
222 (lambda _
223 (substitute* "setup/plugins_mirror.py"
224 (("href=\"//calibre-ebook.com/favicon.ico\"")
225 "href=\"favicon.ico\""))
226 #t))
227 (add-before 'build 'configure
228 (lambda* (#:key inputs outputs #:allow-other-keys)
229 (let ((podofo (assoc-ref inputs "podofo"))
230 (pyqt (assoc-ref inputs "python2-pyqt"))
231 (python-sip (assoc-ref inputs "python2-sip"))
232 (out (assoc-ref outputs "out")))
233 (substitute* "setup/build_environment.py"
234 (("= get_sip_dir\\(\\)")
235 (string-append "= '" pyqt "/share/sip'")))
236
237 (substitute* "src/calibre/ebooks/pdf/pdftohtml.py"
238 (("PDFTOHTML = 'pdftohtml'")
239 (string-append "PDFTOHTML = \"" (assoc-ref inputs "poppler")
240 "/bin/pdftohtml\"")))
241
242 ;; Calibre thinks we are installing desktop files into a home
243 ;; directory, but here we butcher the script in to installing
244 ;; to calibres /share directory.
245 (setenv "XDG_DATA_HOME" (string-append out "/share"))
246 (substitute* "src/calibre/linux.py"
247 (("'~/.local/share'") "''"))
248
249 ;; 'python setup.py rapydscript' uses QtWebEngine, which
250 ;; needs to create temporary files in $HOME.
251 (setenv "HOME" "/tmp")
252
253 ;; XXX: QtWebEngine will fail if no fonts are available. This
254 ;; can likely be removed when fontconfig has been patched to
255 ;; include TrueType fonts by default.
256 (symlink (string-append (assoc-ref inputs "font-liberation")
257 "/share/fonts")
258 "/tmp/.fonts")
259
260 (setenv "SIP_BIN" (string-append python-sip "/bin/sip"))
261 (setenv "PODOFO_INC_DIR" (string-append podofo "/include/podofo"))
262 (setenv "PODOFO_LIB_DIR" (string-append podofo "/lib"))
263 ;; This informs the tests we are a continuous integration
264 ;; environment and thus have no networking.
265 (setenv "CI" "true")
266 ;; The Qt test complains about being unable to load all image plugins, and I
267 ;; notice the available plugins list it shows lacks 'svg'. Adding qtsvg doesn't
268 ;; fix it, so I'm not sure how to fix it. TODO: Fix test and remove this.
269 (setenv "SKIP_QT_BUILD_TEST" "true")
270 #t)))
271 (add-after 'build 'build-extra
272 (lambda* (#:key inputs #:allow-other-keys)
273 (invoke "python2" "setup.py" "mathjax""--system-mathjax"
274 "--path-to-mathjax" (string-append
275 (assoc-ref inputs "js-mathjax")
276 "/share/javascript/mathjax"))
277 (invoke "python2" "setup.py" "rapydscript")
278 #t))
279 (add-after 'install 'install-man-pages
280 (lambda* (#:key outputs #:allow-other-keys)
281 (copy-recursively
282 "man-pages"
283 (string-append (assoc-ref outputs "out") "/share/man"))
284 #t))
285 ;; The font TTF files are used in some miscellaneous tests, so we
286 ;; unbundle them here to avoid patching the tests.
287 (add-after 'install 'unbundle-font-liberation
288 (lambda* (#:key inputs outputs #:allow-other-keys)
289 (let ((font-dest (string-append (assoc-ref outputs "out")
290 "/share/calibre/fonts/liberation"))
291 (font-src (string-append (assoc-ref inputs "font-liberation")
292 "/share/fonts/truetype")))
293 (delete-file-recursively font-dest)
294 (symlink font-src font-dest))
295 #t))
296 ;; Make run-time dependencies available to the binaries.
297 (add-after 'wrap 'wrap-program
298 (lambda* (#:key inputs outputs #:allow-other-keys)
299 (let ((out (assoc-ref outputs "out"))
300 (qtwebengine (assoc-ref inputs "qtwebengine")))
301 (with-directory-excursion (string-append out "/bin")
302 (for-each
303 (lambda (binary)
304 (wrap-program binary
305 ;; Make QtWebEngineProcess available.
306 `("QTWEBENGINEPROCESS_PATH" =
307 ,(list (string-append
308 qtwebengine
309 "/lib/qt5/libexec/QtWebEngineProcess")))))
310 ;; Wrap all the binaries shipping with the package, except
311 ;; for the wrappings created during the 'wrap standard
312 ;; phase. This extends existing .calibre-real wrappers
313 ;; rather than create ..calibre-real-real-s. For more
314 ;; information see: https://issues.guix.gnu.org/43249.
315 (find-files "." (lambda (file stat)
316 (not (wrapper? file)))))))
317 #t)))))
318 (home-page "https://calibre-ebook.com/")
319 (synopsis "E-book library management software")
320 (description "Calibre is an e-book library manager. It can view, convert
321 and catalog e-books in most of the major e-book formats. It can also talk
322 to many e-book reader devices. It can go out to the Internet and fetch
323 metadata for books. It can download newspapers and convert them into
324 e-books for convenient reading.")
325 ;; Calibre is largely GPL3+, but includes a number of components covered
326 ;; by other licenses. See COPYRIGHT for more details.
327 (license (list license:gpl3+
328 license:gpl2+
329 license:lgpl2.1+
330 license:lgpl2.1
331 license:bsd-3
332 license:expat
333 license:zpl2.1
334 license:asl2.0
335 license:public-domain
336 license:silofl1.1
337 license:cc-by-sa3.0))))
338
339 (define-public ebook-tools
340 (package
341 (name "ebook-tools")
342 (version "0.2.2")
343 (source
344 (origin
345 (method url-fetch)
346 (uri (string-append "mirror://sourceforge/ebook-tools/ebook-tools/"
347 version "/ebook-tools-" version ".tar.gz"))
348 (sha256
349 (base32
350 "1bi7wsz3p5slb43kj7lgb3r6lb91lvb6ldi556k4y50ix6b5khyb"))))
351 (arguments
352 `(#:tests? #f)) ; No 'test' target
353 (build-system cmake-build-system)
354 (native-inputs
355 `(("pkg-config" ,pkg-config)))
356 (inputs
357 `(("libzip" ,libzip)
358 ("libxml2" ,libxml2)))
359 (home-page "http://ebook-tools.sourceforge.net")
360 (synopsis "Tools and library for dealing with various ebook file formats")
361 (description "This package provides command-line tools and a library for
362 accessing and converting various ebook file formats.")
363 (license license:expat)))
364
365 (define-public liblinebreak
366 (package
367 (name "liblinebreak")
368 (version "2.1")
369 (source (origin
370 (method url-fetch)
371 (uri (string-append "mirror://sourceforge/vimgadgets"
372 "/liblinebreak/" version
373 "/liblinebreak-" version ".tar.gz"))
374 (sha256
375 (base32
376 "1f36dbq7nc77lln1by2n1yl050g9dc63viawhs3gc3169mavm36x"))))
377 (build-system gnu-build-system)
378 (home-page "http://vimgadgets.sourceforge.net/liblinebreak/")
379 (synopsis "Library for detecting where linebreaks are allowed in text")
380 (description "@code{liblinebreak} is an implementation of the line
381 breaking algorithm as described in Unicode 6.0.0 Standard Annex 14,
382 Revision 26. It breaks lines that contain Unicode characters. It is
383 designed to be used in a generic text renderer.")
384 (license license:zlib)))
385
386 (define-public fbreader
387 (package
388 (name "fbreader")
389 (version "0.99.6")
390 (source (origin
391 (method git-fetch)
392 (uri (git-reference
393 (url "https://github.com/geometer/FBReader")
394 (commit (string-append version "-freebsdport"))))
395 (file-name (git-file-name name version))
396 (sha256
397 (base32
398 "0c0s4silpax74kwfz3dfmzn4lkv6jsyb800vfak166vii0hvbv3d"))
399 (patches (search-patches "fbreader-curl-7.62.patch"))))
400 (build-system gnu-build-system)
401 (inputs
402 `(("curl" ,curl)
403 ("expat" ,expat)
404 ("fribidi" ,fribidi)
405 ("glib" ,glib)
406 ("gtk+-2" ,gtk+-2)
407 ("libjpeg" ,libjpeg-turbo)
408 ("liblinebreak" ,liblinebreak)
409 ("libxft" ,libxft)
410 ("sqlite" ,sqlite)
411 ("zlib" ,zlib)))
412 (native-inputs
413 `(("gcc@5" ,gcc-5)
414 ("pkg-config" ,pkg-config)))
415 (arguments
416 `(#:tests? #f ; No tests exist.
417 #:make-flags `("CC=gcc" "TARGET_ARCH=desktop" "UI_TYPE=gtk"
418 "TARGET_STATUS=release"
419 ,(string-append "INSTALLDIR="
420 (assoc-ref %outputs "out"))
421 ,(string-append "LDFLAGS=-Wl,-rpath="
422 (assoc-ref %outputs "out") "/lib"))
423 #:phases
424 (modify-phases %standard-phases
425 (add-after 'set-paths 'augment-CPLUS_INCLUDE_PATH
426 (lambda* (#:key inputs #:allow-other-keys)
427 ;; Hide the default GCC from CPLUS_INCLUDE_PATH to prevent a header
428 ;; conflict with the GCC provided in native-inputs.
429 (let ((gcc (assoc-ref inputs "gcc")))
430 (setenv "CPLUS_INCLUDE_PATH"
431 (string-join
432 (delete (string-append gcc "/include/c++")
433 (string-split (getenv "CPLUS_INCLUDE_PATH")
434 #\:))
435 ":"))
436 #t)))
437 (delete 'configure)
438 (add-after 'unpack 'fix-install-locations
439 (lambda* (#:key outputs #:allow-other-keys)
440 (let ((out (assoc-ref outputs "out")))
441 (substitute* "fbreader/desktop/Makefile"
442 (("/usr") out))
443 #t))))))
444 (home-page "https://fbreader.org/")
445 (synopsis "E-Book reader")
446 (description "@code{fbreader} is an E-Book reader. It supports the
447 following formats:
448
449 @enumerate
450 @item CHM
451 @item Docbook
452 @item FB2
453 @item HTML
454 @item OEB
455 @item PDB
456 @item RTF
457 @item TCR
458 @item TXT
459 @item XHTML
460 @end enumerate")
461 (license license:gpl2+)))
462
463 (define-public cozy
464 (package
465 (name "cozy")
466 (version "0.7.8")
467 (source
468 (origin
469 (method git-fetch)
470 (uri (git-reference
471 (url "https://github.com/geigi/cozy")
472 (commit version)))
473 (file-name (git-file-name name version))
474 (sha256
475 (base32 "0z2wj9g32aa5g9pw81q49iv1smb6yvlv9zs0vrzbx6mw8cj3c5d2"))))
476 (build-system meson-build-system)
477 (arguments
478 `(#:glib-or-gtk? #t
479 #:phases
480 (modify-phases %standard-phases
481 (add-after 'unpack 'patch-desktop-file
482 (lambda _
483 (substitute* "data/com.github.geigi.cozy.desktop"
484 (("Exec=com.github.geigi.cozy") "Exec=cozy"))
485 #t))
486 (add-after 'install 'patch-executable-name
487 (lambda* (#:key outputs #:allow-other-keys)
488 (with-directory-excursion
489 (string-append (assoc-ref outputs "out") "/bin")
490 (rename-file "com.github.geigi.cozy" "cozy"))
491 #t))
492 (add-after 'wrap 'wrap-libs
493 (lambda* (#:key outputs #:allow-other-keys)
494 (let* ((out (assoc-ref outputs "out"))
495 (pylib (string-append
496 out "/lib/python"
497 ,(version-major+minor
498 (package-version python))
499 "/site-packages"))
500 (gi-typelib-path (getenv "GI_TYPELIB_PATH"))
501 (gst-plugin-path (getenv "GST_PLUGIN_SYSTEM_PATH"))
502 (libmagic-path (string-append
503 (assoc-ref %build-inputs "file")
504 "/lib"))
505 (python-path (getenv "PYTHONPATH")))
506 (wrap-program (string-append out "/bin/cozy")
507 `("LD_LIBRARY_PATH" ":" prefix (,libmagic-path))
508 `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))
509 `("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
510 `("PYTHONPATH" ":" prefix (,python-path ,pylib))))
511 #t)))))
512 (native-inputs
513 `(("desktop-file-utils" ,desktop-file-utils)
514 ("gettext" ,gettext-minimal)
515 ("glib:bin" ,glib "bin")
516 ("gobject-introspection" ,gobject-introspection)
517 ("gtk+:bin" ,gtk+ "bin")
518 ("pkg-config" ,pkg-config)
519 ("python" ,python-wrapper)))
520 (inputs
521 `(("file" ,file)
522 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
523 ("gst-libav" ,gst-libav)
524 ("gst-plugins-bad" ,gst-plugins-bad)
525 ("gst-plugins-good" ,gst-plugins-good)
526 ("gst-plugins-ugly" ,gst-plugins-ugly)
527 ("gtk+" ,gtk+)
528 ("libhandy" ,libhandy)
529 ("python-distro" ,python-distro)
530 ("python-gst" ,python-gst)
531 ("python-mutagen" ,python-mutagen)
532 ("python-packaging" ,python-packaging)
533 ("python-peewee" ,python-peewee)
534 ("python-pycairo" ,python-pycairo)
535 ("python-pygobject" ,python-pygobject)
536 ("python-pytz" ,python-pytz)
537 ("python-requests" ,python-requests)))
538 (home-page "https://cozy.geigi.de/")
539 (synopsis "Modern audiobook player using GTK+")
540 (description
541 "Cozy is a modern audiobook player written in GTK+.
542
543 Some of the current features:
544
545 @itemize
546 @item Import your audiobooks into Cozy to browse them comfortably
547 @item Sort your audio books by author, reader & name
548 @item Remembers your playback position
549 @item Sleep timer
550 @item Playback speed control
551 @item Search your library
552 @item Offline mode
553 @item Add multiple storage locations
554 @item Drag & Drop to import new audio books
555 @item Support for DRM free mp3, m4a (aac, ALAC, …), flac, ogg, opus, wav files
556 @item Mpris integration (Media keys & playback info for desktop environment)
557 @end itemize")
558 ;; TODO: Unbundle python-inject.
559 (license (list license:gpl3+ ;cozy
560 license:asl2.0)))) ;python-inject (bundled dependency)
561
562 (define-public xchm
563 (package
564 (name "xchm")
565 (version "1.32")
566 (source (origin
567 (method url-fetch)
568 (uri (string-append "https://github.com/rzvncj/xCHM"
569 "/releases/download/"
570 version "/xchm-" version ".tar.gz"))
571 (sha256
572 (base32
573 "0b12ym7cn65wy268kbksyhakicwb053c8xfn76q2dawrvbras9dj"))))
574 (build-system gnu-build-system)
575 (inputs
576 `(("wxwidgets" ,wxwidgets)
577 ("chmlib" ,chmlib)))
578 (native-inputs
579 `(("pkg-config" ,pkg-config)))
580 (home-page "https://github.com/rzvncj/xCHM")
581 (synopsis "CHM file viewer")
582 (description "xCHM is a graphical CHM file viewer. It is a frontend to
583 the CHM library CHMLIB.")
584 (license license:gpl2+)))