gnu: vamp: Delete broken files from output.
[jackhill/guix/guix.git] / gnu / packages / audio.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages audio)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix git-download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix build-system gnu)
25 #:use-module (guix build-system waf)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages algebra)
28 #:use-module (gnu packages boost)
29 #:use-module (gnu packages curl)
30 #:use-module (gnu packages databases)
31 #:use-module (gnu packages glib)
32 #:use-module (gnu packages gtk)
33 #:use-module (gnu packages gnome)
34 #:use-module (gnu packages qt)
35 #:use-module (gnu packages linux)
36 #:use-module (gnu packages mp3) ;taglib
37 #:use-module (gnu packages perl)
38 #:use-module (gnu packages pkg-config)
39 #:use-module (gnu packages pulseaudio) ;libsndfile, libsamplerate
40 #:use-module (gnu packages python)
41 #:use-module (gnu packages rdf)
42 #:use-module (gnu packages readline)
43 #:use-module (gnu packages xiph)
44 #:use-module (gnu packages xml)
45 #:use-module (srfi srfi-1))
46
47 (define-public aubio
48 (package
49 (name "aubio")
50 (version "0.4.1")
51 (source (origin
52 (method url-fetch)
53 (uri (string-append
54 "http://aubio.org/pub/aubio-" version ".tar.bz2"))
55 (sha256
56 (base32
57 "15f6nf76y7iyl2kl4ny7ky0zpxfxr8j3902afvd6ydnnkh5dzmr5"))))
58 (build-system waf-build-system)
59 (arguments
60 `(#:tests? #f ; no check target
61 #:configure-flags
62 '("--enable-fftw3f"
63 "--enable-jack"
64 "--enable-sndfile"
65 "--enable-samplerate"
66 ;; enable compilation with avcodec once available
67 "--disable-avcodec")
68 #:python ,python-2))
69 (inputs
70 `(("jack" ,jack-1)
71 ("libsndfile" ,libsndfile)
72 ("libsamplerate" ,libsamplerate)
73 ("fftwf" ,fftwf)))
74 (native-inputs
75 `(("pkg-config" ,pkg-config)))
76 (home-page "http://aubio.org/")
77 (synopsis "A library for audio labelling")
78 (description
79 "aubio is a tool designed for the extraction of annotations from audio
80 signals. Its features include segmenting a sound file before each of its
81 attacks, performing pitch detection, tapping the beat and producing MIDI
82 streams from live audio.")
83 (license license:gpl3+)))
84
85 (define-public ardour
86 (package
87 (name "ardour")
88 (version "3.5.403")
89 (source (origin
90 ;; The project only provides tarballs upon individual request
91 ;; (or after payment) so we take the code from git.
92 (method git-fetch)
93 (uri (git-reference
94 (url "git://git.ardour.org/ardour/ardour.git")
95 (commit version)))
96 (snippet
97 '(call-with-output-file
98 "libs/ardour/revision.cc"
99 (lambda (port)
100 (format port "#include \"ardour/revision.h\"
101 namespace ARDOUR { const char* revision = \"3.5-403-gec2cb31\" ; }"))))
102 (sha256
103 (base32
104 "01b0wxh0wlxjfz5j8gcwwqhxc6q2kn4njz2fcmzv9fr3xaya5dbp"))
105 (file-name (string-append name "-" version))))
106 (build-system waf-build-system)
107 (arguments
108 `(#:tests? #f ; no check target
109 #:python ,python-2))
110 (inputs
111 `(("alsa-lib" ,alsa-lib)
112 ("aubio" ,aubio)
113 ("lrdf" ,lrdf)
114 ("boost" ,boost)
115 ("atkmm" ,atkmm)
116 ("cairomm" ,cairomm)
117 ("gtkmm" ,gtkmm-2)
118 ("glibmm" ,glibmm)
119 ("libart-lgpl" ,libart-lgpl)
120 ("libgnomecanvasmm" ,libgnomecanvasmm)
121 ("pangomm" ,pangomm)
122 ("liblo" ,liblo)
123 ("libsndfile" ,libsndfile)
124 ("libsamplerate" ,libsamplerate)
125 ("libxml2" ,libxml2)
126 ("libogg" ,libogg)
127 ("libvorbis" ,libvorbis)
128 ("flac" ,flac)
129 ("lv2" ,lv2)
130 ("vamp" ,vamp)
131 ("curl" ,curl)
132 ("fftw" ,fftw)
133 ("fftwf" ,fftwf)
134 ("jack" ,jack-1)
135 ("serd" ,serd)
136 ("sord" ,sord)
137 ("sratom" ,sratom)
138 ("suil" ,suil)
139 ("lilv" ,lilv)
140 ("rasqal" ,rasqal)
141 ("raptor2" ,raptor2)
142 ("redland" ,redland)
143 ("rubberband" ,rubberband)
144 ("taglib" ,taglib)
145 ("python-rdflib" ,python-rdflib)))
146 (native-inputs
147 `(("perl" ,perl)
148 ("pkg-config" ,pkg-config)))
149 (home-page "http://ardour.org")
150 (synopsis "Digital audio workstation")
151 (description
152 "Ardour is a multi-channel digital audio workstation, allowing users to
153 record, edit, mix and master audio and MIDI projects. It is targeted at audio
154 engineers, musicians, soundtrack editors and composers.")
155 (license license:gpl2+)))
156
157 (define-public azr3
158 (package
159 (name "azr3")
160 (version "1.2.3")
161 (source (origin
162 (method url-fetch)
163 (uri (string-append "mirror://savannah/ll-plugins/azr3-jack-"
164 version
165 ".tar.bz2"))
166 (sha256
167 (base32
168 "18mdw6nc0vgj6k9rsy0x8w64wvzld0frqshrxxbxfj9qi9843vlc"))))
169 (build-system gnu-build-system)
170 (arguments
171 `(#:tests? #f ; no check target
172 #:make-flags
173 (list "LV2PEG=ttl2c"
174 (string-append "prefix=" %output)
175 (string-append "pkgdatadir=" %output "/share/azr3-jack"))))
176 (inputs
177 `(("gtkmm" ,gtkmm-2)
178 ("lvtk" ,lvtk)
179 ("jack" ,jack-1)
180 ("lash" ,lash)))
181 (native-inputs
182 `(("pkg-config" ,pkg-config)))
183 (home-page "http://ll-plugins.nongnu.org/azr3/")
184 (synopsis "Tonewheel organ synthesizer")
185 (description
186 "AZR-3 is a port of the free VST plugin AZR-3. It is a tonewheel organ
187 with drawbars, distortion and rotating speakers. The organ has three
188 sections, two polyphonic sections with nine drawbars each and one monophonic
189 bass section with five drawbars. A standalone JACK application and LV2
190 plugins are provided.")
191 (license license:gpl2)))
192
193 (define-public jack-1
194 (package
195 (name "jack")
196 (version "0.124.1")
197 (source (origin
198 (method url-fetch)
199 (uri (string-append
200 "http://jackaudio.org/downloads/jack-audio-connection-kit-"
201 version
202 ".tar.gz"))
203 (sha256
204 (base32
205 "1mk1wnx33anp6haxfjjkfhwbaknfblsvj35nxvz0hvspcmhdyhpb"))))
206 (build-system gnu-build-system)
207 (inputs
208 `(("alsa-lib" ,alsa-lib)
209 ("bdb" ,bdb)
210 ("readline" ,readline)))
211 ;; uuid.h is included in the JACK type headers
212 (propagated-inputs
213 `(("libuuid" ,util-linux)))
214 (native-inputs
215 `(("pkg-config" ,pkg-config)))
216 (home-page "http://jackaudio.org/")
217 (synopsis "JACK audio connection kit")
218 (description
219 "JACK is a low-latency audio server. It can connect a number of
220 different applications to an audio device, as well as allowing them to share
221 audio between themselves. JACK is different from other audio server efforts
222 in that it has been designed from the ground up to be suitable for
223 professional audio work. This means that it focuses on two key areas:
224 synchronous execution of all clients, and low latency operation.")
225 ;; Most files are licensed under the GPL. However, the libjack/ tree is
226 ;; licensed under the LGPL in order to allow for proprietary usage.
227 (license (list license:gpl2+ license:lgpl2.1+))))
228
229 (define-public jack-2
230 (package (inherit jack-1)
231 (name "jack2")
232 (version "1.9.10")
233 (source (origin
234 (method url-fetch)
235 (uri (string-append
236 "https://github.com/jackaudio/jack2/archive/v"
237 version
238 ".tar.gz"))
239 (sha256
240 (base32
241 "03b0iiyk3ng3vh5s8gaqwn565vik7910p56mlbk512bw3dhbdwc8"))))
242 (build-system waf-build-system)
243 (arguments
244 `(#:tests? #f ; no check target
245 #:configure-flags '("--dbus"
246 "--alsa")))
247 (inputs
248 `(("alsa-lib" ,alsa-lib)
249 ("dbus" ,dbus)
250 ("expat" ,expat)
251 ("libsamplerate" ,libsamplerate)
252 ("opus" ,opus)
253 ("readline" ,readline)))
254 (native-inputs
255 `(("pkg-config" ,pkg-config)))
256 ;; Most files are under GPLv2+, but some headers are under LGPLv2.1+
257 (license (list license:gpl2+ license:lgpl2.1+))))
258
259 (define-public jalv
260 (package
261 (name "jalv")
262 (version "1.4.6")
263 (source (origin
264 (method url-fetch)
265 (uri (string-append "http://download.drobilla.net/jalv-"
266 version ".tar.bz2"))
267 (sha256
268 (base32
269 "1f1hcq74n3ziw8bk97mn5a1vgw028dxikv3fchaxd430pbbhqgl9"))))
270 (build-system waf-build-system)
271 (arguments `(#:tests? #f)) ; no check target
272 (inputs
273 `(("lv2" ,lv2)
274 ("lilv" ,lilv)
275 ("suil" ,suil)
276 ("gtk" ,gtk+-2)
277 ("gtkmm" ,gtkmm-2)
278 ("qt" ,qt-4)
279 ("jack" ,jack-1)))
280 (native-inputs
281 `(("pkg-config" ,pkg-config)))
282 (home-page "http://drobilla.net/software/jalv/")
283 (synopsis "Simple LV2 host for JACK")
284 (description
285 "Jalv is a simple but fully featured LV2 host for JACK. It runs LV2
286 plugins and exposes their ports as JACK ports, essentially making any LV2
287 plugin function as a JACK application.")
288 (license license:isc)))
289
290 (define-public ladspa
291 (package
292 (name "ladspa")
293 (version "1.13")
294 (source (origin
295 (method url-fetch)
296 (uri (string-append
297 "http://www.ladspa.org/download/ladspa_sdk_"
298 version
299 ".tgz"))
300 (sha256
301 (base32
302 "0srh5n2l63354bc0srcrv58rzjkn4gv8qjqzg8dnq3rs4m7kzvdm"))))
303 (build-system gnu-build-system)
304 (arguments
305 `(#:tests? #f ; the "test" target is a listening test only
306 #:phases
307 (alist-replace
308 'configure
309 (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
310 (chdir "src")
311 (let ((out (assoc-ref outputs "out")))
312 (substitute* "makefile"
313 (("/usr/lib/ladspa/") (string-append out "/lib/ladspa/"))
314 (("/usr/include/") (string-append out "/include/"))
315 (("/usr/bin/") (string-append out "/bin/"))
316 (("-mkdirhier") "mkdir -p")
317 (("^CC.*") "CC = gcc\n")
318 (("^CPP.*") "CPP = g++\n"))))
319 (alist-delete 'build %standard-phases))))
320 (home-page "http://ladspa.org")
321 (synopsis "Linux Audio Developer's Simple Plugin API (LADSPA)")
322 (description
323 "LADSPA is a standard that allows software audio processors and effects
324 to be plugged into a wide range of audio synthesis and recording packages.")
325 (license license:lgpl2.1+)))
326
327 (define-public lash
328 (package
329 (name "lash")
330 (version "0.6.0-rc2")
331 (source (origin
332 (method url-fetch)
333 ;; The tilde is not permitted in the builder name, but is used
334 ;; in the tarball.
335 (uri (string-append
336 "mirror://savannah/lash/lash-"
337 (string-join (string-split version #\-) "~")
338 ".tar.bz2"))
339 (file-name (string-append name "-" version ".tar.bz2"))
340 (sha256
341 (base32
342 "12z1vx3krrzsfccpah9xjs68900xvr7bw92wx8np5871i2yv47iw"))))
343 (build-system gnu-build-system)
344 (inputs
345 `(("bdb" ,bdb)
346 ("gtk" ,gtk+-2)
347 ("jack" ,jack-1)
348 ("readline" ,readline)
349 ("python" ,python-2)))
350 ;; According to pkg-config, packages depending on lash also need to have
351 ;; at least the following packages declared as inputs.
352 (propagated-inputs
353 `(("alsa-lib" ,alsa-lib)
354 ("dbus" ,dbus)
355 ("libxml2" ,libxml2)))
356 (native-inputs
357 `(("pkg-config" ,pkg-config)))
358 (home-page "http://www.nongnu.org/lash/")
359 (synopsis "Audio application session manager")
360 (description
361 "LASH is a session management system for audio applications. It allows
362 you to save and restore audio sessions consisting of multiple interconneced
363 applications, restoring program state (i.e. loaded patches) and the
364 connections between them.")
365 (license license:gpl2+)))
366
367 (define-public liblo
368 (package
369 (name "liblo")
370 (version "0.28")
371 (source (origin
372 (method url-fetch)
373 (uri (string-append
374 "mirror://sourceforge/liblo/liblo-"
375 version
376 ".tar.gz"))
377 (sha256
378 (base32
379 "02drgnpirvl2ihvzgsmn02agr5sj3vipzzw9vma56qlkgfvak56s"))))
380 (build-system gnu-build-system)
381 (arguments
382 `(;; liblo test FAILED
383 ;; liblo server error 19 in setsockopt(IP_ADD_MEMBERSHIP): No such device
384 #:tests? #f))
385 (home-page "http://liblo.sourceforge.net")
386 (synopsis "Implementation of the Open Sound Control protocol")
387 (description
388 "liblo is a lightweight library that provides an easy to use
389 implementation of the Open Sound Control (OSC) protocol.")
390 (license license:lgpl2.1+)))
391
392 (define-public lilv
393 (package
394 (name "lilv")
395 (version "0.20.0")
396 (source (origin
397 (method url-fetch)
398 (uri (string-append "http://download.drobilla.net/lilv-"
399 version
400 ".tar.bz2"))
401 (sha256
402 (base32
403 "0aj2plkx56iar8vzjbq2l7hi7sp0ml99m0h44rgwai2x4vqkk2j2"))))
404 (build-system waf-build-system)
405 (arguments `(#:tests? #f)) ; no check target
406 ;; required by lilv-0.pc
407 (propagated-inputs
408 `(("serd" ,serd)
409 ("sord" ,sord)
410 ("sratom" ,sratom)))
411 (inputs
412 `(("lv2" ,lv2)))
413 (native-inputs
414 `(("pkg-config" ,pkg-config)))
415 (home-page "http://drobilla.net/software/lilv/")
416 (synopsis "Library to simplify use of LV2 plugins in applications")
417 (description
418 "Lilv is a C library to make the use of LV2 plugins as simple as possible
419 for applications. Lilv is the successor to SLV2, rewritten to be
420 significantly faster and have minimal dependencies.")
421 (license license:isc)))
422
423 (define-public lv2
424 (package
425 (name "lv2")
426 (version "1.10.0")
427 (source (origin
428 (method url-fetch)
429 (uri (string-append "http://lv2plug.in/spec/lv2-"
430 version
431 ".tar.bz2"))
432 (sha256
433 (base32
434 "1md41x9snrp4mcfyli7lyfpvcfa78nfy6xkdy84kppnl8m5qw378"))))
435 (build-system waf-build-system)
436 (arguments
437 `(#:tests? #f ; no check target
438 #:configure-flags '("--lv2-system")))
439 (inputs
440 ;; Leaving off cairo and gtk+-2.0 which are needed for example plugins
441 `(("libsndfile" ,libsndfile)))
442 (native-inputs
443 `(("pkg-config" ,pkg-config)))
444 (home-page "http://lv2plug.in/")
445 (synopsis "LV2 audio plugin specification")
446 (description
447 "LV2 is an open specification for audio plugins and host applications.
448 At its core, LV2 is a simple stable interface, accompanied by extensions which
449 add functionality to support the needs of increasingly powerful audio
450 software.")
451 (license license:isc)))
452
453 (define-public lvtk
454 (package
455 (name "lvtk")
456 (version "1.2.0")
457 (source (origin
458 (method url-fetch)
459 (uri (string-append "https://github.com/lvtk/lvtk/archive/"
460 version
461 ".tar.gz"))
462 (sha256
463 (base32
464 "03nbj2cqcklqwh50zj2gwm07crh5iwqbpxbpzwbg5hvgl4k4rnjd"))))
465 (build-system waf-build-system)
466 (arguments
467 `(#:tests? #f ; no check target
468 #:python ,python-2
469 #:configure-flags
470 (list (string-append "--boost-includes="
471 (assoc-ref %build-inputs "boost")
472 "/include"))))
473 (inputs
474 `(("boost" ,boost)
475 ("lv2" ,lv2)))
476 (native-inputs
477 `(("pkg-config" ,pkg-config)))
478 (home-page "https://github.com/lvtk/lvtk")
479 (synopsis "C++ libraries for LV2 plugins")
480 (description
481 "The LV2 Toolkit (LVTK) contains libraries that wrap the LV2 C API and
482 extensions into easy to use C++ classes. It is the successor of
483 lv2-c++-tools.")
484 (license license:gpl3+)))
485
486 (define-public patchage
487 (package
488 (name "patchage")
489 (version "1.0.0")
490 (source (origin
491 (method url-fetch)
492 (uri (string-append "http://download.drobilla.net/patchage-"
493 version
494 ".tar.bz2"))
495 (sha256
496 (base32
497 "1agdpwwi42176l4mxj0c4fsvdiv1ig56bfnnx0msckxmy57df8bb"))))
498 (build-system waf-build-system)
499 (arguments `(#:tests? #f)) ; no check target
500 (inputs
501 `(("alsa-lib" ,alsa-lib)
502 ("boost" ,boost)
503 ("jack" ,jack-1)
504 ("ganv" ,ganv)
505 ("glib" ,glib)
506 ("glibmm" ,glibmm)
507 ("gtkmm" ,gtkmm-2)
508 ("dbus" ,dbus)
509 ("dbus-glib" ,dbus-glib)))
510 (native-inputs
511 `(("pkg-config" ,pkg-config)))
512 (home-page "http://drobilla.net/software/patchage/")
513 (synopsis "Modular patch bay for audio and MIDI systems")
514 (description
515 "Patchage is a modular patch bay for audio and MIDI systems based on JACK
516 and ALSA.")
517 (license license:gpl3+)))
518
519 (define-public rubberband
520 (package
521 (name "rubberband")
522 (version "1.8.1")
523 (source (origin
524 (method url-fetch)
525 (uri
526 (string-append "https://bitbucket.org/breakfastquay/rubberband/get/v"
527 version
528 ".tar.bz2"))
529 (sha256
530 (base32
531 "05amrbrxx0da3w7m237q51799r8xgs4ffqabi2qv06hq8dpcj386"))))
532 (build-system gnu-build-system)
533 (arguments `(#:tests? #f)) ; no check target
534 (inputs
535 `(("ladspa" ,ladspa)
536 ("libsamplerate" ,libsamplerate)
537 ("vamp" ,vamp)))
538 (native-inputs
539 `(("pkg-config" ,pkg-config)))
540 (home-page "http://breakfastquay.com/rubberband/")
541 (synopsis "Audio time-stretching and pitch-shifting library")
542 (description
543 "Rubber Band is a library and utility program that permits changing the
544 tempo and pitch of an audio recording independently of one another.")
545 (license license:gpl2+)))
546
547 (define-public sratom
548 (package
549 (name "sratom")
550 (version "0.4.6")
551 (source (origin
552 (method url-fetch)
553 (uri (string-append "http://download.drobilla.net/sratom-"
554 version
555 ".tar.bz2"))
556 (sha256
557 (base32
558 "080jjiyxjnj7hf25844hd9rb01grvzz1rk8mxcdnakywmspbxfd4"))))
559 (build-system waf-build-system)
560 (arguments `(#:tests? #f)) ; no check target
561 (inputs
562 `(("lv2" ,lv2)
563 ("serd" ,serd)
564 ("sord" ,sord)))
565 (native-inputs
566 `(("pkg-config" ,pkg-config)))
567 (home-page "http://drobilla.net/software/sratom/")
568 (synopsis "Library for serialising LV2 atoms to/from RDF")
569 (description
570 "Sratom is a library for serialising LV2 atoms to/from RDF, particularly
571 the Turtle syntax.")
572 (license license:isc)))
573
574 (define-public suil
575 (package
576 (name "suil")
577 (version "0.8.2")
578 (source (origin
579 (method url-fetch)
580 (uri (string-append "http://download.drobilla.net/suil-"
581 version
582 ".tar.bz2"))
583 (sha256
584 (base32
585 "1s3adyiw7sa5gfvm5wasa61qa23629kprxyv6w8hbxdiwp0hhxkq"))))
586 (build-system waf-build-system)
587 (arguments `(#:tests? #f)) ; no check target
588 (inputs
589 `(("lv2" ,lv2)
590 ("gtk+-2" ,gtk+-2)
591 ("qt-4" ,qt-4)))
592 (native-inputs
593 `(("pkg-config" ,pkg-config)))
594 (home-page "http://drobilla.net/software/suil/")
595 (synopsis "Library for loading and wrapping LV2 plugin UIs")
596 (description
597 "Suil is a lightweight C library for loading and wrapping LV2 plugin UIs.
598
599 Suil makes it possible to load a UI of a toolkit in a host using another
600 toolkit. The API is designed such that hosts do not need to explicitly
601 support specific toolkits – if Suil supports a particular toolkit, then UIs in
602 that toolkit will work in all hosts that use Suil automatically.
603
604 Suil currently supports every combination of Gtk 2, Qt 4, and X11.")
605 (license license:isc)))
606
607 (define-public vamp
608 (package
609 (name "vamp")
610 (version "2.5")
611 (source (origin
612 (method url-fetch)
613 (uri (string-append
614 "https://code.soundsoftware.ac.uk"
615 "/attachments/download/690/vamp-plugin-sdk-"
616 version
617 ".tar.gz"))
618 (sha256
619 (base32
620 "178kfgq08cmgdzv7g8dwyjp4adwx8q04riimncq4nqkm8ng9ywbv"))))
621 (build-system gnu-build-system)
622 (arguments
623 `(#:tests? #f ; no check target
624 #:phases
625 (alist-cons-after
626 'install 'remove-libvamp-hostsdk.la
627 (lambda* (#:key outputs #:allow-other-keys)
628 ;; https://bugs.launchpad.net/ubuntu/+source/vamp-plugin-sdk/+bug/1253656
629 (for-each delete-file
630 (let ((out (assoc-ref outputs "out")))
631 (list (string-append out "/lib/libvamp-sdk.la")
632 (string-append out "/lib/libvamp-hostsdk.la"))))
633 #t)
634 %standard-phases)))
635 (inputs
636 `(("libsndfile" ,libsndfile)))
637 (native-inputs
638 `(("pkg-config" ,pkg-config)))
639 (home-page "http://vamp-plugins.org")
640 (synopsis "Modular and extensible audio processing system")
641 (description
642 "Vamp is an audio processing plugin system for plugins that extract
643 descriptive information from audio data — typically referred to as audio
644 analysis plugins or audio feature extraction plugins.")
645 (license
646 (license:x11-style
647 "https://code.soundsoftware.ac.uk/projects/vamp-plugin-sdk/repository/entry/COPYING"))))