gnu: Add 'make-ld-wrapper' procedure.
[jackhill/guix/guix.git] / gnu / packages / gxmessage.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages gxmessage)
20 #:use-module (guix licenses)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages glib)
25 #:use-module (gnu packages pkg-config)
26 #:use-module (gnu packages gtk)
27 #:use-module (gnu packages))
28
29 (define-public gxmessage
30 (package
31 (name "gxmessage")
32 (version "2.20.1")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "mirror://gnu/gxmessage/gxmessage-"
36 version ".tar.gz"))
37 (sha256
38 (base32 "1b75qjx339c7q0xfxnwb2n5vw6xn8vi6nw2clggfzxnwwx58g2d1"))))
39 (build-system gnu-build-system)
40 (inputs
41 `(("gtk+" ,gtk+-2)))
42 (native-inputs
43 `(("intltool" ,intltool)
44 ("pkg-config" ,pkg-config)))
45 (home-page "http://www.gnu.org/software/gxmessage/")
46 (synopsis "Open popup message window with buttons for return")
47 (description "GNU gxmessage is a program that pops up dialog windows, which display
48 a message to the user and waits for their action. The program then exits
49 with an exit code corresponding to the response.")
50 (license gpl3+)))