gnu: Add 'make-ld-wrapper' procedure.
[jackhill/guix/guix.git] / gnu / packages / ftp.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages ftp)
22 #:use-module ((guix licenses) #:select (gpl2+ gpl3+ clarified-artistic))
23 #:use-module (guix build-system gnu)
24 #:use-module (guix download)
25 #:use-module (guix packages)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages ncurses)
28 #:use-module (gnu packages readline)
29 #:use-module (gnu packages pkg-config)
30 #:use-module (gnu packages gnutls)
31 #:use-module (gnu packages compression))
32
33 (define-public lftp
34 (package
35 (name "lftp")
36 (version "4.6.1")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "http://lftp.yar.ru/ftp/lftp-"
40 version ".tar.xz"))
41 (sha256
42 (base32
43 "1grmp8zg7cjgjinz66mrh53whigkqzl90nlxj05hapnhk3ns3vni"))
44 (patches
45 (list (search-patch
46 "lftp-dont-save-unknown-host-fingerprint.patch")))))
47 (build-system gnu-build-system)
48 (native-inputs
49 `(("pkg-config" ,pkg-config)))
50 (inputs
51 `(("zlib" ,zlib)
52 ("readline" ,readline)
53 ("gnutls" ,gnutls)))
54 (home-page "http://lftp.yar.ru/")
55 (synopsis "Command-line file transfer program")
56 (description
57 "LFTP is a sophisticated FTP/HTTP client, and a file transfer program
58 supporting a number of network protocols. Like Bash, it has job control and
59 uses the Readline library for input. It has bookmarks, a built-in mirror
60 command, and can transfer several files in parallel. It was designed with
61 reliability in mind.")
62 (license gpl3+)))
63
64 (define-public ncftp
65 (package
66 (name "ncftp")
67 (version "3.2.5")
68 (source (origin
69 (method url-fetch)
70 (uri (string-append "ftp://ftp.ncftp.com/ncftp/ncftp-"
71 version "-src.tar.bz2"))
72 (sha256
73 (base32
74 "0hlx12i0lwi99qsrx7nccf4nvwjj2gych4yks5y179b1ax0y5sxl"))
75 (modules '((guix build utils)))
76 (snippet
77 '(begin
78 ;; Use the right 'rm' and 'ls'.
79 (substitute* (cons "configure"
80 (find-files "."
81 "^(Makefile\\.in|.*\\.sh)$"))
82 (("/bin/(rm|ls)" _ command)
83 command))
84
85 ;; This is free software, avoid any confusion.
86 (substitute* (find-files "." "\\.c$")
87 (("a freeware program")
88 "free software"))))))
89 (build-system gnu-build-system)
90 (arguments
91 '(#:phases (alist-replace
92 'configure
93 (lambda* (#:key outputs #:allow-other-keys)
94 ;; This is an old 'configure' script that doesn't
95 ;; understand variables passed as arguments.
96 (let ((out (assoc-ref outputs "out")))
97 (setenv "CONFIG_SHELL" (which "sh"))
98 (setenv "SHELL" (which "sh"))
99 (zero? (system* "./configure"
100 (string-append "--prefix=" out)))))
101 %standard-phases)
102 #:tests? #f)) ;there are no tests
103 (inputs `(("ncurses" ,ncurses)))
104 (home-page "http://www.ncftp.com/ncftp/")
105 (synopsis "Command-line File Transfer Protocol (FTP) client")
106 (description
107 "NcFTP Client (or just NcFTP) is a set of command-line programs to access
108 File Transfer Protocol (FTP) servers. This includes 'ncftp', an interactive
109 FTP browser, as well as non-interactive commands such as 'ncftpput' and
110 'ncftpget'.")
111 (license clarified-artistic)))
112
113
114 (define-public weex
115 (package
116 (name "weex")
117 (version "2.6.1.5")
118 (source
119 (origin
120 (method url-fetch)
121 (uri
122 (string-append "mirror://sourceforge/weex/weex/" version
123 "/weex-" version ".tar.gz"))
124 (sha256
125 (base32
126 "0f5cj5p852wkm24mzy2sxgxyahv2p9rk4wlq21j310pi7wlhgwyl"))
127 (patches (list (search-patch "weex-vacopy.patch")))))
128 (build-system gnu-build-system)
129 (arguments
130 `(#:phases
131 (alist-replace 'configure
132 ;; configure does not work followed by both "SHELL=..." and
133 ;; "CONFIG_SHELL=..."; set environment variables instead
134 (lambda* (#:key outputs #:allow-other-keys)
135 (let* ((out (assoc-ref outputs "out"))
136 (bash (which "bash")))
137 (setenv "SHELL" bash)
138 (setenv "CONFIG_SHELL" bash)
139 (zero? (system* bash "./configure"
140 (string-append "--prefix=" out)))))
141 %standard-phases)))
142 (home-page "http://weex.sourceforge.net/")
143 (synopsis "Non-interactive client for FTP synchronization")
144 (description
145 "Weex is a utility designed to automate the task of remotely
146 maintaining a web page or other FTP archive. It synchronizes a set of
147 local files to a remote server by performing uploads and remote deletes
148 as required.")
149 (license gpl2+)))