Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / perl6.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
3 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages perl6)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix download)
23 #:use-module (guix git-download)
24 #:use-module (guix packages)
25 #:use-module (guix build-system perl)
26 #:use-module (guix build-system rakudo)
27 #:use-module (gnu packages bdw-gc)
28 #:use-module (gnu packages libevent)
29 #:use-module (gnu packages libffi)
30 #:use-module (gnu packages multiprecision)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages tls))
33
34 (define-public moarvm
35 (package
36 (name "moarvm")
37 (version "2019.03")
38 (source
39 (origin
40 (method url-fetch)
41 (uri (string-append "https://moarvm.org/releases/MoarVM-"
42 version ".tar.gz"))
43 (sha256
44 (base32
45 "017w1zvr6yl0cgjfc1b3ddlc6vjw9q8p7alw1vvsckw95190xc14"))
46 (modules '((guix build utils)))
47 (snippet
48 '(begin
49 ;(delete-file-recursively "3rdparty/dynasm") ; JIT
50 (delete-file-recursively "3rdparty/dyncall")
51 (delete-file-recursively "3rdparty/freebsd")
52 (delete-file-recursively "3rdparty/libatomicops")
53 (delete-file-recursively "3rdparty/libuv")
54 (delete-file-recursively "3rdparty/libtommath")
55 (delete-file-recursively "3rdparty/msinttypes")
56 #t))))
57 (build-system perl-build-system)
58 (arguments
59 '(#:phases
60 (modify-phases %standard-phases
61 (replace 'configure
62 (lambda* (#:key inputs outputs #:allow-other-keys)
63 (let ((out (assoc-ref outputs "out"))
64 (pkg-config (assoc-ref inputs "pkg-config")))
65 (setenv "LDFLAGS" (string-append "-Wl,-rpath=" out "/lib"))
66 (invoke "perl" "Configure.pl"
67 "--prefix" out
68 "--pkgconfig" (string-append pkg-config "/bin/pkg-config")
69 "--has-libtommath"
70 "--has-libatomic_ops"
71 "--has-libffi"
72 "--has-libuv")))))))
73 (home-page "https://moarvm.org/")
74 ;; These should be inputs but moar.h can't find them when building rakudo
75 (propagated-inputs
76 `(("libatomic-ops" ,libatomic-ops)
77 ("libtommath" ,libtommath-1.0)
78 ("libuv" ,libuv)))
79 (inputs
80 `(("libffi" ,libffi)))
81 (native-inputs
82 `(("pkg-config" ,pkg-config)))
83 (synopsis "VM for NQP And Rakudo Perl 6")
84 (description
85 "Short for \"Metamodel On A Runtime\", MoarVM is a modern virtual machine
86 built for the Rakudo Perl 6 compiler and the NQP Compiler Toolchain. Highlights
87 include:
88
89 @itemize
90 @item Great Unicode support, with strings represented at grapheme level
91 @item Dynamic analysis of running code to identify hot functions and loops, and
92 perform a range of optimizations, including type specialization and inlining
93 @item Support for threads, a range of concurrency control constructs, and
94 asynchronous sockets, timers, processes, and more
95 @item Generational, parallel, garbage collection
96 @item Support for numerous language features, including first class functions,
97 exceptions, continuations, runtime loading of code, big integers and interfacing
98 with native libraries.
99 @end itemize")
100 (license license:artistic2.0)))
101
102 (define-public nqp
103 (package
104 (name "nqp")
105 (version "2019.03")
106 (source
107 (origin
108 (method url-fetch)
109 (uri (string-append "https://rakudo.perl6.org/downloads/nqp/nqp-"
110 version ".tar.gz"))
111 (sha256
112 (base32
113 "183zhll13fx416s3hkg4bkvib77kyr857h0nydgrl643fpacxp83"))
114 (modules '((guix build utils)))
115 (snippet
116 '(begin
117 (delete-file-recursively "3rdparty") #t))))
118 (build-system perl-build-system)
119 (arguments
120 '(#:phases
121 (modify-phases %standard-phases
122 (add-after 'patch-source-shebangs 'patch-more-shebangs
123 (lambda _
124 (substitute* '("tools/build/install-jvm-runner.pl.in"
125 "tools/build/gen-js-cross-runner.pl"
126 "tools/build/gen-js-runner.pl"
127 "tools/build/install-js-runner.pl"
128 "tools/build/install-moar-runner.pl"
129 "tools/build/gen-moar-runner.pl"
130 "t/nqp/111-spawnprocasync.t"
131 "t/nqp/113-run-command.t")
132 (("/bin/sh") (which "sh")))
133 #t))
134 (add-after 'unpack 'patch-source-date
135 (lambda _
136 (substitute* "tools/build/gen-version.pl"
137 (("gmtime") "gmtime(0)"))
138 #t))
139 (add-after 'unpack 'remove-failing-test
140 ;; One subtest fails for unknown reasons
141 (lambda _
142 (delete-file "t/nqp/019-file-ops.t")
143 #t))
144 (replace 'configure
145 (lambda* (#:key inputs outputs #:allow-other-keys)
146 (let ((out (assoc-ref outputs "out"))
147 (moar (assoc-ref inputs "moarvm")))
148 (invoke "perl" "Configure.pl"
149 "--backends=moar"
150 "--with-moar" (string-append moar "/bin/moar")
151 "--prefix" out)))))))
152 (inputs
153 `(("moarvm" ,moarvm)))
154 (home-page "https://github.com/perl6/nqp")
155 (synopsis "Not Quite Perl")
156 (description "This is \"Not Quite Perl\" -- a lightweight Perl 6-like
157 environment for virtual machines. The key feature of NQP is that it's designed
158 to be a very small environment (as compared with, say, perl6 or Rakudo) and is
159 focused on being a high-level way to create compilers and libraries for virtual
160 machines like MoarVM, the JVM, and others.
161
162 Unlike a full-fledged implementation of Perl 6, NQP strives to have as small a
163 runtime footprint as it can, while still providing a Perl 6 object model and
164 regular expression engine for the virtual machine.")
165 (license license:artistic2.0)))
166
167 (define-public rakudo
168 (package
169 (name "rakudo")
170 (version "2019.03.1")
171 (source
172 (origin
173 (method url-fetch)
174 (uri (string-append "https://rakudo.perl6.org/downloads/rakudo/rakudo-"
175 version ".tar.gz"))
176 (sha256
177 (base32
178 "1nllf69v8xr6v3kkj7pmryg11n5m3ajfkr7j72pvhrgnjy8lv3r1"))))
179 (build-system perl-build-system)
180 (arguments
181 '(#:phases
182 (modify-phases %standard-phases
183 (add-after 'unpack 'patch-source-date
184 (lambda _
185 (substitute* "tools/build/gen-version.pl"
186 (("gmtime") "gmtime(0)"))
187 #t))
188 (add-after 'patch-source-shebangs 'patch-more-shebangs
189 (lambda _
190 (substitute* '("tools/build/create-js-runner.pl"
191 "tools/build/create-moar-runner.p6"
192 "tools/build/create-jvm-runner.pl"
193 "src/core/Proc.pm6")
194 (("/bin/sh") (which "sh")))
195 #t))
196 (replace 'configure
197 (lambda* (#:key inputs outputs #:allow-other-keys)
198 (let ((out (assoc-ref outputs "out"))
199 (nqp (assoc-ref inputs "nqp")))
200 (invoke "perl" "./Configure.pl"
201 "--backend=moar"
202 "--with-nqp" (string-append nqp "/bin/nqp")
203 "--prefix" out))))
204 ;; This is the recommended tool for distro maintainers to install perl6
205 ;; modules systemwide. See: https://github.com/ugexe/zef/issues/117
206 (add-after 'install 'install-dist-tool
207 (lambda* (#:key outputs #:allow-other-keys)
208 (let* ((out (assoc-ref outputs "out"))
209 (dest (string-append out "/share/perl6/tools")))
210 (install-file "tools/install-dist.p6" dest)
211 (substitute* (string-append dest "/install-dist.p6")
212 (("/usr/bin/env perl6")
213 (string-append out "/bin/perl6"))))
214 #t)))))
215 (inputs
216 `(("moarvm" ,moarvm)
217 ("nqp" ,nqp)
218 ("openssl" ,openssl)))
219 (home-page "https://rakudo.org/")
220 (native-search-paths
221 (list (search-path-specification
222 (variable "PERL6LIB")
223 (separator ",")
224 (files '("share/perl6/lib"
225 "share/perl6/site/lib"
226 "share/perl6/vendor/lib")))))
227 (synopsis "Perl 6 Compiler")
228 (description "Rakudo Perl is a compiler that implements the Perl 6
229 specification and runs on top of several virtual machines.")
230 (license license:artistic2.0)))
231
232 (define-public perl6-grammar-debugger
233 ;; Last commit was September 2017
234 (let ((commit "0375008027c8caa216bd869476ce59ae09b2a702")
235 (revision "1"))
236 (package
237 (name "perl6-grammar-debugger")
238 (version (git-version "1.0.1" revision commit))
239 (source
240 (origin
241 (method git-fetch)
242 (uri (git-reference
243 (url "https://github.com/jnthn/grammar-debugger")
244 (commit commit)))
245 (file-name (git-file-name name version))
246 (sha256
247 (base32
248 "0y826z3m276n7ia810hgcb3div67nxmx125m2fzlc16994zd5vm5"))))
249 (build-system rakudo-build-system)
250 (propagated-inputs
251 `(("perl6-terminal-ansicolor" ,perl6-terminal-ansicolor)))
252 (home-page "https://github.com/jnthn/grammar-debugger")
253 (synopsis "Simple tracing and debugging support for Perl 6 grammars")
254 (description "This module provides a simple debugger for grammars. Just
255 @code{use} it: use @code{Grammar::Debugger;} and any grammar in the lexical
256 scope of the use statement will automatically have debugging enabled. The
257 debugger will break execution when you first enter the grammar, and provide a
258 prompt.")
259 (license license:artistic2.0))))
260
261 (define-public perl6-grammar-profiler-simple
262 ;; Last commit was June 2017
263 (let ((commit "c0aca5fab323b2974821dabd6b89330c609e0b7d")
264 (revision "1"))
265 (package
266 (name "perl6-grammar-profiler-simple")
267 (version (git-version "0.02" revision commit))
268 (source
269 (origin
270 (method git-fetch)
271 (uri (git-reference
272 (url "https://github.com/perlpilot/Grammar-Profiler-Simple.git")
273 (commit commit)))
274 (file-name (git-file-name name version))
275 (sha256
276 (base32
277 "1qcsa4lmcilp3vp0jng0hrgzyzxin9ayg2wjvkcd0k6h7djx9dff"))))
278 (build-system rakudo-build-system)
279 (arguments '(#:with-zef? #f))
280 (home-page "https://github.com/perlpilot/Grammar-Profiler-Simple")
281 (synopsis "Simple rule profiling for Perl 6 grammars")
282 (description "This module provides a simple profiler for Perl 6 grammars.
283 To enable profiling simply add use @code{Grammar::Profiler::Simple;} to your
284 code. Any grammar in the lexical scope of the use statement will automatically
285 have profiling information collected when the grammar is used.")
286 (license license:artistic2.0))))
287
288 (define-public perl6-json
289 (package
290 (name "perl6-json")
291 (version "1.0")
292 (source
293 (origin
294 (method git-fetch)
295 (uri (git-reference
296 (url "https://github.com/moritz/json")
297 ;; The commit where 1.0 was "tagged"
298 (commit "a5ef8c179350dae44ce7fb1abb684fc62c1c2b99")))
299 (file-name (git-file-name name version))
300 (sha256
301 (base32
302 "1kzryxkqyr129rcckd4jh0dfxdgzv71qx8dpkpm1divbfjyknlay"))))
303 (build-system rakudo-build-system)
304 (arguments '(#:with-zef? #f))
305 (home-page "https://github.com/moritz/json")
306 (synopsis "A minimal JSON (de)serializer")
307 (description "This module is a simple Perl 6 module for serializing and
308 deserializing JSON.")
309 (license license:artistic2.0)))
310
311 (define-public perl6-json-class
312 (package
313 (name "perl6-json-class")
314 (version "0.0.12")
315 (source
316 (origin
317 (method git-fetch)
318 (uri (git-reference
319 (url "https://github.com/jonathanstowe/JSON-Class.git")
320 (commit (string-append "v" version))))
321 (file-name (git-file-name name version))
322 (sha256
323 (base32
324 "1zyzajc57j3m8q0nr72h9pw4w2nx92rafywlvysgphc5q9sb8np2"))))
325 (build-system rakudo-build-system)
326 (propagated-inputs
327 `(("perl6-json-marshal" ,perl6-json-marshal)
328 ("perl6-json-unmarshal" ,perl6-json-unmarshal)))
329 (native-inputs
330 `(("perl6-json-fast" ,perl6-json-fast)))
331 (home-page "https://github.com/jonathanstowe/JSON-Class")
332 (synopsis "Provide simple serialisation/deserialisation of objects to/from JSON")
333 (description "This is a simple role that provides methods to instantiate a
334 class from a JSON string that (hopefully,) represents it, and to serialise an
335 object of the class to a JSON string. The JSON created from an instance
336 should round trip to a new instance with the same values for the public
337 attributes. Private attributes (that is ones without accessors,) will be
338 ignored for both serialisation and de-serialisation. The exact behaviour
339 depends on that of @code{JSON::Marshal} and @code{JSON::Unmarshal}
340 respectively.")
341 (license license:artistic2.0)))
342
343 (define-public perl6-json-fast
344 (package
345 (name "perl6-json-fast")
346 (version "0.10")
347 (source
348 (origin
349 (method git-fetch)
350 (uri (git-reference
351 (url "https://github.com/timo/json_fast.git")
352 (commit version)))
353 (file-name (git-file-name name version))
354 (sha256
355 (base32 "1g8hr1mdrxwdpzc7hvs9l5r12phvba6y6a5chgkj90ing77ji4b2"))))
356 (build-system rakudo-build-system)
357 (arguments '(#:with-zef? #f))
358 (home-page "https://github.com/timo/json_fast")
359 (synopsis "Perl6 json parser")
360 (description "A naive imperative json parser in pure perl6 (but with direct
361 access to @code{nqp::} ops), to evaluate performance against @code{JSON::Tiny}.
362 It is a drop-in replacement for @code{JSON::Tiny}'s from-json and to-json subs,
363 but it offers a few extra features.")
364 (license license:artistic2.0)))
365
366 (define-public perl6-json-marshal
367 (package
368 (name "perl6-json-marshal")
369 (version "0.0.16")
370 (source
371 (origin
372 (method git-fetch)
373 (uri (git-reference
374 (url "https://github.com/jonathanstowe/JSON-Marshal.git")
375 (commit (string-append "v" version))))
376 (file-name (git-file-name name version))
377 (sha256
378 (base32
379 "0qy7j83h6gjzyyv74ncd92cd9h45rv8diaz3vldiv3b6fqwz4c6i"))))
380 (build-system rakudo-build-system)
381 (propagated-inputs
382 `(("perl6-json-fast" ,perl6-json-fast)
383 ("perl6-json-name" ,perl6-json-name)))
384 (native-inputs
385 `(("perl6-json-fast" ,perl6-json-fast)))
386 (home-page "https://github.com/jonathanstowe/JSON-Marshal")
387 (synopsis "Simple serialisation of objects to JSON")
388 (description "This library provides a single exported subroutine to create
389 a JSON representation of an object. It should round trip back into an object
390 of the same class using @code{JSON::Unmarshal}.")
391 (license license:artistic2.0)))
392
393 (define-public perl6-json-name
394 (package
395 (name "perl6-json-name")
396 (version "0.0.3")
397 (source
398 (origin
399 (method git-fetch)
400 (uri (git-reference
401 (url "https://github.com/jonathanstowe/JSON-Name.git")
402 (commit (string-append "v" version))))
403 (file-name (git-file-name name version))
404 (sha256
405 (base32
406 "130qwdpbj5qdlsdz05y0rksd79lzbq79scy47n6lnf21b0hz1qjc"))))
407 (build-system rakudo-build-system)
408 (arguments '(#:with-zef? #f))
409 (home-page "https://github.com/jonathanstowe/JSON-Name")
410 (synopsis "Provides a trait to store an alternative JSON Name")
411 (description "This is released as a dependency of @code{JSON::Marshal} and
412 @code{JSON::Unmarshal} in order to save duplication, it is intended to store a
413 separate JSON name for an attribute where the name of the JSON attribute might be
414 changed, either for aesthetic reasons or the name is not a valid Perl identifier.
415 It will of course also be needed in classes thar are going to use
416 @code{JSON::Marshal} or @code{JSON::Unmarshal} for serialisation/de-serialisation.")
417 (license license:artistic2.0)))
418
419 (define-public perl6-json-unmarshal
420 ;; Last commit was May 2017
421 (let ((commit "e1b6288c5f3165058f36c0f4e171cdf2dfd640da")
422 (revision "1"))
423 (package
424 (name "perl6-json-unmarshal")
425 (version (git-version "0.0.0" revision commit))
426 (source
427 (origin
428 (method git-fetch)
429 (uri (git-reference
430 (url "https://github.com/tadzik/JSON-Unmarshal.git")
431 (commit commit)))
432 (file-name (git-file-name name version))
433 (sha256
434 (base32
435 "14azsmzmwdn8k0gqcpvballharcvzylmlyrx2wmv4kpqfnz29fjc"))))
436 (build-system rakudo-build-system)
437 (propagated-inputs
438 `(("perl6-json-fast" ,perl6-json-fast)
439 ("perl6-json-name" ,perl6-json-name)))
440 (home-page "https://github.com/tadzik/JSON-Unmarshal")
441 (synopsis "Make JSON from an Object")
442 (description "This library provides a single exported subroutine to
443 create an object from a JSON representation of an object.")
444 (license license:expat))))
445
446 (define-public perl6-license-spdx
447 (package
448 (name "perl6-license-spdx")
449 (version "3.4.0")
450 (source
451 (origin
452 (method git-fetch)
453 (uri (git-reference
454 (url "https://github.com/jonathanstowe/License-SPDX")
455 (commit (string-append "v" version))))
456 (file-name (git-file-name name version))
457 (sha256
458 (base32
459 "0dl263c3fbxk001gm5fisrzqz1dx182ipaa0x2qva2gxvl075xm8"))))
460 (build-system rakudo-build-system)
461 (propagated-inputs
462 `(("perl6-json-class" ,perl6-json-class)))
463 (home-page "https://github.com/jonathanstowe/License-SPDX")
464 (synopsis "Abstraction over the SPDX License List")
465 (description "This provides an abstraction over the SPDX License List as
466 provided in JSON format. Its primary raison d'être is to help the licence
467 checking of @code{Test::META} and to allow for the warning about deprecated
468 licences therein.")
469 (license license:artistic2.0)))
470
471 (define-public perl6-meta6
472 (package
473 (name "perl6-meta6")
474 (version "0.0.23")
475 (source
476 (origin
477 (method git-fetch)
478 (uri (git-reference
479 (url "https://github.com/jonathanstowe/META6.git")
480 (commit (string-append "v" version))))
481 (file-name (git-file-name name version))
482 (sha256
483 (base32
484 "1xnlaamfbdlfb2zidim3bbc4mawsrg6qxhxi6gbld46z1cyry1cw"))))
485 (build-system rakudo-build-system)
486 (propagated-inputs
487 `(("perl6-json-class" ,perl6-json-class)))
488 (native-inputs
489 `(("perl6-json-fast" ,perl6-json-fast)))
490 (home-page "https://github.com/jonathanstowe/META6")
491 (synopsis "Do things with Perl 6 [META files]")
492 (description "This provides a representation of the Perl 6 META files
493 specification - the META file data can be read, created, parsed and written in a
494 manner that is conformant with the specification.
495
496 Where they are known about it also makes allowance for customary usage in
497 existing software (such as installers and so forth.)
498
499 The intent of this is allow the generation and testing of META files for
500 module authors, so it can provide meta-information whether the attributes are
501 mandatory as per the spec and where known the places that customary attributes
502 are used.")
503 (license license:artistic2.0)))
504
505 (define-public perl6-mime-base64
506 (package
507 (name "perl6-mime-base64")
508 (version "1.2.1")
509 (source
510 (origin
511 (method git-fetch)
512 (uri (git-reference
513 (url "https://github.com/perl6/Perl6-MIME-Base64")
514 (commit (string-append "v" version))))
515 (file-name (git-file-name name version))
516 (sha256
517 (base32
518 "0l67m8mvz3gxml425sd1ggfnhzh4lf754k7w8fngfr453s6lsza1"))))
519 (build-system rakudo-build-system)
520 (arguments '(#:with-zef? #f))
521 (home-page "https://github.com/perl6/Perl6-MIME-Base64")
522 (synopsis "Encoding and decoding Base64 ASCII strings")
523 (description "This Perl 6 module implements encoding and decoding to and
524 from base64.")
525 (license license:artistic2.0)))
526
527 (define-public perl6-oo-monitors
528 (package
529 (name "perl6-oo-monitors")
530 (version "1.1")
531 (source
532 (origin
533 (method git-fetch)
534 (uri (git-reference
535 (url "https://github.com/jnthn/oo-monitors")
536 ;; The commit where 1.1 was "tagged"
537 (commit "494db3a3852854f30a80c9bd1489a7d5e429e7c5")))
538 (file-name (git-file-name name version))
539 (sha256
540 (base32
541 "1sbw2x54wwjjanghjnc7ipmplaw1srvbrphsdv4ym6cipnbmbj9x"))))
542 (build-system rakudo-build-system)
543 (arguments '(#:with-zef? #f))
544 (home-page "https://github.com/jnthn/oo-monitors")
545 (synopsis "Monitors with condition variables for Perl 6")
546 (description "A monitor provides per-instance mutual exclusion for objects.
547 This means that for a given object instance, only one thread can ever be inside
548 its methods at a time. This is achieved by a lock being associated with each
549 object. The lock is acquired automatically at the entry to each method in the
550 monitor. Condition variables are also supported.")
551 (license license:artistic2.0)))
552
553 (define-public perl6-svg
554 ;; Latest commit, basically unchanged since August 2015
555 (let ((commit "07190c0602aa276e5319f06aa0012452dbff3582")
556 (revision "1"))
557 (package
558 (name "perl6-svg")
559 (version (git-version "0.0.0" revision commit))
560 (source
561 (origin
562 (method git-fetch)
563 (uri (git-reference
564 (url "https://github.com/moritz/svg")
565 (commit commit)))
566 (file-name (git-file-name name version))
567 (sha256
568 (base32
569 "0mkjdhg7ajksdn61n8fqhyzfd7ly9myazsvpsm02a5c2q73hdygg"))))
570 (build-system rakudo-build-system)
571 (propagated-inputs
572 `(("perl6-xml-writer" ,perl6-xml-writer)))
573 (home-page "https://github.com/moritz/svg")
574 (synopsis "Perl 6 module to generate SVG")
575 (description "This is a Perl 6 module that makes it easy to write
576 @dfn{Scalable Vector Graphic files} (SVG). Right now it is a shallow wrapper
577 around @code{XML::Writer}, adding only the xmlns attributes that identifies an
578 XML file as SVG.")
579 (license license:artistic2.0))))
580
581 (define-public perl6-svg-plot
582 ;; Latest commit
583 (let ((commit "062570a78fd38c3c6baba29dfe2fbb8ca014f4de")
584 (revision "1"))
585 (package
586 (name "perl6-svg-plot")
587 (version (git-version "0.0.0" revision commit))
588 (source
589 (origin
590 (method git-fetch)
591 (uri (git-reference
592 (url "https://github.com/moritz/svg-plot")
593 (commit commit)))
594 (file-name (git-file-name name version))
595 (sha256
596 (base32
597 "095ga5hbg92jnmczxvhk1hjz14yr334zyf8cph4w5w5frcza44my"))))
598 (build-system rakudo-build-system)
599 (propagated-inputs
600 `(("perl6-svg" ,perl6-svg)))
601 (home-page "https://github.com/moritz/svg-plot")
602 (synopsis "Perl 6 charting and plotting library that produces SVG output")
603 (description "@code{SVG::Plot} is a simple 2D chart plotter for Perl 6.
604 It currently supports bars, stacked bars, lines and points (both equally spaced
605 with optional labels, or xy plots).")
606 (license license:artistic2.0))))
607
608 (define-public perl6-tap-harness
609 (package
610 (name "perl6-tap-harness")
611 (version "0.0.7")
612 (source
613 (origin
614 (method git-fetch)
615 (uri (git-reference
616 (url "https://github.com/perl6/tap-harness6.git")
617 (commit (string-append "v" version))))
618 (file-name (git-file-name name version))
619 (sha256
620 (base32
621 "1lig8i0my3fgqvlay9532xslbf3iis2d7wz89gniwvwqffi2kh6r"))))
622 (build-system rakudo-build-system)
623 (arguments
624 '(#:with-zef? #f
625 #:with-prove6? #f
626 #:phases
627 (modify-phases %standard-phases
628 (replace 'check
629 (lambda _
630 (invoke "perl6" "-Ilib" "bin/prove6" "-l" "t"))))))
631 (home-page "https://github.com/perl6/tap-harness6/")
632 (synopsis "TAP harness for perl6")
633 (description "This module provides the @command{prove6} command which runs a
634 TAP based test suite and prints a report. The @command{prove6} command is a
635 minimal wrapper around an instance of this module.")
636 (license license:artistic2.0)))
637
638 (define-public perl6-terminal-ansicolor
639 (package
640 (name "perl6-terminal-ansicolor")
641 (version "0.5")
642 (source
643 (origin
644 (method git-fetch)
645 (uri (git-reference
646 (url "https://github.com/tadzik/Terminal-ANSIColor.git")
647 ;; The commit where 0.5 was "tagged"
648 (commit "edded4a7116ce11cbc9fb5a83669c7ba119d0212")))
649 (file-name (git-file-name name version))
650 (sha256
651 (base32
652 "1apm999azkyg5s35gid12wq019aqnvzrkz7qjmipd74mdxgr00x7"))))
653 (build-system rakudo-build-system)
654 (arguments '(#:with-zef? #f))
655 (home-page "https://github.com/tadzik/Terminal-ANSIColor")
656 (synopsis "Colorize terminal output")
657 (description "This is a @code{Terminal::ANSIColor} module for Perl 6.")
658 (license license:expat)))
659
660 (define-public perl6-test-meta
661 (package
662 (name "perl6-test-meta")
663 (version "0.0.14")
664 (source
665 (origin
666 (method git-fetch)
667 (uri (git-reference
668 (url "https://github.com/jonathanstowe/Test-META")
669 (commit (string-append "v" version))))
670 (file-name (git-file-name name version))
671 (sha256
672 (base32
673 "1mzrglb7lbiy5h9dlc7dyhvv9gppxmdmpmrv6nzbd695jzr38bri"))))
674 (build-system rakudo-build-system)
675 (propagated-inputs
676 `(("perl6-meta6" ,perl6-meta6)
677 ("perl6-uri" ,perl6-uri)))
678 (home-page "https://github.com/jonathanstowe/Test-META")
679 (synopsis "Test a distributions META file")
680 (description "This provides a simple mechanism for module authors to have
681 some confidence that they have a working distribution META description file.")
682 (license license:artistic2.0)))
683
684 (define-public perl6-test-mock
685 (package
686 (name "perl6-test-mock")
687 (version "1.5")
688 (source
689 (origin
690 (method git-fetch)
691 (uri (git-reference
692 (url "https://github.com/jnthn/test-mock")
693 ;; The commit where 1.5 was "tagged"
694 (commit "6eddb42f73f40b9ac29c14badb41ce4a04d876f2")))
695 (file-name (git-file-name name version))
696 (sha256
697 (base32
698 "07yr3qimc8fl29p23562ayj2j9h53madcnf9sgqvgf2kcprh0zd2"))))
699 (build-system rakudo-build-system)
700 (propagated-inputs
701 `(("perl6-oo-monitors" ,perl6-oo-monitors)))
702 (home-page "https://github.com/jnthn/test-mock")
703 (synopsis "Module for simply generating and checking mock objects")
704 (description "@code{Test::Mock} is a module that works alongside the
705 standard Test module to help you write tests when you want to verify what
706 methods are called on an object, while still having calls to undefined methods
707 die. You get started just as normal with the test file, but also add a use
708 statement for @code{Test::Mock}.")
709 (license license:artistic2.0)))
710
711 (define-public perl6-uri
712 (package
713 (name "perl6-uri")
714 (version "0.1.5")
715 (source
716 (origin
717 (method git-fetch)
718 (uri (git-reference
719 (url "https://github.com/perl6-community-modules/uri.git")
720 (commit version)))
721 (file-name (git-file-name name version))
722 (sha256
723 (base32
724 "0h318g75jqn2ckw051g35iqyfxz1mps0jyg5z6pd857y3kacbkpl"))))
725 (build-system rakudo-build-system)
726 (arguments '(#:with-zef? #f))
727 (home-page "https://github.com/perl6-community-modules/uri")
728 (synopsis "URI implementation using Perl 6")
729 (description "A URI implementation using Perl 6 grammars to implement RFC
730 3986 BNF. Currently only implements parsing. Includes @code{URI::Escape} to
731 (un?)escape characters that aren't otherwise allowed in a URI with % and a hex
732 character numbering.")
733 (license license:artistic2.0)))
734
735 (define-public perl6-xml-writer
736 ;; Last commit was May 2017
737 (let ((commit "4d30a9d8e06033ca97387971b653817becd5a759")
738 (revision "1"))
739 (package
740 (name "perl6-xml-writer")
741 (version (git-version "0.0.0" revision commit))
742 (source
743 (origin
744 (method git-fetch)
745 (uri (git-reference
746 (url "https://github.com/masak/xml-writer")
747 (commit commit)))
748 (file-name (git-file-name name version))
749 (sha256
750 (base32
751 "1kwrf7akp70kyzw1b90khp71a6hpilihwndy2jsjpffcd4hd4m4z"))))
752 (build-system rakudo-build-system)
753 (arguments '(#:with-zef? #f))
754 (home-page "https://github.com/masak/xml-writer")
755 (synopsis "Perl 6 module to generate XML")
756 (description "@code{XML::Writer} is a module for creating XML in Perl 6.")
757 (license license:artistic2.0))))
758
759 (define-public perl6-zef
760 (package
761 (name "perl6-zef")
762 (version "0.6.7")
763 (source
764 (origin
765 (method git-fetch)
766 (uri (git-reference
767 (url "https://github.com/ugexe/zef.git")
768 (commit (string-append "v" version))))
769 (file-name (git-file-name name version))
770 (sha256
771 (base32
772 "07n7g1xw2c4g860rs890gx85vyhdq0ysgwbrnzw6q905jph2bkv7"))))
773 (build-system rakudo-build-system)
774 (arguments
775 '(#:with-zef? #f
776 #:phases
777 (modify-phases %standard-phases
778 (replace 'check
779 (lambda _
780 (setenv "HOME" "/tmp")
781 (invoke "perl6" "-I." "bin/zef" "--debug"
782 "--tap-harness" "test" "."))))))
783 (home-page "https://github.com/ugexe/zef")
784 (synopsis "Perl6 Module Management")
785 (description "Zef is a Perl 6 package (module) manager. It can be used to
786 download and install Perl 6 modules in your home directory or as a system-wide
787 module.")
788 (license license:artistic2.0)))