Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / dunst.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2017, 2018 Alex Kost <alezost@gmail.com>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages dunst)
22 #:use-module (guix packages)
23 #:use-module (guix git-download)
24 #:use-module (guix build-system gnu)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (gnu packages base)
27 #:use-module (gnu packages freedesktop)
28 #:use-module (gnu packages glib)
29 #:use-module (gnu packages gtk)
30 #:use-module (gnu packages perl)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages xorg))
33
34 (define-public dunst
35 (package
36 (name "dunst")
37 (version "1.4.1")
38 (source (origin
39 (method git-fetch)
40 (uri (git-reference
41 (url "https://github.com/dunst-project/dunst")
42 (commit (string-append "v" version))))
43 (file-name (git-file-name name version))
44 (sha256
45 (base32
46 "0xjj1f2jr1ja5grj6wrx5jjz1sx5fpqnvkw7nqi4452j3nc4p4l2"))))
47 (build-system gnu-build-system)
48 (arguments
49 '(#:tests? #f ; no check target
50 #:make-flags (list "CC=gcc"
51 (string-append "PREFIX=" %output)
52 ;; Otherwise it tries to install service file
53 ;; to "dbus" store directory.
54 (string-append "SERVICEDIR_DBUS=" %output
55 "/share/dbus-1/services"))
56 #:phases (modify-phases %standard-phases
57 (delete 'configure))))
58 (native-inputs
59 `(("pkg-config" ,pkg-config)
60 ("perl" ,perl) ; for pod2man
61 ("which" ,which)))
62 (inputs
63 `(("dbus" ,dbus)
64 ("gdk-pixbuf" ,gdk-pixbuf+svg) ; for svg support
65 ("glib" ,glib)
66 ("cairo" ,cairo)
67 ("pango" ,pango)
68 ("libx11" ,libx11)
69 ("libxscrnsaver" ,libxscrnsaver)
70 ("libxinerama" ,libxinerama)
71 ("libxrandr" ,libxrandr)
72 ("libxdg-basedir" ,libxdg-basedir)))
73 (home-page "https://dunst-project.org/")
74 (synopsis "Customizable and lightweight notification daemon")
75 (description
76 "Dunst is a highly configurable and minimalistic notification daemon.
77 It provides @code{org.freedesktop.Notifications} D-Bus service, so it is
78 started automatically on the first call via D-Bus.")
79 (license license:bsd-3)))