Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / django.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
3 ;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 ng0 <ng0@n0.is>
5 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
7 ;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
8 ;;; Copyright © 2019 Sam <smbaines8@gmail.com>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages django)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (guix packages)
28 #:use-module (guix download)
29 #:use-module (guix git-download)
30 #:use-module (guix build-system python)
31 #:use-module (gnu packages)
32 #:use-module (gnu packages base)
33 #:use-module (gnu packages databases)
34 #:use-module (gnu packages check)
35 #:use-module (gnu packages python)
36 #:use-module (gnu packages python-web)
37 #:use-module (gnu packages python-xyz)
38 #:use-module (gnu packages sphinx)
39 #:use-module (gnu packages time)
40 #:use-module (gnu packages xml))
41
42 (define-public python-django
43 (package
44 (name "python-django")
45 (version "1.11.25")
46 (source (origin
47 (method url-fetch)
48 (uri (pypi-uri "Django" version))
49 (sha256
50 (base32
51 "0rpgx212n8gh61nwizkyldvskna808xpcvawmavk5mc5c9cfh52k"))))
52 (build-system python-build-system)
53 (arguments
54 '(#:modules ((srfi srfi-1)
55 (guix build python-build-system)
56 (guix build utils))
57 #:phases
58 (modify-phases %standard-phases
59 (add-before 'check 'set-tzdir
60 (lambda* (#:key inputs #:allow-other-keys)
61 ;; The test-suite tests timezone-dependent functions, thus tzdata
62 ;; needs to be available.
63 (setenv "TZDIR"
64 (string-append (assoc-ref inputs "tzdata")
65 "/share/zoneinfo"))
66 #t))
67 (replace 'check
68 (lambda* (#:key inputs #:allow-other-keys)
69 (setenv "PYTHONPATH"
70 (string-append ".:" (getenv "PYTHONPATH")))
71 (substitute* "tests/admin_scripts/tests.py"
72 (("python_path = \\[")
73 (string-append "python_path = ['"
74 (find (lambda (entry)
75 (string-prefix?
76 (assoc-ref inputs "python-pytz")
77 entry))
78 (string-split (getenv "PYTHONPATH")
79 #\:))
80 "', ")))
81 (invoke "python" "tests/runtests.py"))))))
82 ;; TODO: Install extras/django_bash_completion.
83 (native-inputs
84 `(("tzdata" ,tzdata-for-tests)
85 ;; bcrypt and argon2-cffi are extra requirements not yet in guix
86 ;;("python-argon2-cffi" ,python-argon2-cffi) ; >= 16.1.0
87 ;;("python-bcrypt" ,python-bcrypt) ; not py-bcrypt!
88 ;; Remaining packages are test requirements taken from
89 ;; tests/requirements/py3.txt
90 ("python-docutils" ,python-docutils)
91 ;; optional for tests: ("python-geoip2" ,python-geoip2)
92 ("python-jinja2" ,python-jinja2) ; >= 2.7
93 ;; optional for tests: ("python-memcached" ,python-memcached)
94 ("python-numpy" ,python-numpy)
95 ("python-pillow" ,python-pillow)
96 ("python-pyyaml" ,python-pyyaml)
97 ;; optional for tests: ("python-selenium" ,python-selenium)
98 ("python-sqlparse" ,python-sqlparse)
99 ("python-tblib" ,python-tblib)))
100 (propagated-inputs
101 `(("python-pytz" ,python-pytz)))
102 (home-page "http://www.djangoproject.com/")
103 (synopsis "High-level Python Web framework")
104 (description
105 "Django is a high-level Python Web framework that encourages rapid
106 development and clean, pragmatic design. It provides many tools for building
107 any Web site. Django focuses on automating as much as possible and adhering
108 to the @dfn{don't repeat yourself} (DRY) principle.")
109 (license license:bsd-3)
110 (properties `((python2-variant . ,(delay python2-django))
111 (cpe-name . "django")))))
112
113 (define-public python2-django
114 (let ((base (package-with-python2 (strip-python2-variant python-django))))
115 (package
116 (inherit base)
117 (native-inputs
118 `(;; Test requirements for Python 2 taken from
119 ;; tests/requirements/py3.txt: enum34 and mock.
120 ("python2-enum34" ,python2-enum34)
121 ("python2-mock" ,python2-mock)
122 ;; When adding memcached mind: for Python 2 memcached <= 1.53 is
123 ;; required.
124 ,@(package-native-inputs base))))))
125
126 (define-public python-django-extensions
127 (package
128 (name "python-django-extensions")
129 (version "2.1.6")
130 (source
131 (origin
132 (method git-fetch)
133 ;; Fetch from the git repository, so that the tests can be run.
134 (uri (git-reference
135 (url "https://github.com/django-extensions/django-extensions.git")
136 (commit version)))
137 (file-name (string-append name "-" version))
138 (sha256
139 (base32
140 "0p4qrdinrv6indczlc8dcnm528i5fzmcn9xk1ja7ycfkyk5x6j5w"))))
141 (build-system python-build-system)
142 (arguments
143 '(#:tests? #f)) ;TODO collected 378 items / 3 errors / 1 skipped
144 (propagated-inputs
145 `(("python-six" ,python-six)
146 ("python-vobject" ,python-vobject)
147 ("python-werkzeug" ,python-werkzeug)
148 ("python-dateutil" ,python-dateutil)
149 ("python-django" ,python-django)))
150 (native-inputs
151 `(("python-mock" ,python-mock)
152 ("python-factory-boy" ,python-factory-boy)
153 ("python-tox" ,python-tox)
154 ("python-pytest" ,python-pytest)
155 ("python-pytest-cov" ,python-pytest-cov)
156 ("python-pytest-django" ,python-pytest-django)
157 ("python-shortuuid" , python-shortuuid)))
158 (home-page
159 "https://github.com/django-extensions/django-extensions")
160 (synopsis "Custom management extensions for Django")
161 (description
162 "Django-extensions extends Django providing, for example, management
163 commands, additional database fields and admin extensions.")
164 (license license:expat)))
165
166 (define-public python-django-simple-math-captcha
167 (package
168 (name "python-django-simple-math-captcha")
169 (version "1.0.7")
170 (source (origin
171 (method url-fetch)
172 (uri (pypi-uri "django-simple-math-captcha" version))
173 (sha256
174 (base32
175 "0906hms6y6znjhpd0g4wmzv9vcla4brkdpsm4zha9zdj8g5vq2hd"))))
176 (build-system python-build-system)
177 (arguments
178 ;; FIXME: Upstream uses a 'runtests.py' script that is not
179 ;; present in the pypi tarball.
180 '(#:tests? #f))
181 (propagated-inputs
182 `(("python-django" ,python-django)))
183 (home-page "https://github.com/alsoicode/django-simple-math-captcha")
184 (synopsis "Easy-to-use math field/widget captcha for Django forms")
185 (description
186 "A multi-value-field that presents a human answerable question,
187 with no settings.py configuration necessary, but instead can be configured
188 with arguments to the field constructor.")
189 (license license:asl2.0)))
190
191 (define-public python2-django-simple-math-captcha
192 (package-with-python2 python-django-simple-math-captcha))
193
194 (define-public python-django-taggit
195 (package
196 (name "python-django-taggit")
197 (version "1.1.0")
198 (source
199 (origin
200 (method url-fetch)
201 (uri (pypi-uri "django-taggit" version))
202 (sha256
203 (base32
204 "044fzcpmns90kaxdi49qczlam4xsi8rl73rpfwvxx1gkcqzidgq1"))))
205 (build-system python-build-system)
206 (arguments
207 '(#:phases
208 (modify-phases %standard-phases
209 (replace 'check
210 (lambda _
211 (invoke "python3" "-m" "django" "test" "--settings=tests.settings"))))))
212 (propagated-inputs
213 `(("python-django" ,python-django)
214 ("python-isort" ,python-isort)))
215 (native-inputs
216 `(("python-pytest" ,python-pytest)
217 ("python-mock" ,python-mock)))
218 (home-page
219 "https://github.com/jazzband/django-taggit")
220 (synopsis
221 "Reusable Django application for simple tagging")
222 (description
223 "Django-taggit is a reusable Django application for simple tagging.")
224 (license license:bsd-3)))
225
226 (define-public python-pytest-django
227 (package
228 (name "python-pytest-django")
229 (version "3.1.2")
230 (source (origin
231 (method url-fetch)
232 (uri (pypi-uri "pytest-django" version))
233 (sha256
234 (base32
235 "02932m2sr8x22m4az8syr8g835g4ak77varrnw71n6xakmdcr303"))))
236 (build-system python-build-system)
237 (arguments
238 `(#:tests? #f ; FIXME: How to run tests?
239 #:phases
240 (modify-phases %standard-phases
241 (add-after 'unpack 'patch-setuppy
242 (lambda _
243 (substitute* "setup.py"
244 (("setuptools_scm==1.11.1") "setuptools_scm"))
245 #t)))))
246 (native-inputs
247 `(("python-django" ,python-django)
248 ("python-setuptools-scm" ,python-setuptools-scm)))
249 (propagated-inputs
250 `(("python-pytest" ,python-pytest)))
251 (home-page "http://pytest-django.readthedocs.org/")
252 (synopsis "Django plugin for py.test")
253 (description "Pytest-django is a plugin for py.test that provides a set of
254 useful tools for testing Django applications and projects.")
255 (license license:bsd-3)))
256
257 (define-public python2-pytest-django
258 (package-with-python2 python-pytest-django))
259
260 (define-public python-django-filter
261 (package
262 (name "python-django-filter")
263 (version "1.1.0")
264 (source (origin
265 (method url-fetch)
266 (uri (pypi-uri "django-filter" version))
267 (sha256
268 (base32
269 "0slpfqfhnjrzlrb6vmswyhrzn01p84s16j2x1xib35gg4fxg23pc"))))
270 (build-system python-build-system)
271 (arguments
272 '(#:phases
273 (modify-phases %standard-phases
274 (replace 'check
275 (lambda _
276 (invoke "python" "runtests.py"))))))
277 (native-inputs
278 `(("python-django" ,python-django)
279 ("python-djangorestframework" ,python-djangorestframework)
280 ("python-django-crispy-forms" ,python-django-crispy-forms)
281 ("python-mock" ,python-mock)))
282 (home-page "https://django-filter.readthedocs.io/en/latest/")
283 (synopsis "Reusable Django application to filter querysets dynamically")
284 (description
285 "Django-filter is a generic, reusable application to alleviate writing
286 some of the more mundane bits of view code. Specifically, it allows users to
287 filter down a queryset based on a model’s fields, displaying the form to let
288 them do this.")
289 (license license:bsd-3)))
290
291 (define-public python2-django-filter
292 (package-with-python2 python-django-filter))
293
294 (define-public python-django-allauth
295 (package
296 (name "python-django-allauth")
297 (version "0.39.1")
298 (source
299 (origin
300 (method url-fetch)
301 (uri (pypi-uri "django-allauth" version))
302 (sha256
303 (base32
304 "17l0acpr3cihdndzccjhgv58f9z170v2qwx7w0b8w6235x646i24"))))
305 (build-system python-build-system)
306 (arguments
307 '(#:phases
308 (modify-phases %standard-phases
309 ;; TODO: Tagging the tests requiring the web could be done upstream.
310 (add-before 'check 'skip-test-requiring-network-access
311 (lambda _
312 (substitute* "allauth/socialaccount/providers/openid/tests.py"
313 (("import override_settings") "import tag, override_settings")
314 (("def test_login")
315 "@tag('requires-web')
316 def test_login"))))
317 (replace 'check
318 (lambda _
319 ;; TODO: investigate why this test fails
320 (delete-file "allauth/socialaccount/providers/cern/tests.py")
321 (setenv "DJANGO_SETTINGS_MODULE" "test_settings")
322 (invoke "django-admin"
323 "test"
324 "allauth"
325 "--verbosity=2"
326 "--exclude-tag=requires-web"))))))
327 (propagated-inputs
328 `(("python-openid" ,python-openid)
329 ("python-requests" ,python-requests)
330 ("python-requests-oauthlib" ,python-requests-oauthlib)))
331 (native-inputs
332 `(("python-mock" ,python-mock)))
333 (inputs
334 `(("python-django" ,python-django)))
335 (home-page "https://github.com/pennersr/django-allauth")
336 (synopsis "Set of Django applications addressing authentication")
337 (description
338 "Integrated set of Django applications addressing authentication,
339 registration, account management as well as 3rd party (social)
340 account authentication.")
341 (license license:expat)))
342
343 (define-public python2-django-allauth
344 (package-with-python2 python-django-allauth))
345
346 (define-public python-django-debug-toolbar
347 (package
348 (name "python-django-debug-toolbar")
349 (version "1.10.1")
350 (source
351 (origin
352 (method git-fetch)
353 (uri (git-reference
354 (url "https://github.com/jazzband/django-debug-toolbar.git")
355 (commit version)))
356 (file-name (git-file-name name version))
357 (sha256
358 (base32
359 "0zr6yjsms97wlvvd17rdbrx01irkg887dn9x70c1hzfjmfvp9afk"))))
360 (build-system python-build-system)
361 (propagated-inputs
362 `(("python-sqlparse" ,python-sqlparse)
363 ("python-django" ,python-django)))
364 (native-inputs
365 `(("python-django-jinja" ,python-django-jinja)
366 ("python-html5lib" ,python-html5lib)))
367 (arguments
368 '(#:phases
369 (modify-phases %standard-phases
370 (replace 'check
371 (lambda _
372 (invoke "make" "test"))))))
373 (home-page
374 "https://github.com/jazzband/django-debug-toolbar")
375 (synopsis "Toolbar to help with developing Django applications")
376 (description
377 "A configurable set of panels that display information about the current
378 request and response as a toolbar on the rendered page.")
379 (license license:bsd-3)))
380
381 (define-public python-django-gravatar2
382 (package
383 (name "python-django-gravatar2")
384 (version "1.4.2")
385 (source
386 (origin
387 (method url-fetch)
388 (uri (pypi-uri "django-gravatar2" version))
389 (sha256
390 (base32
391 "1qsv40xywbqsf4mkrmsswrpzqd7nfljxpfiim9an2z3dykn5rka6"))))
392 (build-system python-build-system)
393 (arguments
394 '(;; TODO: The django project for the tests is missing from the release.
395 #:tests? #f))
396 (inputs
397 `(("python-django" ,python-django)))
398 (home-page "https://github.com/twaddington/django-gravatar")
399 (synopsis "Gravatar support for Django, improved version")
400 (description
401 "Essential Gravatar support for Django. Features helper methods,
402 templatetags and a full test suite.")
403 (license license:expat)))
404
405 (define-public python2-django-gravatar2
406 (package-with-python2 python-django-gravatar2))
407
408 (define-public python-django-assets
409 (package
410 (name "python-django-assets")
411 (version "0.12")
412 (source (origin
413 (method url-fetch)
414 (uri (pypi-uri "django-assets" version))
415 (sha256
416 (base32
417 "0y0007fvkn1rdlj2g0y6k1cnkx53kxab3g8i85i0rd58k335p365"))))
418 (build-system python-build-system)
419 (arguments
420 `(#:phases
421 (modify-phases %standard-phases
422 (add-before 'check 'fix-tests
423 (lambda _
424 (begin
425 ;; https://github.com/miracle2k/django-assets/issues/87
426 (substitute* "tests/__init__.py"
427 (("settings.configure.*")
428 (string-append
429 "settings.configure(\n"
430 "INSTALLED_APPS=['django_assets', "
431 "'django.contrib.staticfiles'],\n"
432 "TEMPLATES=[{'BACKEND': "
433 "'django.template.backends.django.DjangoTemplates'}],\n"
434 ")\n")))
435 ;; These tests fail
436 (substitute* "tests/test_django.py"
437 (("TestLoader") "NoTestLoader"))))))))
438 (native-inputs
439 `(("python-nose" ,python-nose)))
440 (propagated-inputs
441 `(("python-django" ,python-django)
442 ("python-webassets" ,python-webassets)))
443 (home-page "https://github.com/miracle2k/django-assets")
444 (synopsis "Asset management for Django")
445 (description
446 "Asset management for Django, to compress and merge CSS and Javascript
447 files. Integrates the webassets library with Django, adding support for
448 merging, minifying and compiling CSS and Javascript files.")
449 (license license:bsd-2)))
450
451 (define-public python2-django-assets
452 (package-with-python2 python-django-assets))
453
454 (define-public python-django-jinja
455 (package
456 (name "python-django-jinja")
457 (version "2.4.1")
458 (source
459 (origin
460 (method git-fetch)
461 (uri (git-reference
462 (url "https://github.com/niwinz/django-jinja.git")
463 (commit version)))
464 (file-name (git-file-name name version))
465 (sha256
466 (base32
467 "1fcrxlznlq1xvl26y3j1r22vvy6m08r5l97xi2wj50rdmxhfvhis"))))
468 (build-system python-build-system)
469 (propagated-inputs
470 `(("python-django" ,python-django)
471 ("python-jinja2" ,python-jinja2)
472 ("python-pytz" ,python-pytz)
473 ("python-django-pipeline" ,python-django-pipeline)))
474 (arguments
475 '(;; TODO Tests currently fail due to issues with the configuration for
476 ;; django-pipeline
477 #:tests? #f
478 #:phases
479 (modify-phases %standard-phases
480 (replace 'check
481 (lambda* (#:key tests? #:allow-other-keys)
482 (or
483 (not tests?)
484 (with-directory-excursion "testing"
485 (invoke "python" "runtests.py"))))))))
486 (home-page
487 "https://niwinz.github.io/django-jinja/latest/")
488 (synopsis "Simple jinja2 templating backend for Django")
489 (description
490 "This package provides a templating backend for Django, using Jinja2. It
491 provides certain advantages over the builtin Jinja2 backend in Django, for
492 example, explicit calls to callables from templates and better performance.")
493 (license license:bsd-3)))
494
495 (define-public python-django-jsonfield
496 (package
497 (name "python-django-jsonfield")
498 (version "1.0.3")
499 (source (origin
500 (method url-fetch)
501 (uri (pypi-uri "jsonfield" version))
502 (sha256
503 (base32
504 "19x4lak0hg9c20r7mvf27w7i8r6i4sg2g0ypmlmp2665fnk76zvy"))))
505 (build-system python-build-system)
506 (arguments
507 `(#:phases
508 (modify-phases %standard-phases
509 (add-before 'check 'fix-tests
510 (lambda _
511 (substitute* "jsonfield/tests.py"
512 (("django.forms.util") "django.forms.utils")))))))
513 (propagated-inputs
514 `(("python-django" ,python-django)))
515 (home-page "https://github.com/bradjasper/django-jsonfield")
516 (synopsis "Store validated JSON in your model")
517 (description
518 "Django-jsonfield is a reusable Django field that allows you to store
519 validated JSON in your model. It silently takes care of serialization. To
520 use, simply add the field to one of your models.")
521 (license license:expat)))
522
523 (define-public python2-django-jsonfield
524 (package-with-python2 python-django-jsonfield))
525
526 (define-public python-dj-database-url
527 (package
528 (name "python-dj-database-url")
529 (version "0.4.2")
530 (source (origin
531 (method url-fetch)
532 (uri (pypi-uri "dj-database-url" version))
533 (sha256
534 (base32
535 "024zbkc5rli4hia9lz9g8kf1zxhb2gwawj5abf67i7gf8n22v0x6"))))
536 (build-system python-build-system)
537 (home-page "https://github.com/kennethreitz/dj-database-url")
538 (synopsis "Use Database URLs in your Django Application")
539 (description
540 "This simple Django utility allows you to utilize the 12factor inspired
541 DATABASE_URL environment variable to configure your Django application.
542
543 The dj_database_url.config method returns a Django database connection
544 dictionary, populated with all the data specified in your URL. There is also a
545 conn_max_age argument to easily enable Django’s connection pool.")
546 (license license:bsd-2)))
547
548 (define-public python2-dj-database-url
549 (package-with-python2 python-dj-database-url))
550
551 (define-public python-django-bulk-update
552 (package
553 (name "python-django-bulk-update")
554 (version "1.1.10")
555 (source (origin
556 (method url-fetch)
557 (uri (pypi-uri "django-bulk-update" version))
558 (sha256
559 (base32
560 "0mbng9m7swfc0dnidipbzlxfhlfjrv755dlnha5s4m9mgdxb1fhc"))))
561 (build-system python-build-system)
562 (arguments
563 ;; tests don't support django 1.10, but the module seems to work.
564 `(#:tests? #f))
565 (native-inputs
566 `(("six" ,python-six)
567 ("jsonfield" ,python-django-jsonfield)
568 ("python-dj-database-url" ,python-dj-database-url)))
569 (propagated-inputs
570 `(("python-django" ,python-django)))
571 (home-page "https://github.com/aykut/django-bulk-update")
572 (synopsis "Simple bulk update over Django ORM or with helper function")
573 (description
574 "Simple bulk update over Django ORM or with helper function. This
575 project aims to bulk update given objects using one query over Django ORM.")
576 (license license:expat)))
577
578 (define-public python2-django-bulk-update
579 (package-with-python2 python-django-bulk-update))
580
581 (define-public python-django-contact-form
582 (package
583 (name "python-django-contact-form")
584 (version "1.3")
585 (source (origin
586 (method url-fetch)
587 (uri (pypi-uri "django-contact-form" version))
588 (sha256
589 (base32
590 "0az590y56k5ahv4sixrkn54d3a8ig2q2z9pl6s3m4f533mx2gj17"))))
591 (build-system python-build-system)
592 (arguments
593 `(#:phases
594 (modify-phases %standard-phases
595 (replace 'check
596 (lambda _
597 ;; the next version will need "make test"
598 (invoke "flake8" "contact_form")
599 (invoke "coverage" "run" "contact_form/runtests.py")
600 (invoke "coverage" "report" "-m" "--fail-under" "0"))))))
601 (native-inputs
602 `(("python-coverage" ,python-coverage)
603 ("python-flake8" ,python-flake8)))
604 (propagated-inputs
605 `(("python-django" ,python-django)))
606 (home-page "https://github.com/ubernostrum/django-contact-form")
607 (synopsis "Contact form for Django")
608 (description
609 "This application provides simple, extensible contact-form functionality
610 for Django sites.")
611 (license license:bsd-3)))
612
613 (define-public python2-django-contact-form
614 (package-with-python2 python-django-contact-form))
615
616 (define-public python-django-contrib-comments
617 (package
618 (name "python-django-contrib-comments")
619 (version "1.8.0")
620 (source (origin
621 (method url-fetch)
622 (uri (pypi-uri "django-contrib-comments" version))
623 (sha256
624 (base32
625 "0bxsgw8jrkhg6r5s0z6ksfi4w8yknaqb1s9acmxd9pm3pnsnp5kx"))))
626 (build-system python-build-system)
627 (propagated-inputs
628 `(("python-django" ,python-django)))
629 (home-page "https://github.com/django/django-contrib-comments")
630 (synopsis "Comments framework")
631 (description
632 "Django used to include a comments framework; since Django 1.6 it's been
633 separated to a separate project. This is that project. This framework can be
634 used to attach comments to any model, so you can use it for comments on blog
635 entries, photos, book chapters, or anything else.")
636 (license license:bsd-3)))
637
638 (define-public python2-django-contrib-comments
639 (package-with-python2 python-django-contrib-comments))
640
641 (define-public python-django-overextends
642 (package
643 (name "python-django-overextends")
644 (version "0.4.3")
645 (source (origin
646 (method url-fetch)
647 (uri (pypi-uri "django-overextends" version))
648 (sha256
649 (base32
650 "0qc2pcf3i56pmfxh2jw7k3pgljd8xzficmkl2541n7bkcbngqfzm"))))
651 (build-system python-build-system)
652 (arguments
653 `(#:phases
654 (modify-phases %standard-phases
655 (replace 'check
656 (lambda _ (invoke "./test_project/manage.py" "test"))))))
657 (propagated-inputs
658 `(("python-django" ,python-django)))
659 (native-inputs
660 `(("sphinx-me" ,python-sphinx-me)))
661 (home-page "https://github.com/stephenmcd/django-overextends")
662 (synopsis "Circular template inheritance")
663 (description
664 "A Django reusable app providing the overextends template tag, a drop-in
665 replacement for Django's extends tag, which allows you to use circular template
666 inheritance. The primary use-case for overextends is to simultaneously
667 override and extend templates from other reusable apps, in your own Django
668 project.")
669 (license license:bsd-2)))
670
671 (define-public python2-django-overextends
672 (package-with-python2 python-django-overextends))
673
674 (define-public python-django-pipeline
675 (package
676 (name "python-django-pipeline")
677 (version "1.6.14")
678 (source
679 (origin
680 (method url-fetch)
681 (uri (pypi-uri "django-pipeline" version))
682 (sha256
683 (base32
684 "1a207y71r7za033ira0qmh2yrgp5rq0l04gw2fg9b8jri7sslrzg"))))
685 (build-system python-build-system)
686 (arguments
687 '(#:phases
688 (modify-phases %standard-phases
689 (add-after 'unpack 'patch-source
690 (lambda _
691 (substitute* "tests/tests/test_compiler.py"
692 (("\\/usr\\/bin\\/env")
693 (which "env")))))
694 (replace 'check
695 (lambda*(#:key tests? #:allow-other-keys)
696 (or
697 (not tests?)
698 (begin
699 (setenv "PYTHONPATH"
700 (string-append (getcwd) ":"
701 (getenv "PYTHONPATH")))
702 (setenv "DJANGO_SETTINGS_MODULE" "tests.settings")
703 (invoke "django-admin" "test" "tests"))))))))
704 (propagated-inputs
705 `(("python-django" ,python-django)
706 ("python-slimit" ,python-slimit)
707 ("python-jsmin" ,python-jsmin)))
708 (home-page
709 "https://github.com/jazzband/django-pipeline")
710 (synopsis "Asset packaging library for Django")
711 (description
712 "Pipeline is an asset packaging library for Django, providing both CSS
713 and JavaScript concatenation and compression, built-in JavaScript template
714 support, and optional data-URI image and font embedding.")
715 (license license:expat)))
716
717 (define-public python-django-redis
718 (package
719 (name "python-django-redis")
720 (version "4.10.0")
721 (source (origin
722 (method url-fetch)
723 (uri (pypi-uri "django-redis" version))
724 (sha256
725 (base32
726 "1rxcwnv9ik0swkwvfqdi9i9baw6n8if5pj6q63fjh4p9chw3j2xg"))))
727 (build-system python-build-system)
728 (arguments
729 `(#:phases
730 (modify-phases %standard-phases
731 (replace 'check
732 (lambda _
733 (invoke "redis-server" "--daemonize" "yes")
734 (with-directory-excursion "tests"
735 (invoke "python" "runtests.py")))))))
736 (native-inputs
737 `(("python-fakeredis" ,python-fakeredis)
738 ("python-hiredis" ,python-hiredis)
739 ("python-mock" ,python-mock)
740 ("python-msgpack" ,python-msgpack)
741 ("redis" ,redis)))
742 (propagated-inputs
743 `(("python-django" ,python-django)
744 ("python-redis" ,python-redis)))
745 (home-page "https://github.com/niwibe/django-redis")
746 (synopsis "Full featured redis cache backend for Django")
747 (description
748 "Full featured redis cache backend for Django.")
749 (license license:bsd-3)))
750
751 (define-public python2-django-redis
752 (package-with-python2 python-django-redis))
753
754 (define-public python-django-rq
755 (package
756 (name "python-django-rq")
757 (version "1.3.1")
758 (source (origin
759 (method url-fetch)
760 (uri (pypi-uri "django-rq" version))
761 (sha256
762 (base32
763 "1ips1ikv5qhgwb58ssn496vgqg9qv6jinwmwbrg9l3s75fskd1l5"))))
764 (build-system python-build-system)
765 (arguments
766 `(#:phases
767 (modify-phases %standard-phases
768 (replace 'check
769 (lambda _
770 (invoke "redis-server" "--daemonize" "yes")
771 (invoke "django-admin.py" "test" "django_rq"
772 "--settings=django_rq.tests.settings"
773 "--pythonpath="))))))
774 (native-inputs
775 `(("python-mock" ,python-mock)
776 ("redis" ,redis)))
777 (propagated-inputs
778 `(("python-django" ,python-django)
779 ("python-rq" ,python-rq)))
780 (home-page "https://github.com/ui/django-rq")
781 (synopsis "Django integration with RQ")
782 (description
783 "Django integration with RQ, a Redis based Python queuing library.
784 Django-RQ is a simple app that allows you to configure your queues in django's
785 settings.py and easily use them in your project.")
786 (license license:expat)))
787
788 (define-public python2-django-rq
789 (package-with-python2 python-django-rq))
790
791 (define-public python-django-sortedm2m
792 (package
793 (name "python-django-sortedm2m")
794 (version "1.3.3")
795 (source (origin
796 (method url-fetch)
797 (uri (pypi-uri "django-sortedm2m" version))
798 (sha256
799 (base32
800 "0axf765i7b3c2s83nlph47asi8s071dhq8l7y382v1pw785s22vi"))))
801 (build-system python-build-system)
802 (arguments
803 ;; no tests.
804 `(#:tests? #f))
805 (propagated-inputs
806 `(("python-django" ,python-django)))
807 (home-page "https://github.com/gregmuellegger/django-sortedm2m")
808 (synopsis "Drop-in replacement for django's own ManyToManyField")
809 (description
810 "Sortedm2m is a drop-in replacement for django's own ManyToManyField.
811 The provided SortedManyToManyField behaves like the original one but remembers
812 the order of added relations.")
813 (license license:bsd-3)))
814
815 (define-public python2-django-sortedm2m
816 (package-with-python2 python-django-sortedm2m))
817
818 (define-public python-django-appconf
819 (package
820 (name "python-django-appconf")
821 (version "1.0.3")
822 (source (origin
823 (method url-fetch)
824 (uri (pypi-uri "django-appconf" version))
825 (sha256
826 (base32
827 "1qw0p9qh78bvkgi38ba58djwn0rd5j1lrkg2c2wk5wb7snj3rw9m"))))
828 (build-system python-build-system)
829 (propagated-inputs
830 `(("python-django" ,python-django)
831 ("python-six" ,python-six)))
832 (home-page "https://github.com/django-compressor/django-appconf")
833 (synopsis "Handle configuration defaults of packaged Django apps")
834 (description
835 "This app precedes Django's own AppConfig classes that act as \"objects
836 [to] store metadata for an application\" inside Django's app loading mechanism.
837 In other words, they solve a related but different use case than
838 django-appconf and can't easily be used as a replacement. The similarity in
839 name is purely coincidental.")
840 (license license:bsd-3)))
841
842 (define-public python2-django-appconf
843 (package-with-python2 python-django-appconf))
844
845 (define-public python-django-statici18n
846 (package
847 (name "python-django-statici18n")
848 (version "1.3.0")
849 (source (origin
850 (method url-fetch)
851 (uri (pypi-uri "django-statici18n" version))
852 (sha256
853 (base32
854 "0alcf4g1nv69njhq5k3qw4mfl2k6dc18bik5nk0g1mnp3m8zyz7k"))))
855 (build-system python-build-system)
856 (propagated-inputs
857 `(("python-django" ,python-django)
858 ("django-appconf" ,python-django-appconf)))
859 (home-page "https://github.com/zyegfryed/django-statici18n")
860 (synopsis "Generate JavaScript catalog to static files")
861 (description
862 "A Django app that provides helper for generating JavaScript catalog to
863 static files.")
864 (license license:bsd-3)))
865
866 (define-public python2-django-statici18n
867 (package-with-python2 python-django-statici18n))
868
869 (define-public pootle
870 (package
871 (name "pootle")
872 (version "2.8.2")
873 (source
874 (origin
875 (method url-fetch)
876 (uri (pypi-uri "Pootle" version ".tar.bz2"))
877 (sha256
878 (base32
879 "1ng8igq0alsqzasgxdh3fb23581anyzp121h9041pwdzzv98kn4m"))))
880 (build-system python-build-system)
881 (arguments
882 `(; pootle supports only python2.
883 #:python ,python-2
884 ;; tests are not run and fail with "pytest_pootle/data/po/.tmp: No such
885 ;; file or directory". If we create this directory,
886 ;; pytest_pootle/data/po/terminology.po is missing.
887 #:tests? #f
888 #:phases
889 (modify-phases %standard-phases
890 (add-before 'build 'fix-requirements
891 (lambda _
892 (substitute* "Pootle.egg-info/requires.txt"
893 (("1.7.3") "1.8.0")
894 (("2.0.0") "2.1.0"))
895 (substitute* "requirements/tests.txt"
896 (("==3.0.6") ">=3.0.6"))
897 (substitute* "requirements/base.txt"
898 (("1.7.3") "1.8.0")
899 (("2.0.0") "2.1.0")))))))
900 (propagated-inputs
901 `(("django-allauth" ,python2-django-allauth)
902 ("django-assets" ,python2-django-assets)
903 ("django-bulk-update" ,python2-django-bulk-update)
904 ("django-contact-form" ,python2-django-contact-form)
905 ("django-contrib-comments" ,python2-django-contrib-comments)
906 ("django-overextends" ,python2-django-overextends)
907 ("django-redis" ,python2-django-redis)
908 ("django-rq" ,python2-django-rq)
909 ("django-sortedm2m" ,python2-django-sortedm2m)
910 ("django-statici18n" ,python2-django-statici18n)
911 ("babel" ,python2-babel)
912 ("cssmin" ,python2-cssmin)
913 ("diff-match-patch" ,python2-diff-match-patch)
914 ("dirsync" ,python2-dirsync)
915 ("elasticsearch" ,python2-elasticsearch)
916 ("jsonfield" ,python2-django-jsonfield)
917 ("lxml" ,python2-lxml)
918 ("dateutil" ,python2-dateutil)
919 ("levenshtein" ,python2-levenshtein)
920 ("mysqlclient" ,python2-mysqlclient)
921 ("psycopg2" ,python2-psycopg2)
922 ("pytz" ,python2-pytz)
923 ("rq" ,python2-rq)
924 ("scandir" ,python2-scandir)
925 ("stemming" ,python2-stemming)
926 ("translate-toolkit" ,python2-translate-toolkit)))
927 (native-inputs
928 `(("python2-pytest" ,python2-pytest)
929 ("python2-pytest-django" ,python2-pytest-django)
930 ("python2-pytest-catchlog" ,python2-pytest-catchlog)
931 ("python2-pytest-cov" ,python2-pytest-cov)
932 ("python2-factory-boy" ,python2-factory-boy)))
933 (home-page "http://pootle.translatehouse.org/")
934 (synopsis "Community localization server")
935 (description
936 "Pootle is an online translation and localization tool. It works to
937 lower the barrier of entry, providing tools to enable teams to work towards
938 higher quality while welcoming newcomers.")
939 (license license:gpl3+)))
940
941 (define-public python-django-tagging
942 (package
943 (name "python-django-tagging")
944 (version "0.4.6")
945 (source
946 (origin
947 (method url-fetch)
948 (uri (pypi-uri "django-tagging" version))
949 (sha256
950 (base32
951 "0s7b4v45j783yaxs7rni10k24san0ya77nqz4s7zdf3jhfpk42r1"))))
952 (build-system python-build-system)
953 (home-page "https://github.com/Fantomas42/django-tagging")
954 (synopsis "Generic tagging application for Django")
955 (description "This package provides a generic tagging application for
956 Django projects, which allows association of a number of tags with any
957 @code{Model} instance and makes retrieval of tags simple.")
958 (license license:bsd-3)))
959
960 (define-public python2-django-tagging
961 (package-with-python2 python-django-tagging))
962
963 (define-public python-djangorestframework
964 (package
965 (name "python-djangorestframework")
966 (version "3.7.7")
967 (source
968 (origin
969 (method url-fetch)
970 (uri (pypi-uri "djangorestframework" version))
971 (sha256
972 (base32
973 "11qv117gqwswxjljs7wafxg1hyzzlx3qrviwlk9hw41bsbl997lz"))))
974 (build-system python-build-system)
975 (arguments
976 '(;; No included tests
977 #:tests? #f))
978 (propagated-inputs
979 `(("python-django" ,python-django)))
980 (home-page "https://www.django-rest-framework.org")
981 (synopsis "Toolkit for building Web APIs with Django")
982 (description
983 "The Django REST framework is for building Web APIs with Django. It
984 provides features like a web browseable API and authentication policies.")
985 (license license:bsd-2)))
986
987 (define-public python-django-crispy-forms
988 (package
989 (name "python-django-crispy-forms")
990 (version "1.7.2")
991 (source
992 (origin
993 (method url-fetch)
994 (uri (pypi-uri "django-crispy-forms" version))
995 (sha256
996 (base32
997 "0pv7y648i8iz7mf64gkjizpbx5d01ap2s4vqqa30n38if6wvlljr"))))
998 (build-system python-build-system)
999 (arguments
1000 '(;; No included tests
1001 #:tests? #f))
1002 (propagated-inputs
1003 `(("python-django" ,python-django)))
1004 (home-page
1005 "http://github.com/maraujop/django-crispy-forms")
1006 (synopsis "Tool to control Django forms without custom templates")
1007 (description
1008 "@code{django-crispy-forms} lets you easily build, customize and reuse
1009 forms using your favorite CSS framework, without writing template code.")
1010 (license license:expat)))
1011
1012 (define-public python-django-override-storage
1013 (package
1014 (name "python-django-override-storage")
1015 (version "0.1.6")
1016 (source
1017 (origin
1018 (method url-fetch)
1019 (uri (pypi-uri "django-override-storage" version))
1020 (sha256
1021 (base32 "022arq94lxnlyykn8wvfnkykhi2dldnsn93pa2i41na551i0wpiv"))))
1022 (build-system python-build-system)
1023 (propagated-inputs
1024 `(("python-django" ,python-django)))
1025 (home-page
1026 "https://github.com/danifus/django-override-storage")
1027 (synopsis "Django test helpers to manage file storage side effects")
1028 (description
1029 "This project provides tools to help reduce the side effects of using
1030 FileFields during tests.")
1031 (license license:expat)))