Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / dico.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages dico)
22 #:use-module (guix packages)
23 #:use-module ((guix licenses) #:select (gpl3+))
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages readline)
28 #:use-module (gnu packages m4)
29 #:use-module (gnu packages groff)
30 #:use-module (gnu packages guile)
31 #:use-module (gnu packages python)
32 #:use-module (gnu packages pcre)
33 #:use-module (gnu packages gsasl)
34 #:use-module (gnu packages autotools)
35 #:use-module (gnu packages compression)
36 #:use-module (gnu packages wordnet))
37
38 (define-public dico
39 (package
40 (name "dico")
41 (version "2.9")
42 (source (origin
43 (method url-fetch)
44 (uri (string-append "mirror://gnu/dico/dico-"
45 version ".tar.xz"))
46 (sha256
47 (base32
48 "0i9xqhy3h5nlizcmav4mv5ay8ivdgn4l4k0k7fxix3fsc87nijyr"))))
49 (build-system gnu-build-system)
50 (arguments
51 '(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
52 "/share/guile/site/2.0"))
53 #:make-flags '("V=1")
54 #:phases (modify-phases %standard-phases
55 (add-before 'check 'silence-guile
56 (lambda _
57 ;; Guile is too talkative, which disturbs the test
58 ;; infrastructure. Gag it.
59 (setenv "GUILE_AUTO_COMPILE" "0")
60 (setenv "GUILE_WARN_DEPRECATED" "no")
61 #t))
62 (replace 'check
63 (lambda _
64 ;; Test '71: append + dooffs + env' fails if $V is not 2.
65 (invoke "make" "check" "V=2"))))))
66 (inputs
67 `(("m4" ,m4) ;used at run time
68 ("pcre" ,pcre)
69 ("python" ,python-2)
70 ("guile" ,guile-2.2)
71 ("gsasl" ,gsasl)
72 ("groff" ,groff)
73 ("readline" ,readline)
74 ("zlib" ,zlib)
75 ("wordnet" ,wordnet)
76 ("libltdl" ,libltdl)))
77 (home-page "https://www.gnu.org/software/dico/")
78 (synopsis "Implementation of DICT server (RFC 2229)")
79 (description
80 "GNU Dico implements a flexible dictionary server and client according to
81 RFC 2229 (DICT Server). It is able to access any database available,
82 regardless of format, thanks to its modular structure. New modules may be
83 written in C, Guile or Python. Dico also includes a command-line client,
84 which may be used to query remote dictionary databases.")
85 (license gpl3+)))