Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / cook.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages cook)
21 #:use-module (guix packages)
22 #:use-module (guix licenses)
23 #:use-module (guix download)
24 #:use-module (gnu packages ed)
25 #:use-module (gnu packages bison)
26 #:use-module (gnu packages groff)
27 #:use-module (gnu packages compression)
28 #:use-module (guix build-system gnu))
29
30 (define-public cook
31 (package
32 (name "cook")
33 (version "2.34")
34 (source
35 (origin
36 (method url-fetch)
37 (uri "http://fossies.org/linux/misc/old/cook-2.34.tar.gz")
38 (sha256
39 (base32
40 "104saqnqql1l7zr2pm3f718fdky3ds8j07c6xvwrs1rfkhrw58yw"))))
41 (build-system gnu-build-system)
42 (arguments
43 `(#:parallel-build? #f ; There are some nasty racy rules in the Makefile.
44 #:phases
45 (modify-phases %standard-phases
46 (add-before 'configure 'pre-conf
47 (lambda _
48 (substitute* (append '("common/env.c")
49 (find-files "test" "\\.sh"))
50 (("/bin/sh") (which "sh")))
51
52 ;; Guix's binutils (because it wants bit-reproducable builds) is
53 ;; is configured with the --enable-deterministic-archives flag.
54 ;; This means the timestamp of files appended to an ar archive
55 ;; are automatically and silently mutated to 00:00 1 Jan 1970
56 ;; which plays havoc with this test, for which correct timestamps
57 ;; are very important. Adding the U flag undoes the effect of
58 ;; --enable-deterministic-archives and allows this test to work
59 ;; again.
60 (substitute* "test/00/t0077a.sh"
61 (("ar qc") "ar qcU"))
62
63 (setenv "SH" (which "sh"))
64 #t)))))
65 (native-inputs `(("bison" ,bison)
66 ;; For building the documentation:
67 ("groff" ,groff)
68 ;; For the tests:
69 ("sharutils" ,sharutils)
70 ;; One test wants rsh. However there is no rsh server
71 ;; running in the build environment and so far as I'm
72 ;; aware, it cannot be started without root.
73 ;; This test is therefore just skipped.
74 ;; ("inetutils" ,inetutils)
75 ("ed" ,ed)))
76 (home-page "http://miller.emu.id.au/pmiller/software/cook")
77 (synopsis "Tool for constructing files")
78 (description "Cook is a tool for constructing files. It is given a set of
79 files to create, and recipes of how to create them. In any non-trivial program
80 there will be prerequisites to performing the actions necessary to creating
81 any file, such as include files. Cook provides a mechanism to define these.")
82 (license gpl3+)))