Merge branch 'staging' into core-updates
[jackhill/guix/guix.git] / gnu / packages / autotools.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
3 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
5 ;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
6 ;;; Copyright © 2015, 2017, 2018 Mark H Weaver <mhw@netris.org>
7 ;;; Copyright © 2016 David Thompson <davet@gnu.org>
8 ;;; Copyright © 2017 ng0 <ng0@n0.is>
9 ;;; Copyright © 2017, 2019 Efraim Flashner <efraim@flashner.co.il>
10 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
11 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
12 ;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages autotools)
30 #:use-module (guix licenses)
31 #:use-module (gnu packages)
32 #:use-module (gnu packages perl)
33 #:use-module (gnu packages python)
34 #:use-module (gnu packages m4)
35 #:use-module (gnu packages man)
36 #:use-module (gnu packages bash)
37 #:use-module (guix utils)
38 #:use-module (guix packages)
39 #:use-module (guix download)
40 #:use-module (guix build-system gnu)
41 #:use-module (guix build-system trivial)
42 #:use-module (ice-9 match)
43 #:export (autoconf-wrapper))
44
45 (define-public autoconf
46 (package
47 (name "autoconf")
48 (version "2.69")
49 (source
50 (origin
51 (method url-fetch)
52 (uri (string-append "mirror://gnu/autoconf/autoconf-"
53 version ".tar.xz"))
54 (sha256
55 (base32
56 "113nlmidxy9kjr45kg9x3ngar4951mvag1js2a3j8nxcz34wxsv4"))))
57 (build-system gnu-build-system)
58 (native-inputs
59 `(("perl" ,perl)
60 ("m4" ,m4)))
61 ;; XXX: testsuite: 209 and 279 failed. The latter is an impurity. It
62 ;; should use our own "cpp" instead of "/lib/cpp".
63 (arguments `(#:tests? #f))
64 (home-page
65 "http://www.gnu.org/software/autoconf/")
66 (synopsis "Create source code configuration scripts")
67 (description
68 "Autoconf offers the developer a robust set of M4 macros which expand
69 into shell code to test the features of Unix-like systems and to adapt
70 automatically their software package to these systems. The resulting shell
71 scripts are self-contained and portable, freeing the user from needing to
72 know anything about Autoconf or M4.")
73 (license gpl3+))) ; some files are under GPLv2+
74
75 (define-public autoconf-2.68
76 (package (inherit autoconf)
77 (version "2.68")
78 (source
79 (origin
80 (method url-fetch)
81 (uri (string-append "mirror://gnu/autoconf/autoconf-"
82 version ".tar.xz"))
83 (sha256
84 (base32
85 "1fjm21k2na07f3vasf288a0zx66lbv0hd3l9bvv3q8p62s3pg569"))))))
86
87 (define-public autoconf-2.64
88 ;; As of GDB 7.8, GDB is still developed using this version of Autoconf.
89 (package (inherit autoconf)
90 (version "2.64")
91 (source
92 (origin
93 (method url-fetch)
94 (uri (string-append "mirror://gnu/autoconf/autoconf-"
95 version ".tar.xz"))
96 (sha256
97 (base32
98 "0j3jdjpf5ly39dlp0bg70h72nzqr059k0x8iqxvaxf106chpgn9j"))))))
99
100 (define-public autoconf-2.13
101 ;; GNU IceCat 52.x requires autoconf-2.13 to build!
102 (package (inherit autoconf)
103 (version "2.13")
104 (source
105 (origin
106 (method url-fetch)
107 (uri (string-append "mirror://gnu/autoconf/autoconf-"
108 version ".tar.gz"))
109 (sha256
110 (base32
111 "07krzl4czczdsgzrrw9fiqx35xcf32naf751khg821g5pqv12qgh"))))
112 (arguments
113 `(#:tests? #f
114 #:phases
115 ;; The 'configure' script in autoconf-2.13 can't cope with "SHELL=" and
116 ;; "CONFIG_SHELL=" arguments, so we set them as environment variables
117 ;; and pass a simplified set of arguments.
118 (modify-phases %standard-phases
119 (replace 'configure
120 (lambda* (#:key build inputs outputs #:allow-other-keys)
121 (let ((bash (which "bash"))
122 (out (assoc-ref outputs "out")))
123 (setenv "CONFIG_SHELL" bash)
124 (setenv "SHELL" bash)
125 (invoke bash "./configure"
126 (string-append "--prefix=" out)
127 (string-append "--build=" build))))))))))
128
129
130 (define (make-autoconf-wrapper autoconf)
131 "Return a wrapper around AUTOCONF that generates `configure' scripts that
132 use our own Bash instead of /bin/sh in shebangs. For that reason, it should
133 only be used internally---users should not end up distributing `configure'
134 files with a system-specific shebang."
135 (package (inherit autoconf)
136 (name (string-append (package-name autoconf) "-wrapper"))
137 (build-system trivial-build-system)
138 (inputs `(("guile"
139 ;; XXX: Kludge to hide the circular dependency.
140 ,(module-ref (resolve-interface '(gnu packages guile))
141 'guile-2.0))
142 ("autoconf" ,autoconf)
143 ("bash" ,bash)))
144 (arguments
145 '(#:modules ((guix build utils))
146 #:builder
147 (begin
148 (use-modules (guix build utils))
149 (let* ((out (assoc-ref %outputs "out"))
150 (bin (string-append out "/bin"))
151 (autoconf (string-append
152 (assoc-ref %build-inputs "autoconf")
153 "/bin/autoconf"))
154 (guile (string-append
155 (assoc-ref %build-inputs "guile")
156 "/bin/guile"))
157 (sh (string-append
158 (assoc-ref %build-inputs "bash")
159 "/bin/sh"))
160 (modules ((compose dirname dirname dirname)
161 (search-path %load-path
162 "guix/build/utils.scm"))))
163 (mkdir-p bin)
164
165 ;; Symlink all the binaries but `autoconf'.
166 (with-directory-excursion bin
167 (for-each (lambda (file)
168 (unless (string=? (basename file) "autoconf")
169 (symlink file (basename file))))
170 (find-files (dirname autoconf) ".*")))
171
172 ;; Add an `autoconf' binary that wraps the real one.
173 (call-with-output-file (string-append bin "/autoconf")
174 (lambda (port)
175 ;; Shamefully, Guile can be used in shebangs only if a
176 ;; single argument is passed (-ds); otherwise it gets
177 ;; them all as a single argument and fails to parse them.
178 (format port "#!~a
179 export GUILE_LOAD_PATH=\"~a\"
180 export GUILE_LOAD_COMPILED_PATH=\"~a\"
181 exec ~a --no-auto-compile \"$0\" \"$@\"
182 !#~%"
183 sh modules modules guile)
184 (write
185 `(begin
186 (use-modules (guix build utils))
187 (let ((result (apply system* ,autoconf
188 (cdr (command-line)))))
189 (when (and (file-exists? "configure")
190 (not (file-exists? "/bin/sh")))
191 ;; Patch regardless of RESULT, because `autoconf
192 ;; -Werror' can both create a `configure' file and
193 ;; return a non-zero exit code.
194 (patch-shebang "configure"))
195 (exit (status:exit-val result))))
196 port)))
197 (chmod (string-append bin "/autoconf") #o555)
198 #t))))
199
200 ;; Do not show it in the UI since it's meant for internal use.
201 (properties '((hidden? . #t)))))
202
203 (define-public autoconf-wrapper
204 (make-autoconf-wrapper autoconf))
205
206 (define-public autoconf-archive
207 (package
208 (name "autoconf-archive")
209 (version "2019.01.06")
210 (source
211 (origin
212 (method url-fetch)
213 (uri (string-append "mirror://gnu/autoconf-archive/autoconf-archive-"
214 version ".tar.xz"))
215 (sha256
216 (base32
217 "0gqya7nf4j5k98dkky0c3bnr0paciya91vkqazg7knlq621mq68p"))))
218 (build-system gnu-build-system)
219 (home-page "https://www.gnu.org/software/autoconf-archive/")
220 (synopsis "Collection of freely reusable Autoconf macros")
221 (description
222 "Autoconf Archive is a collection of over 450 new macros for Autoconf,
223 greatly expanding the domain of its functionality. These macros have been
224 contributed as free software by the community.")
225 (license gpl3+)))
226
227 (define-public autobuild
228 (package
229 (name "autobuild")
230 (version "5.3")
231 (source (origin
232 (method url-fetch)
233 (uri (string-append "mirror://savannah/autobuild/autobuild-"
234 version ".tar.gz"))
235 (sha256
236 (base32
237 "0gv7g61ja9q9zg1m30k4snqwwy1kq7b4df6sb7d2qra7kbdq8af1"))))
238 (build-system gnu-build-system)
239 (inputs `(("perl" ,perl)))
240 (synopsis "Process generated build logs")
241 (description "Autobuild is a package that processes build logs generated
242 when building software. Autobuild is primarily focused on packages using
243 Autoconf and Automake, but can be used with other build systems too.
244 Autobuild generates an HTML summary file, containing links to each build log.
245 The summary includes project name, version, build hostname, host type (cross
246 compile aware), date of build, and indication of success or failure. The
247 output is indexed in many ways to simplify browsing.")
248 (home-page "http://josefsson.org/autobuild/")
249 (license gpl3+)))
250
251 (define-public automake
252 (package
253 (name "automake")
254 (version "1.16.1")
255 (source (origin
256 (method url-fetch)
257 (uri (string-append "mirror://gnu/automake/automake-"
258 version ".tar.xz"))
259 (sha256
260 (base32
261 "08g979ficj18i1w6w5219bgmns7czr03iadf20mk3lrzl8wbn1ax"))
262 (patches
263 (search-patches "automake-skip-amhello-tests.patch"))))
264 (build-system gnu-build-system)
265 (native-inputs
266 `(("autoconf" ,autoconf-wrapper)
267 ("perl" ,perl)))
268 (native-search-paths
269 (list (search-path-specification
270 (variable "ACLOCAL_PATH")
271 (files '("share/aclocal")))))
272 (arguments
273 '(#:modules ((guix build gnu-build-system)
274 (guix build utils)
275 (srfi srfi-1)
276 (srfi srfi-26)
277 (rnrs io ports))
278 #:phases
279 (modify-phases %standard-phases
280 (add-before 'patch-source-shebangs 'patch-tests-shebangs
281 (lambda _
282 (let ((sh (which "sh")))
283 (substitute* (find-files "t" "\\.(sh|tap)$")
284 (("#![[:blank:]]?/bin/sh")
285 (string-append "#!" sh)))
286
287 ;; Set these variables for all the `configure' runs
288 ;; that occur during the test suite.
289 (setenv "SHELL" sh)
290 (setenv "CONFIG_SHELL" sh)
291 #t)))
292
293 ;; Files like `install-sh', `mdate.sh', etc. must use
294 ;; #!/bin/sh, otherwise users could leak erroneous shebangs
295 ;; in the wild. See <http://bugs.gnu.org/14201> for an
296 ;; example.
297 (add-after 'install 'unpatch-shebangs
298 (lambda* (#:key outputs #:allow-other-keys)
299 (let* ((out (assoc-ref outputs "out"))
300 (dir (string-append out "/share")))
301 (define (starts-with-shebang? file)
302 (equal? (call-with-input-file file
303 (lambda (p)
304 (list (get-u8 p) (get-u8 p))))
305 (map char->integer '(#\# #\!))))
306
307 (for-each (lambda (file)
308 (when (and (starts-with-shebang? file)
309 (executable-file? file))
310 (format #t "restoring shebang on `~a'~%"
311 file)
312 (substitute* file
313 (("^#!.*/bin/sh")
314 "#!/bin/sh")
315 (("^#!.*/bin/env(.*)$" _ args)
316 (string-append "#!/usr/bin/env"
317 args)))))
318 (find-files dir ".*"))
319 #t))))))
320 (home-page "https://www.gnu.org/software/automake/")
321 (synopsis "Making GNU standards-compliant Makefiles")
322 (description
323 "Automake the part of the GNU build system for producing
324 standards-compliant Makefiles. Build requirements are entered in an
325 intuitive format and then Automake works with Autoconf to produce a robust
326 Makefile, simplifying the entire process for the developer.")
327 (license gpl2+))) ; some files are under GPLv3+
328
329 (define-public libtool
330 (package
331 (name "libtool")
332 (version "2.4.6")
333 (source (origin
334 (method url-fetch)
335 (uri (string-append "mirror://gnu/libtool/libtool-"
336 version ".tar.xz"))
337 (sha256
338 (base32
339 "0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))
340 (patches (search-patches "libtool-skip-tests2.patch"))))
341 (build-system gnu-build-system)
342 (propagated-inputs `(("m4" ,m4)))
343 (native-inputs `(("m4" ,m4)
344 ("perl" ,perl)
345 ;; XXX: this shouldn't be necessary, but without it test
346 ;; 102 fails because it cannot find ltdl/libltdl.la.
347 ("libltdl" ,libltdl)
348 ("help2man" ,help2man) ;because we modify ltmain.sh
349 ("automake" ,automake) ;some tests rely on 'aclocal'
350 ("autoconf" ,autoconf-wrapper))) ;others on 'autom4te'
351
352 (arguments
353 `(;; Libltdl is provided as a separate package, so don't install it here.
354 #:configure-flags '("--disable-ltdl-install")
355
356 ;; XXX: There are test failures on mips64el-linux starting from 2.4.4:
357 ;; <http://hydra.gnu.org/build/181662>.
358 ;; Also, do not run tests when cross compiling
359 #:tests? ,(not (or (%current-target-system)
360 (string-prefix? "mips64"
361 (%current-system))))
362
363 #:phases
364 (modify-phases %standard-phases
365 (add-before 'check 'pre-check
366 (lambda* (#:key inputs native-inputs #:allow-other-keys)
367 ;; Run the test suite in parallel, if possible.
368 (setenv "TESTSUITEFLAGS"
369 (string-append
370 "-j"
371 (number->string (parallel-job-count))))
372 ;; Patch references to /bin/sh.
373 (let ((bash (assoc-ref (or native-inputs inputs) "bash")))
374 (substitute* "tests/testsuite"
375 (("/bin/sh")
376 (string-append bash "/bin/sh")))
377 #t)))
378 (add-after 'patch-source-shebangs 'restore-ltmain-shebang
379 (lambda* (#:key inputs #:allow-other-keys)
380 (substitute* "build-aux/ltmain.in"
381 (("^#!.*/bin/sh$") "#!/bin/sh"))
382 #t)))))
383
384 (synopsis "Generic shared library support tools")
385 (description
386 "GNU Libtool helps in the creation and use of shared libraries, by
387 presenting a single consistent, portable interface that hides the usual
388 complexity of working with shared libraries across platforms.")
389 (license gpl3+)
390 (home-page "https://www.gnu.org/software/libtool/")))
391
392 (define-public libltdl
393 ;; This is a libltdl package separate from the libtool package. This is
394 ;; useful because, unlike libtool, it has zero extra dependencies (making it
395 ;; readily usable during bootstrap), and it builds very quickly since
396 ;; Libtool's extensive test suite isn't run.
397 (package
398 (name "libltdl")
399 (version "2.4.6")
400 (source (origin
401 (method url-fetch)
402 (uri (string-append "mirror://gnu/libtool/libtool-"
403 version ".tar.xz"))
404 (sha256
405 (base32
406 "0vxj52zm709125gwv9qqlw02silj8bnjnh4y07arrz60r31ai1vw"))))
407 (build-system gnu-build-system)
408 (arguments
409 '(#:configure-flags '("--enable-ltdl-install") ;really install it
410 #:phases (modify-phases %standard-phases
411 (add-before 'configure 'change-directory
412 (lambda _ (chdir "libltdl") #t)))))
413
414 (synopsis "System-independent dlopen wrapper of GNU libtool")
415 (description (package-description libtool))
416 (home-page (package-home-page libtool))
417 (license lgpl2.1+)))
418
419 (define-public pyconfigure
420 (package
421 (name "pyconfigure")
422 (version "0.2.3")
423 (source (origin
424 (method url-fetch)
425 (uri (string-append "mirror://gnu/pyconfigure/pyconfigure-"
426 version ".tar.gz"))
427 (sha256
428 (base32
429 "0kxi9bg7l6ric39vbz9ykz4a21xlihhh2zcc3297db8amvhqwhrp"))))
430 (build-system gnu-build-system)
431 (arguments
432 `(#:phases
433 (modify-phases %standard-phases
434 (add-before 'configure 'patch-python
435 (lambda _
436 (substitute* "pyconf.in"
437 (("/usr/bin/env python") (which "python3")))
438 #t)))))
439 (inputs
440 `(("python" ,python-3)))
441 (synopsis "@command{configure} interface for Python-based packages")
442 (description
443 "GNU pyconfigure provides template files for easily implementing
444 standards-compliant configure scripts and Makefiles for Python-based packages.
445 It is designed to work alongside existing Python setup scripts, making it easy
446 to integrate into existing projects. Powerful and flexible Autoconf macros
447 are available, allowing you to easily make adjustments to the installation
448 procedure based on the capabilities of the target computer.")
449 (home-page "https://www.gnu.org/software/pyconfigure/manual/")
450 (license
451 (fsf-free
452 "https://www.gnu.org/prep/maintain/html_node/License-Notices-for-Other-Files.html"))))