gnu: lxc: Update to 4.0.6.
[jackhill/guix/guix.git] / gnu / packages / irc.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
4 ;;; Copyright © 2015, 2017 Ludovic Courtès <ludo@gnu.org>
5 ;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Nikita <nikita@n0.is>
7 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
8 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
9 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
10 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
11 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
12 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
13 ;;;
14 ;;; This file is part of GNU Guix.
15 ;;;
16 ;;; GNU Guix is free software; you can redistribute it and/or modify it
17 ;;; under the terms of the GNU General Public License as published by
18 ;;; the Free Software Foundation; either version 3 of the License, or (at
19 ;;; your option) any later version.
20 ;;;
21 ;;; GNU Guix is distributed in the hope that it will be useful, but
22 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
23 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
24 ;;; GNU General Public License for more details.
25 ;;;
26 ;;; You should have received a copy of the GNU General Public License
27 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
28
29 (define-module (gnu packages irc)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix download)
32 #:use-module (guix git-download)
33 #:use-module (guix packages)
34 #:use-module (guix build-system cmake)
35 #:use-module (guix build-system glib-or-gtk)
36 #:use-module (guix build-system gnu)
37 #:use-module (guix build-system python)
38 #:use-module (guix build-system qt)
39 #:use-module (gnu packages)
40 #:use-module (gnu packages admin)
41 #:use-module (gnu packages aspell)
42 #:use-module (gnu packages autogen)
43 #:use-module (gnu packages autotools)
44 #:use-module (gnu packages base)
45 #:use-module (gnu packages backup)
46 #:use-module (gnu packages check)
47 #:use-module (gnu packages compression)
48 #:use-module (gnu packages curl)
49 #:use-module (gnu packages cyrus-sasl)
50 #:use-module (gnu packages databases)
51 #:use-module (gnu packages file)
52 #:use-module (gnu packages gettext)
53 #:use-module (gnu packages geo)
54 #:use-module (gnu packages glib)
55 #:use-module (gnu packages gnome)
56 #:use-module (gnu packages gnupg)
57 #:use-module (gnu packages gtk)
58 #:use-module (gnu packages guile)
59 #:use-module (gnu packages lua)
60 #:use-module (gnu packages lxqt)
61 #:use-module (gnu packages ncurses)
62 #:use-module (gnu packages openldap)
63 #:use-module (gnu packages kde)
64 #:use-module (gnu packages kde-frameworks)
65 #:use-module (gnu packages password-utils)
66 #:use-module (gnu packages pcre)
67 #:use-module (gnu packages perl)
68 #:use-module (gnu packages pkg-config)
69 #:use-module (gnu packages python)
70 #:use-module (gnu packages python-crypto)
71 #:use-module (gnu packages python-xyz)
72 #:use-module (gnu packages regex)
73 #:use-module (gnu packages ruby)
74 #:use-module (gnu packages sqlite)
75 #:use-module (gnu packages qt)
76 #:use-module (gnu packages tcl)
77 #:use-module (gnu packages textutils)
78 #:use-module (gnu packages time)
79 #:use-module (gnu packages tls)
80 #:use-module (gnu packages web)
81 #:use-module (srfi srfi-1)
82 #:use-module (srfi srfi-26))
83
84 (define-public quassel
85 (package
86 (name "quassel")
87 (version "0.13.1")
88 (source
89 (origin
90 (method url-fetch)
91 (uri (string-append "https://quassel-irc.org/pub/quassel-"
92 version ".tar.bz2"))
93 (sha256
94 (base32
95 "0mg8jydc70vlylppzich26q4s40kr78r3ysfyjwisfvlg2byxvs8"))
96 (patches (search-patches "quassel-qt-514-compat.patch"))
97 (modules '((guix build utils)))
98 ;; We don't want to install the bundled inxi script.
99 (snippet
100 '(begin
101 (delete-file "data/scripts/inxi")
102 #t))))
103 (build-system qt-build-system)
104 (arguments
105 ;; The three binaries are not mutually exlusive, and are all built
106 ;; by default.
107 '(#:configure-flags '(;;"-DWANT_QTCLIENT=OFF" ; 6.1 MiB
108 ;;"-DWANT_CORE=OFF" ; 3.0 MiB
109 ;;"-DWANT_MONO=OFF" ; 7.6 MiB
110 "-DWITH_KDE=OFF" ; no to kde integration ...
111 "-DWITH_BUNDLED_ICONS=ON" ; so we install bundled icons
112 "-DWITH_OXYGEN_ICONS=ON" ; also the oxygen ones
113 "-DWITH_WEBENGINE=OFF") ; we don't depend on qtwebengine
114 #:phases
115 (modify-phases %standard-phases
116 (add-after 'unpack 'patch-inxi-reference
117 (lambda* (#:key inputs #:allow-other-keys)
118 (let ((inxi (string-append (assoc-ref inputs "inxi") "/bin/inxi")))
119 (symlink inxi "data/scripts/inxi")
120 #t))))
121 #:tests? #f)) ; no test target
122 (native-inputs
123 `(("extra-cmake-modules" ,extra-cmake-modules)
124 ("pkg-config" ,pkg-config)
125 ("qttools" ,qttools)))
126 (inputs
127 `(("inxi" ,inxi-minimal)
128 ("libdbusmenu-qt" ,libdbusmenu-qt)
129 ("qca" ,qca)
130 ("qtbase" ,qtbase)
131 ("qtmultimedia" ,qtmultimedia)
132 ("qtscript" ,qtscript)
133 ("qtsvg" ,qtsvg)
134 ("snorenotify" ,snorenotify)
135 ("zlib" ,zlib)))
136 (home-page "https://quassel-irc.org/")
137 (synopsis "Distributed IRC client")
138 (description "Quassel is a distributed IRC client, meaning that one or more
139 clients can attach to and detach from the central core. It resembles the
140 popular combination of screen and a text-based IRC client such as WeeChat or
141 irssi, but graphical.")
142 (license (list license:gpl2 license:gpl3)))) ;; dual licensed
143
144 (define-public irssi
145 (package
146 (name "irssi")
147 (version "1.2.2")
148 (source (origin
149 (method url-fetch)
150 (uri (string-append "https://github.com/irssi/irssi/"
151 "releases/download/" version "/irssi-"
152 version ".tar.xz"))
153 (sha256
154 (base32
155 "0y3mhnyr7x8ir8dlj83vbnchpfld28vdfni9yhpvls45j460c9v7"))))
156 (build-system gnu-build-system)
157 (arguments
158 `(#:phases
159 (modify-phases %standard-phases
160 (replace 'configure
161 (lambda* (#:key inputs outputs #:allow-other-keys)
162 (let ((out (assoc-ref outputs "out")))
163 (setenv "CONFIG_SHELL" (which "bash"))
164 (invoke "./configure"
165 (string-append "--prefix=" out)
166 (string-append "--with-proxy")
167 (string-append "--with-socks")
168 (string-append "--with-bot")))))
169 (add-before 'check 'set-home
170 (lambda _
171 (setenv "HOME" (getcwd)))))))
172 (inputs
173 `(("glib" ,glib)
174 ("ncurses" ,ncurses)
175 ("openssl" ,openssl)
176 ("perl" ,perl)))
177 (native-inputs
178 `(("pkg-config" ,pkg-config)))
179 (home-page "https://irssi.org/")
180 (synopsis "Terminal-based IRC client")
181 (description
182 "Irssi is a terminal based IRC client for UNIX systems. It also supports
183 SILC and ICB protocols via plugins.")
184 (license license:gpl2+)))
185
186 (define-public weechat
187 (package
188 (name "weechat")
189 (version "3.0")
190 (source (origin
191 (method url-fetch)
192 (uri (string-append "https://weechat.org/files/src/weechat-"
193 version ".tar.xz"))
194 (sha256
195 (base32
196 "1yziv4cbcy61c9mb81c5sg3rmw6nh0srzwmry4svhriv6rdd5dvc"))))
197 (build-system cmake-build-system)
198 (native-inputs
199 `(("gettext" ,gettext-minimal)
200 ("pkg-config" ,pkg-config)
201 ;; For tests.
202 ("cpputest" ,cpputest)))
203 (inputs
204 `(("aspell" ,aspell)
205 ("curl" ,curl)
206 ("gnutls" ,gnutls)
207 ("libgcrypt" ,libgcrypt "out")
208 ("ncurses" ,ncurses)
209 ("zlib" ,zlib)
210
211 ;; Scripting language plug-ins.
212 ("guile" ,guile-3.0)
213 ("lua" ,lua-5.1)
214 ("perl" ,perl)
215 ("python" ,python)
216 ("tcl" ,tcl)))
217 (arguments
218 `(#:configure-flags
219 (list "-DENABLE_PHP=OFF"
220 "-DENABLE_RUBY=OFF"
221 "-DENABLE_TESTS=ON") ; ‘make test’ fails otherwise
222 ;; Tests hang indefinitely on non-Intel platforms.
223 #:tests? ,(if (any (cute string-prefix? <> (or (%current-target-system)
224 (%current-system)))
225 '("i686" "x86_64"))
226 '#t '#f)))
227 (synopsis "Extensible chat client")
228 (description "WeeChat (Wee Enhanced Environment for Chat) is an
229 @dfn{Internet Relay Chat} (IRC) client, which is designed to be light and fast.
230 The client uses a curses frontend, and there are remote interfaces for Web,
231 Qt, Android, and Emacs.
232
233 Everything in WeeChat can be done with the keyboard, though it also supports
234 using a mouse. It is customizable and extensible with plugins and scripts.")
235 (home-page "https://www.weechat.org/")
236 (license license:gpl3)))
237
238 (define-public srain
239 (package
240 (name "srain")
241 (version "1.1.2")
242 (source
243 (origin
244 (method git-fetch)
245 (uri (git-reference
246 (url "https://github.com/SrainApp/srain")
247 (commit version)))
248 (file-name (git-file-name name version))
249 (sha256
250 (base32 "1jjs3lrlz67z9ghpc4c406a5r3naisn1famdh9rwwcg4y4y1vcws"))))
251 (arguments
252 `(#:tests? #f ;there are no tests
253 #:phases
254 (modify-phases %standard-phases
255 (add-before 'install 'fix-permissions
256 ;; Make po folder writable for gettext to install translations.
257 (lambda _
258 (for-each make-file-writable
259 (find-files "po" "." #:directories? #t)))))))
260 (build-system glib-or-gtk-build-system)
261 (native-inputs
262 `(("gettext" ,gettext-minimal)
263 ("glib:bin" ,glib "bin")
264 ("pkg-config" ,pkg-config)))
265 (inputs
266 `(("glib-networking" ,glib-networking)
267 ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
268 ("gtk+" ,gtk+)
269 ("libconfig" ,libconfig)
270 ("libsecret" ,libsecret)
271 ("libsoup" ,libsoup)
272 ("openssl" ,openssl)))
273 (home-page "https://srain.im")
274 (synopsis "Modern IRC client written in GTK")
275 (description
276 "Srain is an IRC client written in GTK. It aims to be modern and easy to
277 use while still remaining useful to power users. It also has partial support
278 for the IRCv3 protocol.")
279 (license license:gpl3+)))
280
281 (define-public ircii
282 (package
283 (name "ircii")
284 (version "20151120")
285 (source (origin
286 (method url-fetch)
287 (uri (string-append "https://ircii.warped.com/"
288 name "-" version ".tar.gz"))
289 (sha256
290 (base32
291 "178dc279f5j894qvp96dzz7c0jpryqlcqw5g0dc9yaxg9kgw1lqm"))))
292 (build-system gnu-build-system)
293 ;; TODO: We should package a small socks4/5 library/server to configure
294 ;; ircii with socks client. `ghc-socks' pulls in lots of haskell, which
295 ;; is too big.
296 (arguments
297 `(#:tests? #f
298 #:configure-flags (list
299 "--enable-ipv6"
300 "--with-emacs-meta-keys"
301 (string-append "--with-openssl="
302 (assoc-ref %build-inputs "openssl")))
303 #:phases
304 (modify-phases %standard-phases
305 (add-after 'unpack 'patch-bsdinstall-absolute-path-bins
306 (lambda* (#:key inputs #:allow-other-keys)
307 (substitute* "bsdinstall"
308 (("/bin/strip") "strip")
309 (("/bin/cp") "cp")
310 (("/bin/chmod") "chmod")
311 (("/etc/chown") "chown")
312 (("/bin/chgrp") "chgrp")
313 (("/bin/mkdir") "mkdir")
314 (("/bin/rm") "rm")
315 (("/bin/mv") "mv")))))))
316 (inputs
317 `(("ncurses" ,ncurses)
318 ("openssl" ,openssl)))
319 (native-inputs
320 `(("pkg-config" ,pkg-config)
321 ("perl" ,perl)))
322 (home-page "http://www.eterna.com.au/ircii/")
323 (synopsis "Terminal-based IRC and ICB client")
324 (description
325 "ircII is a terminal based IRC and ICB client for UNIX systems.")
326 (license license:bsd-3)))
327
328 (define-public ii
329 (package
330 (name "ii")
331 (version "1.8")
332 (source (origin
333 (method url-fetch)
334 (uri (string-append "http://dl.suckless.org/tools/"
335 name "-" version ".tar.gz"))
336 (sha256
337 (base32
338 "1lk8vjl7i8dcjh4jkg8h8bkapcbs465sy8g9c0chfqsywbmf3ndr"))))
339 (build-system gnu-build-system)
340 (arguments
341 `(#:tests? #f ; no tests
342 #:make-flags (list (string-append "PREFIX=" %output)
343 "CC=gcc")
344 #:phases
345 (modify-phases %standard-phases
346 (delete 'configure)))) ; no configure
347 (home-page "https://tools.suckless.org/ii/")
348 (synopsis "FIFO and file system based IRC client")
349 (description
350 "ii (Irc it) is a minimalist FIFO and file system based IRC client.")
351 (license license:expat)))
352
353 (define-public sic
354 (package
355 (name "sic")
356 (version "1.2")
357 (source (origin
358 (method url-fetch)
359 (uri (string-append "http://dl.suckless.org/tools/"
360 name "-" version ".tar.gz"))
361 (sha256
362 (base32
363 "11aiavxp44yayibc58bvimi8mrxvbw1plbci8cnbl4syk42zj1xc"))))
364 (build-system gnu-build-system)
365 (arguments
366 `(#:tests? #f ; no tests
367 #:make-flags (list "CC=gcc"
368 (string-append "PREFIX=" %output))
369 #:phases
370 (modify-phases %standard-phases
371 (delete 'configure)))) ; no configure
372 (home-page "https://tools.suckless.org/sic/")
373 (synopsis "Simple IRC client")
374 (description
375 "sic is a simple IRC client, even more minimalistic than ii.")
376 (license license:expat)))
377
378 (define-public limnoria
379 (package
380 (name "limnoria")
381 (version "2019.11.22")
382 (source
383 (origin
384 (method url-fetch)
385 (uri (pypi-uri "limnoria" version))
386 (sha256
387 (base32 "0853xk1ps3v6lkmfx50wv56vynnzpl84v66hxnhl8i34zl36kk3c"))))
388 (build-system python-build-system)
389 (inputs
390 `(("python-pytz" ,python-pytz)
391 ("python-chardet" ,python-chardet)
392 ("python-dateutil" ,python-dateutil)
393 ("python-gnupg" ,python-gnupg)
394 ("python-feedparser" ,python-feedparser)
395 ("python-sqlalchemy" ,python-sqlalchemy)
396 ("python-socksipy-branch" ,python-socksipy-branch)
397 ("python-ecdsa" ,python-ecdsa)))
398 (native-inputs
399 `(("python-mock" ,python-mock)))
400 ;; Despite the existence of a test folder there is no test phase.
401 ;; We need to package https://github.com/ProgVal/irctest and write
402 ;; our own testphase.
403 (arguments
404 `(#:tests? #f))
405 (home-page "https://github.com/ProgVal/Limnoria")
406 (synopsis "Modified version of Supybot (an IRC bot and framework)")
407 (description
408 "Modified version of Supybot with Python 3 and IRCv3 support,
409 embedded web server, translations (fr, fi, it, hu, de), and many
410 other enhancements and bug fixes.")
411 (license license:bsd-3)))
412
413 (define-public epic5
414 (package
415 (name "epic5")
416 (version "2.0.1")
417 (source (origin
418 (method url-fetch)
419 (uri (string-append "http://ftp.epicsol.org/pub/"
420 "epic/EPIC5-PRODUCTION/"
421 name "-" version ".tar.xz"))
422 (sha256
423 (base32
424 "1ap73d5f4vccxjaaq249zh981z85106vvqmxfm4plvy76b40y9jm"))))
425 (build-system gnu-build-system)
426 (arguments
427 `(#:test-target "test"
428 #:phases
429 (modify-phases %standard-phases
430 (add-after 'unpack 'patch-perl
431 (lambda _
432 (substitute* "regress/crash-irc"
433 (("perl5") (which "perl")))
434 #t))
435 (add-after 'unpack 'patch-bsdinstall
436 ;; If we just remove /bin/ some part of the bsdinstall breaks.
437 ;; Furthermore bsdinstalls has a reference to /etc/chmod here, which
438 ;; means if we leave /etc/ in, install fails.
439 (lambda _
440 (substitute* "bsdinstall"
441 (("/bin/strip") "strip")
442 (("/bin/cp") "cp")
443 (("/bin/chmod") "chmod")
444 (("/bin/chgrp") "chgrp")
445 (("/bin/mkdir") "mkdir")
446 (("/bin/rm") "rm")
447 (("/bin/mv") "mv")
448 (("/etc/") ""))
449 #t))
450 (replace 'configure
451 (lambda* (#:key outputs #:allow-other-keys)
452 ;; The tarball uses a very old version of autconf. It does not
453 ;; understand extra flags like `--enable-fast-install', so
454 ;; we need to invoke it with just what it understands.
455 (let ((out (assoc-ref outputs "out")))
456 ;; 'configure' doesn't understand '--host'.
457 ,@(if (%current-target-system)
458 `((setenv "CHOST" ,(%current-target-system)))
459 '())
460 (setenv "CONFIG_SHELL" (which "bash"))
461 (setenv "SHELL" (which "bash"))
462 (invoke "./configure"
463 (string-append "--prefix=" out)
464 "--with-ipv6" "--with-libarchive"
465 ;; We use libressl because openssl does not come
466 ;; with the lib/libssl.a which is needed for epic5.
467 ;; XXX: No matter which implementation is chosen,
468 ;; epic5 fails to connect to tls ports of roundrobin
469 ;; irc networks. This however is believed to be an
470 ;; protocol issue at epic5 related to ircd.
471 (string-append "--with-ssl="
472 (assoc-ref %build-inputs "libressl"))
473 (string-append "--with-tcl="
474 (assoc-ref %build-inputs "tcl")
475 "/lib/tclConfig.sh"))))))))
476 (inputs
477 `(("libressl" ,libressl)
478 ("ncurses" ,ncurses)
479 ("libarchive" ,libarchive) ; CHANGELOG: "Support for loading zip files"
480 ("perl" ,perl)
481 ("tcl" ,tcl)
482 ("ruby" ,ruby)))
483 (native-inputs
484 `(("pkg-config" ,pkg-config)))
485 (home-page "http://epicsol.org")
486 (synopsis "Epic5 IRC Client")
487 (description
488 "EPIC is a IRC client that has been under active development for
489 over 20 years. It is stable and mature, and offers an excellent ircII
490 interface for those who are accustomed to the ircII way of doing things.")
491 (license (list license:bsd-3
492 license:isc
493 license:bsd-4
494 ;; The epic license is equal to the standard three-clause
495 ;; BSD license except that you are not permitted to remove the
496 ;; "Redistribution is permitted" clause of the license if you
497 ;; distribute binaries.
498 (license:non-copyleft "http://epicsol.org/copyright")))))
499
500 (define-public inspircd
501 (package
502 (name "inspircd")
503 (version "3.8.1")
504 (source
505 (origin
506 (method git-fetch)
507 (uri (git-reference
508 (url "https://github.com/inspircd/inspircd")
509 (commit (string-append "v" version))))
510 (file-name (git-file-name name version))
511 (sha256
512 (base32 "1i30649dw84iscxa5as81g96f393mn1i883aq4za5ypdinr5x65g"))))
513 (build-system gnu-build-system)
514 (arguments
515 `(#:configure-flags (map (lambda (module)
516 (string-append "--enable-extras=" module))
517 '("m_argon2.cpp"
518 "m_geo_maxmind.cpp"
519 "m_ldap.cpp"
520 "m_mysql.cpp"
521 "m_pgsql.cpp"
522 "m_regex_pcre.cpp"
523 "m_regex_posix.cpp"
524 "m_regex_stdlib.cpp"
525 "m_regex_re2.cpp"
526 "m_regex_tre.cpp"
527 "m_sqlite3.cpp"
528 "m_ssl_gnutls.cpp"
529 "m_ssl_openssl.cpp"
530 "m_ssl_mbedtls.cpp"
531 "m_sslrehashsignal.cpp"))
532 #:tests? #f ; Figure out later.
533 #:phases
534 (modify-phases %standard-phases
535 (add-before 'configure 'module-configure
536 (lambda* (#:key configure-flags #:allow-other-keys)
537 (apply invoke "./configure"
538 configure-flags)
539 #t))
540 (replace 'configure
541 (lambda* (#:key outputs #:allow-other-keys)
542 (let* ((out (assoc-ref outputs "out"))
543 (out-lib (string-append out "/lib/"))
544 (out-bin (string-append out "/bin/"))
545 (out-etc (string-append out "/etc/"))
546 (name "inspircd"))
547 (invoke "./configure"
548 (string-append "--prefix=" out-lib name)
549 (string-append "--binary-dir=" out-bin)
550 (string-append "--module-dir=" out-lib name "/modules/")
551 (string-append "--config-dir=" out-etc name)))
552 #t)))))
553 (native-inputs
554 `(("pkg-config" ,pkg-config)))
555 (inputs
556 `(("argon2" ,argon2)
557 ("gnutls" ,gnutls)
558 ("libmaxminddb" ,libmaxminddb)
559 ("mbedtls-apache" ,mbedtls-apache)
560 ("mysql" ,mysql)
561 ("openldap" ,openldap)
562 ("openssl" ,openssl)
563 ("pcre" ,pcre "bin")
564 ("perl" ,perl)
565 ("postgresql" ,postgresql)
566 ("re2" ,re2)
567 ("sqlite" ,sqlite)
568 ("tre" ,tre)))
569 (synopsis "Modular IRC server written in C++")
570 (description "InspIRCd is a modular Internet Relay Chat
571 server written in C++ for Unix-like operating systems.")
572 (home-page "https://www.inspircd.org/")
573 (license license:gpl2)))