gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / telephony.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
5 ;;; Copyright © 2015, 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox.org>
7 ;;; Copyright © 2016 Francesco Frassinelli <fraph24@gmail.com>
8 ;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
9 ;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
10 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
11 ;;; Copyright © 2017 Adonay Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@hyperbola.info>
12 ;;; Copyright © 2018 Jovany Leandro G.C <bit4bit@riseup.net>
13 ;;; Copyright © 2018 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
14 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
15 ;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
16 ;;; Copyright © 2019 Ivan Vilata i Balaguer <ivan@selidor.net>
17 ;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
18 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
19 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
20 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
21 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
22 ;;;
23 ;;; This file is part of GNU Guix.
24 ;;;
25 ;;; GNU Guix is free software; you can redistribute it and/or modify it
26 ;;; under the terms of the GNU General Public License as published by
27 ;;; the Free Software Foundation; either version 3 of the License, or (at
28 ;;; your option) any later version.
29 ;;;
30 ;;; GNU Guix is distributed in the hope that it will be useful, but
31 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
32 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
33 ;;; GNU General Public License for more details.
34 ;;;
35 ;;; You should have received a copy of the GNU General Public License
36 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
37
38 (define-module (gnu packages telephony)
39 #:use-module (gnu packages)
40 #:use-module (gnu packages admin)
41 #:use-module (gnu packages aidc)
42 #:use-module (gnu packages algebra)
43 #:use-module (gnu packages autotools)
44 #:use-module (gnu packages avahi)
45 #:use-module (gnu packages audio)
46 #:use-module (gnu packages base)
47 #:use-module (gnu packages boost)
48 #:use-module (gnu packages check)
49 #:use-module (gnu packages compression)
50 #:use-module (gnu packages crypto)
51 #:use-module (gnu packages databases)
52 #:use-module (gnu packages docbook)
53 #:use-module (gnu packages documentation)
54 #:use-module (gnu packages file)
55 #:use-module (gnu packages protobuf)
56 #:use-module (gnu packages gettext)
57 #:use-module (gnu packages gl)
58 #:use-module (gnu packages glib)
59 #:use-module (gnu packages gnome)
60 #:use-module (gnu packages gnupg)
61 #:use-module (gnu packages gtk)
62 #:use-module (gnu packages image)
63 #:use-module (gnu packages libcanberra)
64 #:use-module (gnu packages linphone)
65 #:use-module (gnu packages linux)
66 #:use-module (gnu packages multiprecision)
67 #:use-module (gnu packages ncurses)
68 #:use-module (gnu packages netpbm)
69 #:use-module (gnu packages networking)
70 #:use-module (gnu packages pcre)
71 #:use-module (gnu packages perl)
72 #:use-module (gnu packages pkg-config)
73 #:use-module (gnu packages pulseaudio)
74 #:use-module (gnu packages python)
75 #:use-module (gnu packages qt)
76 #:use-module (gnu packages serialization)
77 #:use-module (gnu packages speech)
78 #:use-module (gnu packages tls)
79 #:use-module (gnu packages upnp)
80 #:use-module (gnu packages video)
81 #:use-module (gnu packages webkit)
82 #:use-module (gnu packages xiph)
83 #:use-module (gnu packages xorg)
84 #:use-module (gnu packages xml)
85 #:use-module (gnu packages readline)
86 #:use-module (gnu packages bison)
87 #:use-module (gnu packages flex)
88 #:use-module ((guix licenses) #:prefix license:)
89 #:use-module (guix packages)
90 #:use-module (guix download)
91 #:use-module (guix git-download)
92 #:use-module (guix build-system cmake)
93 #:use-module (guix build-system gnu)
94 #:use-module (guix build-system qt))
95
96 (define-public libilbc
97 (package
98 (name "libilbc")
99 (version "2.0.2")
100 (source
101 (origin
102 (method git-fetch)
103 (uri
104 (git-reference
105 (url "https://github.com/TimothyGu/libilbc")
106 (commit
107 (string-append "v" version))))
108 (file-name
109 (git-file-name name version))
110 (sha256
111 (base32
112 "1j1pn1w1198qvdiq2hgv9hkyq2nqcvmfnwlgppac633idkjnjrqx"))))
113 (build-system cmake-build-system)
114 (arguments
115 `(#:tests? #f)) ; No target
116 (native-inputs
117 `(("pkg-config" ,pkg-config)))
118 (synopsis "Libre iLBC codec")
119 (description "LibiLBC is a packaging friendly copy of the iLBC codec from
120 the WebRTC project. It provides a base for distribution packages and can be
121 used as drop-in replacement for the non-free code from RFC 3591.")
122 (home-page "https://github.com/TimothyGu/libilbc")
123 (license license:bsd-3)))
124
125 (define-public spandsp
126 (package
127 (name "spandsp")
128 (version "0.0.6")
129 (source
130 (origin
131 (method url-fetch)
132 (uri
133 ;; The original upstream has been down since the end of March 2020.
134 (string-append "https://web.archive.org/web/20180626203108/"
135 "https://www.soft-switch.org/downloads/" name "/"
136 name "-" version ".tar.gz"))
137 (sha256
138 (base32 "0rclrkyspzk575v8fslzjpgp4y2s4x7xk3r55ycvpi4agv33l1fc"))))
139 (build-system gnu-build-system)
140 (outputs '("out" "doc" "static")) ;doc contains HTML documentation
141 (arguments
142 `(#:configure-flags '("--enable-doc=yes" "--enable-tests=yes")
143 #:parallel-build? #f ;non-deterministic build failures may occur otherwise
144 #:parallel-tests? #f ;fails removing the same the files twice otherwise
145 #:phases (modify-phases %standard-phases
146 (add-after 'unpack 'patch-configure.ac
147 (lambda _
148 ;; spandsp looks at hard coded locations of the FHS to
149 ;; find libxml2.
150 (substitute* "configure.ac"
151 (("AC_MSG_CHECKING\\(for libxml/xmlmemory\\.h.*" all)
152 (string-append all
153 "PKG_CHECK_MODULES(XML2, libxml-2.0)\n"
154 "CPPFLAGS+=\" $XML2_CFLAGS\"\n")))
155 ;; Force a regeneration of the autotools build system.
156 (delete-file "autogen.sh")
157 (delete-file "configure")
158 #t))
159 (add-after 'unpack 'do-not-install-data-files
160 ;; The .tiff images produced for tests are not
161 ;; reproducible and it is not desirable to have those
162 ;; distributed.
163 (lambda _
164 (substitute* '("test-data/itu/fax/Makefile.am"
165 "test-data/etsi/fax/Makefile.am")
166 (("nobase_data_DATA")
167 "noinst_DATA"))
168 #t))
169 (add-after 'install 'install-doc
170 (lambda* (#:key outputs #:allow-other-keys)
171 (let ((doc (string-append (assoc-ref outputs "doc")
172 "/share/doc/" ,name "-" ,version)))
173 (copy-recursively "doc/t38_manual" doc)
174 #t)))
175 (add-after 'install 'move-static-libraries
176 (lambda* (#:key outputs #:allow-other-keys)
177 (let ((out (assoc-ref outputs "out"))
178 (static (assoc-ref outputs "static")))
179 (mkdir-p (string-append static "/lib"))
180 (with-directory-excursion out
181 (for-each (lambda (file)
182 (rename-file file
183 (string-append static "/"
184 file)))
185 (find-files "lib" "\\.a$")))
186 #t))))))
187 (native-inputs
188 `(("autoconf" ,autoconf)
189 ("automake" ,automake)
190 ("libtool" ,libtool)
191 ("pkg-config" ,pkg-config)
192 ;; For the tests
193 ("fftw" ,fftw)
194 ("libpcap" ,libpcap)
195 ("libsndfile" ,libsndfile)
196 ("libjpeg" ,libjpeg-turbo) ;XXX: should be propagated from libtiff
197 ("libtiff" ,libtiff)
198 ("netpbm" ,netpbm)
199 ("sox" ,sox)
200 ;; For the documentation
201 ("docbook-xml" ,docbook-xml-4.3)
202 ("docbook-xsl" ,docbook-xsl)
203 ("doxygen" ,doxygen)
204 ("libxml2" ,libxml2)
205 ("libxslt" ,libxslt)))
206 (synopsis "DSP library for telephony")
207 (description "SpanDSP is a library of DSP functions for telephony, in the
208 8000 sample per second world of E1s, T1s, and higher order PCM channels. It
209 contains low level functions, such as basic filters. It also contains higher
210 level functions, such as cadenced supervisory tone detection, and a complete
211 software FAX machine.")
212 (home-page "https://web.archive.org/web/20180626203108/\
213 https://www.soft-switch.org/index.html")
214 (license (list license:lgpl2.1+ ;for the library
215 license:gpl2+)))) ;for the test suites and support programs
216
217 (define-public commoncpp
218 (package
219 (name "commoncpp")
220 (version "1.8.1")
221 (source (origin
222 (method url-fetch)
223 (uri (string-append "mirror://gnu/" name "/commoncpp2-"
224 version ".tar.gz"))
225 (sha256 (base32
226 "0kmgr5w3b1qwzxnsnw94q6rqs0hr8nbv9clf07ca2a2fyypx9kjk"))))
227 (arguments
228 `(#:phases
229 (modify-phases %standard-phases
230 (add-before 'configure 'pre-configure
231 (lambda _
232 (substitute* "src/applog.cpp"
233 (("^// TODO sc.*") "#include <sys/types.h>\n#include <sys/stat.h>\n"))
234 #t)))))
235 (build-system gnu-build-system)
236 (synopsis "(u)Common C++ framework for threaded applications")
237 (description "GNU Common C++ is an portable, optimized class framework for
238 threaded applications, supporting concurrent synchronization, inter-process
239 communications via sockets, and various methods for data handling, such as
240 serialization and XML parsing. It includes the uCommon C++ library, a smaller
241 reimplementation.")
242 (license license:gpl2+) ; plus runtime exception
243 (properties '((ftp-directory . "/gnu/commoncpp")
244 (upstream-name . "commoncpp2")))
245 (home-page "https://www.gnu.org/software/commoncpp/")))
246
247 (define-public ucommon
248 (package
249 (name "ucommon")
250 (version "7.0.0")
251 (source (origin
252 (method url-fetch)
253 (uri (string-append "mirror://gnu/commoncpp/" name "-"
254 version ".tar.gz"))
255 (sha256 (base32
256 "1mv080rvrhyxyhgqiqr8r9jdqhg3xhfawjvfj5zgj47h59nggjba"))))
257 (build-system gnu-build-system)
258 (inputs `(("gnutls" ,gnutls)))
259 (synopsis "Common C++ framework for threaded applications")
260 (description "GNU uCommon C++ is meant as a very light-weight C++ library
261 to facilitate using C++ design patterns even for very deeply embedded
262 applications, such as for systems using uclibc along with posix threading
263 support.")
264 (license license:gpl3+)
265 (home-page "https://www.gnu.org/software/commoncpp/")
266 (properties '((ftp-directory . "/gnu/commoncpp")))))
267
268 (define-public ccrtp
269 (package
270 (name "ccrtp")
271 (version "2.1.2")
272 (source (origin
273 (method url-fetch)
274 (uri (string-append "mirror://gnu/ccrtp/ccrtp-"
275 version ".tar.gz"))
276 (sha256 (base32
277 "17ili8l7zqbbkzr1rcy4hlnazkf50mds41wg6n7bfdsx3c7cldgh"))))
278 (build-system gnu-build-system)
279 (inputs `(("ucommon" ,ucommon)
280 ("libgcrypt" ,libgcrypt)))
281 (native-inputs `(("pkg-config" ,pkg-config)))
282 (synopsis "Implementation of RTP (real-time transport protocol)")
283 (description "GNU ccRTP is an implementation of RTP, the real-time transport
284 protocol from the IETF. It is suitable both for high capacity servers and
285 personal client applications. It is flexible in its design, allowing it to
286 function as a framework for the framework, rather than just being a
287 packet-manipulation library.")
288 (license license:gpl2+) ; plus runtime exception
289 (home-page "https://www.gnu.org/software/ccrtp/")))
290
291 (define-public zrtpcpp
292 (package
293 (name "zrtpcpp")
294 (version "4.6.6")
295 (source
296 (origin
297 (method git-fetch)
298 (uri
299 (git-reference
300 (url "https://github.com/wernerd/ZRTPCPP")
301 (commit
302 (string-append "V" version))))
303 (file-name
304 (git-file-name name version))
305 (sha256
306 (base32
307 "06vphvh4dgi7ah5qkq53wqvswv8l273x0xwbc447qmgvamm0x1vs"))))
308 (build-system cmake-build-system)
309 (arguments
310 `(#:tests? #f)) ; No target
311 (native-inputs
312 `(("pkg-config" ,pkg-config)))
313 (inputs
314 `(("ccrtp" ,ccrtp)
315 ("ucommon" ,ucommon)))
316 (synopsis "C++ Implementation of ZRTP protocol")
317 (description "GNU ZRTP C++ provides a library that adds ZRTP support to the
318 GNU ccRTP stack and serves as library for other RTP stacks
319 (PJSIP, GStreamer).")
320 (home-page "https://www.gnu.org/software/ccrtp/zrtp")
321 (license license:lgpl3+)))
322
323 (define-public osip
324 (package
325 (name "osip")
326 (version "5.1.2")
327 (source (origin
328 (method url-fetch)
329 (uri (string-append "mirror://gnu/osip/libosip2-" version ".tar.gz"))
330 (patches (search-patches "osip-CVE-2017-7853.patch"))
331 (sha256
332 (base32
333 "148j1i0zkwf09qdpk3nc5sssj1dvppw7p0n9rgrg8k56447l1h1b"))))
334 (build-system gnu-build-system)
335
336 (synopsis "Library implementing SIP (RFC-3261)")
337 (description "GNU oSIP is an implementation of the SIP protocol. It is
338 used to provide multimedia and telecom software developers with an interface
339 to initiate and control SIP sessions.")
340 (license license:lgpl2.1+)
341 (properties '((ftp-directory . "/gnu/osip")
342 (upstream-name . "libosip2")))
343 (home-page "https://www.gnu.org/software/osip/")))
344
345
346 (define-public exosip
347 (package
348 (name "exosip")
349 (version "4.1.0")
350 (source (origin
351 (method url-fetch)
352 (uri (string-append "mirror://savannah/exosip/libeXosip2-"
353 version ".tar.gz"))
354 (sha256 (base32
355 "17cna8kpc8nk1si419vgr6r42k2lda0rdk50vlxrw8rzg0xp2xrw"))))
356 (build-system gnu-build-system)
357 (inputs `(("osip" ,osip)))
358 (synopsis "Sip abstraction library")
359 (description "EXosip is a library that hides the complexity of using the
360 SIP protocol for multimedia session establishment. This protocol is mainly to
361 be used by VoIP telephony applications (endpoints or conference server) but
362 might be also useful for any application that wish to establish sessions like
363 multiplayer games.")
364 (license license:gpl2+)
365 ;; (plus OpenSSL linking exception)
366 ;; http://git.savannah.gnu.org/cgit/exosip.git/plain/LICENSE.OpenSSL
367 (home-page "https://savannah.nongnu.org/projects/exosip")))
368
369 (define-public sipwitch
370 (package
371 (name "sipwitch")
372 (version "1.9.15")
373 (source (origin
374 (method url-fetch)
375 (uri (string-append "mirror://gnu/sipwitch/sipwitch-"
376 version ".tar.gz"))
377 (sha256 (base32
378 "10lli9c703d7qbarzc0lgmz963ppncvnrklwrnri0s1zcmmahyia"))))
379 (build-system gnu-build-system)
380 ;; The configure.ac uses pkg-config but in a kludgy way which breaks when
381 ;; cross-compiling. Among other issues there the program name "pkg-config"
382 ;; is hard coded instead of respecting the PKG_CONFIG environment variable.
383 ;; Fortunately we can avoid the use of pkg-config and set the dependency
384 ;; flags ourselves.
385 (arguments `(#:configure-flags
386 `("--without-pkg-config"
387 ,(string-append "UCOMMON_CFLAGS=-I"
388 (assoc-ref %build-inputs "ucommon") "/include")
389 "UCOMMON_LIBS=-lusecure -lucommon -lrt -ldl -lpthread"
390 ,(string-append "LIBOSIP2_CFLAGS=-I"
391 (assoc-ref %build-inputs "osip") "/include")
392 "LIBOSIP2_LIBS=-losipparser2 -losip2"
393 ,(string-append "--sysconfdir=" (assoc-ref %outputs "out")
394 "/etc")
395 "EXOSIP2_LIBS=-leXosip2"
396 ,(string-append "EXOSIP2_CFLAGS=-I"
397 (assoc-ref %build-inputs "exosip")
398 "/include"))))
399 (inputs `(("ucommon" ,ucommon)
400 ("exosip" ,exosip)
401 ("osip" ,osip)))
402 (synopsis "Secure peer-to-peer VoIP server for the SIP protocol")
403 (description "GNU SIP Witch is a peer-to-peer Voice-over-IP server that
404 uses the SIP protocol. Calls can be made from behind NAT firewalls and
405 without the need for a service provider. Its peer-to-peer design ensures that
406 there is no central point for media intercept or capture and thus it can be
407 used to construct a secure telephone system that operates over the public
408 internet.")
409 (license license:gpl3+)
410 (home-page "https://www.gnu.org/software/sipwitch/")))
411
412 (define-public libsrtp
413 (package
414 (name "libsrtp")
415 (version "2.3.0")
416 (source (origin
417 (method git-fetch)
418 (uri (git-reference
419 (url "https://github.com/cisco/libsrtp")
420 (commit (string-append "v" version))))
421 (file-name (git-file-name name version))
422 (sha256
423 (base32
424 "1f7i3jdh1wzdv7zjlz7gs3xw5jqig9zw8z9awsqqcp54f94xdpvd"))))
425 (native-inputs
426 `(("psmisc" ,psmisc) ;some tests require 'killall'
427 ("procps" ,procps)))
428 (build-system gnu-build-system)
429 (arguments
430 '(#:test-target "runtest"
431 #:phases (modify-phases %standard-phases
432 (add-after 'build 'build-shared
433 (lambda* (#:key (make-flags '()) #:allow-other-keys)
434 ;; Build the shared library separately because
435 ;; the test runner requires a static build.
436 (apply invoke "make" "shared_library" make-flags)
437 #t))
438 (add-after 'install 'remove-static-library
439 (lambda* (#:key outputs #:allow-other-keys)
440 (delete-file (string-append (assoc-ref outputs "out")
441 "/lib/libsrtp2.a"))
442 #t)))))
443 (synopsis "Secure RTP (SRTP) Reference Implementation")
444 (description
445 "This package provides an implementation of the Secure Real-time Transport
446 Protocol (@dfn{SRTP}), the Universal Security Transform (@dfn{UST}), and a
447 supporting cryptographic kernel.")
448 (home-page "https://github.com/cisco/libsrtp")
449 (license license:bsd-3)))
450
451 (define-public libiax2
452 (let ((commit "0e5980f1d78ce462e2d1ed6bc39ff35c8341f201"))
453 ;; This is the commit used by the Ring Project.
454 (package
455 (name "libiax2")
456 (version (string-append "0.0.0-1." (string-take commit 7)))
457 (source
458 (origin
459 (method git-fetch)
460 (uri (git-reference
461 (url "https://gitlab.savoirfairelinux.com/sflphone/libiax2.git")
462 (commit commit)))
463 (file-name (git-file-name name version))
464 (sha256
465 (base32
466 "0d269474kk1933c55hx4azw3sak5ycfrxkw6ida0sb2cm00kfich"))))
467 (build-system gnu-build-system)
468 (native-inputs
469 `(("autoconf" ,autoconf)
470 ("automake" ,automake)
471 ("libtool" ,libtool)))
472 (home-page "https://gitlab.savoirfairelinux.com/sflphone/libiax2")
473 (synopsis "Inter-Asterisk-Protocol library")
474 (description "LibIAX2 implements the Inter-Asterisk-Protocol for relaying
475 Voice-over-IP (VoIP) communications.")
476 ;; The file 'src/md5.c' is released into the public domain by RSA Data
477 ;; Security. The files 'src/answer.h', 'src/miniphone.c',
478 ;; 'src/options.c', 'src/options.h', 'src/ring10.h', 'src/winiphone.c' are
479 ;; covered under the 'GPL'.
480 ;; The package as a whole is distributed under the LGPL 2.0.
481 (license (list license:lgpl2.0
482 license:public-domain
483 license:gpl2+)))))
484
485 (define-public seren
486 (package
487 (name "seren")
488 (version "0.0.21")
489 (source (origin
490 (method url-fetch)
491 (uri (string-append "http://holdenc.altervista.org/"
492 "seren/downloads/seren-" version
493 ".tar.gz"))
494 (sha256
495 (base32
496 "06mams6bng7ib7p2zpfq88kdr4ffril9svzc9lprkb0wjgmkglk9"))))
497 (build-system gnu-build-system)
498 (arguments '(#:tests? #f)) ; no "check" target
499 (inputs
500 `(("alsa-lib" ,alsa-lib)
501 ("gmp" ,gmp)
502 ("libogg" ,libogg)
503 ("ncurses" ,ncurses)
504 ("opus" ,opus)))
505 (synopsis "Simple VoIP program to create conferences from the terminal")
506 (description
507 "Seren is a simple VoIP program based on the Opus codec that allows you
508 to create a voice conference from the terminal, with up to 10 participants,
509 without having to register accounts, exchange emails, or add people to contact
510 lists. All you need to join an existing conference is the host name or IP
511 address of one of the participants.")
512 (home-page "http://holdenc.altervista.org/seren/")
513 (license license:gpl3+)))
514
515 (define-public mumble
516 (package
517 (name "mumble")
518 (version "1.3.2")
519 (source (origin
520 (method url-fetch)
521 (uri (string-append "https://mumble.info/snapshot/stable/"
522 name "-" version ".tar.gz"))
523 (sha256
524 (base32
525 "1q91vp3bp7xn67g9kgp1pfgxjj1hks3w60vdxcfm3373wy5db5lz"))
526 (modules '((guix build utils)))
527 (snippet
528 `(begin
529 ;; Remove bundled software. Keep arc4random, celt-0.7.0,
530 ;; celt-0.11.0, qqbonjour, rnnoise, smallft.
531 (for-each
532 delete-file-recursively
533 '("3rdparty/GL" ; in mesa
534 "3rdparty/mach-override-build" ; for macx
535 "3rdparty/mach-override-src"
536 "3rdparty/minhook-build" ; for win32
537 "3rdparty/minhook-src"
538 "3rdparty/opus-build" ; in opus
539 "3rdparty/opus-src"
540 "3rdparty/speex-build" ; in speex
541 "3rdparty/speex-src"
542 "3rdparty/speexdsp-src" ; in speexdsp
543 "3rdparty/xinputcheck-build" ; for win32
544 "3rdparty/xinputcheck-src"))
545 #t))))
546 (build-system qt-build-system)
547 (arguments
548 `(#:tests? #f ; no "check" target
549 #:phases
550 (modify-phases %standard-phases
551 (replace 'configure
552 (lambda* (#:key inputs outputs #:allow-other-keys)
553 (invoke "qmake" "main.pro" "QMAKE_LRELEASE=lrelease"
554 (string-append "MUMBLE_PYTHON="
555 (string-append (assoc-ref inputs "python")
556 "/bin/python3"))
557 (string-append "CONFIG+="
558 (string-join
559 ;; Options used are listed in the same order
560 ;; as in the "INSTALL" file
561 ;; (plus the final "packaged" and "release").
562 (list "no-bundled-speex" ; in speex
563 "no-bundled-opus" ; in opus
564 "no-g15" ; not packaged
565 "no-jackaudio" ; use pulse
566 "no-oss" ; use pulse
567 "no-alsa" ; use pulse
568 "no-update"
569 "no-embed-qt-translations"
570 "no-ice" ; not packaged
571 "packaged"
572 "release")))
573 (string-append "DEFINES+="
574 "PLUGIN_PATH="
575 (assoc-ref outputs "out")
576 "/lib/mumble"))))
577 (add-before 'configure 'fix-libspeechd-include
578 (lambda _
579 (substitute* "src/mumble/TextToSpeech_unix.cpp"
580 (("libspeechd.h") "speech-dispatcher/libspeechd.h"))
581 #t))
582 ;; disable statistic gathering by default. see <https://bugs.gnu.org/25201>
583 (add-before 'configure 'fix-statistic-gathering-default
584 (lambda _
585 (substitute* "src/mumble/Settings.cpp"
586 (("bUsage = true;") "bUsage = false;"))
587 #t))
588 (add-before 'configure 'fix-mumble-overlay
589 (lambda* (#:key outputs #:allow-other-keys)
590 (with-output-to-file "scripts/mumble-overlay"
591 (lambda ()
592 (format #t "#!~a~%" (which "bash"))
593 (format #t "export LD_PRELOAD=\"~a $LD_PRELOAD\"~%"
594 (string-append (assoc-ref outputs "out")
595 "/lib/mumble/libmumble.so.1"))
596 (format #t "exec \"${@}\"")))
597 #t))
598 (add-before 'install 'disable-murmur-ice
599 (lambda _
600 (substitute* "scripts/murmur.ini.system"
601 (("^ice=") ";ice="))
602 #t))
603 (replace 'install ; install phase does not exist
604 (lambda* (#:key inputs outputs #:allow-other-keys)
605 (let* ((out (assoc-ref outputs "out"))
606 (etc (string-append out "/etc/murmur"))
607 (dbus (string-append out "/etc/dbus-1/system.d/"))
608 (bin (string-append out "/bin"))
609 (services (string-append out "/share/services"))
610 (applications (string-append out "/share/applications"))
611 (icons (string-append out "/share/icons/hicolor/scalable/apps"))
612 (man (string-append out "/share/man/man1"))
613 (lib (string-append out "/lib/mumble")))
614 (install-file "release/mumble" bin)
615 (install-file "scripts/mumble-overlay" bin)
616 (install-file "scripts/mumble.protocol" services)
617 (install-file "scripts/mumble.desktop" applications)
618 (install-file "icons/mumble.svg" icons)
619 (install-file "man/mumble-overlay.1" man)
620 (install-file "man/mumble.1" man)
621 (install-file "release/murmurd" bin)
622 (install-file "scripts/murmur.ini.system" etc)
623 (rename-file (string-append etc "/murmur.ini.system")
624 (string-append etc "/murmur.ini"))
625 (install-file "scripts/murmur.conf" dbus)
626 (install-file "man/murmurd.1" man)
627 (for-each (lambda (file) (install-file file lib))
628 (find-files "." "\\.so\\."))
629 (for-each (lambda (file) (install-file file lib))
630 (find-files "release/plugins" "\\.so$"))
631 #t))))))
632 (inputs
633 `(("avahi" ,avahi)
634 ("boost" ,boost)
635 ("libsndfile" ,libsndfile)
636 ("libxi" ,libxi)
637 ("mesa" ,mesa) ; avoid bundled
638 ("openssl" ,openssl)
639 ("opus" ,opus) ; avoid bundled
640 ("protobuf" ,protobuf)
641 ("pulseaudio" ,pulseaudio)
642 ("qtbase" ,qtbase)
643 ("qtsvg" ,qtsvg)
644 ("speech-dispatcher" ,speech-dispatcher)
645 ("speex" ,speex) ; avoid bundled
646 ("speexdsp" ,speexdsp))) ; avoid bundled
647 (native-inputs
648 `(("pkg-config" ,pkg-config)
649 ("python" ,python)
650 ("qttools" ,qttools)))
651 (synopsis "Low-latency, high quality voice chat software")
652 (description
653 "Mumble is an low-latency, high quality voice chat
654 software primarily intended for use while gaming.
655 Mumble consists of two applications for separate usage:
656 @code{mumble} for the client, and @code{murmur} for the server.")
657 (home-page "https://wiki.mumble.info/wiki/Main_Page")
658 (license (list license:bsd-3 ; mumble celt-0.7.0 qqbonjour rnnoise smallft
659 license:bsd-2 ; celt-0.11.0
660 license:isc)))) ; arc4random
661
662 (define-public twinkle
663 (package
664 (name "twinkle")
665 (version "1.10.2")
666 (source
667 (origin
668 (method git-fetch)
669 (uri
670 (git-reference
671 (url "https://github.com/LubosD/twinkle")
672 (commit
673 (string-append "v" version))))
674 (file-name
675 (git-file-name name version))
676 (patches
677 (search-patches "twinkle-bcg729.patch")) ; To support new BCG729 API.
678 (sha256
679 (base32
680 "0s0gi03xwvzp02ah4q6j33r9jx9nbayr6dxlg2ck9pwbay1nq1hx"))))
681 (build-system qt-build-system)
682 (arguments
683 `(#:tests? #f ; no test target
684 #:configure-flags
685 (list
686 ;; FIX-ME: Make Twinkle compatible with libre version of iLBC.
687 ;; "-DWITH_ILBC=On" ; For iLBC Codec Support
688 "-DWITH_ZRTP=On" ; For ZRTP Support
689 "-DWITH_G729=On" ; For G729 Codec Support
690 "-DWITH_SPEEX=On"))) ; For Speex Codec Support
691 (native-inputs
692 `(("bison" ,bison)
693 ("flex" ,flex)
694 ("qttools" ,qttools)))
695 (inputs
696 `(("alsa-lib" ,alsa-lib)
697 ("bcg729" ,bcg729)
698 ("zrtpcpp" ,zrtpcpp)
699 ("ccrtp" ,ccrtp)
700 ("file" ,file)
701 ("libilbc" ,libilbc)
702 ("libsndfile" ,libsndfile)
703 ("libxml2" ,libxml2)
704 ("qtbase" ,qtbase)
705 ("qtdeclarative" ,qtdeclarative)
706 ("qtquickcontrols" ,qtquickcontrols)
707 ("readline" ,readline)
708 ("speex" ,speex)
709 ("speexdsp" ,speexdsp)
710 ("ucommon" ,ucommon)))
711 (synopsis "Softphone for voice over IP and instant messaging")
712 (description "Twinkle is a softphone for your voice over IP and instant
713 messaging communcations using the SIP protocol. You can use it for direct
714 IP phone to IP phone communication or in a network using a SIP proxy to route
715 your calls and messages.")
716 (home-page "http://twinkle.dolezel.info/")
717 (license license:gpl2+)))
718
719 (define-public pjproject
720 (package
721 (name "pjproject")
722 (version "2.10")
723 (source
724 (origin
725 (method git-fetch)
726 (uri (git-reference
727 (url "https://github.com/pjsip/pjproject")
728 (commit version)))
729 (file-name (git-file-name name version))
730 (sha256
731 (base32
732 "1aklicpgwc88578k03i5d5cm5h8mfm7hmx8vfprchbmaa2p8f4z0"))
733 (modules '((guix build utils)))
734 ;; The patches upstream status can be tracked at:
735 ;; https://github.com/pjsip/pjproject/pull/2501.
736 (patches (search-patches "pjproject-correct-the-cflags-field.patch"
737 "pjproject-fix-pkg-config-ldflags.patch"))
738 (snippet
739 '(begin
740 ;; Remove bundled libraries.
741 (delete-file-recursively "third_party")
742 (substitute* "aconfigure.ac"
743 (("third_party/build/os-auto.mak") ""))
744 (substitute* "Makefile"
745 (("third_party/build") ""))
746 #t))))
747 (build-system gnu-build-system)
748 (outputs '("out" "debug" "static"))
749 (arguments
750 `(#:tests? #t
751 #:test-target "selftest"
752 #:configure-flags
753 (list "--enable-shared"
754 "--with-external-speex"
755 "--with-external-gsm"
756 "--with-external-srtp"
757 "--with-external-pa"
758 ;; The following flag is Linux specific.
759 ,@(if (string-contains (or (%current-system)
760 (%current-target-system)) "linux")
761 '("--enable-epoll")
762 '())
763 "--with-gnutls" ;disable OpenSSL checks
764 "--disable-libyuv" ;TODO: add missing package
765 "--disable-silk" ;TODO: add missing package
766 "--disable-libwebrtc" ;TODO: add missing package
767 "--disable-ilbc-codec" ;cannot be unbundled
768 "--disable-g7221-codec" ;TODO: add missing package
769 "--enable-libsamplerate"
770 ;; -DNDEBUG is set to prevent pjproject from raising
771 ;; assertions that aren't critical, crashing
772 ;; applications as the result.
773 "CFLAGS=-DNDEBUG"
774 ;; Specify a runpath reference to itself, which is missing and
775 ;; causes the validate-runpath phase to fail.
776 (string-append "LDFLAGS=-Wl,-rpath=" (assoc-ref %outputs "out")
777 "/lib"))
778 #:phases
779 (modify-phases %standard-phases
780 (add-after 'unpack 'make-source-files-writable
781 ;; Make all the files writable to prevent the following error:
782 ;; "autom4te: cannot open aconfigure: Permission denied".
783 (lambda _
784 (for-each make-file-writable (find-files "."))
785 #t))
786 (add-before 'build 'build-dep
787 (lambda _ (invoke "make" "dep")))
788 ;; The check phases is moved after the install phase so to
789 ;; use the installed shared libraries for the tests.
790 (delete 'check)
791 (add-after 'install 'move-static-libraries
792 (lambda* (#:key outputs #:allow-other-keys)
793 (let ((out (assoc-ref outputs "out"))
794 (s (string-append (assoc-ref outputs "static") "/lib")))
795 (mkdir-p s)
796 (with-directory-excursion out
797 (for-each (lambda (f)
798 (rename-file f (string-append s "/" (basename f))))
799 (find-files "." "\\.a$")))
800 #t)))
801 (add-after 'install 'check
802 (assoc-ref %standard-phases 'check))
803 (add-before 'patch-source-shebangs 'autoconf
804 (lambda _
805 (invoke "autoconf" "-v" "-f" "-i" "-o"
806 "aconfigure" "aconfigure.ac")))
807 (add-before 'autoconf 'disable-some-tests
808 (lambda _
809 (substitute* "pjlib/src/pjlib-test/test.h"
810 ;; Disable network tests which are slow and/or require an
811 ;; actual network.
812 (("#define GROUP_NETWORK.*")
813 "#define GROUP_NETWORK 0\n"))
814 (substitute* "self-test.mak"
815 ;; Fails with: pjlib-util-test-x86_64-unknown-linux-gnu:
816 ;; ../src/pjlib-util-test/resolver_test.c:1501: action2_1:
817 ;; Assertio n `pj_strcmp2(&pkt->q[0].name, "_sip._udp."
818 ;; "domain2.com")==0' failed.
819 ((" pjlib_util_test ") ""))
820 (substitute* "pjsip/src/test/test.h"
821 ;; Fails with: Error: unable to acquire TCP transport:
822 ;; [pj_status_t=120101] Network is unreachable.
823 (("#define INCLUDE_TCP_TEST.*")
824 "#define INCLUDE_TCP_TEST 0\n")
825 ;; The TSX tests takes a very long time to run; skip them.
826 (("#define INCLUDE_TSX_GROUP.*")
827 "#define INCLUDE_TSX_GROUP 0\n"))
828 (substitute* "pjsip/src/test/dns_test.c"
829 ;; The round_robin_test fails non-deterministically (depending
830 ;; on load); skip it (see:
831 ;; https://github.com/pjsip/pjproject/issues/2500).
832 (("round_robin_test(pool)") 0))
833 (substitute* "pjmedia/src/test/test.h"
834 ;; The following tests require a sound card.
835 (("#define HAS_MIPS_TEST.*")
836 "#define HAS_MIPS_TEST 0\n")
837 (("#define HAS_JBUF_TEST.*")
838 "#define HAS_JBUF_TEST 0\n"))
839 (substitute* "Makefile"
840 ;; Disable the pjnath and pjsua tests, which require an actual
841 ;; network and an actual sound card, respectively.
842 (("pjnath-test pjmedia-test pjsip-test pjsua-test")
843 "pjmedia-test pjsip-test"))
844 #t)))))
845 (native-inputs
846 `(("autoconf" ,autoconf)
847 ("automake" ,automake)
848 ("libtool" ,libtool)
849 ("pkg-config" ,pkg-config)))
850 (inputs
851 `(("bcg729" ,bcg729)
852 ("gnutls" ,gnutls)
853 ("gsm" ,gsm)
854 ("libsamplerate" ,libsamplerate)
855 ("libsrtp" ,libsrtp)
856 ("opus" ,opus)
857 ("portaudio" ,portaudio)
858 ("speex" ,speex)
859 ("speexdsp" ,speexdsp)))
860 (home-page "https://www.pjsip.org")
861 (synopsis "Session Initiation Protocol (SIP) stack")
862 (description "PJProject provides an implementation of the Session
863 Initiation Protocol (SIP) and a multimedia framework.")
864 (license license:gpl2+)))
865
866 (define-public libtgvoip
867 (package
868 (name "libtgvoip")
869 (version "2.4.4")
870 (source
871 (origin
872 (method git-fetch)
873 (uri (git-reference
874 (url "https://github.com/grishka/libtgvoip")
875 (commit version)))
876 (file-name (git-file-name name version))
877 ;; Fix compilation on i686-linux architecture.
878 ;; NOTE: Applying these patches is order-dependent!
879 ;; The patch for WebRTC /must/ precede the patch for SSE2.
880 (patches
881 (search-patches "libtgvoip-disable-webrtc.patch"
882 "libtgvoip-disable-sse2.patch"))
883 (sha256
884 (base32
885 "122kn3jx6v0kkldlzlpzvlwqxgp6pmzxsjhrhcxw12bx9c08sar5"))))
886 (build-system gnu-build-system)
887 (inputs
888 `(("alsa-lib" ,alsa-lib)
889 ("libopusenc" ,libopusenc)
890 ("openssl" ,openssl)
891 ("pulseaudio" ,pulseaudio)))
892 (arguments
893 `(#:phases
894 (modify-phases %standard-phases
895 ;; libtgvoip wants to dlopen libpulse and libasound, so tell it where
896 ;; they are.
897 (add-after 'unpack 'patch-dlopen
898 (lambda* (#:key inputs #:allow-other-keys)
899 (substitute* "os/linux/AudioPulse.cpp"
900 (("libpulse\\.so")
901 (string-append (assoc-ref inputs "pulseaudio")
902 "/lib/libpulse.so")))
903 (substitute* '("os/linux/AudioInputALSA.cpp"
904 "os/linux/AudioOutputALSA.cpp")
905 (("libasound\\.so")
906 (string-append (assoc-ref inputs "alsa-lib")
907 "/lib/libasound.so")))
908 #t)))))
909 (synopsis "VoIP library for Telegram clients")
910 (description "A collection of libraries and header files for implementing
911 telephony functionality into custom Telegram clients.")
912 (home-page "https://github.com/zevlg/libtgvoip")
913 (license license:unlicense)))