gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / task-management.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages task-management)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (gnu packages linux)
23 #:use-module (gnu packages lua)
24 #:use-module (gnu packages tls)
25 #:use-module (guix download)
26 #:use-module (guix build-system cmake))
27
28 (define-public taskwarrior
29 (package
30 (name "taskwarrior")
31 (version "2.5.1")
32 (source
33 (origin
34 (method url-fetch)
35 (uri (string-append
36 "http://taskwarrior.org/download/task-" version ".tar.gz"))
37 (sha256 (base32
38 "059a9yc58wcicc6xxsjh1ph7k2yrag0spsahp1wqmsq6h7jwwyyq"))))
39 (build-system cmake-build-system)
40 (inputs
41 `(("gnutls" ,gnutls)
42 ("lua" ,lua)
43 ("util-linux" ,util-linux "lib")))
44 (arguments
45 `(#:tests? #f ; No tests implemented.
46 #:phases
47 (modify-phases %standard-phases
48 (add-before
49 'patch-source-shebangs 'remove-broken-symlinks
50 (lambda _
51 ;; These files are broken symlinks - delete them.
52 (delete-file "src/cal")
53 (delete-file "src/calendar")
54 (delete-file "src/tw"))))))
55 (home-page "https://taskwarrior.org")
56 (synopsis "Command line task manager")
57 (description
58 "Taskwarrior is a command-line task manager following the Getting Things
59 Done time management method. It supports network synchronization, filtering
60 and querying data, exposing task data in multiple formats to other tools.")
61 (license license:expat)))