gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / skribilo.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2020 Ludovic Courtès <ludo@gnu.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages skribilo)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix licenses)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages guile)
25 #:use-module (gnu packages guile-xyz)
26 #:use-module (gnu packages lout)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (gnu packages plotutils)
29 #:use-module (gnu packages imagemagick)
30 #:use-module (gnu packages ghostscript))
31
32 (define-public skribilo
33 (package
34 (name "skribilo")
35 (version "0.9.4")
36 (source (origin
37 (method url-fetch)
38 (uri (string-append "mirror://savannah/skribilo/skribilo-"
39 version ".tar.gz"))
40 (sha256
41 (base32
42 "06ywnfjfa9sxrzdszb5sryzg266380g519cm64kq62sskzl7zmnf"))))
43 (build-system gnu-build-system)
44 (arguments
45 ;; Make the modules available under the usual location.
46 '(#:phases
47 (modify-phases %standard-phases
48 (add-before 'configure 'pre-configure
49 (lambda* (#:key inputs #:allow-other-keys)
50 ;; Make sure the 'skribilo' command gets to see
51 ;; Guile-Reader, even if Guile-Reader is not in the search
52 ;; path.
53 (let ((reader (assoc-ref inputs "guile-reader")))
54 (substitute* "src/skribilo.in"
55 (("^exec (.*) -c" _ things)
56 (string-append "exec " things
57 " -L " reader "/share/guile/site/2.2"
58 " -C " reader "/lib/guile/2.2/site-ccache"
59 " -c"))))
60 #t)))
61
62 #:parallel-build? #f))
63
64 (native-inputs `(("pkg-config" ,pkg-config)))
65
66 (inputs `(("guile" ,guile-2.2)
67 ("imagemagick" ,imagemagick)
68 ("ghostscript" ,ghostscript) ; for 'convert'
69 ("ploticus" ,ploticus)
70 ("lout" ,lout)))
71
72 ;; The 'skribilo' command needs them, and for people using Skribilo as a
73 ;; library, these inputs are needed as well.
74 (propagated-inputs `(("guile-reader" ,guile2.2-reader)
75 ("guile-lib" ,guile2.2-lib)))
76
77 (home-page "https://www.nongnu.org/skribilo/")
78 (synopsis "Document production tool written in Guile Scheme")
79 (description
80 "Skribilo is a free document production tool that takes a structured
81 document representation as its input and renders that document in a variety of
82 output formats: HTML and Info for on-line browsing, and Lout and LaTeX for
83 high-quality hard copies.
84
85 The input document can use Skribilo's markup language to provide information
86 about the document's structure, which is similar to HTML or LaTeX and does not
87 require expertise. Alternatively, it can use a simpler, “markup-less” format
88 that borrows from Emacs' outline mode and from other conventions used in
89 emails, Usenet and text.
90
91 Lastly, Skribilo provides Guile Scheme APIs.")
92 (license gpl3+)))