gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / rdesktop.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
4 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
7 ;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
8 ;;;
9 ;;; This file is part of GNU Guix.
10 ;;;
11 ;;; GNU Guix is free software; you can redistribute it and/or modify it
12 ;;; under the terms of the GNU General Public License as published by
13 ;;; the Free Software Foundation; either version 3 of the License, or (at
14 ;;; your option) any later version.
15 ;;;
16 ;;; GNU Guix is distributed in the hope that it will be useful, but
17 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
18 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
19 ;;; GNU General Public License for more details.
20 ;;;
21 ;;; You should have received a copy of the GNU General Public License
22 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
23
24 (define-module (gnu packages rdesktop)
25 #:use-module ((guix licenses) #:prefix license:)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix git-download)
29 #:use-module (guix build-system cmake)
30 #:use-module (guix build-system gnu)
31 #:use-module (gnu packages compression)
32 #:use-module (gnu packages cups)
33 #:use-module (gnu packages docbook)
34 #:use-module (gnu packages freedesktop)
35 #:use-module (gnu packages glib)
36 #:use-module (gnu packages gstreamer)
37 #:use-module (gnu packages image)
38 #:use-module (gnu packages linux)
39 #:use-module (gnu packages nettle)
40 #:use-module (gnu packages pkg-config)
41 #:use-module (gnu packages pulseaudio)
42 #:use-module (gnu packages tls)
43 #:use-module (gnu packages video)
44 #:use-module (gnu packages xdisorg)
45 #:use-module (gnu packages xorg)
46 #:use-module (gnu packages xml))
47
48 (define-public rdesktop
49 (package
50 (name "rdesktop")
51 (version "1.9.0")
52 (source (origin
53 (method url-fetch)
54 (uri (string-append "https://github.com/rdesktop/rdesktop/"
55 "releases/download/v" version "/rdesktop-"
56 version ".tar.gz"))
57 (sha256
58 (base32
59 "1222f2srlq16bydhy44gph997iajg39sl774xxh9jdwi4cqjyg27"))))
60 (build-system gnu-build-system)
61 (arguments
62 `(#:configure-flags (list ;; XXX: optional dependencies missing
63 "--disable-credssp"
64 "--disable-smartcard")
65 #:tests? #f)) ; No 'check' target
66 (native-inputs
67 `(("pkg-config" ,pkg-config)))
68 (inputs
69 `(("gnutls" ,gnutls)
70 ("libx11" ,libx11)
71 ("libxcursor" ,libxcursor)
72 ("nettle" ,nettle)))
73 (home-page "https://www.rdesktop.org/")
74 (synopsis "Client for Windows Terminal Services")
75 (description
76 "rdesktop is a client for Microsoft's Windows Remote Desktop Services,
77 capable of natively speaking Remote Desktop Protocol (RDP). It allows users
78 to remotely control a user's Windows desktop.")
79 (license license:gpl3+)))
80
81 (define-public freerdp
82 (package
83 (name "freerdp")
84 (version "2.0.0-rc4")
85 (source (origin
86 (method git-fetch)
87 (uri (git-reference
88 (url "git://github.com/FreeRDP/FreeRDP.git")
89 (commit version)))
90 (file-name (git-file-name name version))
91 (sha256
92 (base32 "0546i0m2d4nz5jh84ngwzpcm3c43fp987jk6cynqspsmvapab6da"))))
93 (build-system cmake-build-system)
94 (native-inputs
95 `(("docbook-xml" ,docbook-xml)
96 ("docbook-xsl" ,docbook-xsl)
97 ("glib" ,glib)
98 ("libxml2" ,libxml2)
99 ("libxslt" ,libxslt)
100 ("pkg-config" ,pkg-config)
101 ("xmlto" ,xmlto)))
102 (inputs
103 `(("alsa-lib" ,alsa-lib)
104 ("cups" ,cups)
105 ("ffmpeg" ,ffmpeg)
106 ("libjpeg" ,libjpeg-turbo)
107 ("libx11" ,libx11)
108 ("libxkbcommon" ,libxkbcommon)
109 ("libxkbfile" ,libxkbfile)
110 ("libxcursor" ,libxcursor)
111 ("libxext" ,libxext)
112 ("libxi" ,libxi)
113 ("libxv" ,libxv)
114 ("libxrandr" ,libxrandr)
115 ("libxrender" ,libxrender)
116 ("libxinerama" ,libxinerama)
117 ("libxshmfence" ,libxshmfence)
118 ("openssl" ,openssl)
119 ("pulseaudio" ,pulseaudio)
120 ("wayland" ,wayland)
121 ("zlib" ,zlib)))
122 (arguments
123 `(#:build-type "RELEASE"
124 #:configure-flags
125 (list "-DWITH_JPEG=ON"
126 "-DWITH_LIBSYSTEMD=OFF"
127 ,@(if (string-prefix? "x86_64"
128 (or (%current-target-system)
129 (%current-system)))
130 '("-DWITH_SSE2=ON")
131 '())
132 (string-append "-DDOCBOOKXSL_DIR="
133 (assoc-ref %build-inputs "docbook-xsl")
134 "/xml/xsl/docbook-xsl-"
135 ,(package-version docbook-xsl))
136 "-DWITH_PULSE=ON"
137 "-DWITH_CUPS=ON"
138 "-DBUILD_TESTING=ON")))
139 (home-page "https://www.freerdp.com")
140 (synopsis "Remote Desktop Protocol implementation")
141 (description "FreeRDP implements Microsoft's Remote Desktop Protocol.
142 It consists of the @code{xfreerdp} client, libraries for client and server
143 functionality, and Windows Portable Runtime (WinPR), a portable implementation
144 of parts of the Windows API.")
145 (license license:asl2.0)))