gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / rcm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages rcm)
20 #:use-module (guix packages)
21 #:use-module (guix download)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (gnu packages python-xyz)
25 #:use-module (gnu packages perl))
26
27 (define-public rcm
28 (package
29 (name "rcm")
30 (version "1.3.3")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append "https://thoughtbot.github.io/rcm/dist/rcm-"
34 version ".tar.gz"))
35 (sha256
36 (base32 "1bqk7rrp1ckzvsvl9wghsr77m8xl3a7yc5gqdsisz492dx2j8mck"))))
37 (build-system gnu-build-system)
38 (arguments '(#:phases
39 (modify-phases %standard-phases
40 (add-after 'patch-source-shebangs 'patch-tests
41 (lambda _
42 (substitute* '("test/rcrc-tilde.t"
43 "test/rcdn-hooks-run-in-order.t"
44 "test/rcup-hooks-run-in-order.t")
45 (("/bin/sh") (which "sh")))
46 (substitute* "test/rcup-hooks.t"
47 (("/usr/bin/env") (which "env")))
48 #t)))
49 #:parallel-tests? #f))
50 (native-inputs `(("perl" ,perl)
51 ("python-cram" ,python-cram)))
52 (synopsis "Management suite for dotfiles")
53 (description "The rcm suite of tools is for managing dotfiles directories. This is
54 a directory containing all the @code{.*rc} files in your home directory
55 (@code{.zshrc}, @code{.vimrc}, and so on). These files have gone by many
56 names in history, such as “rc files” because they typically end in rc
57 or “dotfiles” because they begin with a period. This suite is useful
58 for committing your rc files to a central repository to share, but it also
59 scales to a more complex situation such as multiple source directories
60 shared between computers with some host-specific or task-specific files.")
61 (license bsd-3)
62 (home-page "https://github.com/thoughtbot/rcm")))