gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / printers.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages printers)
22 #:use-module (guix packages)
23 #:use-module (guix git-download)
24 #:use-module (guix build-system cmake)
25 #:use-module (guix build-system gnu)
26 #:use-module ((guix licenses) #:prefix license:)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages cups)
29 #:use-module (gnu packages libusb)
30 #:use-module (gnu packages ghostscript)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages qt))
33
34 ;; This is a module for packages related to printer-like devices, but not
35 ;; related to CUPS.
36
37 (define-public robocut
38 (package
39 (name "robocut")
40 (version "1.0.11")
41 (source
42 (origin
43 (method git-fetch)
44 (uri (git-reference
45 (url "https://github.com/Timmmm/robocut")
46 (commit (string-append "v" version))))
47 (file-name (git-file-name name version))
48 (sha256
49 (base32 "0dp9cssyik63yvkk35s51v94a873x751iqg93qzd8dpqkmz5z8gn"))))
50 (build-system gnu-build-system)
51 (arguments
52 '(#:phases (modify-phases %standard-phases
53 (replace 'configure
54 (lambda* (#:key outputs #:allow-other-keys)
55 (let ((out (assoc-ref outputs "out")))
56 (substitute* "Robocut.pro"
57 (("/usr/")
58 (string-append out "/")))
59
60 (invoke "qmake"
61 (string-append "PREFIX=" out))
62 #t))))))
63 (inputs
64 `(("libusb" ,libusb)
65 ("qt" ,qtbase)
66 ("qtsvg" ,qtsvg)))
67 (native-inputs
68 `(("pkg-config" ,pkg-config)
69 ("qmake" ,qtbase)))
70 (synopsis "Graphical program to drive plotting cutters")
71 (description
72 "Robocut is a simple graphical program that allows you to cut graphics
73 with Graphtec and Sihouette plotting cutters using an SVG file as its input.")
74 (home-page "http://robocut.org")
75 (license license:gpl3+)))
76
77 (define-public brlaser
78 (package
79 (name "brlaser")
80 (version "6")
81 (source (origin
82 (method git-fetch)
83 (uri (git-reference
84 (url "https://github.com/pdewacht/brlaser")
85 (commit (string-append "v" version))))
86 (file-name (git-file-name name version))
87 (sha256
88 (base32
89 "1995s69ksq1fz0vb34v0ndiqncrinbrlpmp70rkl6az7kag99s80"))))
90 (build-system cmake-build-system)
91 (arguments
92 `(#:configure-flags
93 (list (string-append "-DCUPS_DATA_DIR="
94 (assoc-ref %outputs "out")
95 "/share/cups")
96 (string-append "-DCUPS_SERVER_BIN="
97 (assoc-ref %outputs "out")
98 "/lib/cups"))))
99 (inputs
100 `(("ghostscript" ,ghostscript)
101 ("cups" ,cups)
102 ("zlib" ,zlib)))
103 (home-page "https://github.com/pdewacht/brlaser")
104 (synopsis "Brother laser printer driver")
105 (description "Brlaser is a CUPS driver for Brother laser printers. This
106 driver is known to work with these printers:
107
108 @enumerate
109 @item Brother DCP-1510 series
110 @item Brother DCP-1600 series
111 @item Brother DCP-7030
112 @item Brother DCP-7040
113 @item Brother DCP-7055
114 @item Brother DCP-7055W
115 @item Brother DCP-7060D
116 @item Brother DCP-7065DN
117 @item Brother DCP-7080
118 @item Brother DCP-L2500D series
119 @item Brother DCP-L2520D series
120 @item Brother DCP-L2540DW series
121 @item Brother HL-1110 series
122 @item Brother HL-1200 series
123 @item Brother HL-2030 series
124 @item Brother HL-2140 series
125 @item Brother HL-2220 series
126 @item Brother HL-2270DW series
127 @item Brother HL-5030 series
128 @item Brother HL-L2300D series
129 @item Brother HL-L2320D series
130 @item Brother HL-L2340D series
131 @item Brother HL-L2360D series
132 @item Brother MFC-1910W
133 @item Brother MFC-7240
134 @item Brother MFC-7360N
135 @item Brother MFC-7365DN
136 @item Brother MFC-7840W
137 @item Brother MFC-L2710DW series
138 @item Lenovo M7605D
139 @end enumerate")
140 (license license:gpl2+)))