gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / linphone.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;;
3 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
4 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages linphone)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages admin)
24 #:use-module (gnu packages audio)
25 #:use-module (gnu packages base)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages documentation)
28 #:use-module (gnu packages gettext)
29 #:use-module (gnu packages gl)
30 #:use-module (gnu packages glib)
31 #:use-module (gnu packages gnome)
32 #:use-module (gnu packages gnome-xyz)
33 #:use-module (gnu packages graphviz)
34 #:use-module (gnu packages gtk)
35 #:use-module (gnu packages image)
36 #:use-module (gnu packages linux)
37 #:use-module (gnu packages pulseaudio)
38 #:use-module (gnu packages python)
39 #:use-module (gnu packages python-xyz)
40 #:use-module (gnu packages qt)
41 #:use-module (gnu packages java)
42 #:use-module (gnu packages sqlite)
43 #:use-module (gnu packages telephony)
44 #:use-module (gnu packages tls)
45 #:use-module (gnu packages video)
46 #:use-module (gnu packages xiph)
47 #:use-module (gnu packages xml)
48 #:use-module (gnu packages xorg)
49 #:use-module ((guix licenses) #:prefix license:)
50 #:use-module (guix packages)
51 #:use-module (guix download)
52 #:use-module (guix build-system cmake)
53 #:use-module (guix build-system qt)
54 #:use-module (guix build-system glib-or-gtk)
55 #:use-module (guix build-system gnu))
56
57 (define-public bcunit
58 (package
59 (name "bcunit")
60 (version "3.0.2")
61 (source
62 (origin
63 (method url-fetch)
64 (uri
65 (string-append "https://www.linphone.org/releases/sources/" name
66 "/" name "-" version ".tar.gz"))
67 (sha256
68 (base32 "0ylchj8w98ic2fkqpxc6yk4s6s0h0ql2zsz5n49jd7126m4h8dqk"))))
69 (build-system cmake-build-system)
70 (arguments
71 '(#:tests? #f ; No test target
72 #:configure-flags
73 (list "-DENABLE_STATIC=NO"))) ; Not required
74 (synopsis "Belledonne Communications Unit Testing Framework")
75 (description "BCUnit is a fork of the defunct project CUnit, with several
76 fixes and patches applied. It is an unit testing framework for writing,
77 administering, and running unit tests in C.")
78 (home-page "https://gitlab.linphone.org/BC/public/bcunit")
79 (license license:lgpl2.0+)))
80
81 (define-public bctoolbox
82 (package
83 (name "bctoolbox")
84 (version "0.6.0")
85 (source
86 (origin
87 (method url-fetch)
88 (uri
89 (string-append "https://www.linphone.org/releases/sources/" name
90 "/" name "-" version ".tar.gz"))
91 (sha256
92 (base32 "1a1i70pb4hhnykkwyhhc7fv67q556l8kprny8xzgfqpj1nby2ms6"))))
93 (build-system cmake-build-system)
94 (arguments
95 '(#:tests? #f ; No test target
96 #:configure-flags
97 (list "-DENABLE_STATIC=OFF"))) ; Not required
98 (inputs
99 `(("bcunit" ,bcunit)
100 ("mbedtls" ,mbedtls-apache)))
101 (synopsis "Belledonne Communications Tool Box")
102 (description "BcToolBox is an utilities library used by Belledonne
103 Communications software like belle-sip, mediastreamer2 and linphone.")
104 (home-page "https://gitlab.linphone.org/BC/public/bctoolbox")
105 (license license:gpl2+)))
106
107 (define-public belr
108 (package
109 (name "belr")
110 (version "0.1.3")
111 (source
112 (origin
113 (method url-fetch)
114 (uri
115 (string-append "https://www.linphone.org/releases/sources/" name
116 "/" name "-" version ".tar.gz"))
117 (sha256
118 (base32 "1fwv2cg3qy9vdc7dimcda7nqcqc1h2cdd7ikhk7ng7q4ys8m96c1"))))
119 (build-system cmake-build-system)
120 (arguments
121 `(#:tests? #f ; No test target
122 #:configure-flags
123 (list "-DENABLE_STATIC=OFF"))) ; Not required
124 (inputs
125 `(("bctoolbox" ,bctoolbox)))
126 (synopsis "Belledonne Communications Language Recognition Library")
127 (description "Belr is Belledonne Communications' language recognition
128 library, written in C++11. It parses text inputs formatted according to a
129 language defined by an ABNF grammar, such as the protocols standardized at
130 IETF.")
131 (home-page "https://gitlab.linphone.org/BC/public/belr")
132 (license license:gpl3+)))
133
134 (define-public belcard
135 (package
136 (name "belcard")
137 (version "1.0.2")
138 (source
139 (origin
140 (method url-fetch)
141 (uri
142 (string-append "https://www.linphone.org/releases/sources/" name
143 "/" name "-" version ".tar.gz"))
144 (sha256
145 (base32 "0iiyrll1shnbb0561pkvdqcmx9b2cdr76xpsbaqdirc3s4xzcl0k"))))
146 (build-system cmake-build-system)
147 (arguments
148 `(#:tests? #f ; No test target
149 #:configure-flags
150 (list "-DENABLE_STATIC=OFF"))) ; Not required
151 (inputs
152 `(("bctoolbox" ,bctoolbox)
153 ("belr" ,belr)))
154 (synopsis "Belledonne Communications VCard Library")
155 (description "Belcard is a C++ library to manipulate VCard standard
156 format.")
157 (home-page "https://gitlab.linphone.org/BC/public/belcard")
158 (license license:gpl3+)))
159
160 (define-public bcmatroska2
161 (package
162 (name "bcmatroska2")
163 (version "0.23")
164 (source
165 (origin
166 (method url-fetch)
167 (uri
168 (string-append "https://www.linphone.org/releases/sources/" name
169 "/" name "-" version ".tar.gz"))
170 (sha256
171 (base32 "1a0vlk4fhh189pfzrwbc3xbc5vyx6cnxy642d1h40045jz9y4h15"))))
172 (build-system cmake-build-system)
173 (arguments
174 `(#:tests? #f ; No test target
175 #:configure-flags
176 (list
177 "-DENABLE_STATIC=NO"))) ; Not required
178 (synopsis "Belledonne Communications Media Container")
179 (description "BcMatroska is a free and open standard multi-media container
180 format. It can hold an unlimited number of video, audio, picture, or subtitle
181 tracks in one file. ")
182 (home-page "https://gitlab.linphone.org/BC/public/bcmatroska2")
183 (license
184 (list
185 ;; For Core C and LibEBML2.
186 ;; https://www.matroska.org/node/47
187 license:bsd-4
188 ;; For LibMatroska2.
189 ;; https://www.matroska.org/node/47
190 license:lgpl2.1+))))
191
192 (define-public bcg729
193 (package
194 (name "bcg729")
195 (version "1.0.4")
196 (source
197 (origin
198 (method url-fetch)
199 (uri
200 (string-append "https://www.linphone.org/releases/sources/" name
201 "/" name "-" version ".tar.gz"))
202 (sha256
203 (base32 "01y34ky7ykjgfnf8a9f59hg61fqfjiprfrzshdz06w0lz4gvy3qs"))))
204 (build-system cmake-build-system)
205 (arguments
206 `(#:tests? #f ; No test target
207 #:configure-flags
208 (list "-DENABLE_STATIC=NO"))) ; Not required
209 (synopsis "Belledonne Communications G729 Codec")
210 (description "BcG729 is an implementation of both encoder and decoder of
211 the ITU G729 speech codec. The library written in C 99 is fully portable and
212 can be executed on many platforms including both ARM and x86 processors. It
213 supports concurrent channels encoding and decoding for multi call application
214 such as conferencing.")
215 (home-page "https://gitlab.linphone.org/BC/public/belcard")
216 (license license:gpl2+)))
217
218 (define-public ortp
219 (package
220 (name "ortp")
221 (version "1.0.2")
222 (source
223 (origin
224 (method url-fetch)
225 (uri
226 (string-append "https://www.linphone.org/releases/sources/" name
227 "/" name "-" version ".tar.gz"))
228 (sha256
229 (base32 "016qg0lmdgmqh2kv19w9qhi4kkiyi5h1xp35g2s65b1j8ccm25d5"))))
230 (build-system cmake-build-system)
231 (arguments
232 `(#:tests? #f ; No test target
233 #:configure-flags
234 (list "-DENABLE_STATIC=NO"))) ; Not required
235 (native-inputs
236 `(("dot" ,graphviz)
237 ("doxygen" ,doxygen)))
238 (inputs
239 `(("bctoolbox" ,bctoolbox)))
240 (synopsis "Belledonne Communications RTP Library")
241 (description "oRTP is a C library implementing the RTP protocol. It
242 implements the RFC 3550 standard.")
243 (home-page "https://gitlab.linphone.org/BC/public/ortp")
244 (license license:gpl2+)))
245
246 (define-public bzrtp
247 (package
248 (name "bzrtp")
249 (version "1.0.6")
250 (source
251 (origin
252 (method url-fetch)
253 (uri
254 (string-append "https://www.linphone.org/releases/sources/" name
255 "/" name "-" version ".tar.gz"))
256 (sha256
257 (base32 "12y0kkh90pixaaxfyx26ca2brhy6nw57fsypp6vh8jk1illv0j5z"))))
258 (build-system cmake-build-system)
259 (arguments
260 `(#:tests? #f ; No test target
261 #:configure-flags
262 (list "-DENABLE_STATIC=NO"))) ; Not required
263 (inputs
264 `(("bctoolbox" ,bctoolbox)
265 ("sqlite3" ,sqlite)
266 ("xml2" ,libxml2)))
267 (synopsis "Belledonne Communications ZRTP Library")
268 (description "BZRTP is an implementation of ZRTP keys exchange protocol,
269 written in C. It is fully portable and can be executed on many platforms
270 including both ARM and x86.")
271 (home-page "https://gitlab.linphone.org/BC/public/bzrtp")
272 (license license:gpl2+)))
273
274 (define-public belle-sip
275 (package
276 (name "belle-sip")
277 (version "1.6.3")
278 (source
279 (origin
280 (method url-fetch)
281 (uri
282 (string-append "https://www.linphone.org/releases/sources/" name
283 "/" name "-" version ".tar.gz"))
284 (sha256
285 (base32 "0s55kggmgxap54dkw5856bgk4xg7yvbzialpxnjm0zhpic3hff1z"))))
286 (build-system cmake-build-system)
287 (arguments
288 `(#:tests? #f ; Requires network access
289 #:configure-flags
290 (list "-DENABLE_STATIC=NO") ; Not required
291 #:phases
292 (modify-phases %standard-phases
293 (add-after 'unpack 'patch
294 (lambda _
295 (substitute* "src/CMakeLists.txt"
296 ;; ANTLR would use multithreaded DFA generation otherwise,
297 ;; which would not be reproducible.
298 (("-Xmultithreaded ") ""))
299 #t)))))
300 (inputs
301 `(("antlr3" ,antlr3-3.3)
302 ("antlr3c" ,libantlr3c)
303 ("bctoolbox" ,bctoolbox)
304 ("java" ,icedtea)
305 ("zlib" ,zlib)))
306 (synopsis "Belledonne Communications SIP Library")
307 (description "Belle-sip is a modern library implementing SIP transport,
308 transaction and dialog layers. It is written in C, with an object-oriented
309 API. It also comprises a simple HTTP/HTTPS client implementation.")
310 (home-page "https://gitlab.linphone.org/BC/public/belle-sip")
311 (license license:gpl2+)))
312
313 (define-public mediastreamer2
314 (package
315 (name "mediastreamer2")
316 (version "2.16.1")
317 (source
318 (origin
319 (method url-fetch)
320 (uri
321 (string-append "https://www.linphone.org/releases/sources/"
322 "mediastreamer/mediastreamer-" version ".tar.gz"))
323 (sha256
324 (base32 "0whpqr69wz0pnzvragkpfblxhd0rds8k06c3mw5a0ag216a1yd9k"))
325 (patches (search-patches "mediastreamer2-srtp2.patch"))))
326 (outputs '("out" "doc" "tester"))
327 (build-system cmake-build-system)
328 (arguments
329 `(#:tests? #f ; No test target
330 #:configure-flags
331 (list "-DENABLE_STATIC=NO" ; Not required
332 "-DENABLE_STRICT=NO" ; Would otherwise treat warnings as err
333 "-DENABLE_BV16=NO" ; Not available
334 "-DCMAKE_C_FLAGS=-DMS2_GIT_VERSION=\\\"unknown\\\""
335 "-DCMAKE_CXX_FLAGS=-DMS2_GIT_VERSION=\\\"unknown\\\"")
336 #:phases
337 (modify-phases %standard-phases
338 (add-after 'install 'separate-outputs
339 (lambda* (#:key outputs #:allow-other-keys)
340 (let* ((out (assoc-ref outputs "out"))
341 (doc (assoc-ref outputs "doc"))
342 (tester (assoc-ref outputs "tester"))
343 (tester-name (string-append ,name "_tester")))
344 ;; Copy the tester executable.
345 (mkdir-p (string-append tester "/bin"))
346 (rename-file (string-append out "/bin/" tester-name)
347 (string-append tester "/bin/" tester-name))
348 ;; Copy the tester data files.
349 (copy-recursively (string-append out "/share/" tester-name)
350 (string-append tester "/share/" tester-name))
351 (delete-file-recursively (string-append out "/share/"
352 tester-name))
353 ;; Copy the HTML documentation.
354 (copy-recursively (string-append out "/share/doc/"
355 ,name "-" ,version "/html")
356 (string-append doc "/share/doc/"
357 ,name "-" ,version "/html"))
358 (delete-file-recursively (string-append out "/share/doc/"
359 ,name "-" ,version
360 "/html"))
361 #t))))))
362 (native-inputs
363 `(("dot" ,graphviz)
364 ("doxygen" ,doxygen)
365 ("python" ,python)))
366 (inputs
367 `(("alsa" ,alsa-lib)
368 ("bcg729" ,bcg729)
369 ("bcmatroska2" ,bcmatroska2)
370 ("bctoolbox" ,bctoolbox)
371 ("ffmpeg" ,ffmpeg)
372 ("glew" ,glew)
373 ("glu" ,glu)
374 ("glx" ,mesa-utils)
375 ("gsm" ,gsm)
376 ("opengl" ,mesa)
377 ("opus" ,opus)
378 ("ortp" ,ortp)
379 ("pcap" ,libpcap)
380 ("portaudio" ,portaudio)
381 ("pulseaudio" ,pulseaudio)
382 ("spandsp" ,spandsp)
383 ("speex" ,speex)
384 ("speexdsp" ,speexdsp)
385 ("srtp" ,libsrtp)
386 ("theora" ,libtheora)
387 ("turbojpeg" ,libjpeg-turbo)
388 ("v4l" ,v4l-utils)
389 ("vpx" ,libvpx)
390 ("x11" ,libx11)
391 ("xv" ,libxv)
392 ("zrtp" ,bzrtp)))
393 (synopsis "Belledonne Communications Streaming Engine")
394 (description "Mediastreamer2 is a powerful and lightweight streaming engine
395 for telephony applications. This media processing and streaming toolkit is
396 responsible for receiving and sending all multimedia streams in Linphone,
397 including media capture, encoding and decoding, and rendering.")
398 (home-page "https://gitlab.linphone.org/BC/public/mediastreamer2")
399 (license license:gpl2+)))
400
401 (define-public liblinphone
402 (package
403 (name "liblinphone")
404 (version "3.12.0")
405 (source
406 (origin
407 (method url-fetch)
408 (uri
409 (string-append "https://www.linphone.org/releases/sources/linphone"
410 "/linphone-" version ".tar.gz"))
411 (sha256
412 (base32 "0phhkx55xdyg28d4wn8l8q4yvsmdgzmjiw584d4s190sq1azm91x"))))
413 (outputs '("out" "doc" "tester"))
414 (build-system cmake-build-system)
415 (arguments
416 `(#:tests? #f ; No test target
417 #:configure-flags
418 (list (string-append "-DGTK2_GDKCONFIG_INCLUDE_DIR="
419 (string-append (assoc-ref %build-inputs "gtk2")
420 "/lib/gtk-2.0/include"))
421 (string-append "-DGTK2_GLIBCONFIG_INCLUDE_DIR="
422 (string-append (assoc-ref %build-inputs "glib")
423 "/lib/glib-2.0/include"))
424 "-DENABLE_STATIC=NO" ; Not required
425 "-DENABLE_STRICT=NO"
426 "-DENABLE_GTK_UI=YES") ; for legacy UI
427 #:imported-modules (,@%cmake-build-system-modules
428 (guix build glib-or-gtk-build-system))
429 #:modules ((guix build cmake-build-system)
430 ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
431 (guix build utils))
432 #:phases
433 (modify-phases %standard-phases
434 (add-after 'unpack 'patch
435 (lambda _
436 (substitute* "gtk/main.c"
437 (("#include \"liblinphone_gitversion.h\"")
438 ""))
439 #t))
440 (add-after 'install 'separate-outputs
441 (lambda* (#:key outputs #:allow-other-keys)
442 (let* ((out (assoc-ref outputs "out"))
443 (doc (assoc-ref outputs "doc"))
444 (tester (assoc-ref outputs "tester"))
445 (tester-name (string-append ,name "_tester")))
446 ;; Copy the tester executable.
447 (mkdir-p (string-append tester "/bin"))
448 (rename-file (string-append out "/bin/" tester-name)
449 (string-append tester "/bin/" tester-name))
450 ;; Copy the tester data files.
451 (mkdir-p (string-append tester "/share/"))
452 (rename-file (string-append out "/share/" tester-name)
453 (string-append tester "/share/" tester-name))
454 ;; Copy the HTML and XML documentation.
455 (copy-recursively
456 (string-append out "/share/doc/linphone-" ,version)
457 (string-append doc "/share/doc/" ,name "-" ,version))
458 (delete-file-recursively
459 (string-append out "/share/doc/linphone-" ,version))
460 #t)))
461 (add-after 'install 'install-man-pages
462 (lambda* (#:key outputs #:allow-other-keys)
463 (let* ((out (assoc-ref outputs "out"))
464 (man (string-append out "/share/man/man1")))
465 (for-each (lambda (file)
466 (install-file file man))
467 (find-files ".." ".*.1$"))
468 #t)))
469 (add-after 'separate-outputs 'glib-or-gtk-compile-schemas
470 (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
471 (add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap
472 (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
473 (native-inputs
474 `(("gettext" ,gettext-minimal)
475 ("udev" ,eudev) ;for libudev.h
476 ;; For generating the C++ wrappers.
477 ("dot" ,graphviz)
478 ("doxygen" ,doxygen)
479 ("python" ,python)
480 ("pystache" ,python-pystache)
481 ("six" ,python-six)))
482 (inputs
483 `(("bctoolbox" ,bctoolbox)
484 ("belcard" ,belcard)
485 ("bellesip" ,belle-sip)
486 ("bzrtp", bzrtp)
487 ("iconv" ,libiconv)
488 ("glib" ,glib)
489 ("gtk2" ,gtk+-2)
490 ("mediastreamer2" ,mediastreamer2)
491 ("notify" ,libnotify)
492 ("ortp" ,ortp)
493 ("sqlite" ,sqlite)
494 ("xml2" ,libxml2)
495 ("zlib" ,zlib)))
496 (synopsis "Belledonne Communications Softphone Library")
497 (description "Liblinphone is a high-level SIP library integrating
498 all calling and instant messaging features into an unified
499 easy-to-use API. It is the cross-platform VoIP library on which the
500 Linphone application is based on, and that anyone can use to add audio
501 and video calls or instant messaging capabilities to an application.")
502 (home-page "https://gitlab.linphone.org/BC/public/liblinphone")
503 (license license:gpl2+)))
504
505 (define-public linphoneqt
506 (package
507 (name "linphoneqt")
508 (version "4.1.1")
509 (source
510 (origin
511 (method url-fetch)
512 (uri
513 (string-append "https://www.linphone.org/releases/sources/" name
514 "/" name "-" version ".tar.gz"))
515 (sha256
516 (base32 "1g2zrr9li0g1hgs6vys06vr98h5dx36z22hx7a6ry231536c002a"))
517 (patches (search-patches "linphoneqt-tabbutton.patch"))))
518 (build-system qt-build-system)
519 (arguments
520 `(#:tests? #f ; No test target
521 #:phases
522 (modify-phases %standard-phases
523 (add-after 'unpack 'fix-cmake-error
524 (lambda _
525 ;; This is fixed in commit efed2fd8 of the master branch.
526 (substitute* "CMakeLists.txt"
527 (("js)\\$\"")
528 "js$\""))
529 #t))
530 (add-after 'unpack 'set-version-string
531 (lambda _
532 (substitute* "src/app/AppController.cpp"
533 (("LINPHONE_QT_GIT_VERSION")
534 (format #f "~s" ,version)))
535 #t))
536 (add-after 'install 'extend-shared-resources
537 ;; Not using the FHS exposes an issue where the client refers to
538 ;; its own "share" directory, which lacks sound files installed by
539 ;; liblinphone.
540 (lambda* (#:key inputs outputs #:allow-other-keys)
541 (let ((liblinphone (assoc-ref inputs "linphone"))
542 (out (assoc-ref outputs "out")))
543 (symlink (string-append liblinphone "/share/sounds")
544 (string-append out "/share/sounds"))
545 #t))))))
546 (native-inputs
547 `(("qttools" ,qttools)))
548 (inputs
549 `(("bctoolbox" ,bctoolbox)
550 ("belcard" ,belcard)
551 ("bellesip" ,belle-sip)
552 ("linphone" ,liblinphone)
553 ("mediastreamer2" ,mediastreamer2)
554 ("qtbase" ,qtbase)
555 ("qtdeclarative" ,qtdeclarative)
556 ("qtgraphicaleffects" ,qtgraphicaleffects)
557 ("qtquickcontrols" ,qtquickcontrols)
558 ("qtquickcontrols2" ,qtquickcontrols2)
559 ("qtsvg" ,qtsvg)))
560 (synopsis "Desktop client for the Linphone SIP softphone")
561 (description "Linphone is a SIP softphone for voice and video over IP calling
562 (VoIP) and instant messaging. Amongst its features are:
563 @itemize
564 @item High Definition (HD) audio and video calls
565 @item Multiple call management (pause and resume)
566 @item Call transfer
567 @item Audio conferencing (merge calls into a conference call)
568 @item Call recording and replay (audio only)
569 @item Instant Messaging with message delivery status (IMDN)
570 @item Picture and file sharing
571 @item Echo cancellation
572 @item Secure user authentication using TLS client certificates
573 @item SRTP, zRTP and SRTP-DTLS voice and video encryption
574 @item Telephone tone (DTMF) support using SIP INFO or RFC 4733
575 @item Audio codecs: opus, speex, g711, g729, gsm, iLBC, g722, SILK, etc.
576 @item Video codecs: VP8, H.264 and H.265 with resolutions up to 1080P, MPEG4
577 @end itemize")
578 (home-page "https://gitlab.linphone.org/BC/public/linphone-desktop")
579 (license license:gpl2+)))
580
581 (define-public msopenh264
582 (package
583 (name "msopenh264")
584 (version "1.2.1")
585 (source
586 (origin
587 (method url-fetch)
588 (uri
589 (string-append "https://www.linphone.org/releases/sources/plugins/"
590 name "/" name "-" version ".tar.gz"))
591 (sha256
592 (base32 "0rdxgazm52560g52pp6mp3mwx6j1z3h2zyizzfycp8y8zi92fqm8"))
593 (patches
594 (list
595 ;; For support for OpenH264 version >= 2.
596 (origin
597 (method url-fetch)
598 (uri
599 (string-append "https://gitlab.linphone.org/BC/public/msopenh264/"
600 "commit/493d147d28c9a0f788ba4e50b47a1ce7b18bf326"
601 ".diff"))
602 (file-name "msopenh264-openh264.patch")
603 (sha256
604 (base32
605 "0mmd7nz5n9ian4rcwn200nldmy5j0dpdrna7r32rqnaw82bx3kdb")))))))
606 (build-system cmake-build-system)
607 (arguments
608 `(#:tests? #f ; No test target
609 #:configure-flags
610 (list "-DENABLE_STATIC=NO"))) ; Not required
611 (inputs
612 `(("mediastreamer2" ,mediastreamer2)
613 ("openh264" ,openh264)
614 ("ortp" ,ortp)))
615 (synopsis "Media Streamer H.264 Codec")
616 (description "MsOpenH264 is an H.264 encoder/decoder plugin for
617 mediastreamer2 based on the openh264 library.")
618 (home-page "https://gitlab.linphone.org/BC/public/msopenh264")
619 (license license:gpl2+)))
620
621 (define-public mssilk
622 (package
623 (name "mssilk")
624 (version "1.1.1")
625 (source
626 (origin
627 (method url-fetch)
628 (uri
629 (string-append "https://www.linphone.org/releases/sources/plugins/"
630 name "/" name "-" version ".tar.gz"))
631 (sha256
632 (base32 "07ip0vd29d1n98lnqs5wpimcsmpm65yl7g5vk4hbqghcbsjw94lj"))))
633 (build-system cmake-build-system)
634 (arguments
635 `(#:tests? #f ; No test target
636 #:configure-flags
637 (list "-DENABLE_STATIC=NO"))) ; Not required
638 (inputs
639 `(("mediastreamer2" ,mediastreamer2)
640 ("ortp" ,ortp)))
641 (synopsis "Media Streamer SILK Codec")
642 (description "MSSILK is a plugin of MediaStreamer, adding support for AMR
643 codec. It is based on the Skype's SILK implementation.")
644 (home-page "https://gitlab.linphone.org/BC/public/mssilk")
645 (license license:gpl2+)))
646
647 (define-public mswebrtc
648 (package
649 (name "mswebrtc")
650 (version "1.1.1")
651 (source
652 (origin
653 (method url-fetch)
654 (uri
655 (string-append "https://www.linphone.org/releases/sources/plugins/"
656 name "/" name "-" version ".tar.gz"))
657 (sha256
658 (base32 "1wj28hl9myhshqmn64xg0jf07aw75gmnilb5rff6rcbdxim87mqr"))))
659 (build-system cmake-build-system)
660 (arguments
661 `(#:tests? #f ; No test target
662 #:configure-flags
663 (list
664 "-DENABLE_STATIC=NO"))) ; Not required
665 (inputs
666 `(("bctoolbox" ,bctoolbox)
667 ("mediastreamer2" ,mediastreamer2)
668 ("ortp" ,ortp)))
669 (synopsis "Media Streamer WebRTC Codec")
670 (description "MSWebRTC is a plugin of MediaStreamer, adding support for
671 WebRTC codec. It includes features from WebRTC, such as, iSAC and AECM.")
672 (home-page "https://gitlab.linphone.org/BC/public/mswebrtc")
673 (license license:gpl2+)))
674
675 (define-public msamr
676 (package
677 (name "msamr")
678 (version "1.1.3")
679 (source
680 (origin
681 (method url-fetch)
682 (uri
683 (string-append "https://www.linphone.org/releases/sources/plugins/"
684 name "/" name "-" version ".tar.gz"))
685 (sha256
686 (base32 "16c9f3z4wnj73k7y8gb0fgpr4axsm7b5zrbjvy8vsgz9gyg3agm5"))))
687 (build-system cmake-build-system)
688 (arguments
689 `(#:tests? #f ; No test target
690 #:configure-flags
691 (list "-DENABLE_STATIC=NO" ; Not required
692 "-DENABLE_WIDEBAND=YES")))
693 (inputs
694 `(("mediastreamer2" ,mediastreamer2)
695 ("opencoreamr" ,opencore-amr)
696 ("ortp" ,ortp)
697 ("voamrwbenc" ,vo-amrwbenc)))
698 (synopsis "Media Streamer AMR Codec")
699 (description "MSAMR is a plugin of MediaStreamer, adding support for AMR
700 codec. It is based on the opencore-amr implementation.")
701 (home-page "https://gitlab.linphone.org/BC/public/msamr")
702 (license license:gpl3+)))