gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / libphidget.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages libphidget)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (guix licenses)
25 #:use-module (gnu packages libusb))
26
27 (define-public libphidget
28 (package
29 (name "libphidget")
30 (version "2.1.8.20180607")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append
34 "https://www.phidgets.com/downloads/phidget21/libraries/"
35 "linux/libphidget/libphidget_"
36 version ".tar.gz"))
37 (sha256
38 (base32 "1mdw8k13yy5dq3r41v9w5yijdk87alzix0qagslc2mxh1pf17npn"))))
39 (build-system gnu-build-system)
40 (inputs `(("libusb" ,libusb)))
41 (outputs '("out" "debug"))
42 (home-page "https://www.phidgets.com/")
43 (license lgpl3+)
44 (synopsis "C library to manipulate Phidgets")
45 (description synopsis)))