gnu: ruby-pandoc-ruby: Use pandoc instead of ghc-pandoc.
[jackhill/guix/guix.git] / gnu / packages / julia-xyz.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2020 Nicolò Balzarotti <nicolo@nixo.xyz>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages julia-xyz)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix git-download)
23 #:use-module (guix build-system julia))
24
25 (define-public julia-compat
26 (package
27 (name "julia-compat")
28 (version "3.9.1")
29 (source
30 (origin
31 (method git-fetch)
32 (uri (git-reference
33 (url "https://github.com/JuliaLang/Compat.jl")
34 (commit (string-append "v" version))))
35 (file-name "Compat")
36 (sha256
37 (base32 "01vwjr2134bzgnaxwd67knbibbhnfgnqjw7gxrp29s6y2a6j3882"))))
38 (build-system julia-build-system)
39 (home-page "https://github.com/JuliaLang/Compat.jl")
40 (synopsis "Compatibility across Julia versions")
41 (description "The Compat package is designed to ease interoperability
42 between older and newer versions of the Julia language. The Compat package
43 provides a macro that lets you use the latest syntax in a backwards-compatible
44 way.")
45 (license license:expat)))